(Topic ID: 310150)

maverick raise/fold hole is not registering some of the time

By maveric18

4 months ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 64 days ago by maveric18
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

Capture (resized).PNG

#1 4 months ago

good afternoon. I have a new to me Maverick which I have to say is a blast to play. Everything was working perfect until Sunday night. Typically when you shoot to the upper left, there is a "hole" that the ball will drop into and you have the option to raise or fold. Sometimes, when it's lit, you can play Blackjack. Sunday night the wife was playing and the ball would just sit in the hole and not give you the option to raise or fold. it will sit for 5 to 8 seconds and then kick out. once it does this all of the drop targets banks will all cycle back to the upper position. Any thoughts or help would be appreciated

#2 4 months ago

There is a switch in that hole that is apparently not registering. You can verify that by going into test mode with the service buttons (check the manual for details on that).

You will likely need to pop the hood on the playfield. With that location, you'll need to stand it up and lean it against the back box so you can investigate that switch further.

Could need an adjustment, could be a loose wire, I'd say.

Jeff

#3 4 months ago

Def a switch issue. The machine uses switch hits to detect the location of the ball. When it detects the ball sitting in the hole (saucer btw), it then knows to kick it out. If the ball sits in the saucer but the switch is broken, the machine doesn't know where the ball is, and will sit there waiting for you to hit a switch. If you don't hit a switch after a while, it will automatically kick all the mechanical components (saucers, scoops, flippers, etc) until it finds the ball again aka "do a ball search"

There is a switch that is connected to the saucer that is supposed to make contact when the ball sits in the saucer.

Many times you can just file the connectors because they are simply dirty and it'll work again. Here's where to file.

Capture (resized).PNG

But also what Grangeomatic said. Check the wires. If a wire is loose, you will need to solder it back.

2 months later
#4 64 days ago

to close this post, i replaced the switch up at the raise/fold vuk hole. the switch has a round hoop that the ball engages when it drops into the hole. works perfect now. thanks everyone

Promoted items from the Pinside Marketplace
2,850
Sale Pending! Machine - For Sale
Phoenixville, PA
4,500 (OBO)
Machine - For Sale
Lake Elsinore, CA
$ 27.95
Eproms
Pinballrom
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
€ 339.00
Displays
GermanGamingSupplies.com
From: $ 18.00
Apparel - Men
Pinside Shop
$ 21.00
Electronics
Yorktown Arcade Supply
$ 27.95
Eproms
Pinballrom
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
Trade
Machine - For Trade
Richmond, VA
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 9.99
Wanted
Machine - Wanted
Lake Park, GA
From: $ 389.95
Boards
PinSound

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!