(Topic ID: 79446)

Maverick fan thread - We play till we drop, winner takes all!


By Atomicboy

6 years ago



Topic Stats

  • 1,208 posts
  • 117 Pinsiders participating
  • Latest reply 8 days ago by classicgamefan
  • Topic is favorited by 38 Pinsiders

You

Linked Games

Topic Gallery

There have been 292 images uploaded to this topic. (View topic image gallery).

ball release post (resized).jpg
2BE030F3-B0CB-44F2-9C22-272028C78F78 (resized).jpeg
72FAA07A-2043-4A0F-9E24-F883FC1CD47C (resized).jpeg
5BE029FD-6C10-4452-9464-0A913BF224B4 (resized).jpeg
C334285A-43B0-451A-93D8-E32D6082750C (resized).jpeg
AC4C4838-A7E9-4605-9F11-732678BB5CF5 (resized).jpeg
C9D8B642-D161-48F5-AC6C-85B94D139F53 (resized).jpeg
P1020861 (resized).JPG
P1020859 (resized).JPG
P1020860 (resized).JPG
P1020858 (resized).JPG
Maverick_Custom Card 2.png
Maverick_Custom Card 1.png
7924CD33-7865-4EEA-A31E-E6B799883532 (resized).jpeg
D6B0F0EF-CF22-4EC9-AD1E-A299E1A19CFE (resized).jpeg
F776F04C-40A4-49E3-A88D-C06A6486E4EC (resized).jpeg

You're currently viewing posts by Pinsider sirgubster9.
Click here to go back to viewing the entire thread.

#923 9 months ago

I just got myself a maverick and Im absolutely in love!!! its my very first pin and im super overwhelmed with all the mods and all the tests and all the switches and just everything. Im slowly learning as best I can. I got a bunch of links to websites to gather info for noobes like myself. Ive read through 11 pages on this forum and Im tired, i wanted to read em all and I will go back and finish what I started but for now I skipped form page 12 to this page and read this page all the way through since it was a bit more current. My game plays great!!!!! for now ha ha except one major issue... not the belle funny enough. But ok so when you go to raise or fold and you try and push the right or left flipper to choose your option absolutely nothing happens. it finally times out and just spits the ball back out and chooses an option for you i think... Im new to everything even the modes of play and getting points and basically everything past just trying not to get the ball down the drain. so ya any ideas of where to start on fixing my raise em or fold em problem? hopefully they are fairly easy suggestions at least to start. thanks in advanced

#926 9 months ago

wow thanks for responding back so quickly guys. I found a manual online and its like 100 pages!!! so that was scary. I havent figured out how to look through the settings yet, but i read about it and it doesnt seem to hard. just sounds like you point one switch up or down and then click the other switch until you find what your looking for... of course I got no clue what im looking for. I can do my best to run the switch and coil test as well. ps. is there a test that basically turns on all the lights so you can see which bulbs work and which ones I just havent seen on during game play because Im not good yet? this is obviously a much more miner issue. Sounds like i should run through all the settings when I get a chance and see what happens. oh and as far as the latest cpu code.. how do I find out which one Im running? and how do I upgrade to the latest if Im not already running it? thanks again so much guys for all your help

#928 9 months ago

Ohh thanks mav that's easy enough to do. Will turn the machine on and check that out today.

#929 9 months ago

ok so mine is 4.01. should i upgrade to 4.02? and where is this chip at? let me know. then ill contact meloy about getting the new chip. also my version is the sega version with sonic. and at first i didnt have mel gibson or jodie foster or any of them pop up for a while but then they finally did after a long time of it being in attract mode which made me very happy. screens also popped up about tournament play and saving the dolphins!! is there any way to change these screens or alter their orders? and is there a way to get music playing for the attract mode?? finally my pin came with maverick playing cards!!!!!!! score!!!!! just found em inside the pin!!!!

sorry if too many questions right off the bat, just super excited about finally getting a pin!!!!

#931 9 months ago

Sweet! Thank you! Just curious what is the point of the updates. Like in general on any of these pinball machines, like why update? do they really change the game all that much?

Oh and my game also came with this little board, anybody know what it is?

20190615_125925 (resized).jpg
#933 9 months ago

Oh sweet. Ya I think it's new, but hard to say. I'll definitely hold onto it. You said 3 of them where in the game. Are they all in the laurelle bell? Is it possible one of them is in the vuk that I'm having problems with?

I talked to the room chip guy and he said they are actually up to 4.04, so I'm pretty far behind. So I'm going to update to that version from 4.01 and cross my fingers that that'll fix my issue. I'm assuming it's not that, but I can definitely try it especially because I'd want to update anyways.

#937 9 months ago

so i turned on my pin and it did says 4.01 for something, but then it said 4.04 for the cpu so I am up to date. I also ran through all the tests and diagnostics and there was nothing there to help my hold em fold em issue. I did discover hat when I push the flippers for the switch tests I get nothing as well. and when I try to put in a custom message where you can use the flippers to change the letter I also get nothing there. so basically my flippers go up and down for pinball use but thats it. Do we have any new ideas based on that additional info?

#939 9 months ago

Ok well first off I'm assuming this is the flipper board and is probably the main culprit right? It can't have anything to do with the flippers themselves right? I opened up the pin and I believe my pin is missing a bolt on the right side that it should have to help it open. Like on the left side I open it up and there is a bolt that kind of goes on a track that allows you to pull it close to you. The right side is missing that bolt that goes into the track. That worries me. I do have a little metal Jack on the right hand side that allows me to lift it up and then put that Jack in there to keep it open. Is this how I should be opening it or can I also open it all the way up and have it flip back on to the head box?

Anyways I couldn't see anything wrong with the flipper board, I took some pictures if something jumps out at you. I can definitely take better pictures once I'm more confident opening up the pin. Oh ya all switches did test ok.

20190616_203612 (resized).jpg20190616_203740 (resized).jpg
#942 9 months ago

When I did the individual switch test and pressed the start button for instance it would show on the screen that I was pressing that button. When I pressed the flipper buttons it wouldn't show anything on the screen. However when I first got into the switch test mode it popped up on the screen that "all switches ok" or something like that, can't remember exact wordage now.

I do have a multimeter and can definitely test each fuse and unplug and re plug in both cables.

There are two red lights on the board I believe should those be doing anything specifically?

My level of electronic experience is probably pretty low. I can definitely check and confirm on 63 and 64 passing again individually. So should I be trying to find these transistors?

Thanks again for all your guys is help, sorry I'm so noobe at this stuff.

#944 9 months ago

ok yes Ive been in that mode and it does go through the 4 ball spots like you are talking about... (side note, doesnt this game play with 5 balls and if that 5th ball inside the captured laurell bell, and if you want to replace all the balls do you just manually put the 5th ball in that captive area somehow?) Im like 90 percent sure it doesnt report the flipper switches when I press them in during that mode, but I will try that as soon as I get home just to confirm. Would purchasing a new flipper board solve my problems either way here, because they are surprisingly not that expensive I was shocked to find out.

by leds on the flipper board i mean the little red lights, attached is picture of what I was talking about.... I know in arcade game boards people can tell whats wrong with a board just based on how they are blinking or whatever. just thought Id ask.

lights (resized).jpg
#946 9 months ago

Ya I guess that makes sense. I was just surprised how reasonably priced they where. Ok so when I get home I'll try and cut out some time to check the 63 and 64 just to confirm that they aren't triggering and I'm going to try and also open the back box and make sure all the wire are connected and look reasonable at the cpu.

#947 9 months ago

ok so i officially checked 63 and 64. I held down the flippers just like i did the start button. The start button said it was being pressed and so did the 4 balls in the rough. The flippers did not say that they where being pressed so that answers that question. The red lights did flash correctly on the flipper board though in case that matters. I also checked the 5 fuses on the flipper board and they all worked and I disconnected the two cables going to and from the flipper board as well. Then I opened up the head box and checked out those wires. only one wire on cn10 was caught and seemed out of ordinary that I could tell so i fixed that real quick and nothing changed. I made sure all the other cables where plugged into the board securely. I still have exact same problem with fold em hold em sadly.

I do have two molex cables not connected to anything on the right side but i believe those are for the printer and then I have one on the left side as well by the coin door but I read that was something else... maybe bill acceptor or something. Where should I be heading to next as far as trouble shooting goes?

also this might not be right right place for this question, but does anyone know how to fix the part that makes it so the board lifts up and then goes back down. mine is missing a bolt on the right side so it has nothing to rest on when you lift it up and put it back down so it does down super unevenly and scrapes pretty bad on the right side. maybe that question is for a more general pinball thread though.

#948 9 months ago

Attached is a photo of cpu board just in case something wrong pops out to you.

20190617_183411 (resized).jpg20190617_185643 (resized).jpg20190617_185633 (resized).jpg20190617_185638 (resized).jpg
#950 9 months ago

Got it. Ok thank you. I was hoping that wouldn't be the next step ha ha. Will have to work on learning how to use those items. Thank you so much for your times guys. Appreciate it very much.

#951 9 months ago

So I read through a bunch of posts for other games where people are having a somewhat similar problem and there where several fixes that they ended up doing. Some of those fixes where easy stuff that I already tried, some where very complicated and would involve me having much more knowledge and some involved buying a new flipper board. I decided to purchase a new flipper board since I was already buying a bunch of bulbs and plastics and other misc pieces. Figure worse case scenario I'll have an extra board down the line. Hopefully the board arrives by this weekend and I'll be able to test out the new board and see if that fixes it. If that doesn't then I'll be sad and be back to trying to learn how to read schematics and use new tools. Keep you guys posted. Thanks again for all your help.

#952 9 months ago

Well a very sad update... The new board did not change anything. So at this point am I basically checking the wires that go from the flipper board to the cpu board at the back box? And seeing if there is a snag or something else along the way? Could I use a multimeter to test congruence on the wires going from flipper board to wherever they are going?

#953 9 months ago

so I discovered some more info!!! maybe you guys can help me understand it. Also I apologize that i keep leaving more and more posts on here, I dont know exactly what the rules are and Im sorry if at this point Im really annoying and just taking up space, I think it would just be super cool to figure this out and Im hoping that if we do figure this out that somebody in the future who has this problem will be able to figure it out from reading this info. so Its like 90 percent selfish and 10 percent helping others.... anywho this is the info i discovered:

Backbox circuit board relays and their functions:

PPB/MRB board relay K1: this relay controls the solenoid L/R select circuit, and is controlled by CPU transistor Q29 (TIP122). It is extremely common for this relay to have cold solder joints! If the L/R (or A/B) select coils or flashlamps do not work, this relay should be checked. This relay is a 24 vdc 10 amp relay with two DPDT switches. There are a total of 8 solder points on this relay; two connect to the winding of the relay coil (to turn the relay on and off). The other six contacts (two distinct sets of three contact DPDT switches) are the relay switches. Source number FRL264 P024/02CK, Sega part 190-5002-00.

Im reading "this relay controls the solenoid L/R select circuit" and "If the L/R (or A/B) select coils or flashlamps do not work" as my exact issue right? like when they say L/R select i assume that are talking about selecting things with the left flipper button and right flipper button? If this is the case i think we found our problem right? now how the heck do i fix it? How does one replace a relay and what does the relay even look like?

i found this relay which says its for star wars, but maybe itll work for me as well, I can probably confirm part number in my manual: https://www.marcospecialties.com/pinball-parts/190-5002-00

#956 9 months ago

oh really? I was soooo excited I thought I found it, super bummer. ok thanks for info.
Ya right now I really only have the one problem.. that i know of ha ha, Im guessing once I get the flipper push button switches working there will be other stuff that pops up, but for now just the one tiny thing holding me back. thanks guys.

#958 9 months ago

now when you say switch edge test do you mean the in house test mode. I went to the test mode and it originally says "all tests ok", or something along those lines. Then I go to the next screen and you can press different switches and it shows up that all 4 trough balls are being used. Then i press the start button for instance and it says that Im pressing the start button on the screen now as well as the 4 ball troughs. I kind of thought the original screen saying that all switches where good was basically saying that all other switches where registering correctly, but obviously that doesnt make sense because the two flipper switches aren't registering so I apologize for my obliviousness... so should I basically go through and test all the other switches and see if any other ones don't register? and see if its like a whole column or whole row or just them?.. would that be the first step? thanks again for your help.

#961 9 months ago

ohhh ok i did not realize that wayout, thank you.

ok the active switch test i believe i have already ran and had no anomalies, but I can definitely run it again. i have yet to take the balls out of the trough, so i can do that as well. I tried popping them up by using that little metal plunger piece at the bottom (i saw some guy do it in a video, he said to make sure all balls where out before you lifted playfield), but whenever i tried to do that no balls would come out, im thinking i have a different style of pinball machine. so can I just eject each ball using the test mode option that allows you to do that then?

#965 9 months ago

I was unable to flick the balls out even with the playfield down, I'm probably just not doing it right. But I know there are some other ways to get the balls out.

I will empty em all just for clarity.

And ya I have pressed the flippers in, they don't register at all on the dmd so they definitely are no working as push buttons.

But I think it finally clicked as far as testing and checking the test matrix, I was having difficulty understanding for some reason, but now I get it. Just got to test all the stuff in the column and row and maybe other items are out and maybe I can find a pattern and go from there. No clue why this wasn't sinking in before. Thanks for all your help. Once I get some more info I'll be back asking more questions ha ha. Thanks again everyone

#967 9 months ago

Oh dude this is beautiful. Thank you for the filled out diagram and all the info. Seriously thanks for the time you put in to help me out. This weekend definitely the plan. Will let you know what I find.

Side note I must have miscommunicated. The start button only comes on when I press the start button. Nothing phantom there, but I will be taking all 4 balls out and basically testing every possible switch and especially that column. I finally feel like things are going to work out. Thanks a lot once again.

#969 9 months ago

Oh ya sorry I guess in my brain it makes sense, but typing it out poorly. Basically when in the mode where it says what things are active and each item pops up on the screen. When I do nothing and the 4 balls are in the trough cuz I haven't emptied them yet it basically flashes up on the screen each ball switch. So it'll scroll through all 4 switches. Then I will push and hold down the start button as well and now it'll scroll through and name each ball switch and the start switch and then when I held down extra ball button it would show that switch being active as well. And then I would push either flipper button and sadly it will still just say the active 4 balls and no other switches. So I believe the start button and extra ball button and 4 ball trough buttons are all doing good. And then the flipper buttons aren't registering which they obviously are supposed to. So next I need to open glass and press other switches. Prior to this I was scared to open glass and press stuff by hand so start and extra ball where the only switches I was able to use the active test mode on.

1 week later
#985 8 months ago

allright team!!!! well Im finally no longer sick so i went out to the machine and finally tested all the stuff you guys had been trying to explain to me for several posts. Im super sorry for being such a dunce.... anywho. here is the verdict. the entire right column on the switch matrix doesn't work. Im like 90 ish percent sure that the rest of the switches work. There are a few lights and flashers that i cant get working but i believe those are on a different deal so it doesnt really matter for this topic. ok so all of column 8 which is the entire green grey wire. a couple odd things to note is first off the right flipper doesnt have a green grey wire at all. the left does. also there two green grey wires that are kind of connected together running side by side going from some of the switches to other switches and going to what looks to be a ground bolt randomly. I can take some pictures if that would help. are you guys able to help me out on what my next steps should be? and/or are you guys able to send me some pictures of your underside slash your flippers so i can see how my setup is different. also on the switch matrix it says row (return) CN8-9. now the green grey wire is definitely coming out of the CN8 plug, but is the green grey wire supposed to be going to the CN9 plug as well? is that what return means?

#987 8 months ago

Already posted response at other thread, but this one probably makes more sense for people looking up info in the future...

Ok let's assume the transistor ends up being shorted, can I just purchase a new transistor and remove the old one and solder in the new one? And where is this transistor that I'm testing located.. picture attached location?

And thanks so much for the info and getting back to me so quick

Screenshot_20190706-203019_Gallery (resized).jpg
#989 8 months ago

There is legitimately one 5 minutes from me... Yessss. I have a multi meter that I used for arcade dc testing. I've never used it like your suggesting though, but I'll try and figure it out. And then I'll hopefully find a YouTube video of someone replacing a pinball transistor.

#991 8 months ago

Ok so q48 definitely doesn't look so hot. I think maybe some one tried to fix this before.... Maybe? Attached is pic of backside of board. What should I do? BTW Q48 is the top one

20190707_092019 (resized).jpg
#993 8 months ago

Ya that scares me a little bit. Makes me think someone already tried this fix. Anywho. I went to Fry's and according to Google this is the transistor cross over version. But I used the 20 ohm on the transistor before connecting it to the board and I only get something when I go from the middle connector to either outside connector and I have to have the red probe on the middle connector and black on outside ones. And if I go outside pin to outside pin I get nothing. Does that make sense or did google lie to me and I got the wrong transistor?

20190707_175204 (resized).jpg
#995 8 months ago

I don't think Fry's does. But I can try harder. Oh 2k. I think I was using 20. But I can double check that as well. I typed in the 2n3904 part on Google and the nte123ap was the cross over supposedly. I don't think Fry's had any numbers even close to 2n3904. All the numbers where nte31 all the way to like nte908 or something like that. Nothing that seemed even in the same category as 2n3904. Maybe I will just purchase that exact number online. Will take a bit longer to get, but I probably won't have time to work on until next weekend anyways.

#996 8 months ago

These ones are the exact right ones right? And I'm getting a couple 100 for 5 bucks when I just paid 2 dollars for 1 at Fry's ha ha. Just wanted confirm these where correct right?

Screenshot_20190707-191245_Amazon Shopping (resized).jpg
#998 8 months ago

Oh ok I'll try Fry's again. In the meantime I did go to the nte website and there was an arcade or electronics distributer that had a website. I order a few from them just in case my Fry's is out of stock. Thanks. Keep you posted on after the install.

#1000 8 months ago

Oh gotcha ok that makes sense. Well now I got nte ones coming so that should solve that problem. Now I just gotta work on installing it correctly and not ruining other stuff as I do it.

#1002 8 months ago

First off... Holy crap! How is your display in sweet color! Sonic looks so tight!

Second off I replaced the transistor and no change what so ever. Now it is possible that I replaced it poorly, I'm not very good with a soldering gun, but I feel like it might be something else. The fact that the board had already been repaired at q48 makes me think whoever had this machine before me tried the exact same thing. I was thinking about buying a new computer board but they are like 300 bucks which is a bit pricey, but probably cheaper then someone coming out to fix it actually. Ok so are there other tests that I should be running and does anyone know any video tutorials for those tests? Or should I bit the bullet and buy that new mad dog board or whatever it's called...?

#1004 8 months ago

None of them register at all. So transistor or main board problem then?

#1006 8 months ago

I'm pretty sure I installed the transistor going the right way. The plastic head kind of has a design to it and I made sure the one I installed looked the same as the ones behind it. I can try and ohm test though and confirm it was done correctly. My fear is that the previous person was a bit messy and then I was even more messy and I feel like we may have jacked up this area with solder and burn marks and what not. Could this circled area be damaged and therefore be causing the issue?

Also do you know of a place that repairs them? I just assumed I would have to pay for shipping back and forth plus the repair of course which I thought would add of pretty quick, and then if there's a place in socal, its probably pretty pricey. But if you know of a place or a guy or something, definitely let me know.

20190715_141104 (resized).jpg
#1007 8 months ago

side note to test that i dont have a solder short between the legs should i just put a prong on each leg and basically compare it to the transistor next to it and make sure they are the same?

#1009 8 months ago

and will that damage on the backside of the board cause any issues?

#1010 8 months ago

just confirming... do we know for a fact that its supposed to be a 2n3904? because i feel like it is reading very very differently then the transistors that are next to it... I looked in the manual but it didnt list any transistor numbers.

i did find a pinball repair website that did agree with you that 2n3904 was correct for q48 though, it also said you could use NTE 123AP and so is a 2N4401

on the pinball repair website it also said this:When Replacing Bad Driver Transistors...
ALWAYS check the coil mounted diode too! Often the coil mounted diode will break, causing the driving transitor to fail. If the diode is not replaced also, the driving transistor will fail again and again. This is often overlooked in DataEast/Sega games.

is this something i should be doing for q48 transistor?

#1012 8 months ago

Looks amazing weed! I feel like post 1001 found a way, looks awesome.

On my fix it front, found a guy that everyone recommends named Jerry to fix my cpu board. I'm gonna send it in and have him do it before I ruin it any further. Thanks so much for all your guys help, and sorry I took up so much of this thread with my crap.

I am going to try and do some tests to make sure it's the board first. I think I saw some other threads about how to do that, so hopefully I can follow those with some success. Thanks again guys!

#1016 8 months ago

not related, i was afraid that was going to be the case. thank you

here is the top of the board

and ya post 1001 has a fully colored one right?

11b18dba13918e062e7b29cc22ec84da7cc5659f.jpeg (resized).jpgq48 (resized).jpg
#1018 8 months ago

It's officially the board. Thanks for all your help guys again. See you on the other side.

And side note seriously post 1001 seems to totally have full color just saying.

#1027 8 months ago

so weeds is a colorDMD, what is post 1001s? Isnt that basically a color version but like full color of what Weed has?

1 week later
#1031 8 months ago

And even though those sound like pretty much the exact same words they aren't the same thing.... got it.

2 weeks later
#1034 7 months ago

So just to let everyone know how it turned out. My board had a damaged trace at the q48 transistor. Once the damaged trace was fixed by someone with better soldering skills then me I am 100 percent up and running. Well almost... does anyone have any close up pictures of there Lauren belle assembly? I think my rubber belt fell off. Thanks guys for everyone who attempted to help me through this process.

#1037 7 months ago

Oh ya mine is definitely missing that black rubber belt! Thank you so much. Is that belt easy to install or do I have to take a whole bunch of stuff apart to get to it?

#1039 7 months ago

Beautiful. I think I already accidentally bought one so hopefully it's as easy as you suggest. Thank you sir.

#1040 7 months ago

Oh hey do you do that work from underneath so lift up the table? Or do you do it from above so just take off the glass?

#1042 7 months ago

I will give it a whirl and post back if I can't figure it out. Thanks.

#1044 7 months ago

I am at a loss. I started to take some stuff off, but then I realized I needed to go much much deeper. I feel like no matter what I take off I will have to take off more and more to get to it. Is there something I'm missing here. Any hints or videos of somebody doing this? Attached is my pic from above and below.
20190823_091804 (resized).jpg20190823_091843 (resized).jpg

#1046 7 months ago

This whole deal??? Is it just the two screws on each side?

20190824_074104 (resized).jpg
#1047 7 months ago

Yes! Got it around it. Thank you!

#1049 7 months ago

I AM ENJOYING MY GAME!!!! this is the first time its been 100 percent and its sooooooo friggen fun!!! I have absolutely no idea what im doing when it comes to the scoring and the rules and the combos and all that, but now that I can raise or fold and the ball can lock and get multi ball... oh oh and I get to play blackjack!!!!! dude its so awesome. I need to figure out how to play so I can someday have a highscore on my own game in my own house, but hopefully thatll happen someday... my real goal is to get that extra trapped ball under the boat, but wow it seems like an impossible shot. thanks a lot guys ill probably be talking to you shortly about my next problem ha ha. thanks!!!

#1055 7 months ago

guys Ive looked at my board and Ive looked at a bunch of pictures of other peoples boards on here and I cant seem to figure out where the dice and the jack plastic pieces go, does anyone have these on theres? attached is the photo and below is the ebay listing:
ebay.com link » Maverick Data East Pinball Machine Original Playfield Plastics Shields Lot Of 10

and then this one i cant figure out either:
ebay.com link » Maverick Pinball Machine Playfield Plastic

s-l1600 (resized).jpgs-l1600 (1) (resized).jpg
#1064 6 months ago

im super new to the pinball game, but I love my maverick even though I have yet to get it 100 percent working.... and of course the wife is going to prefer having Mel Gibson in his prime staring at her rather than Pamela Anderson. Hope you love it.... Im still very confused by the color DMD thing, just saying. Maybe after you get it post some pics.

#1065 6 months ago

new fun issue. the ball lock keeps going off while Im playing. The white plunger underneath the boat will every few minutes randomly go off. The game then things I have a locked ball and will release another ball at the plunger start. Even when the game is over but still turned on that white plunger by the boat will go off. I see that there are 2 sensors on the left and 2 sensors on the right. Which ones need to be replaced when this starts to happen?

20190823_091843 (resized).jpg
#1069 6 months ago

There are 6!!!! Where the heck are the other 2!? I see two on the left and two on the right. Am I missing something?

#1071 6 months ago

ok that makes sense wayout. Now if the ball is randomly locking here and there and shooting me out a ball and making that weird clown laugh that would suggest that its the lock optos and not the entrance optos. So for now I can just focus on the 4 lock optos then right?

Also I did find the part pretty easily for the lock optos sensors transmitter and receiver sold as a set, now if all my attempts to fix and correct fail and I do need to buy this product. Is it the same product for the left and right side?... trans and recieve on one side, trans and reciev on other side?

#1073 6 months ago

No whistle. Just a clown type laugh and that weird jester dude on the screen locking up the ball. But I will do my best to get an index card and check out those lights. They are probably just slightly off or loose. Because sometimes everything will be good for a while until I hit the button real hard or slam on the side of the cabinet.

#1075 6 months ago

So I took off the boat and one of the wires was loose on the right opto board and it wasn't exactly pointed correctly as well. I messed with them all a little bit and now I haven't had any issues yet. I'm assuming over time the bumping will probably move them out of place again but for now I officially have everything working 100 percent. thanks guys! I can now continue on my goal to get that captured ball

4 weeks later
#1093 5 months ago

mine doesnt go past the apron, it sits a little bit back when not engaged. I had to purchase a strong spring. I think they have like black, red, and yellow which are different power settings. I purchased a stronger spring and it wraps around that ramp with ease now.

#1098 5 months ago
Quoted from mad_carl:

my rubber kit came with a green. which color are you using now?

I have a red spring, which now Im looking at your tension guide is the strongest one so no wonder it shoots all the way around with ease ha ha. I have the yellow DE poker chip rod as well. Im thinking red is probably over kill, but I do know for a fact that green was too weak (my green may have been weaker cuz it was older of course). I also read on another forum that several people where having trouble with the green spring even though that what was listed in the manual. I probably could downgrade to orange like the other poster, but with the red it doesn't feel unnaturally strong or anything like that. I havent tried the other springs though, maybe if I tried purple or orange it might feel better.

#1100 5 months ago

let me know how the orange spring treats you, i might need to drop my spring power down a bit.

4 months later
#1175 46 days ago

One is bidding on Ebay now starting at 40 bucks.

Promoted items from the Pinside Marketplace
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
Wanted
Machine - Wanted
Collingwood, ON
From: $ 9.99
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 369.95
Boards
PinSound
€ 339.00
Displays
GermanGamingSupplies.com
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
Wanted
Machine - Wanted
Levittown, NY

You're currently viewing posts by Pinsider sirgubster9.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside