We're back!

After a disaster in our datacenter took down our server, we are now running Pinside on a brand new server. However, things may not work as expected as we are still polishing the playfield and adjusting some switches! We might be switching to maintenance mode a few times. Please see this forum topic for more info.

(Topic ID: 79446)

Maverick fan thread - We play till we drop, winner takes all!


By Atomicboy

7 years ago

Topic Heartbeat


Topic Stats

  • 1,449 posts
  • 130 Pinsiders participating
  • Latest reply 5 hours ago by Williampinball
  • Topic is favorited by 45 Pinsiders

You

Linked Games

There are 1449 posts in this topic. You are on page 23 of 29.
#1101 1 year ago
Quoted from Sirgubster9:

let me know how the orange spring treats you, i might need to drop my spring power down a bit.

So the orange spring definitely has enough power to at least get me to the flipper skill shot hole (4) with ease but definitely not enough punch to make the ramp loop.

That being said, I just finished shopping the playfield and haven’t even looked at the pitch/level of the game. I know it’s off but I still have some cosmetic work to do. The legs and lockdown bar are a mess and need some attention. Already started stripping all the paint off of the lockdown.

For anyone interested, here is what I have done so far. Lit the Lauren Belle and ball trough. Still waiting on a replacement 5 drop target bank to replace the mangled one in there and a knocker assembly that is missing. I also made up some apron cards while I was waiting on the rest of my parts order

1ABAF3FE-2116-4FA5-BEBC-21E20DDF6A80 (resized).jpeg37341957-1870-4AE3-826C-8937BA705218 (resized).jpegD602F367-50BB-41A0-ABE0-EE73BB64F79F (resized).jpeg
#1102 1 year ago

Hello, have hopefully a quick question for everyone. I’m replacing my Lauren bell motor, it’s really loud and struggling. In replacing the old one (right in photo) with the one I bought from Marcos (left) I noticed that the old one has a light and resister across the connection wires? Anyone know what they’re for as they’re not on my new one. Also, really stupid question but it looks like my motor is wrapped in tape in the new one? Do I need to take this off? Sorry, I’m still learning all the electrical stuff. Thanks in advance.

C114C1B0-C1E8-4DD5-BCAD-BA32F610A2D1 (resized).jpeg
#1103 1 year ago

Data east yellow shooter rod and the orange spring
Mine works well

#1104 1 year ago
Quoted from KrazyIvan14:

Hello, have hopefully a quick question for everyone. I’m replacing my Lauren bell motor, it’s really loud and struggling. In replacing the old one (right in photo) with the one I bought from Marcos (left) I noticed that the old one has a light and resister across the connection wires? Anyone know what they’re for as they’re not on my new one. Also, really stupid question but it looks like my motor is wrapped in tape in the new one? Do I need to take this off? Sorry, I’m still learning all the electrical stuff. Thanks in advance.[quoted image]

Controlling arc damage from coils and motors is done by suppressing inductive kickback. A neon lamp serves the same basic function as an MOV, with slightly less precision and at lower voltages. In this case, when the voltage climbs high enough to light the lamp, the inductive energy dissipates through the element. When neon lamps are used for transient suppression, they are placed in the same location as the MOV

1 week later
#1105 1 year ago
Quoted from KrazyIvan14:

Hello, have hopefully a quick question for everyone. I’m replacing my Lauren bell motor, it’s really loud and struggling. In replacing the old one (right in photo) with the one I bought from Marcos (left) I noticed that the old one has a light and resister across the connection wires? Anyone know what they’re for as they’re not on my new one. Also, really stupid question but it looks like my motor is wrapped in tape in the new one? Do I need to take this off? Sorry, I’m still learning all the electrical stuff. Thanks in advance.[quoted image]

I was concerned about this as well and I just put it in as it was and have had no problems. Hopefully I won’t in the future. I asked Marco and they were not sure.

#1106 1 year ago
Quoted from Damagio:

I was concerned about this as well and I just put it in as it was and have had no problems. Hopefully I won’t in the future. I asked Marco and they were not sure.

I did the same motor swap close to 2 years ago and haven't had a problem. my old motor looked like the one pictured, the new motor i got a parts lots purchase so not sure where it came from but also looked like this one in the pic. the new one is definitely a lot quieter.

#1107 1 year ago

I have recently joined your ranks as a Maverick owner. Last week a lady called me at my Pinball Repair business and asked me to give her $500 for her old broken Pin. So I went to check it out and it was a one owner, Maverick that didn’t boot! It has some minor sun fade on the right side and heavy sun fade on the plastics... but other wise in great shape!

Needless to say, I bought it and took it home... on its Birthday even!! October 25th!

I put in a Rotten Dog MPU while I diagnose the original MPU. I just finished stripping and cleaning everything, installed all new Titan Rubber everywhere and new bulbs. No LEDs. I also installed all new drop targets and decals from Marco. However, many of them are badly warped, so I may have to do that again.

Now I am chasing down multiple switch issue, but once I have it fixed it should be a hoot!

Here are a few pics. Not bad for $500 and a 30 minute drive.
3839DABF-90F5-4550-ABF8-D3FB83430141 (resized).jpeg44991F8B-34D0-4360-AB19-816FDB2B0413 (resized).jpeg6481096B-A5C8-49FF-8360-66BC4FC8F4C4 (resized).jpeg67C570C5-9973-47B8-ABB6-136A9AD6A613 (resized).jpegE0E5B037-BB34-450C-BC10-DDC559D617C0 (resized).jpegE6965CAE-8981-4B29-A782-C4FBE8C9F1C5 (resized).jpeg

1A588831-280B-4C24-85FE-37F6ABD8AFBA (resized).jpeg
#1108 1 year ago

One heck of deal for that price.
I love mine, good rule set and a lot of fun to play!
Congrats!

#1109 1 year ago

Awesome deal for sure!

I thought i got a good deal for mine at $800 a few years ago. My was suck with the Open Coin Door message because the batteries were dead and they didn't know where the key was. My cab has a few dings on the front but yours is really nice.

Congrats its a really fun game

#1110 1 year ago
Quoted from BertoDRINK1:

Awesome deal for sure!
I thought i got a good deal for mine at $800 a few years ago. My was suck with the Open Coin Door message because the batteries were dead and they didn't know where the key was. My cab has a few dings on the front but yours is really nice.
Congrats its a really fun game

I paid $1500 for mine, but it didn't need any work at all. As it turned out, it is one of my favorite games and isn't going anywhere - no regrets!

#1111 1 year ago

I’m very happy with mine. Now if I could just figure out what is wrong with it. Apparently, slapping on the side triggers several switches. And several drop targets seem to cause an end of ball.

Slowly but surely. I also need to rebuild all the opto sensors

#1112 1 year ago
Quoted from RandyW:

I’m very happy with mine. Now if I could just figure out what is wrong with it. Apparently, slapping on the side triggers several switches. And several drop targets seem to cause an end of ball.
Slowly but surely. I also need to rebuild all the opto sensors

The slapping on the side will likely be the easiest to troubleshoot. Check the gap on your switches. Run the switch tests for the drop targets, making sure each indication is only one and the correct switch. What exactly happens at this "end of ball"?

#1113 1 year ago

That’s the odd thing. I have tested every single switch and they all report only firing their switch. All SEEM to work fine. But I’ll be playing a game, the ball will strike a seemingly random drop target and it just ends the ball. My bonus will start counting and the flippers go dead. Then it spits out the next ball.

I say it seems random, because it has done it on almost every drop target at least once. But, if I hit the king and ace of spades at the same time.... ball ends almost every time.

#1114 1 year ago

Sounds like a connector issue loose.
See if they are all related to the same connector on the boards

#1115 1 year ago

I’m having a hard time discerning what is causing the ball to end. What is the trigger for that in this game?

*Edit*
It is the trough roll overs and CPU Logic.

#1116 1 year ago

The more I screw with it, the more I agree it is a connection issue. It eems to be vibration based.. not drop target based... Which is why it
moves around.

*Edit*
It seems with your all's help, I have solved that issue. The ball trough rollover harness was zip tied to the coil for the sling. The zip tie was pushing the connector apart. Once I fixed that, I am now able to play a game, without the ball ending prematurely!! Thank you!!

Now to pull it all back apart, to get at the optos for in front of the wheel.. and try to fix them.

#1117 1 year ago

That took a while, but it is now playing seemingly 100%. Is the paddle wheel supposed to run the entire time a game is playing? That seems like unnecessary wear on the motor.

#1118 1 year ago
Quoted from RandyW:

That took a while, but it is now playing seemingly 100%. Is the paddle wheel supposed to run the entire time a game is playing? That seems like unnecessary wear on the motor.

Mine does. I had to replace the motor not long ago. I paid $1800 and had some issues at first but it’s running like a champ now. Love the game. You got a great deal.

#1119 1 year ago

It is officially done. It was completely stripped and cleaned, all new Titan Rubber and all new bulbs. All six options have been repaired and multiple shorts and bad connections fixed.

Addams has a new set of Titan Rubber waiting on it as well. I’ll start in it’s shop job next.

BTW, this is my great deal wall. I have less than $3600 in all three tables. TAF and Maverick both were bought from their original owners. Paid asking price on both.

EB2D5BE2-4C5D-48AE-9714-906A277755B6 (resized).jpeg

#1120 1 year ago

That didn't last long. I got about 20 games in and it went haywire again. I think, instead of fighting with possible connector issues under the playfield, I am just going to go ahead and replace all of them with something else. Maybe weatherpack connectors.

Added 17 months ago:

I replaced the trough switches and the problem went away. YAY!!!!

#1121 1 year ago

Looking for a Maverick if anyone looking to sell thanks,

#1122 1 year ago

I replaced every piece of rubber on my Maverick with Titan rubbers. Even those odd short post rubbers. It looks and plays phenomenally!!! I also created a black and a white kit of Titan's site, for Maverick based off of what I used to do mine. Enjoy!

2 weeks later
#1123 1 year ago

Well, after a couple weeks of chasing issues... I have decided to replace every single switch diode on the table. I cannot seem to track down my random switch issues. I have fixed a couple, but more always turn up and so far, all but one has been a blown diode. I have no idea what fried so many of them.... But it must have happened when the MPU burned up the 3W resistors.

1 week later
#1124 1 year ago

Update, for posterity. Maverick is now playing at 98%!! The issues found were, a bad diode on the right slingshot, a bad diode on the VUK, Bad diodes all 4 on the start and buy in buttons, bad buy in button, bad ramp switch, broken VUK armature, rebuilt all 6 opto boards, all new drop targets.

Not bad all in all. I am also going to replace the slingshot plastics. And any others I can find.

The only issue I have left is a real head scratcher. It is impossible, seemingly, to get the middle (2) skill shot. It will always give you 1. I have checked, all 4 skill shot switches activate, every time a ball rolls over them. But send the ball into hole 2 and you will always get the 1 skill shot reward instead.

#1125 1 year ago
Quoted from RandyW:

The only issue I have left is a real head scratcher. It is impossible, seemingly, to get the middle (2) skill shot. It will always give you 1. I have checked, all 4 skill shot switches activate, every time a ball rolls over them. But send the ball into hole 2 and you will always get the 1 skill shot reward instead.

Might be the switch needs better adjustment for it to register when a ball drops on it in gameplay versus testing?

#1126 1 year ago

I have tried it six ways from sunday, it always registers. I guess I will just go ahead and replace it, see what happens then.

#1127 1 year ago
Quoted from RandyW:

I have tried it six ways from sunday, it always registers. I guess I will just go ahead and replace it, see what happens then.

This 100%. Adjusting that switch will drive you crazy. Replace and be done with it.

#1128 1 year ago

I do have to say, it is going to almost be a shame to sell this table when done. It turned out to be a LOT more fun that I ever expected. But the proceeds from it will fund my A13 restore and my High Speed restore.

#1129 1 year ago
Quoted from RandyW:

I do have to say, it is going to almost be a shame to sell this table when done. It turned out to be a LOT more fun that I ever expected. But the proceeds from it will fund my A13 restore and my High Speed restore.

I bought mine with the intention of selling it 6 months later...here we are 3 years later and I doubt I will ever sell it
It’s a great pin. I love the rule set. The only thing I would have liked is a better ramp setup.

#1130 1 year ago

My biggest gripe, is how the paddle wheel runs all the time during game play. I don't care for the constant noise.

#1131 1 year ago

Joined the club rescently.
Picked up a really clean machine with the exception of the post being broken off next to the drop target bank.
Waiting for parts to come in from Marco to replace the broken post for fear of messing up the drop targets with a direct hit from the upper right flipper.

Looking forward to playing this and getting familiar with the rule set.

F776F04C-40A4-49E3-A88D-C06A6486E4EC (resized).jpeg
#1132 1 year ago
Quoted from Coindork:

Joined the club rescently.
Picked up a really clean machine with the exception of the post being broken off next to the drop target bank.
Waiting for parts to come in from Marco to replace the broken post for fear of messing up the drop targets with a direct hit from the upper right flipper.
Looking forward to playing this and getting familiar with the rule set.[quoted image]

Welcome and enjoy!

#1133 1 year ago
Quoted from Damagio:

Welcome and enjoy!

Thanks man.
I’m actually really looking forward to getting acquainted with this pin. The rule set and gameplay intreages the hell out of me. I feel like this pin will make me a better shooter if I log some time on it.

#1134 1 year ago
Quoted from Coindork:

Thanks man.
I’m actually really looking forward to getting acquainted with this pin. The rule set and gameplay intreages the hell out of me. I feel like this pin will make me a better shooter if I log some time on it.

There is ALOT of strategy needed if you want to make it to the Poker Championship.

#1135 1 year ago

Ok, so it is time to order parts to repair the MPU on my Maverick, so the replacement RD can go into Batman forever.

These entire sections are pretty well smoked. Are there any updates I should do? Or is it just pretty much replace same with same?

7924CD33-7865-4EEA-A31E-E6B799883532 (resized).jpegD6B0F0EF-CF22-4EC9-AD1E-A299E1A19CFE (resized).jpeg
#1136 1 year ago

Strange behavior. Looks like my rows are shorted on my switches (white wires). When I activate one switch it activates them all. Most noticable on the left flipper when it slam tilts. Did not do this before I shopped it. I did take out one of the drop target banks but did not modify any wiring (changed targets and lights underneath). Any thoughts on where to check? Thanks.

#1137 1 year ago
Quoted from ViperJelly:

Strange behavior. Looks like my rows are shorted on my switches (white wires). When I activate one switch it activates them all. Most noticable on the left flipper when it slam tilts. Did not do this before I shopped it. I did take out one of the drop target banks but did not modify any wiring (changed targets and lights underneath). Any thoughts on where to check? Thanks.

Check/replace all of your Diodes on those switches. I just spent a month chasing down a similar issue.. see my previous posts.

#1138 1 year ago
Quoted from RandyW:

Check/replace all of your Diodes on those switches. I just spent a month chasing down a similar issue.. see my previous posts.

Thanks, I was leaning that direction. I probably messed something up when I pulled out the drop target bank.

#1139 1 year ago

I will get to work on the diodes but when I was checking the switches I noticed that none of the drop targets registered, would they normally show closed when dropped (on switch test)?

#1140 1 year ago

Off the top of my head, I believe that yes they should register closed when down.

#1141 1 year ago

Yes, they register as closed when down. Check and make sure that when down they are indeed making contact.
Also, the wires on the drop targets have a habit of getting pinched between the PF and cab. Make sure none are broken, or cut.

If you can't find anything, find the two connections for them on the board and jumper them, see if the switch works. That section of the MPU on my original board is fried. I am just about to rebuild it.

#1142 1 year ago

Also switches only register for a second on one of the switch tests. you may have to go to Active Switches.

#1143 1 year ago

You are correct, the drop target banks all work in active switches. Makes me feel a little better. Have checked about 20 or so diodes, they all look good so far. Will keep grinding tonight.

Edit: I just put a new rottendog board in when I got the machine. The original had some bad acid damage. I don't think it is the board but wanted to clarify that point.

#1144 1 year ago
Quoted from ViperJelly:

You are correct, the drop target banks all work in active switches. Makes me feel a little better. Have checked about 20 or so diodes, they all look good so far. Will keep grinding tonight.
Edit: I just put a new rottendog board in when I got the machine. The original had some bad acid damage. I don't think it is the board but wanted to clarify that point.

I was unable to find the faulty diode from a test. I just found the switch column that all my errors were on and replaced them all, one by one, until I found the one that solved all of my issues. In my case, it was the one on my right slingshot switch. I tested that diode prior to replacing it, it tested fine. Even with the switch active.

#1145 1 year ago

Started working on my Maverick over the weekend.

Got the two broken off posts replaced.
One I was able to back out the broken screw, the other I had to drill out.
Either way both are fixed and replaced now.

While I was at it, I put in some LEDs in to lighten things up a bit.
Also took the Laura Bell apart and reflowed the solder on all of the optos and connectors.
I did all six of them and it seems to have corrected a bunch of the problems with the balls locking up, not registering or feeding three balls.
It was a total bitch to get to those last two optos, but got it done.

Quick question. Is there anything else like the optos that need attention?
Known problems or general preventative maintenance that I should do while I'm at it?
Game seems to be playing well now, just want to bang it all out at once if I can.

So far I've played about 10 or so games and its playing pretty smoothly now.
I'm really liking this machine so far.
Not sure why it wasn't on my radar before, but this game is awesome.

#1146 1 year ago
Quoted from RandyW:

I was unable to find the faulty diode from a test. I just found the switch column that all my errors were on and replaced them all, one by one, until I found the one that solved all of my issues. In my case, it was the one on my right slingshot switch. I tested that diode prior to replacing it, it tested fine. Even with the switch active.

I might just do the same. My issue is that it affects multiple rows and that I don't think there was a problem before. Thanks for the advice!

#1147 1 year ago

After saying some horrible things about the maverick machine (I took most of them back) I think it ended up being a board issue. I disconnected the swich matrix from the playfield and replicated the behavior with a diode and an alligaotr test clip. I immediately checked the mosfet but it checks out ok. Anyone have thoughts on where to look next? Video below. Once again new rottendog board, not original.

https://photos.app.goo.gl/ZYBb48qj2RVc9jjT7

#1148 1 year ago
Quoted from ViperJelly:

After saying some horrible things about the maverick machine (I took most of them back) I think it ended up being a board issue. I disconnected the swich matrix from the playfield and replicated the behavior with a diode and an alligaotr test clip. I immediately checked the mosfet but it checks out ok. Anyone have thoughts on where to look next? Video below. Once again new rottendog board, not original.
https://photos.app.goo.gl/ZYBb48qj2RVc9jjT7

Didn't see a video. I got a static image in Google Photos????
Check upstream logic from the driving transistor, it can't be much different than the original board, since it is probably running the same software.

#1149 1 year ago
Quoted from Coindork:

Started working on my Maverick over the weekend.
Got the two broken off posts replaced.
One I was able to back out the broken screw, the other I had to drill out.
Either way both are fixed and replaced now.
While I was at it, I put in some LEDs in to lighten things up a bit.
Also took the Laura Bell apart and reflowed the solder on all of the optos and connectors.
I did all six of them and it seems to have corrected a bunch of the problems with the balls locking up, not registering or feeding three balls.
It was a total bitch to get to those last two optos, but got it done.
Quick question. Is there anything else like the optos that need attention?
Known problems or general preventative maintenance that I should do while I'm at it?

Upgrade the DMD wiring harness according to service bulletin #106. Pinball Life carries the part.

#1150 1 year ago
Quoted from wayout440:

Upgrade the DMD wiring harness according to service bulletin #106. Pinball Life carries the part.

Thanks brother, ill check it out.

On another note, how did I not get into this game sooner?
I guess I just kind of passed it up because the theme at the time didn't really speak to me at the time.
I'm having a ton of fun with this machine and really love the gameplay.
What a great game.

There are 1449 posts in this topic. You are on page 23 of 29.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside