(Topic ID: 294787)

Magic City won't start new game.

By Tonup69

4 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 4 months ago by Tonup69
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

pasted_image (resized).png

#1 4 months ago

Hey guys - been playing my Magic City a lot after a minor rehabilitation a few months ago. Other than a weak right flipper coil, it plays fine - until today. Turned it on and it wouldn't start up a new game. Touched the left flipper to turn on the lights - they would go on but not stay on. Tried to trip the lock relay manually and the lights stay on, but no new game. The playfield is dead, but the machine says I am on ball one. As I said, been playing the machine, so this was not something I knocked off or messed up while working on it. Just all of a sudden - nothing. I can manually fire some of the other relays and get the relay bank to reset - score motor is not stuck.

Where do I look for this problem?

Yes I have a schematic.

Thanks in advance.

LTR

#2 4 months ago

If the Replay Button doesn't activate the Coin relay, Inspect and diagnose this circuit with Alligator clip jumper wires
https://pinside.com/pinball/forum/topic/gottlieb-big-shot-repair#post-6305153
http://www.planetimming.com/Pinball/troubleshooting/EM%20Troubleshooting.pdf
http://www.pinrepair.com/em/index3.htm#features
Example of a pinsider actually doing this https://pinside.com/pinball/forum/topic/red-baron-tech-question#post-5858156
Be careful because this circuit runs on 120 volts

pasted_image (resized).png
#3 4 months ago

Thanks. I will check the coin RE.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside