(Topic ID: 285312)

LW 3, launch coil and transistor replaced, worked for 2 days now not launching

By blantonwh

6 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 6 months ago by blantonwh
  • No one calls this topic a favorite

You

Linked Games

#1 6 months ago

So, I have replaced the transistor, coil and resistors and it worked great for 2 days. Then all of a sudden when playing the launcher would not launch the ball any longer. I checked the coil through the DMD and coil test. It is not firing the coil. I checked the fuse and it is still good.

Any ideas on how to proceed with fixing this? What would cause the transistor to go out again if that is the problem?

Thanks to all for any recommendations.

#2 6 months ago

Lost continuity across or through the board around the transistor ?

LTG : )

#3 6 months ago

LTG, thanks for the reply. I will check that again as the previous fix prior to mine was botched. The person that did it before damaged the board and the traces. I had to scrape off the green fiberglass coating to reveal some fresh trace and then bridge solder to my transistor legs. Maybe something wasn't soldered good enough and the movement of the machine caused it to loose connection.

Do you know of a better way to fix the traces without replacing the board? I will upload pictures later so you and the forum members can see the extent of the damage to the board and traces. A new board may be warranted.

Thanks again.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside