(Topic ID: 265592)

loud pop on ST-TNG when powered up


By monkeygiggles

65 days ago



Topic Stats

  • 6 posts
  • 6 Pinsiders participating
  • Latest reply 64 days ago by ElkhartPinball
  • No one calls this topic a favorite

You

Linked Games

#1 65 days ago

Pulled my ST-TNG from storage, and got her back up and running. (got nothin' else to do). When you turn on, after 1 sec. a load pop comes from speakers then normal "test" screen. Games runs fine and 100%. removing J1 and j2 (speaker out) removes pop. I've heard about this in the past but its been awhile. Anybody wanna refresh my memory ? BTW: anyone know where Jonathan Frakes may be hiding? He's the only one I don't have a signature from on my translite.

#2 65 days ago

Mine has done this on start up and power down for the 4 years I’ve had it.

#3 65 days ago

I had one that did the same. Annoying as fuck but harmless....at least mine was.

#4 65 days ago
Quoted from monkeygiggles:

BTW: anyone know where Jonathan Frakes may be hiding? He's the only one I don't have a signature from on my translite.

He will be on the Star Trek cruise if they don’t cancel it.
https://www.startrekthecruise.com/

Ps : Mine always popped, I never worried about it.

#5 64 days ago

Games making a loud pop at start up or shut down is normal and won't hurt the machine. There used to be no-pop boards that would eliminate the pop. The remaining stock was sold to Rob Anthony, so you might reach out to him to see if he has any left.

Promoted items from the Pinside Marketplace

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside