(Topic ID: 220973)

LOTR LE - Backbox light off

By bmlors

3 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by bmlors
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

pasted_image (resized).png
IMG_1578 (resized).JPG
IMG_1577 (resized).JPG

You're currently viewing posts by Pinsider bmlors.
Click here to go back to viewing the entire thread.

#1 3 years ago

First, I know I'm an idiot...shouldn't have done what I did. But, I'm hoping it's something simple...

I recently purchased a LOTR LE and while setting it up, I laid the backbox down without removing the DMD. And, the DMD slid out onto the main table...seemed fine. However, now my backbox light is off (everything else works completely fine), so I'm assuming a cable just got pulled out somewhere.

There is a cable running from the power board (CN2 connector) to the DMD and then a larger connector that isn't hooked to anything -- see the attached picture. I can't figure out from the wiring diagrams where this is supposed to be going. So perhaps this is my issue or maybe something completely independent.

Any suggestions?

IMG_1577 (resized).JPGIMG_1578 (resized).JPG
#3 3 years ago

Thanks for the confirmation on that cable. Turns out the bulb had been jarred loose/turned. Got it snapped back into place and all is well again.

You're currently viewing posts by Pinsider bmlors.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside