(Topic ID: 124959)

LOTR display is possessed… need help.


By NEOphyte

5 years ago



Topic Stats

  • 11 posts
  • 5 Pinsiders participating
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

sb157.pdf (PDF preview)

You're currently viewing posts by Pinsider NEOphyte.
Click here to go back to viewing the entire thread.

#1 5 years ago

I recently installed a ColorDMD in my LOTR… no problems, everything looked great. Fired up for a game tonight and the display is not showing anything related to what's happening on the play field. Everything looks good, it just has nothing to do with where I am in the game. The game physically plays fine and the audio/call-outs are what you'd expect, but the display is doing it's own thing.

I tried reseating cables, chips, replaced batteries… nothing has changed. I have the chips required to install a shaker, so I installed all three thinking it might be a bad game ROM, display, etc. no change. I'd like to try a reset, but I can't see where I'm going.

I feel like I might be out of my element with this one… fixing plastics and bulbs is where I like to be.

Any ideas?

Thanks in advance!

#6 5 years ago

Thanks guys, I appreciate all the help.

I should probably make it clear that after I installed the ColorDMD and before I replaced any of the ROM chips, the game worked fine (and looked incredible!). It was working fine for about a week, and then decided to go crazy yesterday. I've tried reseating cables, reloading the ColorDMD software, etc. I only replaced the ROM's because I had them and thought that one might have been corrupted… it didn't change anything… still crazy.

Could a faulty battery pack cause these issues? There's no sign of leakage and I replaced the batteries at Christmas, but it's still mounted on the board (I'm going to try and move it off the board this afternoon).

You should see this thing… it's bringing up crazy stuff… this morning it displayed "120! Secret Message"… I feel privileged that it wants to share its secrets with me (I just don't understand them).

Thanks again for any insight!

#8 5 years ago


A few new things have popped up. Looks like there's been a reset. The machine is now asking for coin when it was previously on Free Play, and the it's set for 3 ball when it was previously on 5.

There is a delay/freeze now in what the display is showing, and in the second vid you will see the game play is now being affected. It awarded me Fellowship Multiball while running the POTD (having not made a single shot and playing with one hand).

Thanks.

Promoted items from the Pinside Marketplace
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 16.00
$ 219.99

You're currently viewing posts by Pinsider NEOphyte.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside