(Topic ID: 124959)

LOTR display is possessed… need help.


By NEOphyte

5 years ago



Topic Stats

  • 11 posts
  • 5 Pinsiders participating
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

sb157.pdf (PDF preview)

#1 5 years ago

I recently installed a ColorDMD in my LOTR… no problems, everything looked great. Fired up for a game tonight and the display is not showing anything related to what's happening on the play field. Everything looks good, it just has nothing to do with where I am in the game. The game physically plays fine and the audio/call-outs are what you'd expect, but the display is doing it's own thing.

I tried reseating cables, chips, replaced batteries… nothing has changed. I have the chips required to install a shaker, so I installed all three thinking it might be a bad game ROM, display, etc. no change. I'd like to try a reset, but I can't see where I'm going.

I feel like I might be out of my element with this one… fixing plastics and bulbs is where I like to be.

Any ideas?

Thanks in advance!

#2 5 years ago

Maybe try re-flashing the color dmd rom? You may want to email them. It may be a known issue.

#3 5 years ago

Make sure the Whitestar display board is receiving 5V power at the upper left corner of the board.

Check the seating of the wide ribbon cable going to the Whitestar display board. Red stripe should be toward the corner of the board.

#4 5 years ago

What version Game ROM version do you have installed? You need at least 10.0 or 10.01 which if you do have installed make sure your Whitestar OS is version 8 not below. Many known errors with the lesser OS version running game roms and displays of 10.0 or 10.01.

sb157.pdf
#5 5 years ago

If the image don't load for you, below the image on the right side click the middle button that says "Direct link to full size image"

#6 5 years ago

Thanks guys, I appreciate all the help.

I should probably make it clear that after I installed the ColorDMD and before I replaced any of the ROM chips, the game worked fine (and looked incredible!). It was working fine for about a week, and then decided to go crazy yesterday. I've tried reseating cables, reloading the ColorDMD software, etc. I only replaced the ROM's because I had them and thought that one might have been corrupted… it didn't change anything… still crazy.

Could a faulty battery pack cause these issues? There's no sign of leakage and I replaced the batteries at Christmas, but it's still mounted on the board (I'm going to try and move it off the board this afternoon).

You should see this thing… it's bringing up crazy stuff… this morning it displayed "120! Secret Message"… I feel privileged that it wants to share its secrets with me (I just don't understand them).

Thanks again for any insight!

#7 5 years ago

Make a short video of it from the point of boot up to playing for a minute or so this way we can have a look.

#8 5 years ago


A few new things have popped up. Looks like there's been a reset. The machine is now asking for coin when it was previously on Free Play, and the it's set for 3 ball when it was previously on 5.

There is a delay/freeze now in what the display is showing, and in the second vid you will see the game play is now being affected. It awarded me Fellowship Multiball while running the POTD (having not made a single shot and playing with one hand).

Thanks.

#9 5 years ago

After watching the vids I would think this has nothing to do with the ColorDMD. It would most likely do the same thing if you swapped back to a regular dmd. Have you removed the CPU and looked very closely with a magnifying glass for any signs of battery acid damage? It does seem like a cpu related failure, especially since you mentioned the reset occurred, it could be battery related.

#10 5 years ago

The ColorDMD will hold the last frame in it's frame buffer until it receives a new frame to display. It can't show anything other than what is being sent to it by the display board. If you're seeeing incorrect animations during gameplay, there's a problem in the communication between the CPU and the Whitestar display board.

The wide ribbon cable is the communication channel between the two boards. The problem could be there or with the 5V power supply (2 pin connector) to the Whitestar display board.

Also, the Whitestar display ROM and game ROM work together. If while changing chips, you've mixed two different versions, that could explain the game calling up incorrect animations.

#11 5 years ago

Check for corrosion on the top right area where the batteries and ram are.

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Miami, FL
$ 219.99

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside