(Topic ID: 259709)

Lethal Weapon coils and flashers not working


By itshowtime

8 days ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 5 days ago by Roverius
  • No one calls this topic a favorite

You

Linked Games

#1 8 days ago

game powers up and starts fine....ball shoots out into lane and when you touch the flipper to pick a song the flippers go dead.....when you go into diagnostics and cycle through everything is normal until you check flashers ....it freezes there and won't let me move forward and coils are next on the chart....when the coils shuts down the blanking will turn off ...when game is turned on 5 volt and blanking light stay on like they should and game acts normal in attract mode ....fuses all look good.....so all the coils and flashers die when i ether touch a flipper or launch a ball

#2 5 days ago

I've had somekind of similar problem. Maybe disconnect the lamp cables and the switch cables and try to do diagnostic again.

Promoted items from the Pinside Marketplace
3,495
Machine - For Sale
West Chicago, IL
$ 15.00
Playfield - Decals
Metal-Mods
2,500 (OBO)
Machine - For Sale
Rio Rancho, NM
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 27.00
Electronics
Yorktown Arcade Supply
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 369.95
Boards
PinSound
3,999
Machine - For Sale
West Chicago, IL
From: $ 18.00
Apparel - Men
Pinside Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside