(Topic ID: 108848)

Lethal Weapon 3 - Not able to choose music


By Bishop

6 years ago



Topic Stats

  • 19 posts
  • 3 Pinsiders participating
  • Latest reply 6 years ago by balboarules
  • No one calls this topic a favorite

You

Linked Games

#1 6 years ago

Hi everyone. My LW3 won't give me the option to choose what music I want playing. It is also cutting short the "Back in action" phrase to "Back in ac"any ideas or suggestions of what might be causing this? Thanks.

#2 6 years ago

do a switch test, sounds like the ball shooter lane is a bit wonky. Or the gun trigger launcher.
Switch test will reveal all, check your manual.

#3 6 years ago

Ok thanks. I'll give it a go. Let u know how I go tomorrow.

#4 6 years ago

Ok. So the active switch test shows that numbers 11, 12, 13 & 27 are active.

#5 6 years ago

do you have a manual? what switch do those numbers say? did you take the balls out as it sounds like they are still in ball trough ( 11,12,13 )
27 I am curious on? what is this active switch?

#6 6 years ago

Yes I do have a manual. The first three were because the balls were still in. The 27 is the centre bank of drop targets. The one on the far right.

#7 6 years ago

I also don't think that the ball shooter has anything wrong with it. Just because when it is supposed to say back in action, but gets cut short, that happens in attract mode.

#8 6 years ago

Bad sound rom?

#9 6 years ago
Quoted from Bishop:

Yes I do have a manual. The first three were because the balls were still in. The 27 is the centre bank of drop targets. The one on the far right.

that switch is closed then, adjust so it only registers when hit, this can make the difference.
believe it or not?
good luck

#10 6 years ago

Had a good look at the switch. It seems fine and the same as the rest. In saying that, once I go into the diagnostics, the switch quickly goes from closed to open. Also had a play around with the ball launch and trigger. When the game is on and I press start, it doesn't let me choose, but if I remove all the balls and then put them back in the trough, it spits out the first ball to the launcher and then let's me choose the song.

#11 6 years ago

Put the game is switch test mode, check all the trough switches and the shooter lane switch, see if your getting 2 switches going when you hit them, or if any of them are not reading the correct switch.. also check for any bent diodes in the trough.

#12 6 years ago

If you aren't familiar with the game, here is what I have. In the centre of the machine is a set of 3 drop targets numbered 25,26 & 27. (Left to right). On active switch test mode, I have number 27 as active and yet number 25 doesn't register. Maybe I'm missing something, but they seem fine.

#13 6 years ago

If 25 does not register, I would be checking the switch and diode behind the drop, 27 as active always? Sounds like something is off there, was this always the case, or did this just start? Any work done to the game lately?

#14 6 years ago

I recently changed the drop targets. Not sure if there was a problem before as I didn't play it much as it was in pretty bad shape. I do know that I didn't have the above mentioned speech and song selection issues. Could those switches really effect them?

#15 6 years ago

If the switch matrix was affected then anything is possible... Did you change just the targets them selfs or the switches as well? I would be really looking at that area, recent change, recent problem, usually go hand in hand.... Look for anything broken off, touching, etc...

#16 6 years ago
Quoted from Bishop:

I recently changed the drop targets. Not sure if there was a problem before as I didn't play it much as it was in pretty bad shape. I do know that I didn't have the above mentioned speech and song selection issues. Could those switches really effect them?

Again Dude, Yes!
I do hope you get it sorted as it is a fun game that I remember from my youth and glad I restored one for my big brothers 50th birthday present.

#17 6 years ago

Only changed the targets themselves as they are prone to breaking off. Going to check all the switches again including the diodes tomorrow. Thanks for your help guys. Let you know how I go.

#18 6 years ago

Removed the target housing. Would you believe that the housing itself was bent where the switches attach? When I was checking the switches, I removed them from the housing to look at, that's why they always seemed fine. Music selection works but the back in action part still cuts short. I'll live. Thanks for all your help guys. Greatly appreciated.

#19 6 years ago

Not surprised issue was there, so much better when the issue is gone, might want to order new sound roms for the game..

Promoted items from the Pinside Marketplace
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 15.00
Playfield - Decals
Metal-Mods
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 50.00
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
$ 17.50
Playfield - Plastics
Pinball Haus
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 369.95
Boards
PinSound
$ 27.00
Electronics
Yorktown Arcade Supply
From: $ 18.00
Apparel - Men
Pinside Shop
€ 95.00
Lighting - Led
FlipperLED
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 35.00
Cabinet - Other
Arcade Upkeep

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside