(Topic ID: 67379)

Last Action Hero club, come on in!


By Matt_Rasmussen

6 years ago



Topic Stats

  • 2,266 posts
  • 254 Pinsiders participating
  • Latest reply 1 hour ago by Jarson
  • Topic is favorited by 91 Pinsiders

You

Linked Games

Topic Gallery

There have been 535 images uploaded to this topic. (View topic image gallery).

1385331C-873A-43B0-A00C-FE58C76D8096 (resized).jpeg
20191110_164411 (resized).jpg
20191110_164225 (resized).jpg
image (resized).jpg
20191106_182643.jpg
20191106_183559 (resized).jpg
IMG_6372 (resized).JPG
20190922_143258 (resized).jpg
20190922_184302 (resized).jpg
20190922_181535 (resized).jpg
587AC443-B339-4870-ADB4-AAB4FBEEA534 (resized).jpeg
IMG_20190916_192027 (resized).jpg
20190913_000300 (resized).jpg
20190913_201130 (resized).jpg
20190913_210422 (resized).jpg
20190913_212023 (resized).jpg

You're currently viewing posts by Pinsider rdonohue13.
Click here to go back to viewing the entire thread.

#2085 6 months ago

Ok I just got mine back from the shop and the left scoop is bricking terrible. I have the cliffy on it and after playing three games last night it went in 2 out of 26 times i hit it directly. what can I do to get a better percentage on this shot falling.

2 months later
#2168 4 months ago

Well I got some dead stop foam for the left scoop because it was impossible to hit. I tried installing it several different positions and it didn’t help at all. I take that back when I would hit the shot solid it be a dull thud instead of loud metal clank. So I removed the cliffy and now it plays great. Not sure why the cliffy made it that bad but it did. Does anyone have another solution using Mylar or something else to protect the area that has some wear?

Second I started playing and after a bit the left flipper intermittently stops working. Like it will play great and then I’ll hit the button and nothing I pop it two or three times and it comes back. Any idea what would cause that?

#2172 3 months ago

Sorry guys I’m a little lost? Are you saying the issue is with the eos by the flipper button or there is an eos issue on the flipper board?

Promoted items from the Pinside Marketplace
From: $ 369.95
Boards
PinSound
From: $ 9.99
$ 40.00
Playfield - Decals
Great American Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 14.50
Electronics
PinballElectronics.com
From: $ 18.00
Apparel - Men
Pinside Shop
$ 30.00
Electronics
Yorktown Parts and Equip
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 16.95
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 229.99
From: $ 40.00
Lighting - Interactive
Professor Pinball

You're currently viewing posts by Pinsider rdonohue13.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside