(Topic ID: 67379)

Last Action Hero club, come on in!


By Matt_Rasmussen

6 years ago



Topic Stats

  • 2,452 posts
  • 273 Pinsiders participating
  • Latest reply 6 hours ago by Iwasthebruce
  • Topic is favorited by 101 Pinsiders

You

Linked Games

Topic Gallery

There have been 604 images uploaded to this topic. (View topic image gallery).

20200531_093805 (resized).jpg
20200531_093556 (resized).jpg
20200531_093549 (resized).jpg
20200531_102139 (resized).jpg
20200601_205405 (resized).jpg
20200601_170125 (resized).jpg
20200601_122428 (resized).jpg
20200601_110440 (resized).jpg
D53AF08E-360B-4D17-A772-9941B45C9985 (resized).jpeg
07624F66-F9DB-4507-9FD0-960CE056D1B1 (resized).jpeg
pasted_image (resized).png
pasted_image (resized).png
20200529_134749 (resized).jpg
20200507_214345 (resized).jpg
20200507_214335 (resized).jpg
20200507_212420 (resized).jpg

There are 2452 posts in this topic. You are on page 19 of 50.
#901 3 years ago

Yes and don't over titghten and break that screw

#902 3 years ago

Has anyone ever seen a collector quality LAH? Original not blown out scoops? I would probably overpay for one of those

#903 3 years ago
Quoted from Butch2099:

Has anyone ever seen a collector quality LAH? Original not blown out scoops? I would probably overpay for one of those

Define blown out .
Mine has some wear, and I have seen one once without any, but usually you have other issues in such case. There aren't too many out there

#904 3 years ago

Just got a nice LAH last week, it does have the scoop hole wear but otherwise pretty much perfect. I know Cliffy made protectors for this game but all sellers seem to be out of stock and for quite a while. Does anybody know where I could get a set? Or anyone have a set for sale? There were only three protectors but that would cover the wear pretty well and protect it. Thing is they tend to impede the ball a bit and make the scoop holes harder to get especially with random roll ins. Are they going to be produced again or is cliffy done. I suppose I should contact them and find out! Great fun game though, makes me want to watch the movie now. I heard it was a huge flop but is a lot better movie than people seem to remember....

#905 3 years ago
Quoted from homebrood:

Just got a nice LAH last week, it does have the scoop hole wear but otherwise pretty much perfect. I know Cliffy made protectors for this game but all sellers seem to be out of stock and for quite a while. Does anybody know where I could get a set?.

I bough the three piece set from the Man himself a little over a month ago. Buy direct

http://www.passionforpinball.com

#906 3 years ago

I tried to post a video of the lah i was working on now that its done, but it was the wrong type of file. The leds turned out great and it cleaned up great. All it needs is a sticker over the admit one ticket on the playfield. Does anyone sell those?

#907 3 years ago

Was wondering if anyone can help me find why my game is showing a double display on my DMD. This just started doing this. I have used another game controller and basically narrowed it down to the DMD Controller. Not sure if this can be repaired or I should just replace the board. Where is the best place to go?

Last Action Hero DMD (resized).jpg

Last Action Hero DMD Controller (resized).jpg

#908 3 years ago

I rebuilt my flippers last night, and now i'm having a weird issue. Both flippers work if I press them individually, or at exactly the same time, but if I press the left flipper then the right, the right won't work. Vice versa as well. I'm really new to pinball, but have been trying to troubleshoot.

In diagnostic mode if I press a flipper button the EOS switch triggers, and I see the LED light up on the flipper board. If I hold that flipper and hit the other flipper the EOS switch triggers, but the LED on the flipper board doesn't like up.

I'm not sure what I did wrong when rebuilding. I reversed the EOS switch wires, but I don't think that should matter. I had a hard time getting the sleeve out of the right side coil, but doubt that would matter. I think I put the plunger assemblies on the wrong side (lock washer is facing out), but I can't imagine that would cause that issue. I'm guessing it's something electrical, but not sure where to look or test.

Other than that, it's been fun learning how to work on a pinball machine.

#909 3 years ago
Quoted from jester523:

I'm not sure what I did wrong when rebuilding. I reversed the EOS switch wires

Is it possible you have the left eos switch connected to the wires for the right eos switch and vice versa?

#910 3 years ago
Quoted from caker137:

Is it possible you have the left eos switch connected to the wires for the right eos switch and vice versa?

Embarrassingly enough, that seems like what I did. I'm looking back at the pictures I took, and I definitely soldered the left wires to the right EOS and vice versa.

Thanks! I'll re-solder tonight or tomorrow and post back if it fixed it.

I took a lot of pics, but as I tear things down, I feel like I need to take even more pics. It really helps.

#911 3 years ago
Quoted from jester523:

Embarrassingly enough, that seems like what I did. I'm looking back at the pictures I took, and I definitely soldered the left wires to the right EOS and vice versa.
Thanks! I'll re-solder tonight or tomorrow and post back if it fixed it.
I took a lot of pics, but as I tear things down, I feel like I need to take even more pics. It really helps.

Idiot...

#912 3 years ago

Funny Phil. Wait until I "fix" the crane drop targets. You'll never play this game again.

#913 3 years ago
Quoted from caker137:

Is it possible you have the left eos switch connected to the wires for the right eos switch and vice versa?

I switch over the connections and this fixed the problem. Thanks again.

Today I took apart one slingshot, cleaned and put back together. Surprisingly easy. Definitely cleaned up the movement.

#914 3 years ago

Anybody have a scan of the Dekker face for the spinner? I added a new spinner, but it's just blank right now.

This is my first pinball machine and I've had it about 4 weeks. I took a good portion apart already. I couldn't help it. So far I've:
1. Removed batteries and added NVRAM
2. removed a good portion of the playfield for cleaning. Parts were really dirty.
3. Rebuilt the flippers
4. Cleaned about half of the coils and replaced the coil sleeves. On some of the coils it was very tough to get the sleeves out. I imagined they might have overheated. You can kind of see the yellowing where the ripper coil was, which I think was from heat, and I had to work the coil sleeve out with a screwdriver.
5. Changed out the broken chicken scoop switch with a new one.
6. Added a spinner (was missing)
7. Broke two screws (they are like putty), one on the flipper assembly and the other on the sling. I'm not happy about it. The flipper one won't be bad because it's on the metal bracket, but the sling is right into the wood. I'll try my best to extract and see how it goes.

I still have to finish cleaning and waxing the playfield, update the GI bulbs / flashers with LEDs (not purchased yet), clean and fix the CRANE dropdowns, clean the remaining coils, solder a few diodes and wires that came loose, the left m-ball advance and save danny lights aren't working (not bulb related), replace rubbers with Titan rings. Unfortunately, I bought 5/16 rings as suggested by the manual, and they don't fit the metal posts. So i'll have to place another order.

I'm leaving the playfield on the machine, so it's a bit tough as I get further back. I'm not quite sure how i'll do the VUK coil. Perhaps in the future i'll be brave enough to remove the playfield entirely, but considering i'm new to this, I figure going half way isn't a bad plan. I already miss playing as I don't have a backup pinball machine. Next year...

lah-playfield (resized).jpg

lah-playfield-1 (resized).jpg

#915 3 years ago
Quoted from jester523:

Anybody have a scan of the Dekker face for the spinner? I added a new spinner, but

PM your email and I will see if I can find the file.

#916 3 years ago
Quoted from PTHermes:

PM your email and I will see if I can find the file.

PM sent. If you can't find it, that's fine. I'm just going to put a sticker of my wife's face on it instead.

#917 3 years ago

Hi all LAH fans!

Does anybody have a picture of their ball through ? Especially interested in the through #7 switch wiring.

Best regards
Peter

#918 3 years ago
Quoted from dahlman:

Hi all LAH fans!
Does anybody have a picture of their ball through ? Especially interested in the through #7 switch wiring.
Best regards
Peter

Check my post. Post #871 should be what you need.

#919 3 years ago

Thank's! For your reply!
I don't see the ball through #7 wiring...the last one being activated before the ball is kicked up to the shooter lane. (On the right side of the assembly)

Best regards Peter

#920 3 years ago
Quoted from dahlman:

Thank's! For your reply!
I don't see the ball through #7 wiring...the last one being activated before the ball is kicked up to the shooter lane. (On the right side of the assembly)
Best regards Peter

Not from my machine, but is this what you are talking about:
http://www.enteryourinitials.com/images/lah/lah_trough_switch7.jpg

A lot of good pictures on this blog thread.
http://www.aussiearcade.com/showthread.php/79733-Data-East-Last-Action-Hero-1993-Repair-amp-Service-Log

#921 3 years ago

Thank's a lot!
I don't see any diode on that switch. Is this correct?

#922 3 years ago
Quoted from dahlman:

Thank's a lot!
I don't see any diode on that switch. Is this correct?

It doesn't look like it from the pictures, and from my memory I just remember their being the three pink connectors, but I will let you know if about 3 hours when I get home if nobody else answers.

John

#923 3 years ago

There is an inline diode on one of the wires.

IMG_20170509_175639976 (resized).jpg

#924 3 years ago
Quoted from jester523:

Funny Phil. Wait until I "fix" the crane drop targets. You'll never play this game again.

This jackalope has been "fixing" my pinball machine for quite awhile now. Tons of new parts and lights..I fear it will never play again

#925 3 years ago

Jester523: Thank's a bunch!

#926 3 years ago

I was looking at buying a LAH pinball, but a WoZ popped up instead...I got a call for a local repair on a LAH, so it's cool that I now get to play one.

I replaced blown fuse F5 on the main power board and the game worked again....everything except switch 47 VUK in the top righthand corner. I went into switch test and this switch did not register at all. Wires seemed to be soldered on. Checked nearby connectors and they were tight. I am going to replace this with a new switch. Anything else I should be concerned about with that?

Has anyone else come across the issue of when the shaker motor activates and the crane moves, Arnie says "don't move" and a second ball is kicked out? Would this be shaking a trough switch?

Cheers!
Adam.

#927 3 years ago
Quoted from ahdelarge:

I was looking at buying a LAH pinball, but a WoZ popped up instead...I got a call for a local repair on a LAH, so it's cool that I now get to play one.
I replaced blown fuse F5 on the main power board and the game worked again....everything except switch 47 VUK in the top righthand corner. I went into switch test and this switch did not register at all. Wires seemed to be soldered on. Checked nearby connectors and they were tight. I am going to replace this with a new switch. Anything else I should be concerned about with that?
Has anyone else come across the issue of when the shaker motor activates and the crane moves, Arnie says "don't move" and a second ball is kicked out? Would this be shaking a trough switch?
Cheers!
Adam.

Before purchasing a new switch I would just use an aligator clip in switch test mode to test the switch. That would bypass the switch itself and let you know if its another issue. Also, the shaker motor causing another ball to kick out is a sign that you have loose trough switch connections. The game thinks you lost a ball too soon. The outhole switch would be the possible culprit. Data east is known for crappy solder joints. Then you throw a shaker motor in the mix and all the loose connections are amplified.

#928 3 years ago

Quick question. For those who have 6 LED bulbs for the "RIPPER" lights, what LEDs are you using?

(normally #44 bulbs)

Thanks!

#929 3 years ago
Quoted from Bendit:

Quick question. For those who have 6 LED bulbs for the "RIPPER" lights, what LEDs are you using?
(normally #44 bulbs)
Thanks!

cointaker frosted yellow

#930 3 years ago

Hey guys. I just bought a LAH and was going through all the fuses to make sure they are correct. There is a fuse that is under the playfield that is inline with the crane. Can someone tell me what amp that fuse is?

#931 3 years ago
Quoted from TheCapn:

cointaker frosted yellow

Thank you, Sir.

#932 3 years ago

My LAH has been playing great, but the crane is now becoming an issue. I've tried adjusting it to hit both switches consistently, but can't get there. If the playfield is vertical it has no problem, but when in the normal position there is enough play in the gears that the shaft doesn't make the crane go all the way to the switch. Can the gears be replaced? Anybody do that work? I looked for a new one and didn't see any in stock anywhere (but one in Germany in the marketplace). TIA

#933 3 years ago

Can someone please look at there fuse under the playfield at the very back and tell me what size amp the crane fuse is? Thank you.

#934 3 years ago

mine is a 250V MDL3 If that helps.

#935 3 years ago
Quoted from angus:

My LAH has been playing great, but the crane is now becoming an issue. I've tried adjusting it to hit both switches consistently, but can't get there. If the playfield is vertical it has no problem, but when in the normal position there is enough play in the gears that the shaft doesn't make the crane go all the way to the switch. Can the gears be replaced? Anybody do that work? I looked for a new one and didn't see any in stock anywhere (but one in Germany in the marketplace). TIA

That's Kevin.... the German one. I got a nice NOS main ramp from him.

#936 3 years ago

I've only got 1 of the three magnets working. I've tested the other 2 by using a 9 volt battery and they work. I'm guessing it's the transistors on the magnet controller board under the playfield. Is there a way to test them like you can the tip102 with a meter? Also is it better to replace the old transistors or just buy a new style board?

#937 3 years ago
Quoted from PinballHog:

I've only got 1 of the three magnets working. I've tested the other 2 by using a 9 volt battery and they work. I'm guessing it's the transistors on the magnet controller board under the playfield. Is there a way to test them like you can the tip102 with a meter? Also is it better to replace the old transistors or just buy a new style board?

That board is falling on most machines. There is a link to a very good repair guide for it somewhere in this thread.
....
Found it.
http://www.techdose.com/repairlog/Repairing-a-Data-East-Last-Action-Hero-Magnet-Controller-Board/306/page1.html

2 weeks later
#938 3 years ago

Joining today the project starts

IMG_3618 (resized).JPG

#939 2 years ago

New to the club, I've owned LAH for one day, but I quite like it. Lots of stuff going on.

I hit the Grand Finale and was confused. Was rocking the six ball multi ball, then it locked the flippers and drained all the balls. Then I had to sell movie tickets, and after a while it again locked down the flippers and drained the balls. Did I fail to do something, or is that success, advancing me through stages of wizard mode?

#940 2 years ago
Quoted from EvanDickson:

New to the club, I've owned LAH for one day, but I quite like it. Lots of stuff going on.
I hit the Grand Finale and was confused. Was rocking the six ball multi ball, then it locked the flippers and drained all the balls. Then I had to sell movie tickets, and after a while it again locked down the flippers and drained the balls. Did I fail to do something, or is that success, advancing me through stages of wizard mode?

6 ball is limited time after you hit Last Action Hero. Totally normal.

#941 2 years ago

I've noticed it often loses count of balls in play during super crane. I'll be down to 1 ball and it will still think the scene is active. Drain that last ball and it will do a ball search and auto launch a new ball into play, and the mode ends. Is this a bug others experience, or something unique to my LAH?

#942 2 years ago
Quoted from EvanDickson:

I've noticed it often loses count of balls in play during super crane. I'll be down to 1 ball and it will still think the scene is active. Drain that last ball and it will do a ball search and auto launch a new ball into play, and the mode ends. Is this a bug others experience, or something unique to my LAH?

I would check your trough switches to make sure there isn't a loose connection. Switch edges in test mode is gonna be your friend. Verify all switches are working accordingly.

#943 2 years ago

great chances that next pin coming home will be LAH... seems i have some stuff to read here

#944 2 years ago

to be, or not to be ? ... TO BE !

LAH (resized).JPG

GB freeplace is just taken by LAH
of course, something completly different, but just wanted that way
even if LAH is easy, very easy (too much easy ?), as others DE from that era, with same style of play (including JP, TOMMY, TFTC)
wizard mode on my 1st game, and my son already at 887M after few games

this one is in very good shape, with topper (working), magnets (working), shaker (working), crane (working), the playfield is very nice (ticket is perfect), as the external cab is more than OK with nice colors... only the scoops are "eaten" but logical of course, its not NIB/HUO...

i'm right now trying to burn an 27c512 eprom with the 1.13 rom - tanx to Caker (got all i need, just found how to complete all the process, burn it seems a prob)

PS : got only a small prob while reassembling pin home, the half down of the GI of the backglass is not working...
checked connector, fuse, no cable cut... an idea may be ?
tanx in advance

#945 2 years ago
Quoted from RipleYYY:

to be, or not to be ? ... TO BE !

GB freeplace is just taken by LAH
of course, something completly different, but just wanted that way
even if LAH is easy, very easy (too much easy ?), as others DE from that era, with same style of play (including JP, TOMMY, TFTC)
wizard mode on my 1st game, and my son already at 887M after few games
this one is in very good shape, with topper (working), magnets (working), shaker (working), crane (working), the playfield is very nice (ticket is perfect), as the external cab is more than OK with nice colors... only the scoops are "eaten" but logical of course, its not NIB/HUO...
i'm right now trying to burn an 27c512 eprom with the 1.13 rom - tanx to Caker (got all i need, just found how to complete all the process, burn it seems a prob)
PS : got only a small prob while reassembling pin home, the half down of the GI of the backglass is not working...
checked connector, fuse, no cable cut... an idea may be ?
tanx in advance

Exactly how did you "check" the connectors, fuse, cable? Visual? Or test with DMM? The GI gonnector can have a poor connection due to burnt pins. The GI is fed directly from the PSU. Using the DMM I would see if you have current going to the bottom half of the backbox GI.

#946 2 years ago
Quoted from TheCapn:

Exactly how did you "check" the connectors, fuse, cable? Visual? Or test with DMM? The GI gonnector can have a poor connection due to burnt pins. The GI is fed directly from the PSU. Using the DMM I would see if you have current going to the bottom half of the backbox GI.

well, tanx for the reply, and lets admit i'm confused, checked visual 1st of course, all seems OK without a doubt, but...
and while using the DMM i have... nothing, even on the part above where all lamps are ON !!!??? and the DMM is not out of order

a friend of mine will came home, as i'm more than bad to restore pinballs (i'm way better at playing)
if needeed i'll came back to you later, tanx again and have a nice sunday

#947 2 years ago

ok, yesterday, step 1, bring back the pinball home, play/test it as it

today, step 2 : cleaning the upper playfield, and wax it (now its plays 2X quicker ! much less easy than yesterday), set-up the pin and check all i can

to do : step 3 : first wanna LED it, but not sure, as its already very "illuminate" as it, and that even with the under playfield (inserts + lamps) being very (very) dirty... than first clean all these, and see if its OK or not

btw, pics from today, and small video to "check" the speed-play :

https://get.google.com/albumarchive/110304160913314353072/album/AF1QipMN5FRb-m0ChEZU1stxx2t2jIgG77LvJVA8ytOi

#948 2 years ago

I'm now a member of this club! Love the game, translite is killing me! I would love any advice on any alternate translites that might be out there. How I can get them or at least the artwork to get it printed. Thanks!

#949 2 years ago
Quoted from robx46:

I'm now a member of this club! Love the game, translite is killing me! I would love any advice on any alternate translites that might be out there. How I can get them or at least the artwork to get it printed. Thanks!

There is an alternate that is usually available on eBay for around $100. There is even a Donald Trump version now too. lol.

#950 2 years ago

The alternate looks like so:

20170525_205952-1 (resized).jpg

Promoted items from the Pinside Marketplace
From: $ 9.99
From: $ 369.95
Boards
PinSound
$ 25.00
Boards
nvram.weebly.com
$ 99.00
Playfield - Other
Arcade Upkeep
$ 40.00
Playfield - Decals
Great American Pinball
$ 229.99
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 35.00
Cabinet - Other
Arcade Upkeep
2,500 (Firm)
Machine - For Sale
Sacramento, CA
There are 2452 posts in this topic. You are on page 19 of 50.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside