(Topic ID: 257166)

Laser Ball club. Watch out for her balls!

By Mitch

1 year ago


Topic Heartbeat

Topic Stats

  • 28 posts
  • 11 Pinsiders participating
  • Latest reply 44 days ago by BallyKISS1978
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

66B33F2A-D477-4B8C-95E8-CA2C10C62543 (resized).jpeg
A1E3ACD5-44AC-48BB-9A69-E15AF8877851 (resized).jpeg
FF73DED1-26A5-4BA8-B8C6-BF9D10F552B1 (resized).jpeg
759BA8D5-E74D-4127-9079-8B67E452B5CC (resized).jpeg
B8945B1C-D8AC-444A-BFBE-6E3A07C89948 (resized).jpeg
2B17317E-57A4-4973-B6C9-9242042B305B (resized).jpeg
2B916FBF-D6EC-4868-B53E-4A0A330AA89E (resized).jpeg
20201018_190557 (resized).jpg
20201018_190601 (resized).jpg
20201018_190551 (resized).jpg
LaserBall (resized).jpg
20191208_225906 (resized).jpg
20191208_215309 (resized).jpg
20191113_224314 (resized).jpg
20191110_141451 (resized).jpg
20191110_150249 (resized).jpg

#1 1 year ago

Seeing as there is no club and 4500 made.
I figured I'd see who else has one.

Let's see what you got!

Backglass (resized).jpg
#2 1 year ago

I just put way to much time into my laser ball.

I re did all the mpu and driverboard connectors, headers, and 40 pin interconnect. Then on a spare partially populated playfield I had I stripped the top down, removed all mylar, removed and reglued all loose inserts. Cleaned, touched up and waxed playfield.
Put mylar back on around pops and saucer kick out. I rebuilt flippers, rebuilt drops, rebuilt pops. All plastic pieces ultrasonic all metal tumbled.

Then every socket unscrewed and cleaned inside with dremel, all inserts backsides cleaned and full LEDs.

Just got playfield back in today. Gonna fire it up tomorrow.
20191110_124642 (resized).jpg20191110_141451 (resized).jpg20191110_150249 (resized).jpg20191110_223509 (resized).jpg20191113_224314 (resized).jpg20191115_172840 (resized).jpg20191115_172845 (resized).jpg20191205_194413 (resized).jpg

#3 1 year ago
20191208_215309 (resized).jpg20191208_225906 (resized).jpg
#4 1 year ago

I tried to start a Laser Ball club awhile back....

https://pinside.com/pinball/forum/topic/laser-ball-club-big-girls-need-love-too

But I didn’t get enough members to start a news letter....
Not a lot of love for this pin. It deserves a lot more. Mine plays fast and mean, which makes it a great drinking with your buddies game. And trying to get a extra ball is not easy and very rewarding to get.
Yours looks beautiful! Probably the nicest one on the planet.
Best wishes on your club- count me in as a lifetime member.

#5 1 year ago
Quoted from ryan1234:

I tried to start a Laser Ball club awhile back....
https://pinside.com/pinball/forum/topic/laser-ball-club-big-girls-need-love-too
But I didn’t get enough members to start a news letter....
Not a lot of love for this pin. It deserves a lot more. Mine plays fast and mean, which makes it a great drinking with your buddies game. And trying to get a extra ball is not easy and very rewarding to get.
Yours looks beautiful! Probably the nicest one on the planet.
Best wishes on your club- count me in as a lifetime member.

That's strange I searched for all laser ball threads and I didnt see that one. Wouldn't have started a new club page if I had seen it.

#6 1 year ago

No problem at all!
I’m happy this pin is getting some love.
Only 85 people on pinside own Laser Ball.
Pretty crazy given 4500 were made.
Probably not to many left.

#7 1 year ago
Quoted from ryan1234:

No problem at all!
I’m happy this pin is getting some love.
Only 85 people on pinside own Laser Ball.
Pretty crazy given 4500 were made.
Probably not to many left.

I have 5 populated playfeilds lol stripped them down and used the best for this game. Just wish mine had the plywood cab not the MDF.
Had a plywood cab version but had to burn it. Too moldy.

#8 1 year ago

If anyone needs game specific parts or plastics I have lots.

1 month later
#9 1 year ago

hi guys,
i just bought a laser ball. brought it home, and now it doesnt work. it was playing fine at the seller's home. we keep blowing the 2.5A fuse on power up. the lights dont work whatsoever.

the game turns on, but the game is simply growling/vibrating under the PF. i am worried the game will self destruct. the sling shots seem to be semi-firing. they are moving slowly. its so wierd. this is my first OLDer game. my other games are from the 90s and 2000s.

any help would be greatly appreciated!!!

Thanks,
HOG

#10 1 year ago
Quoted from Mitch:If anyone needs game specific parts or plastics I have lots.

I also have game specific parts and plastics that I would like to get rid of.

#11 1 year ago
Quoted from HEAD_boss_HOG:

hi guys,
i just bought a laser ball. brought it home, and now it doesnt work. it was playing fine at the seller's home. we keep blowing the 2.5A fuse on power up. the lights dont work whatsoever.
the game turns on, but the game is simply growling/vibrating under the PF. i am worried the game will self destruct. the sling shots seem to be semi-firing. they are moving slowly. its so wierd. this is my first OLDer game. my other games are from the 90s and 2000s.
any help would be greatly appreciated!!!
Thanks,
HOG

Has the 40 pin interconnect been replaced? If not I'd start there

#12 1 year ago
Quoted from Mitch:

Has the 40 pin interconnect been replaced? If not I'd start there

Thanks for the recommendation!

I have heard that from another Tech. perhaps i should bite the bullet and replace it. any other suggestions?

#13 1 year ago
Quoted from Mitch:

Has the 40 pin interconnect been replaced? If not I'd start there

This is not a recommendation!
This is a MUST!

1 week later
#14 1 year ago

Fixed it

Actually I screwed up a connector. Now its correctly connected and fully functional !!!

Playing this game for hours today

1 week later
#15 1 year ago

Just brought one back from the dead yesterday. PIA #4 was misfiring coils. It had a nice layer of protective dust on it and looks great with only minor wear.

LaserBall (resized).jpg
4 months later
#16 1 year ago

Hope to be picking up my Laser Ball this weds. Ill post pics once i get the girls home.

1 month later
#17 1 year ago

Hi all, My Laser Ball has developed a problem where nothing happens when all 10 lights on the upper lanes are lit. Normally lighting all these causes the flashing effect and lights one of the "AE" lights at the bottom of the playfield. Has anyone else experienced this issue?

Added 13 months ago:

Edit: I've noticed that what is actually happening is when the ball goes through lane one, two other lanes will light also. These lanes do not, however, register as though the ball has gone through them (It's just lane lights coming on when they shouldn't.)

2 months later
#18 10 months ago

Count me in. First pin. Don't remember playing it back in the day but playing the hell out of it now!

20201018_190551 (resized).jpg20201018_190557 (resized).jpg20201018_190601 (resized).jpg
#19 10 months ago
Quoted from Hangernade:

Count me in. First pin. Don't remember playing it back in the day but playing the hell out of it now!
[quoted image][quoted image][quoted image]

Looks beautiful!!

#20 10 months ago

Quick note: I'm coming into a nice populated playfield next week if anybody needs a donor. I'll post pics when I get it.

#21 10 months ago
Quoted from SadSack:

Quick note: I'm coming into a nice populated playfield next week if anybody needs a donor. I'll post pics when I get it.

Where are you located?

1 week later
#22 10 months ago

Hi, does anyone have a pic of the switch matrix for Laserball? Tx! Greg

Added 10 months ago:

Got it!

#23 10 months ago
Quoted from ryan1234:

Where are you located?

Billings, MT. I haven't picked it up, but this week I will. I'll post some pics in this thread.

4 months later
#24 6 months ago

Question for you Laser Ball fans - picked one up and got her going, looking & playing great.

Had a few switches needing adjustments & the outhole wasn't kicking out as it should. All a-ok now.

Problem I'm having - after a while, the sounds stop. Or go off on to some random sounds, not when I hit a target, etc. Then silent... I can re-boot, and she starts up ok. (Sometimes) Thought it was the connector, but now thinking more on the sound board? Anyone else have a similar issue?

#25 6 months ago
Quoted from Nikrox2:

Problem I'm having - after a while, the sounds stop. Or go off on to some random sounds, not when I hit a target, etc. Then silent... I can re-boot, and she starts up ok. (Sometimes) Thought it was the connector, but now thinking more on the sound board? Anyone else have a similar issue?

It always seems to be connector problems after connector problems with these system sixes...
I would replace all sound board capacitors (super cheap from GPE) and replace connectors.... maybe try reseating the chips first...

#26 6 months ago

Great tips. Thank you

4 months later
#27 45 days ago

Hopefully joining the club soon. Pics of the one I will be getting.

2B916FBF-D6EC-4868-B53E-4A0A330AA89E (resized).jpeg2B17317E-57A4-4973-B6C9-9242042B305B (resized).jpeg759BA8D5-E74D-4127-9079-8B67E452B5CC (resized).jpegB8945B1C-D8AC-444A-BFBE-6E3A07C89948 (resized).jpeg
#28 44 days ago

Picked it up today. Added GI LEDs and some under the playfield. Still has some incandescent under some inserts.

A1E3ACD5-44AC-48BB-9A69-E15AF8877851 (resized).jpegFF73DED1-26A5-4BA8-B8C6-BF9D10F552B1 (resized).jpeg66B33F2A-D477-4B8C-95E8-CA2C10C62543 (resized).jpeg

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside