(Topic ID: 84387)

Just looking for sympathy... My TZ clock started acting up


By altan

5 years ago



Topic Stats

  • 12 posts
  • 9 Pinsiders participating
  • Latest reply 5 years ago by altan
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

IMG_3645.jpg

You're currently viewing posts by Pinsider NM.
Click here to go back to viewing the entire thread.

#8 5 years ago
Quoted from altan:

I'll take it apart and check it out. I'm thinking it might be as simple as the connectors at the bottom because, after slightly touching them, it started freaking out in test mode (opts going on off).
I haven't heard people having to rebuild the female connector (because of cracked wires), but I'm wondering if that's my problem. Or if I need to reflow the connectors on the clock.

Might need to replace the header pins too if they're tarnished.

While it's apart, might want to quiet the gears down with some grease specifically designed for use with plastic--such as Synthetic Polyolefin (PAO) Lubricant/Grease; M-Kote EM-30L; NLGI#1.

Small jars of it can be found on Ebay.

Mine turned out nice and quite.

My sympathies--and good luck.

Promoted items from the Pinside Marketplace
7,200
Machine - For Sale
Kinnelon, NJ
$ 234.99
$ 44.00
Playfield - Toys/Add-ons
Lermods

You're currently viewing posts by Pinsider NM.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside