(Topic ID: 150522)

Jurassic Park: Keeping the Fuse Industry Alive!


By JohnSteed

3 years ago



Topic Stats

  • 21 posts
  • 5 Pinsiders participating
  • Latest reply 3 years ago by JohnSteed
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 6 images uploaded to this topic. (View topic image gallery).

166_(resized).jpg
169_(resized).jpg
168_(resized).jpg
164_(resized).jpg
JP_BR1_BR2_(resized).png
JP_backbox_(resized).png

#1 3 years ago

Howdy Everyone!

After about 5 years of being in storage, I finally decided to dust off my Jurassic Park Pinball Machine and get it going! I knew there were problems with it when I bought it, but the playfield is in perfect shape and I couldn't resist. Here's what is going on and what I did so far:

Power Supply Board Overhaul:

I first powered up the machine. Most of the lights came on and there were a few red dots on the DMD. No sound, no power to any coils, no display. The LEDs on the CPU were all off.

I pulled the power supply board out and checked EVERY component on it. Two of the fuses were burnt out (I replaced all of them with the correct value based on the JP manual). Also, I checked all of the capacitors with and ESR meter. I replaced C4, and 18000uF 25V capacitor with a 25000uF 35V cap. This cap looked fine when it was on the board, but after I pulled it, I could see it leaked out on the bottom. I also added a wire trace to the leg of a diode the cap traced to. That was all that appeared to be the problems with this board! I checked all the diodes, fuses, resistors and transistors too. I put the board back in, powered up the machine and the machine immediately went into diagnostic mode, the DMD worked fine and the sound came on when I started up the game. Also, the first two LEDs came on the CPU board.

Playing the Game

I started up a game. When I pressed the start button, a ball was placed in the shooter lane, but after pressing the shooter trigger the shooter solenoid did not shoot a ball onto the playfield. Also, both of the flippers were not working. It seemed also that not all of the lights were working, nor the flashers.

Flipper Board Under the Playfield

I pulled the flipper board from under the playfield. Sure enough, two of the fuses were blown (both 9V hold for each flipper) F2 and F4, both 3A slo blow fuses. I checked every component on this board too, and everything checked out ok.

PPB

I checked all of the fuses first with my ohm meter. F5 was blown, as well as one of the GI fuses and F6. I then checked the bridge rectifier out and the readings were fine for that. I check all of the transistors next. Q1 and Q2 tested with under .2 volts and Q3, Q4 and Q5 were all completely shorted! Why would these short out? That's as far as I got last night. I did not get a chance to pull this board yet and check all of the components. Anybody got any ideas????

Extra Point

While checking the fuses in the back box, I also tested the two 8A 250volt fuses above the big blue capacitor in the lower left side of the back box. The fuse closest to the capacitor was blown. Not sure what these are for. GI? Flashers? Must be flashers.... I did not get a chance to look it up yet.

My overall impression of Data East electronics is the boards were very cheaply made! I could tell that they were repaired before. There are multiple burn marks on the molex connectors and a lot of rewiring. The traces on the underside of the board are all bubbling up. No wonder there is a market for after-market PCBs for these boards!

However, they are so very easy to fix....

Please let me know if you have any insight on this game or if there is anything I should look out for. I will be pulling the PPB board this evening or tomorrow to check it out.

Thanks!

Mike

#2 3 years ago

Mike -

It sounds like some problems I had when I bought a dead JP. One of the things I found was lots of blown fuses and shorted transistors on several of the boards. (Happily, none on the MPU!) After replacing all of that, I noticed black marks on the ground plane behind the circuit boards, especially the upper left board. It appeared that the heat sinks for the transistors were arcing to the ground plane, causing all kinds of problems. I ended up installing some film to create an insulated barrier between the circuit board and the ground plane. (Don't isolate the boards from the ground plane! Your ground reference will be using the wiring to the boards and the metal screws that hold the boards to the ground plane.) Since then, no more blown fuses and transistors.

Methodically go through each board, checking all caps, transistors, and fuses. Any toasty connectors - replace both sides - the plug and receptacle. I like trifurcon pins best. Shotgunning will only lead to frustration. (At least for me!)

Good Luck and report back with progress.

Bill C

#3 3 years ago

Wow, that's an extreme case. I've seen this sort of thing happen after a power surge or lightning strike. Usually takes out bridge rectifiers, MOSFETs, fuses, diodes, etc. I used to know a location who had their AC unit wired incorrectly and it was causing big enough voltage drops to shatter fuses in the backbox. Another case of lightning caused several coils and transistors to short and even a relay that really should not have failed under normal circumstances. Another good example, a location had major power issues during the summer. They were having a roof AC unit replaced and some idiot electrician wired the return leg incorrectly, which fed 240v into the 120v mains circuit. That little stunt blew the power supply and obliterated half of the sound board. When I sent the sound board off to Clive he told me there was a dead short on the 5v rail and was stunned at how much damage was done. Bad power will also blow GI fuses but cause no damage to the game.

I would check the directional relay for T-Rex and the transistor that drives it. Q23 I think?

#4 3 years ago

Hey Bill!

Thanks for the great tip about using film to isolate the pcb from that metal grounding plate! I already do something similar: I put dabs of hot glue over some of the solder points (especially any that might be a bit high off of the back of the board). I once noticed that when I pushed down on one of the connectors in another pinball machine, the back of the board shorted against one of those grounding plates! I've been doing this trick ever since, although I admit, it does look goofy...

Hey Crash!

I did not have any lightning strikes or anything like that. I have a bunch of pinball machines all powered on the same circuit. Thanks for the tip about the directional relay for T-Rex and the Q23 transistor....I will have to look into that.

Well, I popped the PPB board out of the machine, and just for giggles, I opened up the back box of my Tommy the Who pinball machine and compared values of the transistors, diodes, resistors and that big 100mf 250V cap (which was the real reason for comparison - my ESR meter gave me a low reading on that cap, but both caps measured the same at 0.26). I now determined that there were only 3 bad shorted transistors and the other ones were okay. I replaced them, added some hot glue to the back of the board, and replaced the board. I turned on the machine and watched the back box. The 8A fuse above the big blue capacitor immediately blew (it made a big spark!) But, truthfully, I put in a 5A fuse there because I did not have an 8A fuse available.... Everything seems to be working fine now! The flippers and ball shooter now work, flashers are back on, lights are on, sound and DMD work great. I wonder what that 8A fuse is that keeps blowing??? Anybody have a clue? I have a manual and I did not state what it is used for.

Oh! One other problem is that the T-Rex does not eat the ball. It goes through the motions and the machine shakes a lot, but it has not eaten a ball after playing several games. Anybody have any idea why the T-Rex does not eat the ball? I did read someone else's post here that it had to do with a cable of some sort...not sure what to look for.

BTW - fixing these boards is EASY!!! I showed my 12 year old son how to check out the components and de-solder and re-install new components. The new components can be found on lots of online stores that sell pinball machine parts or electronics parts. It took me about 1/2 hour while watching an old re-run of the old 1970's show Emergency.

See ya!

Mike

#5 3 years ago

for testing stuff out. Those mini breakers with fuses soldered to them are great for troubleshooting.

#6 3 years ago

Your directional relay is fine since T-Rex is moving left and right.

#7 3 years ago

Hey CaptainNeo!

I've been looking all over for mini-breakers. Do you know of a source that sells 8A slo-blow? Great idea!

Hey Crash!

I haven't had a chance to check the T-Rex out...probably on Sunday. The machine is working very well now, even without the T-Rex working properly.

Anybody know what those two 8A fuses are for that are sitting in the back box in the lower left corner above the big blue capacitor? Thanks!

Mike

#8 3 years ago
Quoted from JohnSteed:

Anybody know what those two 8A fuses are for that are sitting in the back box in the lower left corner above the big blue capacitor?

Those are for coil and flasher power. One for 28(?)v, one for 50v.

#9 3 years ago
Quoted from JohnSteed:

I first powered up the machine. Most of the lights came on and there were a few red dots on the DMD. No sound, no power to any coils, no display. The LEDs on the CPU were all off.

The LEDs on the CPU off originally was because your 5volts was not there.

The main cause of 5volts going low or game resets is the C2 leaked out and then corrodes the trace under it. So change your C2 (100uf 25v) cap with either 100uf 35v or 50 v cap. Examine your trace under it too. You may have to use the + lead of the cap as a trace to the 2 diodes to make up for the damaged trace.

I change C2 any time I work on a DE games, as the above will eventually happen.

#10 3 years ago
Quoted from JohnSteed:

Anybody know what those two 8A fuses are for that are sitting in the back box in the lower left corner above the big blue capacitor?

Are your insert lamps working?
Is your shaker motor working?

Shorted bridge rectifier is a possibility. You were not specific with fuse blew out, so test both bridge rectifiers.

JP_backbox_(resized).png
JP_BR1_BR2_(resized).png

#11 3 years ago

I don't know if i have an 8 amp one. I forgot where I even got mine from. I think mouser.

#12 3 years ago

Hey PinballManiac40!

I did change that 100mf cap. I agree with the idea of that being a go-to thing for all of the Data East pinball games. My MO is to always start with the power supply ball and pull it out of a non-working game. I then visually inspect every component for burn marks, breakage, enlargement (like caps), etc. I then systematically test everything with my multimeter and my ESR meter. I replace all suspect parts. This way I know at least I have a working Power Supply! If everyone did this, I bet there would be a LOT less problems being posted on these boards....

Regarding your second post, yes my shaker motor works well! The lower half of the insert lights do not come on. I did not check the two BRs mounted above the fuses....I will do that this weekend. The fuse that blew out on my pin is the lower one (closest to the blue cap). Thanks for the suggestions!

Hey CaptainNeo!

Throughout lunch I have been checking websites for one of these mini breakers. I found an 8A mini breaker at Great Plains Electronics: https://www.greatplainselectronics.com/products.asp?cat=56. I would need to solder a burnt fuse to the bottom to make it fit the fuse holder (or use clips!). Thanks again!

Mike

#13 3 years ago

GPE is where i got them, that's right. Good call. I just took blown fuses and soldered them across each breaker. I put a lot of solder on as well, but only on the part that the blades touch, So you can stick them in the fuse clips easy. I bought them in every pinball size I could find.

#14 3 years ago

Hey CaptainNeo!

I will give it a try next time I order parts.

After spending a day in the snow at my son's boy scouts troop's Klondike Derby, at got home and right to work on this pinball machine. I checked both BRs that were sloppily mounted directly to the back box, above the fuse that is blowing on me. Both BRs check out just fine using the diode tester on my multi meter. I confirmed the fuse that is blowing is the one associated with GI. It has a blue wire going to it with white dashes on it. It is also associated uniquely with BR1. BR1 has purple and black wires attached to it. The purple wire goes to the cap beneath the fuse. The black wire supposedly goes to the power supply board to CN2, according to the online manual. However, CN2 on the power supply board does not have a black wire connected to it. Any ideas? Also, I verified that the lights on the bottom half of the display are not working, nor most of the feature lights on the playfield.

Thanks!

Mike

#15 3 years ago

GI actually comes in straight from the transformer to the power supply board, which switches directly to the strings via the relay through the fuses on the PPB board.

#16 3 years ago

Hey Crash!

Yeah, you're right...it is not the GI lights that are out on my JP pin. The lights that are out are considered the controlled lights via the CPU board. These are the lights on the bottom part of the display board mounted in the back box and many of the lights under the playfield.

I did place an order for one of those 8A breakers today (along with a box of fuses and other electronics supplies). I went over a LOT of these forum posts and it seems this is a popular problem with Data East pins. But, not too many people have clearly indicated where the problem stemmed from. I know it is not either of the BRs above the fuse, nor is it the big blue cap. I checked over the connections going to the CPU board. I'm thinking it is either a shorted lamp or perhaps a bad transistor on the CPU board. I would appreciate any suggestions from those who experienced this problem before...

I am going to wait until I get my 8A circuit breaker and new box of 8A fuses before testing anything under power again. I bet this has to be something simple.

Mike

#17 3 years ago

Can you post a picture of the backbox lamps and the playfield with the game on?

#18 3 years ago

I had this issue once, it was a wire that had broken off the rectifier. Have you tried tracing the 18v power through the circuit?

#19 3 years ago

Hey PM40!

Sure thing! Here's a pic showing the bottom lights out on the back box and only a handful of lights on during attract mode. (See below).

Hey Crash!

Yes, I traced the 18 volts via the schematics, but they were not easy to follow. I also took a look at the wires and everything seems to be in check. I am awaiting a new batch of fuses and that 8A circuit breaker. Right now, I have to wait (ho-hum).

Thanks!

164_(resized).jpg

#20 3 years ago

By the way, I read some of the other posts with pin owners looking for the answer to this similar situation. One recent post has a guy with a Star Wars pin blowing the same fuse. He traced the short to some board that was mounted to his coin door. This board traced to a small connector leading to connection CN4 on his CPU board. I found that blue wire with the white dots (it has a little plastic disconnect plug connected to it about 3 inches down from the wire is connected at the board). I looked all over the coin door area for a blue wire with white dots on it but could not find one.

When I get my 8A fuses and circuit breaker, the first thing I am going to do is disconnect that plug though....

168_(resized).jpg

169_(resized).jpg

166_(resized).jpg

3 weeks later
#21 3 years ago

Hello everyone!

I just got the electronics parts last week that I ordered a month ago from Mouser.com! (Always make sure they have all parts in stock before ordering, if you want to save on shipping and still get the parts timely). Anyway, one of those parts was a mini 8A circuit breaker. I took an old burnt out fuse, soldered two small wires, one to each end. The other ends of the wires I put spade connectors on and attached to my mini breaker. I inserted the breaker in to the F2 slot, powered up the machine and poof! The breaker blew like I knew it would. I turned the power to the machine off, reset the breaker, and systematically removed each plug related to the controlled lamps from the CPU board, until all of them were removed, but the circuit blew each time.

Thoroughly stumped, I rechecked the bridge rectifier associated with F2 and it checked out fine. Nevertheless, I changed it with a new one. No go. Poof! The circuit breaker blew again.

Now thoroughly stumped and completely out of options, I went back to the internet and searched all over the place for a solution. It seems a lot of other people had the same problem, but never bothered to come back to post their solution (including in this forum....). Anyway, I figured the problem must be related to the power supply board since I had previously taken that PCB out to replace some components last month. Before I took the board out, I took a look at each connector closely and low and behold, the CN4 connector was plugged in one pin over to the right! Holy Smokes! I pulled it out, plugged it in correctly, reset my circuit breaker in once again, turned the power on....and all the lights lit up without blowing the circuit breaker! Yeah!

Lessons learned: Always check your work over carefully before powering up. Also, if something different happens -an unexpected result elsewhere - always step back to look to see if something you did previously caused the problem.

Enough said...off to play some JP. Have a nice day everyone!

Mike

Promoted items from the Pinside Marketplace
$ 18.95
$ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
3,600
Machine - For Sale
The Colony, TX
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside