(Topic ID: 7921)

Jurassic Park Flipper goes dead randomly. Help please!

By ThePostmaster

11 years ago

Topic Heartbeat

Topic Stats

  • 13 posts
  • 9 Pinsiders participating
  • Latest reply 6 years ago by KenH
  • No one calls this topic a favorite


Linked Games

#1 11 years ago

Here is what is going on:

The lower Right flipper goes dead intermittently, it feels like it is being held down by electrical force. It will stay this way for random periods of time, ranging from 5 mins to over an hour, then it just starts working again.

Things I have done:

Changed coil sleeve, cleaned plunger, cleaned switch, and EOS switch. It has a double leaf switch, to run both flippers on the right.

Any help/suggestions would be welcome. Thanks,


#2 11 years ago

If i remember correctly isn't there a flipper board in the cabinet
one on the right and one on the left?

#3 11 years ago
Quoted from ThePostmaster:

it feels like it is being held down by electrical force.

So you are saying it is as if the flipper coil is activating but in the opposite direction? Is that even possible?

#4 11 years ago

So you are saying it is as if the flipper coil is activating but in the opposite direction?

That's what it feels like. What's driving me nuts, is the fact that it does this randomly, and for different amounts of time, when it happens.

#5 11 years ago
Quoted from ThePostmaster:

So you are saying it is as if the flipper coil is activating but in the opposite direction?

We're asking you if that's the case, because it sounds so weird, and we want to make sure we're clear on what's happening. I have extreme doubt that that's happening - I can't think of how that could come about - but the feel of something held in place by an electromagnet is distinctive.

#6 11 years ago

Check the fuse holders on the flipper boards. Press down against the middle of the fuse. If the fuse holder clip splits then it might have been a cracked fuse clip that was only working part of the time. Something quick and easy to try.

#7 11 years ago

Sorry for any confusion, my iPhone won't let me use the quote function.

It does feel like it is being held down by electrical force. Turn machine off, and it moves freely. Turn machine on, a good amount of resistance to move flipper. I know it is a unique problem, that's what is so puzzling. When it starts to work again, flipper moves freely.

I will check the fuzes/holders, and post my findings.

I'm at a loss, as it only does this to the lower right flipper, and not the upper one.

Are they controlled by the same fuse? I haven't looked at the schematic yet, to figure it out.

#8 11 years ago

Wow... I guess measure the voltages on the coil, when it's failing? This is bizzare.

#9 11 years ago

Diodes ok on the coil??

There is alot of repair info in clays guides about flipper problems. If it was stuck electronically, you would think it has a bad transistor or maybe diode.

I've never worked on DE's very much though...

Section 3i in his guide...

#10 11 years ago

If there is a short, blown TIP or pre driver it would energize the coil and pull the plunger into the coil. The flipper would be stuck in the up position. When the power was turned off the plunger would go back to it's normal position. Never heard of this "backwards" problem of it being held in the down position unless it was something mechanical. At this point if I was you I would switch the coil to the other flipper and see if the problem follows the coil. If it does get a new coil if it doesn't I would take a close look at the flipper assembly. To see if there is something put on wrong.
Very strange problem. Good luck with it.

5 years later
#11 6 years ago

Did you ever resolve this problem with the lower right flipper? I'm have the exact same issue on my JP right now too. Need to find a solution.

#12 6 years ago

spikedbat - check your EOS switch for that flipper and make sure it is getting good contact and is clean. I ended up replacing mine due to a similar problem and I haven't had a problem since doing that.

#13 6 years ago

Its probably the EOS thing, but just for completeness, there's a SB on correcting a problem with the flipper board. If you decide to do the modification, be skeptical of the drawings, because I think the change they shown in the schematic didn't agree with the picture, so you have to follow the schematic.


Promoted items from the Pinside Marketplace
From: $ 38.00
Cabinet - Other
Arcade Upkeep
$ 130.00
Pinball Machine
Pinball Machine


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/jurassic-park-flipper-goes-dead-randomly-help-please and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.