(Topic ID: 323609)

Jurassic Park DE flippers sticking momentarily

By SgtPin18

5 months ago

Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 5 months ago by SgtPin18
  • Topic is favorited by 2 Pinsiders


Linked Games

You're currently viewing posts by Pinsider SgtPin18.
Click here to go back to viewing the entire thread.

#1 5 months ago

DE JP both lower flippers will randomly stick up, not at the same time. It tends to happen early in the game, almost immediately after ball launch and seems to go away over time. I shut off game and whichever one is sticking immediately drops back down, so I'm sure it is electrical, just no idea where at this point.

I have completely rebuilt the flippers. New coils, stops, sleeves, arms w/plungers, bushings and EOS'. The flipper board fuses are fine, no play on the fuse clips. I have cleaned and thoroughly inspected the cabinet switches and they don't appear to be sticking. I'm kind of at a loss right now.

#3 5 months ago
Quoted from PinRetail:

On your flipper board, does the LED stay on when you push the flipper button in?
More importantly, do you have a Rottendog replacement flipper driver board?
Take the glass off your playfield, get the flipper to stick. Push the flipper back to rest position. Is it being held with a strong feeling buzz, or does it 'break back' with the slightest encouragement?
The correct flipper return spring is QUITE strong. Did you somehow get a weak return spring? The correct spring number is 265-5029-02. I definitely had this happen with a machine that someone had put weak (Williams) flipper return springs in. I suspected that the plunger was getting magnetized to the stop, but since the stronger return spring fixed it, I didn't look further.
This could be a combination of EOS switch and marginal/bad parts on the Flipper driver board. The EOS switch on Data East Jurassic Park is... challenging. Make SURE that it is REALLY tightly closed, and is the correct part. The correct EOS should be part number 180-5124-01, and be adjusted so that when the flipper is engaged there is about a 1/16 gap. Contacts on this switch frequently need to be cleaned with Alcohol fresh from the factory to make sure they making very solid connection.
Let us know what you find!

Thanks for the thoughtful reply. The LED board does not stay lit when I hit the button. Even when it sticks, the light does not stay on.

I have an original flipper board in the game. Like I said I checked all the fuse clips heavily, I might have another flipper board I could get a hold of to test.

I have taken the glass off and tried pushing it down on my own and it didn't feel magnetized, it pushed down fairly easily. The crazy thing is, it only happens immediately after ball launch from the shooter lane. After that, it doesn't happen again. I would think if it were the springs, it would continue into gameplay.

I did replace both EOS' with the model you mentioned and the gap appears correct.

I think I will try another flipper board. This does appear to be an electrical issue somewhere. It most definitely drops back down after I turn the game off.

#5 5 months ago

So, I tried with another flipper board. The sticking went away on the right flipper and it works perfectly, but my left flipper is completely not working. I checked the tip36c on the flipper board and it was bad. Replaced it and still getting nothing on the left flipper. I also am not getting any light on the LED for the left flipper on the flipper board. The previous board works with both flippers, but is still sticking at the beginning of the game.

#7 5 months ago
Quoted from grantopia:

Does this happen with the playfield raised slightly out of the game? I have had instances where something on the playfield was shorting a flipper and also instances where the cabinet switch was being closed by the playfield. Try and raise the playfield clear of the cabinet switches and see what happens.

It actually does only do it when the playfield is raised, however it leads me to believe it may be a power issue with the flipper board as it only does it after firing the ball from the shooter lane. I actually thought the same that maybe the flipper switches were being pinched by the playfield, but I don't believe that to be the case. Good suggestion though.

Promoted items from the Pinside Marketplace
$ 299.95
Lighting - Led
Pin Stadium Pinball Mods
$ 250.00
Playfield - Other
Avid Creations Wireforms
From: $ 9.99
Matt's Basement Arcade

You're currently viewing posts by Pinsider SgtPin18.
Click here to go back to viewing the entire thread.


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/jurassic-park-de-flippers-sticking-momentarily?tu=SgtPin18 and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.