(Topic ID: 195925)

Junk yard 5 gongs ?

By Stripes

4 years ago


Topic Heartbeat

Topic Stats

  • 11 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by Taxman
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

20170814_200742 (resized).jpg
20170816_230041 (resized).jpg

You're currently viewing posts by Pinsider pinballmaniac40.
Click here to go back to viewing the entire thread.

#9 4 years ago
Quoted from Stripes:

Removed, inspected, and re-enstalled the old ribbons, no change, currently no display, I know the display functions, so I ordered cables, but expect it to be something bad on the board? Maybe the caps are dried out?

Check the -112, -100 and -62 voltages to the DMD if you have nothing on the screen. I had just repaired an A/V board for a friend that -62v was shorted and blew out F1 and F2 (500mA) fuses on the board. I had to replace the 3 transistors and diode in that circuit.

It is still a chance you do have a bad ribbon cable if the voltages are good.

Promoted items from the Pinside Marketplace
From: $ 389.95
Boards
PinSound
From: $ 27.00
Boards
KAHR.US Circuits
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
Wanted
Machine - Wanted
Santa Clara, CA
$ 125.00
$ 29.95
Electronics
PinSound
6,400
Machine - For Sale
Forest Hill, MD
$ 27.50

You're currently viewing posts by Pinsider pinballmaniac40.
Click here to go back to viewing the entire thread.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!