(Topic ID: 195925)

Junk yard 5 gongs ?

By Stripes

4 years ago


Topic Heartbeat

Topic Stats

  • 11 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by Taxman
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

20170814_200742 (resized).jpg
20170816_230041 (resized).jpg

#1 4 years ago

Hello all. I have a Williams Junk Yard pin. When it is first powered on, it goes ding, then 5 gongs. The manual sais that's S5 failure. I believe that's on the audio visual board. The game plays great, sound appears 100%, but the display sometimes displays, sometimes freezes, sometimes blank. Would replacement of S5 correct this? I thought S5 was just for sound?
I have replaced the display with a color rgb version and have the same issues. The diagnostic leds are all lit properly. Suggestions? Thanks!

#2 4 years ago

First rule is reseat the ribbon cables. Push the all down nice and tight.

Also, is there a credit dot? Is there any reported problems?

#3 4 years ago

Occasionally the display runs ok, but now it's either all blank or frozen at "game over". Sometimes it displays half text. Remainer of game runs fine. When it works, it will play fine until it's turned off and on again.

I reset all the ribbon cables, checked all connections and chips on board to ensure they are tight. No change.leds ok.

Since the board freezes yet displays some text, does that indicate a cpu issue or video audio board issue? When the display is acting up, I can't get into the test mode. It just tones when I press any of the 4 buttons.

Should I start with new ribbon cables?

My test said right out lane switch 27, switch 67 & 68 bowl entry/exit. I adjusted 67 & 68 and they work now. I can't tell of I get a decimal as it won't display now.

20170816_230041 (resized).jpg

20170814_200742 (resized).jpg

#4 4 years ago

Any Junkyard owners out there?

#5 4 years ago

Yes, I own a JY. But the issue is not game specific.

When another WPC game had screen started freezing up the game would play even when frozen. I could unplug the data and power cable from the DMD, plug it all back in and the frozen image would come back. (I know, doing this with the game on is not cool kids)

So the MPU was running the game but the image in the RAM for the display was not getting refreshed. Even though I had reseated the cables I did the one from the CPU to the A/V board again and everything was fine.

So when you are trying to get it in test mode those beeps you hear are the game getting into the menu and all, but you just can't see it.

Just a thought. Those cable are the cause of issues like this most of the time.

#6 4 years ago

ok, thanks, i'll order cables and try it out.

#7 4 years ago
Quoted from Stripes:

ok, thanks, i'll order cables and try it out.

First check the ones you have. Sometimes the plastic connector that is crimped on the ribbon cable itself starts to separate.

#8 4 years ago

Removed, inspected, and re-enstalled the old ribbons, no change, currently no display, I know the display functions, so I ordered cables, but expect it to be something bad on the board? Maybe the caps are dried out?

#9 4 years ago
Quoted from Stripes:

Removed, inspected, and re-enstalled the old ribbons, no change, currently no display, I know the display functions, so I ordered cables, but expect it to be something bad on the board? Maybe the caps are dried out?

Check the -112, -100 and -62 voltages to the DMD if you have nothing on the screen. I had just repaired an A/V board for a friend that -62v was shorted and blew out F1 and F2 (500mA) fuses on the board. I had to replace the 3 transistors and diode in that circuit.

It is still a chance you do have a bad ribbon cable if the voltages are good.

#10 4 years ago

My new ribbon cables arrived and it totally fixed my problem! Thank you so much for the sound advice and assistance!!!

#11 4 years ago
Quoted from Stripes:

My new ribbon cables arrived and it totally fixed my problem! Thank you so much for the sound advice and assistance!!!

It is nice when it is the cheap and easy fix. Glad it worked. Now go collect some junk

Promoted items from the Pinside Marketplace
$ 37.50
$ 109.95
Electronics
PinSound
$ 99.00
Playfield - Other
Arcade Upkeep
Wanted
Machine - Wanted
Blackwood, NJ
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 35.00
Cabinet - Other
Arcade Upkeep
From: $ 27.00
Boards
KAHR.US Circuits
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!