(Topic ID: 212681)

Jungle Queen no startup, backbox lights + tilt only


By Boise_D

1 year ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Boise_D
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hoping someone can give some ideas on why 1977 Jungle Queen won't start.
The game has power. Backbox lights when turned on. Tilt is also lit on backbox. No playfield lights.
The continuous hold relays are not activated.
Checked all the slam tilts I could find, and all look correct.
The game has credits.
The coindoor lockout is not engaged.
Clue? If I use a wooden chopstick to manually activate the Tilt Hold relay, the tilt goes off on the backbox and all of the playfield GI lights come on
The Jones plugs are all plugged in
Score motor does nothing if gently moved
There is a very low hum, which I think is the transformer, since nothing else is activated in the bottom

#2 1 year ago

I'd need to see a high quality scan of the schematic. Make it easy for us to help you!

#3 1 year ago

What about if you hit the Start relay after Tilt Hold? Might be in the latch relays, but as noted by HowardR, a good schematic is the first step.

#4 1 year ago

I tried the start button while manually activating the tilt hold, but the start sequence did not begin. There are 3 continuous hold relays on this game I think, so I need to figure out why power is not reaching any of them.

#5 1 year ago

Guessing the 24 volt fuse is blown or the transformer isn't supplying that voltage. Or a wire is broken. Trace using standard electrical troubleshooting techniques.

Unless the "Service plug" on the score motor is out or in the "off" position, the motor should cycle 120° when the game is on (lights on) otherwise, you are missing voltage.

#6 1 year ago

Typo on my post: Start "relay," not "replay."

#7 1 year ago

solved. I noticed that the slam tilt on the cabinet bottom left (above a hole and near the motor) was not contacted. I'm always unsure of whether these should be contacted or not since some are NO and others are NC. I adjusted it to be NC and power came back. The coin door lockout activated, as did the hold relays. Pressing start begins the startup sequence. I need to look at my score reels next. I don't think they all reset properly. I need to check the schematic. I didn't think that the tilt switches came before the hold relays or coin door lockout.

Promoted items from the Pinside Marketplace
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
795 (OBO)
Machine - For Sale
Hauppauge, NY
€ 8.40
From: € 3.70
Flipper Parts
Buthamburg
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 189.00
Boards
Little Shop Of Games
$ 99.99
Lighting - Other
Lighted Pinball Mods
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 249.99
Cabinet - Armor And Blades
Great American Pinball
$ 35.95
Playfield - Other
MicksPinball
$ 24.99
Lighting - Led
Lee's Parts
$ 22.50
$ 66.95
Cabinet - Shooter Rods
Super Skill Shot Shop
€ 9.10
$ 35.00
$ 999.00
$ 69.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 239.99
Lighting - Led
PinballBulbs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside