(Topic ID: 234002)

Jungle Lord System 7 Repair


By Platinumcd

4 months ago



Topic Stats

  • 11 posts
  • 6 Pinsiders participating
  • Latest reply 3 months ago by Platinumcd
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 months ago

Hello,

I have sent off my Jungle Lord CPU for repair. The repair shop has given me doubt as to the ability of the repair. What are my options if this board cant be repaired. Is there a new style replacement ? or what other options do I have. I have went too far into into the restore to back out now.

Thanks for any help

#2 3 months ago
Quoted from Platinumcd:

Hello,
I have sent off my Jungle Lord CPU for repair. The repair shop has given me doubt as to the ability of the repair. What are my options if this board cant be repaired. Is there a new style replacement ? or what other options do I have. I have went too far into into the restore to back out now.
Thanks for any help

Thanks for all the help ?

#3 3 months ago

What’s wrong with the boards that the shop can’t fix them? What shop is it ?

#4 3 months ago
Quoted from ryanbrooks:

What’s wrong with the boards that the shop can’t fix them? What shop is it ?

It was the shop that bought out two bits in Texas. He said he did not have the necessary test equipment to test it further but it was blowing something when hooked up to his blacknight. I was just curious if I should send to someone else for repair or try and buy a new board.

#5 3 months ago

Check ks arcade for replacements. Here's a new swemmer board https://ksarcade.net/swemmer-system-7-mpu-1d-2001-133-7-w-roms.html

Also here's a list of board repair guys. Have some good pics ready to send them including any damaged areas.http://www.pinwiki.com/wiki/index.php?title=Pinball_Board_Repair_Services

#6 3 months ago

I'm using a Rottendog mpu. Works great and replaces both cpu and driver.

#7 3 months ago
Quoted from Caveman-Gurkan:

I'm using a Rottendog mpu. Works great and replaces both cpu and driver.

I thought the rottendog replacement board doesn't support system 7 anymore because of a bug.

#8 3 months ago
Quoted from action76:

I thought the rottendog replacement board doesn't support system 7 anymore because of a bug.

Yes, Rottendog claims it wont run on system7. My mpu is from 2015 and everything plays fine. Think they had sound issues on Black knight.

1 week later
#9 3 months ago

Well I wanted to follow up to this. I took the advice I was given and sent my MPU board in for repair. The game was not firing up prior to this as it had set for along time. It only had the back lights and the sound when it would first come on. So fast forward I had a local tech replace the capacitors in my power supply board and I got the MPU back from the other repair shop. It looks like they replaced some roms. The local tech came and installed all of this last night then the game came. At first it had game sounds but then that quit working. All of the drop targets are working fine. Even with no sounds now the score is still registering. It would originally eject the ball out but that quit working as well. The small bonus ball in the top left would light up when activated but it never shot the ball. I have not replaced any capacitors in the sound board yet but I can if I need to. The magna save works on one side but does nothing on the other side when pressed. I am sure I have multiple issues but what are your suggestions. Where do I start ? Does it sound like some of this could be from the MPU I just got back or a driver board ? I sure would appreciate some feedback on this.

#10 3 months ago

Your plan of attack should be to look at each of the issues independently, as they don't sound related yet.

Make sure you learn how to use the test menu.

Sound - try in test mode. Check your connectors, play with your volume potentemeter.

Ball eject - check the switch test to see if the trough is registering both balls. It won't activate otherwise. Use the coil test to make sure both the eject coil and the out hole coil are moving the balls to the right position.

Same process for your bagatelle eject. Probably a switch adjustment.

Magnasve can be tested with coil test too I think. But check your cab button and there is a relay under the playfield for it too.

If you cant make any progress, I'd call your tech back and see if he can figure it out.

#11 3 months ago

Thank you sir. Sounds like a great place to start !!

Promoted items from the Pinside Marketplace
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 14.99
Electronics
PinballElectronics.com
From: $ 9.00
$ 20.00
Electronics
Yorktown Parts and Equip
$ 15.00
Cabinet - Other
Siegecraft Electronics
$ 399.95
From: $ 54.00
$ 54.00
Playfield - Toys/Add-ons
Lermods
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 69.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 65.00
Cabinet - Armor And Blades
Texas Pinball
$ 7,500.00
Pinball Machine
Nitro Pinball Shop
$ 9.00
Playfield - Other
Hdmike mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside