(Topic ID: 143352)

Judge Dredd - Various Issues


By RetroGeet

3 years ago



Topic Stats

  • 14 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by RetroGeet
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 7 images uploaded to this topic. (View topic image gallery).

IMG_20151107_213359160.jpg
IMG_20151107_213350027.jpg
IMG_20151104_240838271.jpg
IMG_20151103_224017528.jpg
IMG_20151103_223737408.jpg
IMG_20151103_223714038.jpg
IMG_20151103_223729495.jpg

#1 3 years ago

Just bought my first pin, seems to be in good nick with only a couple of issues. I'm a bit scared to start investigating as when the coin door is opened it doesn't acknowledge this on the display. Does this mean that it isn't disabling the high voltage circuitry? I don't really want to start fiddling unless I know I'm not gonna zap myself!

The other problems are:
- Crane magnet isn't picking up ball (machine doesn't have deadworld mod so this isn't too big a deal)
- 'D' drop target isn't popping up
- Machine isn't detecting ball entering subway
- Ball lock 3 & 'D' drop target lamps not lighting (I assume that's just the lamps that have gone, I've got some new ones on order)
- Volume down button isn't working

Just wondering if any of these are common problems? Once I know the high voltage is disabled then I'm much more happy to have a fiddle

#2 3 years ago

Crane just needs adjusted( very finiky). Bulbs or sockets are prob bad on lights, drop target missing a spring, if volume only goes down to 8 its normal.

#3 3 years ago

Subway not working is a switch or opto

#4 3 years ago

My JD doesn't say anything about the power being disabled either when the coin door is open. You could probably check if it is by trying the flipper or something high powered with the door open.

I had to clean my judge drops to get them to operate smoothly. Don't lube them! Just clean with novus and reassemble correctly

#5 3 years ago

Yep, pull off 5 bank drop target assembly and rebuild. Really easy and the drops should work much better. Might have to replace a drop or repair if it's cracked.

I can't remember exactly but optos should be as easy as one Philips screw to remove to gain easy access to opto. Clean with alcohol and a Q-tip.

Volume down button probably doesn't work because volume is already down to 8. You have to go into the menus to override minimum volume setting.

#6 3 years ago

Cheers for the quick reply all

D'oh, didn't think to try the flippers with the door open. Seems obvious now. I'll try that when I get back from work.

Didn't specify properly before. When I say the volume down button isn't working I mean the actual button isn't working, doesn't do anything in the menus either.

#7 3 years ago

I checked the coin door open\close switch in switch test mode although it's reporting as working fine, it still lets me start a game with the coin door open and the flippers operate. I assume that means high voltage isn't being disabled when the coin doors opened for some reason?

Managed to fix the drop targets although the subway still isn't working. Does that just need removing from underneath and checking to make sure the opto is lined up?

I did the most nooby thing to do and forgot to grab the balls before flipping up the playfield. The strange thing is I seem to have lost two balls completely, I swear I've looked everywhere for them. One was in the cabinet, a couple were wedged behind the playfield and one had dropped into the sniper tower but I can't for the life of me find the other two. Is there anywhere obvious I'm forgetting to look? It's now kicking out two balls when a game is started, is this because there isn't enough balls loaded into the trough? It was working fine with six balls before.

And finally, still can't get the 'down' button to work even though the other three buttons work fine. I've attached pictures of everywhere I think it's connected, can anyone see any faults anywhere?

IMG_20151103_223729495.jpg

IMG_20151103_223714038.jpg

IMG_20151103_223737408.jpg

IMG_20151103_224017528.jpg

IMG_20151104_240838271.jpg

#8 3 years ago

Game seems to eject the correct number of balls as long as an odd number isn't loaded into the trough, is this normal? I've got new balls on order so that should sort that problem out.

Just the subway opto and volume down button to sort out now

#9 3 years ago

There are no optos fir the subway, just switches, and it may be as simple as adjusting the switch arm.

As for the balls, not sure what you mean by an even number vs an odd number. There should be 6 balls in there. If it is kicking out 2 balls still then you probably have a bad opto on the trough board. If you take all the balls out you can use a card or piece of paper to to each switch in test mode. You can also use a camera to see if the optos are emitting any light.

#10 3 years ago

Was going to try the subway switch out in test mode but realised the flippers are still working even when the coin door is open. Doesn't this mean the high voltage circuits are still active? I'm still a bit paranoid about zapping myself

I've tested the coin door open/close switch in test mode and that's working fine there. Any ideas?

#11 3 years ago

Fixed the subway switch. Found a problem with the trough opto now though. LED 4, 6 & 7 aren't transmitting (tested with my phone camera). Is the board knackered? Pinball Heaven sell one for £20 so thinking of just getting a replacement rather than attempting repair.

Still can't find where the problem with the volume down button is as well. Can anyone see any faults in the previous pics I posted of it?

IMG_20151107_213350027.jpg

IMG_20151107_213359160.jpg

#12 3 years ago

One of my machines developed a fault which I thought was the optos. Kept ejecting balls to trough..Turned out when I moved to get to the back of my TZ. One of the EPROMs had unseated itself a bit. Just a gentle push on the chips and all was well. So wasn't booting up correctly..

Did you buy the machine from Arbroath in Scotland

#13 3 years ago
Quoted from RetroGeet:

Fixed the subway switch. Found a problem with the trough opto now though. LED 4, 6 & 7 aren't transmitting (tested with my phone camera). Is the board knackered? Pinball Heaven sell one for £20 so thinking of just getting a replacement rather than attempting repair.
Still can't find where the problem with the volume down button is as well. Can anyone see any faults in the previous pics I posted of it?

I am no expert, but it looks like some work may have been done to that board already. Unless you know your stuff, I'd say that you should just get the new board and be done with it.

#14 3 years ago

I've ordered a new board. It had definitely been worked on before, tried reflowing solder on round the components which managed to get one of them working intermittently, but two are still dead.

Yeh I did get it from Arbroath, did it used to be yours?

Promoted items from the Pinside Marketplace
$ 29.50
Playfield - Plastics
Pinball Haus
$ 25.00
Playfield - Plastics
Pinball Haus
Wanted
Machine - Wanted
Chicago, IL
Wanted
Machine - Wanted
Fort Lauderdale, FL
$ 47.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside