(Topic ID: 181797)

Judge Dredd Launcher Repeatly Fires


By paulywalnuts23

2 years ago



Topic Stats

  • 18 posts
  • 7 Pinsiders participating
  • Latest reply 2 years ago by kvan99
  • No one calls this topic a favorite

You

Linked Games

#1 2 years ago

So I have had an issue with a Judge Dredd where if you power on the game with balls remaining in the Dead World from a previous game. If you hit the start button the game goes into pinballs missing and the ball launcher starts to repeatedly fire till it blows the fuse.

Anyone ever see this type of behavior or have any suggestions.

#3 2 years ago
Quoted from paulywalnuts23:

So I have had an issue with a Judge Dredd where if you power on the game with balls remaining in the Dead World from a previous game. If you hit the start button the game goes into pinballs missing and the ball launcher starts to repeatedly fire till it blows the fuse.
Anyone ever see this type of behavior or have any suggestions.

Wow! Interesting...

I believe this is, at least partially, expected.

First, later versions of the JD software specifically called out changing the timing of the launcher coils to prevent the fuse from blowing. Since you are running Deadworld mod, you don't have this improvement. So the fuse blowing is undesirable but is probably expected with L1 / L1AT under aggressive ball hunting. I haven't seen this myself, however.

As for why your JD is going into ball hunt mode, is your Deadworld mod working 100%? If I have balls in Deadworld, power the game off, power it back on... The game will use the crane to remove them when start is pressed

Did you end up powering off the game with balls in Deadworld because it was acting weird?

Is the switch in the shorter lane working?

#4 2 years ago
Quoted from altan:

Wow! Interesting...
I believe this is, at least partially, expected.
First, later versions of the JD software specifically called out changing the timing of the launcher coils to prevent the fuse from blowing. Since you are running Deadworld mod, you don't have this improvement. So the fuse blowing is undesirable but is probably expected with L1 / L1AT under aggressive ball hunting. I haven't seen this myself, however.
As for why your JD is going into ball hunt mode, is your Deadworld mod working 100%? If I have balls in Deadworld, power the game off, power it back on... The game will use the crane to remove them.
Did you end up powering off the game with balls in Deadworld because it was acting weird?
Is the switch in the shorter lane working?

If I have balls left in Deadworld and I turn the machine on, it DOES NOT automatically empty the balls.

They were left there from a previous game for no real reason.

The switch in the shooter lane worked last time I checked. I will check again and report back.

#5 2 years ago

You probably have a grounded out switch in the lane....remove the balls, pick up the playfield and look at the switch and the wires make sure it's not touching the sides or anything metal in the area, also look at the diode to see it's not bent out and touching something.

#6 2 years ago

it sounds to me like you need a new trough opto board.

#7 2 years ago

I agree with Zinzangzoom. I had that exact same issue with my Judge Dredd that also has the deadworld mod. Mine ended up being a loose wire that plugs into the trough opto board. You might try checking that.

#8 2 years ago

I will check out both the lane switch and test out the trough as well and check all connections then report back.

Thanks for the help guys.

#9 2 years ago

This may be a simple adjustment of the switch, on my dredd I was having the problem where when the plunger fired it would hit the switch in the shooter lane just enough to reactivate it, I had to bend the switch arm to sit lower then the plunger but still activate with the ball.

Also if I have balls left on my dead world when the game is turned off they will not clear until I try to start a game and it goes into ball search

#10 2 years ago
Quoted from PunkPin:

This may be a simple adjustment of the switch, on my dredd I was having the problem where when the plunger fired it would hit the switch in the shooter lane just enough to reactivate it, I had to bend the switch arm to sit lower then the plunger but still activate with the ball.
Also if I have balls left on my dead world when the game is turned off they will not clear until I try to start a game and it goes into ball search

Well that is what it is trying to do when I hit the start button. The Deadworld and crane start to move to remove the balls however at the same time the launcher starts to jack hammer, with no balls in the trough, until it blows the fuse.

#11 2 years ago

Test trough optos/boards for proper operation. Then check for divots in the trough where the ball might hang up. Verify correct quantity of balls installed.

#12 2 years ago

For clarity, I did mean the balls are removed after power cycle when start is pressed.

#13 2 years ago
Quoted from altan:

For clarity, I did mean the balls are removed after power cycle when start is pressed.

Got it.

#14 2 years ago

The ball search to clear the dead world would activate the shooter plunger, while you are down there checking the trough optos I would also manually push out your shooter plunger and see if it is making contact with the lane switch, if it is reactivating itself over and over that could blow the fuse.

#15 2 years ago

The plunger would activate during search, yes but when a plunger is machine gunning more often than not it's the switch in the shooter lane .

#16 2 years ago
Quoted from PunkPin:

The ball search to clear the dead world would activate the shooter plunger, while you are down there checking the trough optos I would also manually push out your shooter plunger and see if it is making contact with the lane switch, if it is reactivating itself over and over that could blow the fuse.

Never thought to look to see if the plunger is reactivating the switch, will check when I get home.

#17 2 years ago

Ok. Checked the Trough in switch test and 1-6 and Top Trough register as expected. The kicker touches the switch but does not activate it, and the switch registers as expected when depressed.

examined switch looked fine as did the diode. However just tested the diode and it appears to be dead and is shorting the switch.

So I think I have found the issue. I will replace the diode and see if that fixes the issue. Thanks for the help all.

#18 2 years ago

Ding...ding..ding. Nice, the Judge will ride again.

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 28.00
Wanted
Machine - Wanted
Portland, OR
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
Wanted
Machine - Wanted
Chicago, IL

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside