(Topic ID: 244666)

JJPOTC Treasure Chest Open/Close mod, now working!

By pinballj

5 years ago


Topic Heartbeat

Topic Stats

You

Linked Games

Topic Gallery

View topic image gallery

IMG_20230211_193725 (resized).jpg
IMG_20230211_193309 (resized).jpg
IMG_20230211_174738 (resized).jpg
2022-12-10 18.13.36 (resized).jpg
2022-12-03 16.39.16 (resized).jpg
2022-12-03 16.39.03 (resized).jpg
20221109_175012 (resized).jpg
20221109_190714 (resized).jpg
20221109_175033 (resized).jpg
20221109_174757 (resized).jpg
IMG_20221017_152356_edit_415805112164156 (resized).jpg
IMG_20221017_151959 (resized).jpg
IMG_20221017_151839_edit_415860847540189 (resized).jpg
IMG_20221017_151846_edit_415835308941755 (resized).jpg
D51450B8-C097-4943-9B2C-5358436C4892 (resized).jpeg
IMG_2497 (resized).jpg

Topic index (key posts)

4 key posts have been marked in this topic (Show topic index)

There are 1,330 posts in this topic. You are on page 27 of 27.
#1301 3 years ago
Quoted from djsoup:

So I figured out the issue. The white bushings (on the fork mechanism) aren't fully depressing the silver switch on the mod when it rolls all the way back. Unfortunately the housing of the mod doesnt sit far forward enough on my machine, so while the bushings slide back and touch it, it doesnt push it back enough to trigger the mod to open/close.. in order to get this to work I had to move the mod/housing up so when the bushing rolls back it actually hits this silver switch and triggers it. Right now I just have tape holding it down, but I think may need to drill some new holes into the bracket to hold it in place, since this new placement isnt in line with the current holes on the mod bracket. I was just about to give up on it.. but glad I didnt! This is a really cool mod and it adds a lot to the game now. Hope this helps you guys with yours!

Just re-bend the switch actuator out more. This is a common problem and an easy fix.

#1302 3 years ago
Quoted from Mrsiyufy:

Can you post a picture of the other side of the mod where the switch is. Most likely the leg of the switch needs to be bent so that the nylon spacers from the fork assembly activate the switch

20210102_202820 (resized).jpg20210102_202820 (resized).jpg
#1304 3 years ago

Do I need to bend that switch more so it's clicking when it's touching?

#1305 3 years ago

Thanks for all the help! Seemed to be a combination of the switch on the right side not seeing that it was being hit and on the left side the motor when it started up pushed it back into a different starting position that would not move the rod enough to work the chest. I took the screw out of where the rod connects to and let it go through calibration and then put it back on. . Working!

2 months later
#1306 3 years ago
Quoted from harryhoudini:

Thanks
Here's a video on some common questions and cutting the rod:

I had installed the original lid insert but purchased the most recent mod. I struggled tying to figure out how to install it until I found this video. It is extremely useful.

I think it would be helpful to include this on your installation page, and put it on the 'Key Posts' list. And it took me a while to figure out how to install the clevis. Never having worked with one before, I did not realize I pry it open. My clevis pin did not go through the hole well, so I drilled it out. Works fine.

It looks like the top installs with the LEDs facing up. I assume that is correct. I initially installed with the LEDs down, but then the hinge is in the wrong position.

When I try to change the color, I briefly see other colors, but then it goes back to dark red.

Since the flexible rod is installed on the lid, then the lid is put in position, I cannot figure out how to install the second nut holding the hinge to the chest body. So I currently just have one nut installed.

I don't have a laptop (desktop and tablets) so installing the software update will not be easy. It seems to work fine as is. What does the software update bring us?

Thanks again. Best mod ever.

1st picture shows the inside lid with the LEDs up. That is correct? The chest does not get very bright, even at full brightness.
2nd picture shows the chest open, working properly.
3rd picture shows clevis position with the chest lid closed.
4th picture shows clevis position with the chest lid open.
5th and 6th pictures show LED colors that appear briefly, when selecting change color button. But the color immediately reverts to dark red.
7th shows the missing nut on the chest hinge, that I cannot figure out how to install.

IMG_2486 (resized).jpgIMG_2486 (resized).jpgIMG_2487 (resized).jpgIMG_2487 (resized).jpgIMG_2488 (resized).jpgIMG_2488 (resized).jpgIMG_2489 (resized).jpgIMG_2489 (resized).jpgIMG_2493 (resized).jpgIMG_2493 (resized).jpgIMG_2495 (resized).jpgIMG_2495 (resized).jpgIMG_2497 (resized).jpgIMG_2497 (resized).jpg
#1307 3 years ago

I got this mod last week and finally had some time to work on installation the past few days. After reading through here and watching the installation videos I got the mod working and dialed in, with many extra hours of fiddling. However, the chest will no longer drop balls once three have been locked. I am not sure what I did to cause that issue. How do I adjust this? I cannot find a timing option in game for it, and didn't want to undo the entire mod just to look in the back and see what I may have messed up. Does anyone have any advise on how to adjust this timing? Once the third ball is locked, it tries to release the balls, but doesn't leave the gate open long enough to allow a ball to pass, so whatever is wrong is a minor issue. Maybe something too tight or a lever hit, or a screw turned in error.

Thanks!

#1308 3 years ago
Quoted from Furio:

How do I adjust this? I cannot find a timing option in game for it, and didn't want to undo the entire mod just to look in the back and see what I may have messed up. Does anyone have any advise on how to adjust this timing?

First, please ensure that the 3 optos inside the chest are still in place. They very easy ‘pop out’ while installing the mod.

Second, there is a Chest Release timer in the JJP software menu. Please look for it, and increase by 1 second or more in order to allow enough time to release the balls.

#1309 3 years ago
Quoted from Furio:

I got this mod last week and finally had some time to work on installation the past few days. After reading through here and watching the installation videos I got the mod working and dialed in, with many extra hours of fiddling. However, the chest will no longer drop balls once three have been locked. I am not sure what I did to cause that issue. How do I adjust this? I cannot find a timing option in game for it, and didn't want to undo the entire mod just to look in the back and see what I may have messed up. Does anyone have any advise on how to adjust this timing? Once the third ball is locked, it tries to release the balls, but doesn't leave the gate open long enough to allow a ball to pass, so whatever is wrong is a minor issue. Maybe something too tight or a lever hit, or a screw turned in error.
Thanks!

Check here:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/50#post-5433533

#1310 3 years ago
Quoted from ellips6:

First, please ensure that the 3 optos inside the chest are still in place. They very easy ‘pop out’ while installing the mod.
Second, there is a Chest Release timer in the JJP software menu. Please look for it, and increase by 1 second or more in order to allow enough time to release the balls.

Also it's very easy to slightly bend the arm that holds the balls in tighter. It then doesn't have enough time to swing out and let the balls out. That coil doesn't hold the arm open for long to allow the ball to drop out

11 months later
#1311 2 years ago

The chest lid does not open anymore. The UP-switch is working. The DOWN-switch doesn’t register in test. I believe this is normal since it is an extra switch.
The motor finds a rest position once I turn the Wheel a bit. But the wheel does not turn when the UP-switch is engaged.
Any advice?

#1312 2 years ago

Game off and on: works again!!!

3 months later
#1314 2 years ago

My chest opens ok, but doesn’t close at all or just about 0,5 cm. The coil works and the fork moves up and down ad it should. In test the forks mech tests ok.
I re-adjusted the rod. But the problem is sometimes gone but comes back after a few up and down cycles.
Any advice on how to solve this? I now have a unlit open chest when it is supposed to be closed and unlit.

#1315 2 years ago

I removed the rod from the servo: only movement to open the chest, no movement in the other direction (to close).
Any thoughts anyone?

#1316 2 years ago

Could be anything from needing to be reprogrammed (e.g. if it "lost" the close part of the program) to something like the actual servo being broken?

But if it is able to open, it sounds like at some point it must be "reversing"? Otherwise it would run out of space in the "open" direction?

If it is not closing, the simplest solution is to check (and I am going from memory from years ago) is if the switch that is part of this mod is working / hooked up etc? I thought there was a switch that helped read whether the forks were up or down. If that is not working, the mod would not work...

#1317 2 years ago

I already replaced the switch that is attached to the mod: no difference.
The regular switch that detects the “up” position works fine.
I believe the servo is 50% broken: it only moves in 1 direction. Or the program is partially malfunctioning.
What is the servo part number?
How can I re-install the software on this mod?

#1318 2 years ago

Replaced servo: problem solved.

1 month later
#1319 1 year ago

hoping someone can give me a bit of guidance. I have everything connected (i think) but the weird thing is the mod works on boot up but then not during the game.

I've made two videos to show what I mean. Any guesses what might be happening? (thanks for any advice)

working on boot up -

not working in game -

#1320 1 year ago
Quoted from dmj1977:

hoping someone can give me a bit of guidance. I have everything connected (i think) but the weird thing is the mod works on boot up but then not during the game.

I've made two videos to show what I mean. Any guesses what might be happening? (thanks for any advice)

working on boot up -

It's been a while, but the chest will activate on bootup every time. Since it's working there, it looks like you probably have the rod installed correctly. When in a game, the chest is instead activated by a switch that is triggered by the movement of the diverter forks. I would suspect an issue with the alignment of that switch. There's some info about it in the posts at the top of this page.

#1321 1 year ago
Quoted from dmj1977:

hoping someone can give me a bit of guidance. I have everything connected (i think) but the weird thing is the mod works on boot up but then not during the game.
I've made two videos to show what I mean. Any guesses what might be happening? (thanks for any advice)
working on boot up -
not working in game -

Align the switch under the playfield so it triggers properly from the forks movement. Either the switch is dead or it's not being triggered by the movement of the forks.

#1322 1 year ago
Quoted from Betelgeuse:

It's been a while, but the chest will activate on bootup every time. Since it's working there, it looks like you probably have the rod installed correctly. When in a game, the chest is instead activated by a switch that is triggered by the movement of the diverter forks. I would suspect an issue with the alignment of that switch. There's some info about it in the posts at the top of this page.

Quoted from PinMonk:

Align the switch under the playfield so it triggers properly from the forks movement. Either the switch is dead or it's not being triggered by the movement of the forks.

Thanks both! I'll tackle that this evening - much appreciated.

1 month later
#1323 1 year ago

EDIT: was able to find JUST enough slack to make the connection, it might actually lift the lid a little over time, it did so right out of the gate but not after a tiny bit more stretching.

Anyhow working for now!

_________

I’m probably one of them last people to be installing this mod, but I just received it.
Took me a LONG time to piece together the right instructions, as the PMC instructions skip past chest lid disassembly and then jumps around in the sequence of videos. I kept doing things out of order. Anyhow, I’d guess there aren’t many people after me so maybe not worth the effort to fix, but feel free to ping me if anyone in the future struggles here.

My remaining question: the lighting wiring is only shown from the topside, and on mine the wire cannot reach over to the right side of the mechanism where the connector is. Can anyone show me what theirs looks like, or what to do if the wire doesn’t reach? I don’t think I have any slack in the topside/chest part, and it looks like the red wire for the 3-pin connector coming from Arduino is too short to let out any further.

PS: This is definitely a top-5 mod of all time, and #1 amongst the non-artistic mods. . Well done to both the creator and the kit-seller.
D51450B8-C097-4943-9B2C-5358436C4892 (resized).jpegD51450B8-C097-4943-9B2C-5358436C4892 (resized).jpeg

#1324 1 year ago
Quoted from prentice:

EDIT : a été en mesure de trouver JUSTE assez de mou pour établir la connexion, il pourrait en fait soulever un peu le couvercle avec le temps, il l'a fait dès la sortie de la porte, mais pas après un tout petit peu plus d'étirement.
Quoi qu'il en soit travailler pour l'instant!
_________
Je suis probablement l'une des dernières personnes à installer ce mod, mais je viens de le recevoir.
Il m'a fallu beaucoup de temps pour rassembler les bonnes instructions, car les instructions PMC sautent le démontage du couvercle de la poitrine, puis sautent dans la séquence de vidéos. J'ai continué à faire les choses dans le désordre. Quoi qu'il en soit, je suppose qu'il n'y a pas beaucoup de monde après moi, donc cela ne vaut peut-être pas la peine de réparer, mais n'hésitez pas à me contacter si quelqu'un à l'avenir se débat ici.
Ma question restante : le câblage d'éclairage n'est montré que du dessus, et sur le mien, le fil ne peut pas atteindre le côté droit du mécanisme où se trouve le connecteur. Quelqu'un peut-il me montrer à quoi ressemble le sien ou quoi faire si le fil n'atteint pas? Je ne pense pas avoir de mou dans la partie supérieure/poitrine, et il semble que le fil rouge du connecteur à 3 broches provenant d'Arduino soit trop court pour sortir plus loin.
PS : C'est définitivement l'un des 5 meilleurs mods de tous les temps, et le n°1 parmi les mods non artistiques. . Bravo à la fois au créateur et au vendeur du kit.
[quoted image]

Here are pictures of my setup. I hope that that will be able to help you.

IMG_20221017_151839_edit_415860847540189 (resized).jpgIMG_20221017_151839_edit_415860847540189 (resized).jpgIMG_20221017_151846_edit_415835308941755 (resized).jpgIMG_20221017_151846_edit_415835308941755 (resized).jpgIMG_20221017_151959 (resized).jpgIMG_20221017_151959 (resized).jpgIMG_20221017_152356_edit_415805112164156 (resized).jpgIMG_20221017_152356_edit_415805112164156 (resized).jpg
3 weeks later
#1325 1 year ago
Quoted from prentice:

EDIT: was able to find JUST enough slack to make the connection, it might actually lift the lid a little over time, it did so right out of the gate but not after a tiny bit more stretching.
Anyhow working for now!
_________
I’m probably one of them last people to be installing this mod, but I just received it.
Took me a LONG time to piece together the right instructions, as the PMC instructions skip past chest lid disassembly and then jumps around in the sequence of videos. I kept doing things out of order. Anyhow, I’d guess there aren’t many people after me so maybe not worth the effort to fix, but feel free to ping me if anyone in the future struggles here.
My remaining question: the lighting wiring is only shown from the topside, and on mine the wire cannot reach over to the right side of the mechanism where the connector is. Can anyone show me what theirs looks like, or what to do if the wire doesn’t reach? I don’t think I have any slack in the topside/chest part, and it looks like the red wire for the 3-pin connector coming from Arduino is too short to let out any further.
PS: This is definitely a top-5 mod of all time, and #1 amongst the non-artistic mods. . Well done to both the creator and the kit-seller.
[quoted image]

Guess what! I'm also late to the party, having just received my unmodded POTC. And like you...yeah, trying to piece together the instructions was interesting, since there have been so many changes to the mod. Just figuring out what to ignore, or even what has changed, took a while. This video really helped, but even so, now there is no "yellow" thing to cut ->

https://pinside.com/pinball/forum/topic/jjpotc-treasure-chest-open-and-close/page/24#post-5385656

The rod is essentially cut to the right length, though if it was ANY shorter I would have some install problems. (I lengthened it to the max and was still a bit tight).

I also noticed that the LED light wire lengths were too short. An easy fix which gives 2" or so more length...is to just cut the ziptie on the arduino and attach it to some other cables under the playfield to get it moved over closer to the led light.

20221109_174757 (resized).jpg20221109_174757 (resized).jpg

I'm also not sure what everyone else is doing with the bundle of wires from the optos/ball lock coil? Initially I just pushed everything forward (towards the chest) but then the optos seemed to be pushing against the rod too much, so I then slipped the rod between the opto wires and the rest of the wire bundle.

20221109_175012 (resized).jpg20221109_175012 (resized).jpg

20221109_175033 (resized).jpg20221109_175033 (resized).jpg

These rubber posts are also a pain....I eventually first attached the rubber nubs to the plastic, and then put a tiny amount of soapy water to lubricate them so they would more easily fit into the metal bracket. I wonder if there is a better way of handling it (or maybe I should have used a tiny bit of superlube or something).

20221109_190714 (resized).jpg20221109_190714 (resized).jpg

3 weeks later
#1326 1 year ago

I was also wondering how to get that cover back on that is behind the chest, it was off of mine and laying in the coinbox. I don't think it will go back on unless it is trimmed as it seems to interfere with the arm that opens and closes the chest.

2022-12-03 16.39.03 (resized).jpg2022-12-03 16.39.03 (resized).jpg2022-12-03 16.39.16 (resized).jpg2022-12-03 16.39.16 (resized).jpg
#1327 1 year ago

I still need to install mine one day also. Maybe over Christmas week. This will be tough to figure out after this long with the different tweaks that were made to the design. I bought a upgrade for the lift gizmo, so I probably have 2 options for it. The original design and the upgraded design. Over time, which one worked better?

#1328 1 year ago

The chest mod is incredibly cool, highly recommend and mine works great! I checked out my cover again today, it 100% needs to be trimmed... Easy fix.

#1329 1 year ago

Install the MAP protector this weekend as well as a addressing a bunch of other small details. FYI for anyone who needs to remove the Black Pearl, you do not have to loosen or remove any ramps. I was even able to get mine off without removing the VUK but when reinstalling I did remove the VUK.

2022-12-10 18.13.36 (resized).jpg2022-12-10 18.13.36 (resized).jpg
2 months later
#1330 1 year ago

Hi. I just installed the new version of the mod (with Upgraded flexible rod and Upgraded chest lid bracket (bracket v2)) and I have questions/problems.
I didn't find specific instructions for this version so I just followed instructions of the original version : "In your install please place the brass piece towards the ceiling, rotating it 180 degrees from where it was". The problem is that I have a servo with 2 blades and not 4 (as in the video) and I have no blade which goes towards the ceiling. So I considered the positive rotation and I installed the rod as you can see on the first photo. I'm not sure this is correct. Must I change the servo knuckle and replace it with the other servo knuckle provided in the package I received ? This one is 4 armed black plastic piece as we can see on the video instruction.
Other problem, I think the installation I did is not reliable as I did. I had lid's opening but it was not complete and finally, I had a message test : "problem with the fork : check the device". When I unhooked the rod, the message disappeared. Finally, I think the path of the rod as I installed it is maybe not as well as it should be ; can you check and tell me ?
2nd photo : the rod dehind the lid goes to the right of grey wires. Correct for you ?
3rd photo : not sure the path is correct before the junction with the servo.
Thanks for all your answers and advices ! I'm sure this mod is unbelivieable, I'm looking forward to making it work

IMG_20230211_174738 (resized).jpgIMG_20230211_174738 (resized).jpgIMG_20230211_193309 (resized).jpgIMG_20230211_193309 (resized).jpgIMG_20230211_193725 (resized).jpgIMG_20230211_193725 (resized).jpg
Promoted items from Pinside Marketplace and Pinside Shops!
$ 29.25
Playfield - Toys/Add-ons
The MOD Couple
 
$ 43.00
Playfield - Toys/Add-ons
The MOD Couple
 
$ 29.00
Gameroom - Decorations
Pinball Photos LLC
 
$ 24.00
Lighting - Other
Pinball Mod Co.
 
$ 20.50
Playfield - Toys/Add-ons
The MOD Couple
 
$ 24.95
Cabinet - Shooter Rods
Hookedonpinball.com
 
30,000 (Firm)
Machine - For Sale
Marshville, NC
21,500
Machine - For Sale
Smithtown, NY
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
 
$ 18.95
Playfield - Toys/Add-ons
ULEKstore
 
$ 38.00
$ 29.00
Gameroom - Decorations
Pinball Photos LLC
 
$ 24.00
Cabinet - Shooter Rods
The MOD Couple
 
$ 100.00
Boards
Led Pinball
 
$ 32.00
Playfield - Decals
Pinball Mod Co.
 
19,900 (Firm)
Machine - For Sale
La Cañada Flintridge, CA
31,000 (OBO)
Machine - For Sale
Guéret, NOUVELLE-AQUITAINE
$ 427.00
Cabinet - Sound/Speakers
PinWoofer
 
From: $ 30.00
Cabinet - Other
Rocket City Pinball
 
$ 29.25
Playfield - Toys/Add-ons
The MOD Couple
 
$ 130.00
Gameroom - Decorations
Dijohn
 
$ 25.00
Playfield - Protection
Pinball Mod Co.
 
From: $ 85.00
Playfield - Toys/Add-ons
Pinball Mod Co.
 
From: $ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
 
There are 1,330 posts in this topic. You are on page 27 of 27.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.