(Topic ID: 244666)

JJPOTC Treasure Chest Open/Close mod, now working!


By pinballj

4 months ago



Topic Stats

  • 1,101 posts
  • 99 Pinsiders participating
  • Latest reply 4 minutes ago by cooked71
  • Topic is favorited by 84 Pinsiders

You

Linked Games

Topic Gallery

There have been 156 images uploaded to this topic. (View topic image gallery).

A2EC4704-98FE-475F-8BA5-F3C50A941C98 (resized).jpeg
AB9689CC-3E86-4BB8-B6E2-5DBF56051599 (resized).jpeg
D53B4D19-804C-4B88-9B81-113673AD8017 (resized).jpeg
E04A8370-E614-4E7F-8B6D-9403DC65F1FD (resized).jpeg
3121975F-7923-4EE1-9684-2979549F239B (resized).jpeg
pasted_image (resized).png
Cheat Heartbeat-min.gif
Lid-Bracket (resized).jpg
1FE2A9BF-5D88-4ECD-AD42-87C4602EC681 (resized).jpeg
pasted_image (resized).png
AC1ECC09-D487-4768-BEE6-91B577172798 (resized).jpeg
AACE8A99-8237-4F7C-BF48-2ADE8B1E54EF (resized).jpeg
8E1496FC-8D2B-455A-8DE6-48C38BDE210B (resized).png
0438BDDE-11B1-4237-9616-5A01D5228894 (resized).png
6E683879-C722-454D-8BE4-06CB1E5035CF (resized).jpeg
20190930_143532 (resized).jpg

Topic index (key posts)

4 key posts have been marked in this topic (Show topic index)

There are 1101 posts in this topic. You are on page 20 of 23.
#951 35 days ago
Quoted from harryhoudini:

Like a 2d vertical piece of plastic with a decal on it?
I think I'd rather go like the "beach scene" with some treasure and palm trees. Doesn't that jive with the treasure chest?

IMO, anything you put there must be proportionate to the chest. The chest is huge and if you add tiny palm trees or tiny rowboats they will look out of place. Why not add some gold or something along those lines? Or just hide it with a decal. Less is more IMO

#952 35 days ago
Quoted from KornFreak28:

IMO, anything you put there must be proportionate to the chest. The chest is huge and if you add tiny palm trees or tiny rowboats they will look out of place. Why not add some gold or something along those lines? Or just hide it with decal. Less is more IMO

Gold = treasure/loot, that was one of the ideas.

Row boat would be as big as the chest but only about the top half of the boat.

I don't think an out of proportion beach scene would look out of place, it would be more like forced perspective (think cinderella castle in disneyland).

Working on some options, we'll see what looks good. I'm partial to the loot option but I'll likely print at least the row boat to see what it looks like.

If less is more, a black box would be the ideal one. Hardly visible, no lights really shine on it. I think we'll offer the box as a base and then a topper of your choosing.

#953 35 days ago
Quoted from harryhoudini:

Gold = treasure/loot, that was one of the ideas.
Row boat would be as big as the chest but only about the top half of the boat.
I don't think an out of proportion beach scene would look out of place, it would be more like forced perspective (think cinderella castle in disneyland).
Working on some options, we'll see what looks good. I'm partial to the loot option but I'll likely print at least the row boat to see what it looks like.
If less is more, a black box would be the ideal one. Hardly visible, no lights really shine on it. I think we'll offer the box as a base and then a topper of your choosing.

I love the treasure/loot idea! Interested to see the row boat too. I do see what you mean about the beach scene....

#954 35 days ago
Quoted from harryhoudini:

Gold = treasure/loot, that was one of the ideas.
Row boat would be as big as the chest but only about the top half of the boat.
I don't think an out of proportion beach scene would look out of place, it would be more like forced perspective (think cinderella castle in disneyland).
Working on some options, we'll see what looks good. I'm partial to the loot option but I'll likely print at least the row boat to see what it looks like.
If less is more, a black box would be the ideal one. Hardly visible, no lights really shine on it. I think we'll offer the box as a base and then a topper of your choosing.

All good ideas. I'm in. That area is in dire need of help. : )

#955 33 days ago
Quoted from JimWilks:

Given that I seem to be the only one with this problem and 50+ other (successful) installs of this mod I think my problem is one of:
A) My game has an abnormal 5V level at 4.65V
B) I have an abnormally sensitive (to turn on voltage) Arduino Nano
A lack of other games and a lack of additional Arduinos make both of these difficult for me to confirm. Perhaps other owners can measure theirs?
In any event, I need to get this mod working. I've ordered the the following which should do the job:
https://www.robotshop.com/en/5v-step-up-voltage-regulator-u3v12f5.html

Got the boost regulator. Boy is it small!

pic (resized).jpg

Installed it and mod is working fine now.

Sorry for the pic being out of focus, but you get the idea of size relative to a dime.

#956 33 days ago
Quoted from JimWilks:

Got the boost regulator. Boy is it small!
[quoted image]
Installed it and mod is working fine now.
Sorry for the pic being out of focus, but you get the idea of size relative to a dime.

Thanks for the update, sounds like from your email it is working. Great information to know.

#957 33 days ago
Quoted from JimWilks:

Got the boost regulator. Boy is it small!
[quoted image]
Installed it and mod is working fine now.
Sorry for the pic being out of focus, but you get the idea of size relative to a dime.

I think I may have this same issue! I did not order Scott's mod, but built it myself - I am following the exact connections, code, and setup as Jeremy's original setup, plus a couple of changes I've read about in the thread - and I'm getting basically the same behavior.

The servo moves a bit when first powered on, but then after that it just sort of hums and I hear an adjustment move here and there, but nothing occurs when the switch is triggered.

I haven't worked on this mod in a few weeks, having started on a game restore, but I went over everything today - switched to another Nano, even. Same behavior. I have not checked the debug log yet, so I will do that next and make sure the switch is being registered. Bummer, this one!

#958 33 days ago
Quoted from Rdoyle1978:

I think I may have this same issue! I did not order Scott's mod, but built it myself - I am following the exact connections, code, and setup as Jeremy's original setup, plus a couple of changes I've read about in the thread - and I'm getting basically the same behavior.
The servo moves a bit when first powered on, but then after that it just sort of hums and I hear an adjustment move here and there, but nothing occurs when the switch is triggered.
I haven't worked on this mod in a few weeks, having started on a game restore, but I went over everything today - switched to another Nano, even. Same behavior. I have not checked the debug log yet, so I will do that next and make sure the switch is being registered. Bummer, this one!

Have you plugged it in to an external power supply? That would give you a clear indication if it was a power supply issue from the game.

#959 33 days ago
Quoted from harryhoudini:

Gold = treasure/loot, that was one of the ideas.
Row boat would be as big as the chest but only about the top half of the boat.
I don't think an out of proportion beach scene would look out of place, it would be more like forced perspective (think cinderella castle in disneyland).
Working on some options, we'll see what looks good. I'm partial to the loot option but I'll likely print at least the row boat to see what it looks like.
If less is more, a black box would be the ideal one. Hardly visible, no lights really shine on it. I think we'll offer the box as a base and then a topper of your choosing.

Thinking outloud, could we somehow leverage the up/down actuation of the rod that controls the lid for another mod?

For example, when the lid closes, a chest key could raise up at the same time since it has an upward motion anyways? Might not be feasible, just an idea I had.

#960 33 days ago
Quoted from harryhoudini:

Have you plugged it in to an external power supply? That would give you a clear indication if it was a power supply issue from the game.

Good idea - I have not. I tried initially with the USB power, which was laughable. I'll find a 5V wall wart next

#961 32 days ago

harryhoudini I'm installing one of these for a local friend tomorrow. The only thing I am unclear on is the removal of the existing lid, does this require Pearl removal?

#962 32 days ago
Quoted from zaphX:

harryhoudini I'm installing one of these for a local friend tomorrow. The only thing I am unclear on is the removal of the existing lid, does this require Pearl removal?

He posted a really cool video on his site. Pretty easy IMO.

#963 32 days ago
Quoted from KornFreak28:

He posted a really cool video on his site. Pretty easy IMO.

I must have missed it. I reviewed the install instruction videos which started with the parts and ended with the alternate rod setup. Did not see one for the initial chest disassembly?

#964 32 days ago
Quoted from zaphX:

I must have missed it. I reviewed the install instruction videos which started with the parts and ended with the alternate rod setup. Did not see one for the initial chest disassembly?

Look at post 826

#966 32 days ago

So I reprogrammed my Arduino with the new code. Went reasonable well. But now my chest opens all the way then closes most of the way (when it should be wide open). Did I miss part of the instructions? Is there a homing routine or do I need to change something mechanical?

#967 32 days ago
Quoted from paynemic:

So I reprogrammed my Arduino with the new code. Went reasonable well. But now my chest opens all the way then closes most of the way (when it should be wide open). Did I miss part of the instructions? Is there a homing routine or do I need to change something mechanical?

Are you using the star arm on the servo? If so, you probably have the rod on the wrong one.

#968 32 days ago
Quoted from vireland:

Are you using the star arm on the servo? If so, you probably have the rod on the wrong one.

Yes. Star arm. It worked on the old code but I was one of the people that had to mount to the opposite arm. I’ll figure it out.

#969 32 days ago
Quoted from paynemic:

So I reprogrammed my Arduino with the new code. Went reasonable well. But now my chest opens all the way then closes most of the way (when it should be wide open). Did I miss part of the instructions? Is there a homing routine or do I need to change something mechanical?

Are you saying this happens when it first turns on? It does a new startup routine yes, it cycles the chest once. It should go the same distance it did before the update (I don't think that changed). I think the direction should also be the same on the new version, which is why there was a non-versioned update to 1.1 (which I think only one or two people downloaded). Did you move anything hardware wise when you did the update? Like, take the whole thing out and put it back in? I would only question if the rod is binding on the lid (in the hole) and needs a little bend. Unless it's hitting something else that was really the only reason I saw for partial movements, that or the rod not being aligned/adjusted. But if you didn't move anything that would be odd.

#970 32 days ago
Quoted from harryhoudini:

Are you saying this happens when it first turns on? It does a new startup routine yes, it cycles the chest once. It should go the same distance it did before the update (I don't think that changed). I think the direction should also be the same on the new version, which is why there was a non-versioned update to 1.1 (which I think only one or two people downloaded). Did you move anything hardware wise when you did the update? Like, take the whole thing out and put it back in? I would only question if the rod is binding on the lid (in the hole) and needs a little bend. Unless it's hitting something else that was really the only reason I saw for partial movements, that or the rod not being aligned/adjusted. But if you didn't move anything that would be odd.

I did take some slack out of the rod (I know better than to adjust two variables at once, but I did it anyway). Before the update, the nut was maybe 7mm above the lid plastic when the lid was closed. So I kept it closed and took that slack out of the rod and retightened. Now it opens all the way and then mostly closes again.

I’m a little confused about the version I should have downloaded. It’s my recollection I did download 1.1

#971 31 days ago

Got it!

Turned out to be bad code, I think. Or perhaps the additional LED code (I have not added the heartbeat LED strip)

Once I reverted back to Fleitz’s latest .ino from github, it worked immediately. Weird! KILLER MOD!

#972 31 days ago

Also, having gone through all the assembly, troubleshooting and purchasing of the raw materials, I want to wholeheartedly say that I think scott’s price is INCREDIBLY fair.

#973 31 days ago
Quoted from Rdoyle1978:

Also, having gone through all the assembly, troubleshooting and purchasing of the raw materials, I want to wholeheartedly say that I think scott’s price is INCREDIBLY fair.

Agreed. After receiving the kit from Scott I think he is undercharging a bit. For sure now that the code should be settled and with maybe a few tweaks as suggested to the install videos.

#974 31 days ago

harryhoudini Ive installed the chest mod for cheshirefilms and it seems to work perfectly except the state is inverted. It closes when it should open and vice versa.

Does flashing the software fix this?

#975 31 days ago
Quoted from zaphX:

harryhoudini Ive installed the chest mod for cheshirefilms and it seems to work perfectly except the state is inverted. It closes when it should open and vice versa.
Does flashing the software fix this?

Putting the rod on the opposite arm of the servo also fixes this.

#976 31 days ago

Does anybody have a video of the lighting mod?

#977 31 days ago
Quoted from vireland:

Putting the rod on the opposite arm of the servo also fixes this.

Thanks for this tip! That fixed us. The only other hicky was inconsistent operation at first, corrected with a slight bend to the switch arm.

The mod is cool!

#978 31 days ago
Quoted from zaphX:

Thanks for this tip! That fixed us. The only other hicky was inconsistent operation at first, corrected with a slight bend to the switch arm.
The mod is cool!

Great friendship times, great mod! Thanks Magical/concept crew for making this reality.

Two Pirates, making this pinball great again. Arrghh!!

First game solo I hit DMC Wizard, a couple games later I did it again with Angelica
IMG_20190918_134740 (resized).jpgIMG_20190918_141235 (resized).jpg
IMG_20190918_152613 (resized).jpgIMG_20190918_151720 (resized).jpg
IMG_20190918_164000 (resized).jpg
IMG_20190918_163954 (resized).jpg

#979 31 days ago
Quoted from zaphX:

harryhoudini Ive installed the chest mod for cheshirefilms and it seems to work perfectly except the state is inverted. It closes when it should open and vice versa.
Does flashing the software fix this?

Sounds like you got it Glad to hear it went relatively smoothly.

Quoted from BC_Gambit:

Agreed. After receiving the kit from Scott I think he is undercharging a bit. For sure now that the code should be settled and with maybe a few tweaks as suggested to the install videos.

Yeah, I have those videos open in FinalCut.. just need to do it. We had no idea what we were getting in to, lol. I owe my wife big time for doing a lot of the soldering and production. It was a good learning experience and gave us a push to make more mods, so all good.

Quoted from paynemic:

I did take some slack out of the rod (I know better than to adjust two variables at once, but I did it anyway). Before the update, the nut was maybe 7mm above the lid plastic when the lid was closed. So I kept it closed and took that slack out of the rod and retightened. Now it opens all the way and then mostly closes again.
I’m a little confused about the version I should have downloaded. It’s my recollection I did download 1.1

You're good. I had an early version of 1.1 where I changed the rotation direction and that got confusing. Right now all the code versions go the same direction, it's just my video that is wrong.

Quoted from Rdoyle1978:

Got it!

Turned out to be bad code, I think. Or perhaps the additional LED code (I have not added the heartbeat LED strip)
Once I reverted back to Fleitz’s latest .ino from github, it worked immediately. Weird! KILLER MOD!

If you used the code I posted there are some changes, I think, to the way pinballj had his connections laid out. I could look at his prototype and compare if you want to know. I can post a pic of the controller wiring and such laid out if you want to duplicate it.

#980 31 days ago
Quoted from harryhoudini:

Sounds like you got it Glad to hear it went relatively smoothly.

It's a great mod. After seeing it in action, the game seems so broken without it.

#981 31 days ago

v3.0?

I don't feel so comfortable with the tab being so small now. I might consider doing another batch of lids with a modified design for this. Move the tab to the left a bit, widen it and maybe make the lid just a bit thinner. It almost seems unnecessary at this point. I broke one lid doing this (it was hard to get that horizontal hole just right) and then another one in the pic, costly! I'm leaving the original in my game for now, not going to mess with greatness.

pasted_image (resized).png
#982 30 days ago
Quoted from zaphX:

It's a great mod. After seeing it in action, the game seems so broken without it.

Totally agree - it is very cool, every time you see it

#983 30 days ago
Quoted from harryhoudini:

Sounds like you got it Glad to hear it went relatively smoothly.

Yeah, I have those videos open in FinalCut.. just need to do it. We had no idea what we were getting in to, lol. I owe my wife big time for doing a lot of the soldering and production. It was a good learning experience and gave us a push to make more mods, so all good.

You're good. I had an early version of 1.1 where I changed the rotation direction and that got confusing. Right now all the code versions go the same direction, it's just my video that is wrong.

If you used the code I posted there are some changes, I think, to the way pinballj had his connections laid out. I could look at his prototype and compare if you want to know. I can post a pic of the controller wiring and such laid out if you want to duplicate it.

Thanks Scott - I didn’t think to check. I’ll read through the updated code. Were there further updates? There are only 5 connections to the board for the servo mod, so I’ll just read through the .ino more carefully. I thought I checked the servo control connection (which I have wired to D10), but I didn’t check the switch connections.

#984 30 days ago
Quoted from Rdoyle1978:

Thanks Scott - I didn’t think to check. I’ll read through the updated code. Were there further updates? There are only 5 connections to the board for the servo mod, so I’ll just read through the .ino more carefully. I thought I checked the servo control connection (which I have wired to D10), but I didn’t check the switch connections.

Here's a pic.

D10 servo white wire
D3 is lighting DIN green
D2 Switch red

D5-D8 keypad controller

Ground IN from game goes to switch black, servo black, lighting black, GND on board
Power DC+ IN from game goes to servo red, lighting red and VIN on board
Power DC- IN from game goes to GND on board
pasted_image (resized).png

#985 30 days ago
Quoted from harryhoudini:

Here's a pic.
D10 servo white wire
D3 is lighting DIN green
D2 Switch red
D5-D8 keypad controller
Ground IN from game goes to switch black, servo black, lighting black, GND on board
Power DC+ IN from game goes to servo red, lighting red and VIN on board
Power DC- IN from game goes to GND on board
[quoted image]

NICE! Thanks for that

#986 29 days ago

I have installed the mod today, but for some reason the chest does not seem to open or close...
I have followed HarryHoudini's instructions, but still it does not seem to work for me.
I attach some pics - where to start to diagnose, what went wrong?

Also in my installation the bracket touches a bit the clear plastic piece that apparently is there to protect
or to ensure no ball locks would take place. I draw a yellow arrow there. What have you done, have you
removed it altogether?

Thank you for any help!

IMG_7002 (resized).JPGIMG_7003 (resized).JPGIMG_7004 (resized).JPGIMG_7005 (resized).JPG
#987 29 days ago
Quoted from Nepi23:

I have installed the mod today, but for some reason the chest does not seem to open or close...
I have followed HarryHoudini's instructions, but still it does not seem to work for me.
I attach some pics - where to start to diagnose, what went wrong?
Also in my installation the bracket touches a bit the clear plastic piece that apparently is there to protect
or to ensure no ball locks would take place. I draw a yellow arrow there. What have you done, have you
removed it altogether?
Thank you for any help![quoted image][quoted image][quoted image][quoted image]

Does it move at all when you turn the power on to the machine initially? It should initialize automatically if it's getting power. If it's not initializing, it's not getting any power.

#988 29 days ago

Only the rod moves and the chest a bit. Have a look here:

#989 29 days ago
Quoted from Nepi23:

Only the rod moves and the chest a bit. Have a look here:

1. Remove and rotate the servo knuckle (4 armed black piece) 180 degrees. The brass connector should be starting on the other side.
2. There is too much slack in the rod. You can see it going way above the chest in your video. When the chest is closed the rod should be snug against the lid. I think if you do #1 that may help this as well.

#990 29 days ago
Quoted from Nepi23:

Only the rod moves and the chest a bit. Have a look here:

Definitely too much slack in the rod.

Does it move during gameplay when the forks go up and down? If not, then you need to adjust the switch arm on the mod near the servo by bending it out a little more so the forks moving trigger it.

#991 29 days ago

Thanks for the tips!

Rotating the 4-wing arm 180 degrees did the trick. Now the lid opens and closes correctly.
The leds are glowing yellow color, I guess that is correct and they will display red at some other time? Or should I adjust the color to red as a default?

There seems to be another problem developed now though. Treasure Chest multiball does not seem to be able to start. Have a look at the video:

Any ideas what the correct here? Thank you!

IMG_7008 (resized).JPG
#992 29 days ago
Quoted from Nepi23:

Thanks for the tips!
Rotating the 4-wing arm 180 degrees did the trick. Now the lid opens and closes correctly.
The leds are glowing yellow color, I guess that is correct and they will display red at some other time? Or should I adjust the color to red as a default?
There seems to be another problem developed now though. Treasure Chest multiball does not seem to be able to start. Have a look at the video:

Any ideas what the correct here? Thank you![quoted image]

Either you accidentally bent the release arm away from the tiny coil a little too much when installing the hinge bracket (you can bend it back a little more towards the coil post so the coil can "grab it" and pull the door flap open) OR you need to increase the chest release time on the system menu so it holds the flap open a little longer.

#993 29 days ago
Quoted from vireland:

Either you accidentally bent the release arm away from the tiny coil a little too much when installing the hinge bracket (you can bend it back a little more towards the coil post so the coil can "grab it" and pull the door flap open) OR you need to increase the chest release time on the system menu so it holds the flap open a little longer.

Thank you, will experiment more tomorrow!

#994 29 days ago
Quoted from Nepi23:

Thanks for the tips!
Rotating the 4-wing arm 180 degrees did the trick. Now the lid opens and closes correctly.
The leds are glowing yellow color, I guess that is correct and they will display red at some other time? Or should I adjust the color to red as a default?
There seems to be another problem developed now though. Treasure Chest multiball does not seem to be able to start. Have a look at the video:

Any ideas what the correct here? Thank you![quoted image]

I had this issue Yesterday without this mod, balls seems to be magnetized. I actionned the release coil by test mode and finally release balls. Next game had good work

#995 29 days ago
Quoted from Nepi23:

I have installed the mod today, but for some reason the chest does not seem to open or close...
I have followed HarryHoudini's instructions, but still it does not seem to work for me.
I attach some pics - where to start to diagnose, what went wrong?
Also in my installation the bracket touches a bit the clear plastic piece that apparently is there to protect
or to ensure no ball locks would take place. I draw a yellow arrow there. What have you done, have you
removed it altogether?
Thank you for any help![quoted image][quoted image][quoted image][quoted image]

Just trim the plastic so it doesn’t touch

#996 29 days ago
Quoted from Thot:

I had this issue Yesterday without this mod, balls seems to be magnetized. I actionned the release coil by test mode and finally release balls. Next game had good work

Yup, that's another common reason. Can't use chrome balls, apparently.

#997 29 days ago
Quoted from harryhoudini:

Yup, that's another common reason. Can't use chrome balls, apparently.

What kind then?

#998 28 days ago
Quoted from KornFreak28:

What kind then?

I'm no expert but I believe someone recommended the ones Titan sells. From what I understand you want carbon steel balls but it seems like it's somewhat of a crap shoot. I've never had issues, others have reported issues quickly with various kinds of balls. The only two brands I've really bought are from Marco and Titan and never had issues.

#999 26 days ago

Chest mod doesn't open and close with the game but goes through the open/close cycle when you power it on? Likely your switch needs adjusting:

#1000 26 days ago
Quoted from harryhoudini:

Chest mod doesn't open and close with the game but goes through the open/close cycle when you power it on? Likely your switch needs adjusting:

This was exactly my problem last month when I installed mine. Simple fix!
As it's been said before - the game looks "broken" without this additional mod. It's like it's supposed to be there! : )

Promoted items from the Pinside Marketplace
$ 45.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 28.00
Wanted
Machine - Wanted
Redmond, WA
$ 239.99
Cabinet - Toppers
Tilttopper
There are 1101 posts in this topic. You are on page 20 of 23.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside