(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

7 months ago



Topic Stats

  • 2,331 posts
  • 135 Pinsiders participating
  • Latest reply 8 hours ago by vireland
  • Topic is favorited by 98 Pinsiders

You

Linked Games

Topic Gallery

There have been 434 images uploaded to this topic. (View topic image gallery).

JJP_mobo_buttons_sml (resized).jpg
fix-dead-jjpotc-H110_mobo (resized).jpg
fix-dead-jjpotc (resized).jpg
IMG_1901.jpeg
Screen Shot 2019-11-30 at 6.52.53 PM.png
1B7C8008-D057-4BB4-8D38-23634CFEAB94 (resized).jpeg
reset motherboard (resized).jpg
jumpstart (resized).jpg
20191128_210803 (resized).jpg
moboreset (resized).jpg
IMG_20191128_194814971 (resized).jpg
B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg
9F1B9D3E-F2D5-4E3E-9AEB-3BD0EED68DBF (resized).jpeg

Topic index (key posts)

3 key posts have been marked in this topic

Post #306 Tip on removing the black pearl Posted by rs812 (7 months ago)

Post #501 More tips on removing black pearl mini playfield Posted by LTG (7 months ago)

Post #1776 Broken trunk mount bracket picture Posted by Soulrider911 (5 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider zaphx.
Click here to go back to viewing the entire thread.

#33 7 months ago
Quoted from heni1977:

Auto plunger irregular/ still not fixed

Yeah, I'm struggling with this too. Things I have tried:

- Checking the alignment of the whole mech (seems fine)
- Checking the tightness of the coil in the mech
- Adding a washer so the autoplunger "forks" are consistent and toeing up the ball solidly

It still ends up failing fairly frequently.

#108 7 months ago
Quoted from vireland:

PROBLEM: Autoplunger is inconsistent and frequently fails to launch past the “hill.”
SOLUTION: This may be one of a couple things.
Finally check the shooter lane rails, I found my right rail is ever so slightly lifted at the back of the lane, causing balls to contact the locker post and bounce back. Backing the autolaunch power down 2-3 points from default may make your auto-plunges consistent.

Just to update this, I just removed my shooter lane and gently bent the rails until they were true with each other. This appears to have resolved the issue at last!

#110 7 months ago

PROBLEM: Your LE topper is off-center
SOLUTION: Remove the backglass. Using a nut driver, remove the nut in the top of the backbox. Put towels down over the playfield glass, unlock the backbox and lower it down gently. Using a flat screwdriver, remove the black plastic plugs and press them out from behind, taking care not to scratch the topper. Set the backbox upright again and lock it in, then remove the topper screws and topper. Finally, remove the two black screws from the topper bracket and remove the bracket. Measure and drill new holes (I fit my drill bits into the existing holes to size them correctly.) Finally reassemble everything.

IMG_0239 (resized).jpegIMG_0819 (resized).jpegIMG_0820 (resized).jpegIMG_0821 (resized).jpegIMG_0822 (resized).jpeg
#114 7 months ago
Quoted from vireland:

When you say "bent the rails" are you talking about the auto launch forks or the guides on the habitrail?

Guides on the habitrail.

#117 7 months ago
Quoted from vireland:

Can you take a picture and point out what area you adjusted?

Not taking it apart again. I pulled out the shooter wireform, bent the 2 rails in the shooter lane to remove irregularities between the two, and put it back in.

#119 7 months ago
Quoted from KornFreak28:

What tool did you use to bend the rails?

My hands This machine shipped with very bent rails, and I was instructed to carefully_ bend them down and apart (by hand) so they would hug the shooter lane.

Apparently there was some slight deviation between the two which was causing the mis-plunges. They lined up better after I re-bent them today.

#126 7 months ago
Quoted from wesman:

Should the cable ties be snipped when installing this loom, or be kept as they are?
How long-ish would you recommend cutting and using for this implementation?

I did not cut anything to install the loom. I eyeballed the amount of cable, cut off a length of loom to match, and installed it from under the playfield sliding it up. 2 minute fix and avoids a potentially serious problem.

#130 7 months ago
Quoted from wesman:

Ooooh. So no ship removal, eh? (Though I've already taken it off twice.).
Have you had your plastic under the ship creak at all?

Nope, I have not removed this ship at all for any reason, knock on wood. No creaking either.

#132 7 months ago
Quoted from rs812:

I have and it works great. It is much more forgiving than the corrugated plastic. I think it looks better, too.

I like it too!

#134 7 months ago
Quoted from wesman:

Oh good for you! It's not the worst thing, if you end up needing to, it's more a pain in the ass freeing and pulling the proper wire bundles underneath apart for the first time. Then the dreaded resetting of the ship on the eyelets, which have been pretty cruddy both times I've done it.

Excellent! So I assume you got the 1" and 10 feet of it? I can see where the mesh would allow less friction. Cancelled the order of the other I just put in an hour ago, and will get this.

I did have to pull the pearl on my friend's CE to solder wires OOTB so I know what it's about.

BTW One reason I went with the wide plastic corrugated stuff was to plug the hole so balls would stop getting stuck there.

#145 7 months ago
Quoted from Clint12:

Man these machines are junk with a huge price tag

And yet, the people who own them have them bolted to the floor and love them.

#147 7 months ago
Quoted from vireland:

Still in the honeymoon period, but it impresses in some way every time so far, and that's a good sign. Unbelievably good machine with incredible production values. The video production and musical themes are much better than what I've seen of Wonka so far, and there's a great game under the glass to match.

I still love playing it every single day. I’m 4 months into ownership. The honeymoon on my first pin (Star Wars) sure wasn’t this long.

#154 7 months ago
Quoted from Heater:

Perfect. And much thanks!

When you tighten it, be careful not to overdo it. The two metal pieces should not touch.

#206 7 months ago
Quoted from Pinballomatic:

On Wonka they switched to magnetic latches instead of the clips.

I'm very excited by this, it sounds like a good upgrade.

#228 7 months ago
Quoted from rj_tenn:

Installing the Cliffy kit. Can someone shed some light on where this protector goes? Thanks[quoted image]

The Depths?

#238 7 months ago
Quoted from Lazar:

Getting our POTC dialed in and noticed our flipper power is drastically lower than those seen on stream. Did anyone adjust their flipper power? I am thinking this might also help with shots into the chest. Thanks for the help.

Mine are set to default - check yours against that (green is default.)

Also check leveling. Top of the bubble should be on the second line from the bottom.

#242 7 months ago
Quoted from vireland:

Okay, so following up on the screw making a bulge in the bottom of the Black Pearl and tearing the sticker.
DO NOT do the fix I did with the flatter screw top to stop the pressure on the underside of the BP ramp that's tearing the sticker!
It's become clear the BP ramp is a terrible design. There is no support on the left side of the ramp to hold it up. The screw bump and edge of the partial sling cover IS the support. Nevermind that it's tearing the ramp sticker underneath. The upshot of the change I made is the ramp now sags about 3mm to the left, which has the effect of dragging on the ship and causing slow balls to get stuck on the gate (because there's not enough of an angle to direct it to the right and down).
So I guess tomorrow I will work on designing a 3D printed support for the left side of the ramp that screws onto the back of the sling cover to gently support the ramp in a much better way.

Just stick a clear plastic cabinet bumper on top of the screw. Solves the sticker tearing -and- ensures the ramp has the right lean.

#253 7 months ago
Quoted from BC_Gambit:

Anybody ever have their slings arm get pushed "outside" of the flipper rubber? I have had that happen a few times on each sling; not sure if changing to white rubbers would help or if there is another fix.

Funny you mention that, as it happened to me twice today. Maybe it's time for new sling rubber for me. I do have the star post + washer mod which I was blaming for it, but maybe it's just worn slings.

#256 7 months ago
Quoted from BC_Gambit:

Thank you. I will give new rings a try!

My wife just lost a ball. I checked the subway, Dauntless, under the Pearl...nowhere to be found. Then I finally found it -inside- the right sling.

That was the last straw for me, coupled with two “escaped kickers” on that sling. I replaced the rubbers with fresh ones and will report back how it behaves.

#322 7 months ago
Quoted from rj_tenn:

Help - How do you install the Cliffy at the Mystery hole? Do you need to remove the jet bumper wafer that's half blocking screws? If so, how the heck do you remove the jet bumper components?
Thanks

There are some good tutorials with photos on removing tortuga tom. Search for him in the club thread.

#364 7 months ago
Quoted from GnarLee:

Speaking of color changes. After 1000 plays my flipper rubbers were toast. Did yellows on main flippers (always yelling at me about gold) and did blue for the inner loop flipper. Looks pretty good imo

That's about how long my stock flipper rubbers lasted as well. I went Titan after that and haven't had to change them again after another 1900 plays.

#383 7 months ago
Quoted from harryhoudini:

BAH! Just noticed that the right spinner on the BP isn't registering and is always closed (is that green on the switch test?). I'll dig around that one to see if any wires are loose. Any existing tips on the optos for the spinners?

You're blazing a new trail on that one I'm afraid. Great troubleshooting on the broken wire with Tortuga Tom!

#404 7 months ago
Quoted from rs812:

As a PSA, you may want to check your map hole to make sure the ball entering the maphole will not collide with the T-nuts holding on the diverter. I noticed a few of my balls were all chewed and nicked up after only a few plays. I discovered that the left screw behind the diverter had a T-nut under the playfield which interfered with the ball entering the map hole. It is not a quick fix. I had to remove the ship to get to the screw, remove the screw, raise the playfield, and remove the stainless steel subway to get to the T-Nut. You can pull the T-Nut off by screwing in the screw from the bottom side and pulling. Based upon where the hole was, there was no orientation where the T-Nut wings did not in some way interfere with the ball as it entered the map hole. I had to grind one of the wings off of the T-Nut and orient it so that the ground off wing was facing the maphole, but no longer exposed to ball interference.
Not sure if this all machines, but my guess is that based upon the angle of the diverter there are other machines that will have the same issue.

A friend in CA had this same issue and his fix was the same. I thought his was an anomaly but now that there's a second report I guess this should be added to the index. Good work fixing it!

#407 7 months ago
Quoted from Axl:

The balls get stuck here often.
[quoted image]
It looks like the ramp is bent out of shape.
[quoted image]
As I see it I have two options.
Either put a washer on the foxing on the post by the pirate lanes, or try to bend the wire forms back to shape. Very reluctant to do any bending.
Any other suggestions?

The wireform can slide in/out of the Black Pearl plastic ramp - have you tried making an adjustment there to see if it changes the angle?

#416 7 months ago
Quoted from wesman:

How do you remove the button from the lockdown bar? I couldn't discover a way to remove it from that black screw in bracket.
Even loosening the screw, for more contact from the button, rather than raise the sensor contact, took some jiggling to discover. It was screwed in so damn tight.

There is a black plastic nut of sorts under the lockbar. Rotate it counter clockwise while grasping the button body from the other side.

#418 7 months ago
Quoted from joseph5185:

Or just replace the button.
Might be easier.

To replace it he needs to remove it, which is what he needed help with.

#424 7 months ago
Quoted from wesman:

Thank you for the info. I'll definitely check next time I'm under the hood, and if there's an issue, I'll post to add it to the number of occurrences.

Aaaah! Yeah, that makes sense. I figured it was a pretty simple mechanism, couldn't find anything in the manual or searching either.
When you changed yours out, was the screw really, really locked in also? I finally discovered pressing the action button forward, while unscrewing, allowed better grip. Otherwise nothing was budging, and trying to use a wrench with a towel/paper around it, wasn't gripping either.

When I removed the screw, yes it was in there firmly but came out easily enough. I am not sure how to further simplify this task.

#480 7 months ago
Quoted from AUKraut:

I have handled playfield glass thousands of times, and now this.......Scheiße!!!!

Condolences for your loss

#537 7 months ago
Quoted from rs812:

That’s the conclusion I’ve come to, also. I think it just goes unnoticed until the balls are checked. I have been looking at old pics in the other thread. It looks like they all have it.

Not the case. Neither of my LEs had it nor a friend’s CE.

Another friend with an LE -did- have this issue which I thought was unique to him at the time.

#550 7 months ago
Quoted from DarthSinex:

Defying the laws of physics, if I hold the left flipper up to catch the kick out from the mystery hole it swoops through the gate to the left of the flipper and straight down the I hole. With the glass off, I can't see how that gate allows the ball to travel backwards through it, but it does...everytime. Anyone vaguely understand the way this is happening?

Maybe the ball is jumping through the hoop like Evil Kneival?

#604 7 months ago
Quoted from joseph5185:

If I can get the playfield cleaned/waxed, the ship reinstalled, the playfield leveled, and power on the game and be error free and finally play a few, I think it will be a successful day.

I am very hopeful your next post is "I performed all those tasks and I've been playing for the past 5 hours, this game is awesome!"

#617 7 months ago
Quoted from joseph5185:

I want to express how I feel right now...but I’m not going to.
I am trying...

Did you confirm all the harness molexes are plugged back in correctly?

#636 7 months ago

Have you checked the manual? It’s pretty extensive and well written.

#638 7 months ago
Quoted from joseph5185:

Not yet.
Trying to solve some other battles atm.

Well, you should. It's a good resource. Specifically page C-95 where it states the wiring for the lantern RGBs plugs into J803 under the Pearl mini playfield. I'd look at that to make sure it didn't get dislodged during reinstallation.

#647 7 months ago
Quoted from joseph5185:

OMG!
It is disconnected ! That book just did it for me ...
I did my damnest to show it with this photo..[quoted image]

Told ya. It’s awesome.

#651 7 months ago
Quoted from joseph5185:

I have to stop assuming the worse .. "oh, must be a broken wire" Nope. Doesn't have to be ...
I feel so accomplished right now!
If I may ... I'm getting this when I boot the game up and I didn't used to...
...
IDK if it's based on the number of errors it sees or since it's been awhile since a game has been played or ... something else .. lol
But I don't particularly care .. I just wanted to mention it!
[quoted image]

Need to see the actual switch failures when you open the coin door and hit the button.

More than likely it is boat related switches that you haven’t hit yet, but it can also indicate a faulty switch that needs adjustment.

#656 7 months ago
Quoted from joseph5185:

I'm just about IN BUSINESS, sir!

Very happy to hear it. Hopefully you can move from troubleshooting to playing now!

My first machine took me about a week to get through all the issues. The second was pretty much legit OOTB. Then helped a friend set up a CE which had a BP broken wire issue, otherwise solid.

Once you’re into playing and out of troubleshooting you will really grow to love this game. I am fully convinced it is the best game in pinball.

#657 7 months ago
Quoted from Yelobird:

The manual (especially a JJP manual) will provide a rather clear picture most times.

It is one of the best technical manuals for a product I’ve seen. Butch Peel deserves as much credit for the thorough manual as Eric does for the excellent game design.

#673 7 months ago

joseph5185 Please chill.

The switch warnings on boot are normal.
If you're audio clipping, adjust the values down in the software menu (which even warns you clipping will occur if the values are too high.)

Respectfully, this thread is to collect and categorize fixes. Your AFMr is not on topic here. Congrats, but please remember this thread is not a blog or Twitter feed.

#678 7 months ago
Quoted from joseph5185:

Thanks.
FWIW, Master volume can be under 20 easily and I did not adjust any settings.

I'm not talking about the master volume. I'm talking about the audio mix levels which are detailed on page B-25.

#680 7 months ago
Quoted from joseph5185:

I'll play around with it.
It doesn't happen with headphones and if I disconnect the "right thing" it might prevent it as well.
We'll see...

What happens with headphones is irrelevant to what is going through the audio amp. Try reducing the audio mix values uniformly.
This is a simple thing to do in software which will immediately give you feedback.

You should do this before disconnecting random things and resulting in another 500 posts about it.

If it doesn't help, fine, next thing to try.

#696 7 months ago
Quoted from joseph5185:

I guess the million dollar question is if upgrading the speakers, sub, and amp ELIMINATES the audio clipping entirely.
If so, it's well worth the money and will sound better anyways...
Edit: Like, I can't even choose a character with the music playing before starting a game without the audio messing up. It's kinda crazy!

Did you try backing down the gain levels in the software yet?

#697 7 months ago

I think harryhoudini is referring to the noise and chatter on bootup, where joseph5185 is referring to clipping during_ gameplay. Different things.

They all chatter and pop on bootup in my experience.

#699 7 months ago
Quoted from joseph5185:

Yea I couldn't care less about that popping when the game boots.
Just WHILE I'm playing the game. I have not yet looked at the gain levels, but seems silly to me if they have to be reduced from default. If it solves the problem, so be it.

Defaults are not always gold standards for everyone in every machine. Minor variations exist.

I don't know why you haven't even tried this as it literally takes less time to tweak than to post about it!

#716 7 months ago
Quoted from joseph5185:

Love the passion and level of attention on this post.
I think you have it worse than I do. If by crackling, you mean static then ok. I think the clipping drives me crazier than anything else. No “loud whining” or anything. That’s...interesting.
I unplugged one cable (purple/black) near the bottom left at the front of the cabinet. Either it was the wrong cable or the fix didn’t help.
To reiterate, plug in headphones and 0 issue. I feel this “should” be a solid clue as to what’s going on. I.E. one thing is not like the other.
I couldn’t care less about that ridiculous pop when the game turns on. My AFMr doesn’t actually do this, but whatever.
Just wanted to echo my sentiments on this and I will work on this today and try to figure something out.

When are you going to try lowering the gain levels? Why do you keep complaining about it without even trying that? It will take 15 seconds and you'll either have it fixed or know one more thing that doesn't fix it.

#734 7 months ago
Quoted from joseph5185:

I'm SO CLOSE to playing this game...
I noticed my right wireform exit hole or w/e that sites over the inlane is not level. It's at an angle and driving me crazy.
I'm trying to adjust it and it's...hell.
I haven't tried removing the pressure washer that tightens on the right side of the BP.
From what I can gather, the wireform does not go in very far underneath that ramp. When I go to try and tighten the screw on the right sling it just leans to the right and it's not level ... like from the pressure or something.
Idk...

It won't be perfectly level. I've never seen it so on any machine. As long as it's dropping the ball in the right place, move on.

Please seek help.

#737 7 months ago
Quoted from harryhoudini:

PLAY THE FREAKING GAME ALREADY!

But then it will dimple and there will be more to obsess over!

#742 7 months ago
Quoted from joseph5185:

Sorry!
If something "doesn't look right" I'm going to question it. BUT, if it's a non-issue then great!

Seeking perfection in pinball lies the path to madness.

#769 7 months ago
Quoted from gumnut01:

Action button getting stuck. I guess just ask for a new one from Jack? Also thanks to all the posters who helped with the shorter hex spacers. Great fun shooting the bullseye. Damn difficult to do during black pearl Multiball. Anyone else resolved the sticking action button?

Or lubricate it, or get a Stern button from pinballlife.

#771 7 months ago
Quoted from gumnut01:

Thanks zaphx. I tried silicon lubricant. It did not do much. I think this button has a few burrs on it that are catching. I wonder if it is because the angle is different to a normal flipper button and that it gets pounded.

I've seen that. Try lightly sanding the button shaft.

#785 7 months ago

Yes, chromed balls cannot be used in games with magnets.

#787 7 months ago
Quoted from joseph5185:

That's absolutely crazy to me.

I also have opinions about crazy.

#789 7 months ago
Quoted from joseph5185:

My patience is running out on this pin.
Like. I'm trying really hard. I know I get teased for over-obsessing, overthinking, or w/e, but I keep running into legitimate things that is hindering me from actually enjoying this game.
And I WANT to...

If it’s providing more aggravation than joy, sell it. Demand is high, you’ll get your money back out of it. You have absolutely spent more time messing with it than playing it.

#793 7 months ago
Quoted from joseph5185:

I'll be better for it in the long run. I know that.
But it's frustrating now...

If you were closer I’d buy it myself to put you out of your misery.

Some of your problems are self-induced here. For example the chromed balls magnetizing and sticking in the trough. Why didn’t you just play with the stock balls for your first 500-1000 games? Why did you buy chromed ones when the sites warn you specifically against using them with magnets?

You really need to consider if pinball is the right hobby for you. You seem to be someone who seeks perfection - I get that, and respect it - but you’re not going to find it in pinball.

#796 7 months ago
Quoted from joseph5185:

You're right. I'm a perfectionist.
But I love pinball or I wouldn't have bought it in the first place. The game thinks it's great. NO errors whatsoever. I just keep running into stupid, silly, things. Like the spinner won't spin. Really? Like...Okay. Haha
It "looks" fine to me. Am I wrong? [quoted image]

The game self-test is not a 100% indicator. Plenty of things can cause problems that don’t get caught by the test. For example, magnetized chrome balls.

The stuck spinner is a physical device. Look at it. Spin it with your finger. Find out what is binding it. It’s not something we can see from the picture.

#798 7 months ago
Quoted from joseph5185:

Sure. Looks like there are some nuts on top so I'll work on that.
I'm NOT sleeping until this game is rolling. It's pretty much personal at this point.

In car forums, sometimes people post “XXX build thread” to chronicle all their personal projects on a car without driving the rest of the forum crazy. Interested parties can subscribe, disinterested ones ignore it.

Would you consider a “Joseph’s Pinball OCD” thread?

#815 7 months ago
Quoted from Yelobird:

Ok I keep wanting to look away from this thread but you keep firing off zingers that Make me not want to walk away. I am in tears laughing at this feedback. lol Sad but just can't turn away......

It’s amazing, really. I keep telling myself I will ignore and disengage...then I feel bad, and try to be helpful again. Then my suggestion gets ignored and more posts keep spewing.

I’m simultaneously transfixed and irritated.

I would absolutely buy/rescue this machine. It’s a CE which I have regret for missing out on already, and holding POTC cabs is like holding gold. The more people get a chance to play this game, the more people want it. Demand is increasing while supply is decreasing.

#816 7 months ago

PROBLEM: Rubber in the star map / chapter select area is worn through.
SOLUTION: This is a lot of work and there's a lot that can go wrong, so be sure you're prepared...

1. Remove the Black Pearl (see other posts for this)
2. Block all the holes AND the rear orbit with shop towels. This is important!
3. Remove the 5 hex nuts that keep the plastic shield in place. Use a wrench under the plastic to hold the nut underneath when you remove the topside hex nut. Failure to do this will just cause the post to spin.
4. Once the plastic is free, lift up on the chest and rotate it clockwise to the metal bracket out of the way.
5. While everything is open, clean it! You won't get a better opportunity.
6. Replace the rubbers and reassemble in reverse order. Be aware the rubbers are different sizes as are the posts they ride on.

I failed to block the holes and I managed to lose a plastic post somewhere inside the bowels of the machine. I looked for it for over an hour, shook to listen for it, etc...never did find it. I happened to have the right post because I had spares from doing the star post mod so I eventually reassembled with one of those. Don't make the mistake I did!

UhOhRubber (resized).jpgIMG_0954 (resized).jpegIMG_0955 (resized).jpeg

#819 7 months ago
Quoted from harryhoudini:

Those are just nuts, my man... bolts are male.

Doh, thanks. Will edit!

#822 7 months ago
Quoted from Yelobird:

I have been trying for hours to do this but I can't reach the BP. Was I suppose to take the glass off?? Plus, the ship keeps moving should I remove it when it sways left or right?

LOL!!!!

#825 7 months ago
Quoted from harryhoudini:

It's not intuitive but you need to go clockwise while unscrewing the BP. Just get a good bite on it with the wrench and crank away. I think it has some red locktite on the mounting post so don't be afraid to lean in to it. A small sledge will help coerce it out.

Man, someone's going to read that and snap their BP post.

#827 7 months ago
Quoted from heni1977:

I am guessing but did you have to adjust the leaf switch again there and do you think the star post will help with the sdtm from chapter start?

I did not have to adjust the leafs. I never had the SDTM problem from the star post.

#836 7 months ago
Quoted from wesman:

I was trying to gander at your t-nut situation from these photos. Did yours have that issue or just your friend's?
Which is the topside hex nut? Is that regarding the chest or one for that plastic piece near it?

Friend in CA had it. Mine are ok. The topside hex nuts are on top of the plastic piece.

#846 7 months ago
Quoted from Heater:

Thanks for documenting this Zaphx. I have the same problem and need to replace the same rubber. I dread removing the BP and was wondering if I were able to remove 4 of the nuts, could I bend the plastic shield up enough to fit the band over the posts?
-If not and I have to remove the BP, I noticed all the posts so far seem to start off with just removing the BP. Then it went to removing the wire form ramp, then it went to not removing it and just removing the VUK to get it off (I know I know, That's what she said). What seems to be the consensus of the easiest way to remove the BP.
Thanks everyone

I was trying to sneak a rubber in there without disassembly. I loosened the front left nut, which just spun the post in place and then dropped the under-playfield nut holding it in. At that point, I had to disassemble everything in order to make it right again so I sucked it up and did the pearl.

I did not remove any Pearl ramp or wireforms. I did not remove the vuk, though I would have if I'd remembered the procedure.

#848 7 months ago
Quoted from Heater:

Thanks for the info! Looks like I have my weekend project ahead of me!

I believe I spent around 3 hours. I did things very slowly and carefully, especially dealing with the Pearl.

#850 7 months ago
Quoted from gumnut01:

See rs812, the target audience is going to ignore my post anyway. I think I will stop posting as well. Thanks for the acknowledgement. Enjoy this great game!!

No, don’t stop posting. You’re absolutely right that if it’s a problem for you, an optional ball save would be a fair solution.

I wish the SDTM was not happening for you or that I had a potential fix. I’ve had hands on setup and extensive play time on 3 different machines. Some patterns have emerged (for example all of them had gold button issues.). But I’ve not seen the SDTM myself. That does not mean it’s not happening and I’m sorry for making you feel this way.

#858 7 months ago

Yeah maybe I should just disengage for a while.

#863 7 months ago
Quoted from gumnut01:

I looked at the plastic removal over the star map and thought you might be able to loosen the top nut and sneak the rubber under as well. Alas, that causes the problem you mentioned.

Yeah, I -really- didn’t want to pull the pearl and was hopeful that technique would work. Honestly it still might, IF one uses a wrench to hold the lower nut still while loosening the top one. I didn’t grok that until I was already too far into mistakes.

I do feel better now that it’s done, except that somewhere in the bowels of my machine a loose plastic post is lurking around. It blows my mind that it just vanished.

#872 6 months ago
Quoted from Psw757:

I said this months ago.
Likely 50% of all issues in this thread are from people tinkering with shit and not putting it back together exactly the same or bumping something out of position or even breaking things whether it be from modding, installing cliffys, PF protectors, I could go on and on.
Only real issue I’ve seen that I would say is a real issue was the button and that is on a machine built way back on 10/8.

Some issues are without question user induced. I had one of these myself where I snapped a screw in a post adjusting the black pearl ramp.

However saying the button is the only real issue is flatly inaccurate. Soldering broken wires on the pearl was a real issue, for example. I’d posit most of the issues on the index qualify as “real issues.”

Most machines only have one or two of the items on the list. The point of having it is to help people find fast solutions and get playing again. This hopefully relieves some support pressure on JJP and shortens the turnaround time for people to fix their problems.

#877 6 months ago
Quoted from Psw757:

Kind of what I figured. It’s a nylon bushing but a very thin one and the screw doesn’t seem to look like any of the others at least the rounded head of it anyway.
Mystery parts I guess until something falls apart, lol.

The nylon bushing looks like the ones used on the Pearl control arm behind the playfield. Are both of them present? If so you got a bonus one!

#879 6 months ago
Quoted from Psw757:

I’ll take a look next time I yank the PF, I haven’t had any issues with the Pearl so I’m going to assume it’s an extra. I haven’t removed the Pearl so there is zero chance I dropped it in there while removing etc...

It is pretty common to find "bonus parts" in the cabinet. When you drop things in a game, sometimes they aren't easy to find. I had a screw and a washer in mine.

#884 6 months ago
Quoted from Maurice:

I believe this post should be out of and not in the Subway ramp, isn’t it? Correct me if I’m wrong. I received my machine NIB like this. I already removed the Subway and positioned the post out of the Subway ramp.

Yes you are correct, the post goes on the outside of the subway. Well fixed!

Glad your machine is great!

#895 6 months ago
Quoted from harryhoudini:

I would if I could...Looks like that might be another change from earlier games (sigh.. JJP, COMEON). And I'm missing a subway screw, it seems. So.. now the question is, is the post necessary?
[quoted image]

Yeah you need the post. Search the main POTC thread for "Ace Hardware" and you can get the parts list to build your own.

#916 6 months ago
Quoted from joseph5185:

Yea guys.
I get it. I was pretty ticked off when I said what I said. I’m still not happy about it, but life will move on...
Dare I say my game is flawless minus the now two BP issues. It’s just unfortunate that the BP is probably the most difficult component of this game especially when needing to take it off.
And it’s still difficult to come to terms with being the “only one” that has a bound left spinner. But I guess it’s entirely possible that others have in fact experienced this and just added washers since it’s such a “simple” fix, but just seems unlikely that literally no one would say anything.
I was actually considering a break/fix post to help contribute to this thread instead of flooding it and having everyone against me.

I concur with others that the cover binding your spinner may have gotten bent during one of the Pearl removals.
Did you ever set it face down?

Honestly if this were me I would just lift up on it gently until the bracket is bent enough that the spinner is free.

I had a similar issue with the Dauntless on another game where the top cover was bent down and not allowing the ship to freely rock.

I don’t think being outraged or “why me” over this minor issue is worth it. Pinball is like this.
Instead you should feel proud that you diagnosed the problem and have a couple of easy solutions to it that don’t require waiting on any parts!

I may regret this, but what is the second BP issue?

#918 6 months ago
Quoted from gumnut01:

After struggling with Multiballs ever since I set this game up I thought “screw it” and lowered the pitch from a whopping 6.55 to 6.5. The nose of the bubble used to be just above the second line, now it just meets it. Night and day. Multiballs so much more manageable. Easier BP. Less drains when going for Jack in the star map. Less drains going for Devil’s Triangle. More fun. No other game has changed this much from such a small adjustment. Really advise people to take the pitch down a little if the balls are feeling too heavy during Multiballs.
On another note, not only is my action button sticking, but so is left flipper. Pretty crap. I am actually going to change both flippers to single leaf switches. I know this means each button will now fire all flippers on either side with no independent flipper control. But don’t give a rats, I need to save my tennis elbow. The double leaf switches are way to firm for me. Yeah I’m a wimp.
Lastly, on pressing the start button the game rebooted today. I know I need to check power cable as posted, but this is the first time in 80 games. On .99 will advise if it reoccurs.
Got my first pirate hat and eyepatch today!!! Woohoo! Sorry... I meant AAAARRRRRR!!

Agree 100% on the pitch. Top of bubble to the second line plays perfect for me. I’ve played them steeper at shows and it makes it more frustrating not more fun.

For the flipper, it is almost certainly not the double-leaf switch that is causing excess resistance - those things take VERY little effort to engage.
Instead try just replacing the button. You may have one that is binding like the gold button, or maybe it just has a really stiff spring.

If you’re still unhappy at that point, then look at doing more...but you really want to retain the two stage functionality if you can.
As you progress in skill there will be a point where you want to cradle a ball on the lower flipper while engaging the top one.

#922 6 months ago
Quoted from joseph5185:

The other issue was the original flipper issue which is mostly resolved. I was just counting the issues. The plunger is coming up out of the assembly sort of sluggish or slower than the other (so when the flipper is coming back down) so since I have the ship off I was going to look at this a little closer.

You know, while moving flippers during waxing, I happened to notice that the right Pearl flipper had a lot of friction that the left one didn't.

Upon inspection I found that the vertical position of the flipper clamp was incorrect which caused the plunger to go into the coil at an angle. I loosened the pawl nut, adjusted things so the plunger and fipper had smooth travel and tightened it back up.

This greatly improved my upper playfield gameplay! I didn't realize how underpowered my right flipper was, and now I can tip it diagonally into the cannon hole more frequently. Plus get better spinner rips.

Not sure if this is your issue or not but since you have the pearl accessible I figured I'd mention it. BTW I made this adjustment without removing the Pearl.

#926 6 months ago
Quoted from joseph5185:

Possibly.
I was simply going to take the flipper bay out of the housing that it’s in and test the plunger.
If it’s smooth, then I know it was the flipper.
Seems like 0.99 is generating higher scores as well for reasons..

I really wouldn't take it out. I would put the playfield into the service position, manually move the flippers and examine the plunger operation underneath. The diagnosis and the fix both can be done without Pearl removal.

Even if the Pearl is already out, I would not remove the flipper mech again because its -installed- position is the issue here.

#933 6 months ago

Trust me, it's thing you'll want to do at some point!

#945 6 months ago
Quoted from vireland:

Wow, that's crazy. Definitely looks like some kind of chemical reaction with the disc and the star post plastic.

Well between this and my escaping sling kicker I'm ready to switch to mylar circles.

Do you have any that are the size of the star posts? I really don't want a visible ring around them if I can help it.

#948 6 months ago
Quoted from vireland:

You won't see them unless you're really looking since they're very hard to see installed, especially if you smooth them to your playfield with a fingernail when installing to remove any hint of air.
I originally made them MUCH bigger (see the post in the index where I posted pics), then made them exactly the size of the star post base, but that posed a problem because you're trying to protect the edges from cutting and chipping and the star post plastic can shift about a mm on the metal post, which shifts it OFF the mylar, so then I settled on this size which gives enough of a buffer that the edges can't get off the mylar, even if the star post shifts a little any direction.

Gotcha. Ok I am in for a set of 6 large and 6 small (in case I return the original posts for some reason.) What a whipping this is.

#986 6 months ago
Quoted from gumnut01:

Solved my flipper buttons being too stiff. Used my leaf switch bending tool, and bent the leaf closest to the button so that it is almost vertical. Before it had a very aggressive bend towards the flipper button. WOW what a difference. So much easier to use, and can easily activate both upper and lower flipper independently now. New action button also installed. Very happy.

Good job!

#988 6 months ago
Quoted from gumnut01:

Thanks for your advice on not ripping out the layered leaf switches and replacing with a single switch. You made me realise what a bad decision that was!

Anything I can do to help folks enjoy their games more makes me happy.

#990 6 months ago
Quoted from Lermods:

Can someone point me to the instructions to remove the ship to Install the cliffy for the map hole?
Does the pop bumper need to come out to Install the mystery hole cliffy?

To remove the Pearl, lift the playfield. You will have to clip some of the zip ties to free up all the plugs going to the Pearl, I think there are 7 of them. Make careful note of what goes where. Most of the plugs only go in one place, but there are 3 on the right that are all the same and are color-coded to their homes.
Once you have the harness loose and unplugged, go back topside. Move the spotlight out of the way. Remove the hex bolt behind the Pearl and push the Pearl toward the back, then up and out. Some people loosen the Pearl ramp and/or remove the VUK to make removal/replacement easier. I didn't do these things, kinda wish I did. When you put the Pearl back on, consider adding some kind of wire loom protection to the harness so it won't rub.

To remove Tortuga Tom there is a hole in the side that takes an Allen wrench. Loosen that and Tom lifts right off. From there 2 screws to remove the motor (watch for falling spacers) and then loosen the two screws in the bottom of the pop - do not remove them. From this point you can remove the Tortuga scoop for your cliffy install. When you reassemble, aim it to the left and test it a few times to make sure it hits the flipper (and not the ball guide or SDTM.) I used blue loctite on this scoop which has held it solidly and my scoop ejects are perfect.

#992 6 months ago
Quoted from Lermods:

Many thanks! Doesn't sound too bad.

It's not. It's a bit intimidating but it really was designed to be serviceable. The main caveat I have is make sure you block off any holes/cracks with shop towels before you remove things. It's super easy to drop a nut or something into the bowels of the machine. When I replaced the rubber in the star map area I lost a plastic post that I still haven't found!

#994 6 months ago
Quoted from JamCat:

Does anyone know if it's possible to install the starmap on an SE? Or is the SE missing the connectors and other essential hardware for it? I've been trying to get an LE or CE and just can't get my hands on one to save my life. As soon as one is listed it's sold in minutes. I've got all of the instant alerts setup, but still miss out every time. I was thinking of buying an SE and trying to upgrade it as an alternative. What else is missing off the SE besides startmap, powder coat topper, shaker and invisiglass?

Spinning pop bumpers.

#1003 6 months ago
Quoted from MarZ_78:

I didn't think the rails could be the issue if the manual shooter worked ok.

That was exactly my experience; the manual plunger was 100% problem free while the autoplunger struggled more than half the time. I guess it has to do with angle of attack on the autoplunger fork vs the manual plunger?

Glad you were able to fix it! Mine has been dead perfect since correcting my rails and I'm very happy with it.

#1030 6 months ago
Quoted from Mr_G_Hosting:

I like the topper flickering too, but the spotlights should just
light up and stay on without flickering. Wish there was an option
for that in the menu.

The spots should be staying on. Are you 100% sure the spots are flickering in tandem with the topper?

#1045 6 months ago
Quoted from joseph5185:

Honestly, I think I need to put a good 1,000 games on this or so and ACTUALLY PLAY the damn thing before I start obsessing over something new.

This is the absolute best advice you’ve ever given yourself.

I un favorited the other thread on the issue because it’s borderline hysteria.

#1103 6 months ago

PROBLEM: Balls getting stuck on the "Man Overboard" self by the Pearl
SOLUTION: There is a clear cabinet bumper there to prevent this; it may be installed in the wrong place. I had two machines, one which was having this problem and one which was not. I carefully removed the bumper and relocated it to match the good machine and I've never had the problem recur.

Here is the location that seems to work perfectly. (Note the position relative to the text as well as the position of the shooter lane wireform.)

IMG_0998 (resized).jpeg
#1107 6 months ago
Quoted from harryhoudini:

Can you put an arrow on that pic? I am not sure what specifically I am looking at.

IMG_0998 (resized).jpeg
#1109 6 months ago
Quoted from GnarLee:

On a side note got my replacement wireform a in. The shooter lane wireform fixed the last of my inconsistent ball shooter. The ball travel up the lane is soo much smoother now and the ball exits like a rocket.

Glad to hear it! My autoplunger is 100% now as well after straightening mine. Really happy to get these little adjustments sorted out, the game is so much fun!

#1138 6 months ago
Quoted from indypinhead:

I just realized that my chest ball lock isn't working at all.
Any pointers?

Is the fork loose? Easy known fix.

#1168 6 months ago
Quoted from wesman:

For some reason that's an iPhone only app...

Heh “for some reason.”

Android apps do not magically spawn from iOS codebases. Developers must explicitly create a version for the lesser platform, or compromise from the start using a cross-platform development tool.

Most iOS developers only do iOS. Companies that support both usually have teams for both.

Source: I do this.

#1170 6 months ago
Quoted from harryhoudini:

Sidebar... are you saying all cross-platform development tools are compromised from the start? I started using them back when they first came out and they were shit. I imagined by now there are so many kinks worked out to offer native support for both platforms pretty closely.

Yes. It is impossible to create a one-size-fits-all solution due to the different paradigms of the platform. You either make an iOS app that shoehorned into Android, or vice-versa. Native dev FTW.

#1172 6 months ago

Moved to PM as we're increasingly off topic.

#1193 6 months ago
Quoted from gliebig:

My BP VUK wouldn't get the ball up on stock settings. I had to turn it up, but can't remember what I turned it up to. I'll have to check and maybe dial it back if needed.

The default value is in green. Friend had a CE with VUK problems there and it was shipped well below default. Default fixed it.

I -think- the default is actually 32 but don't quote me.

#1202 6 months ago
Quoted from TZBen:

I everyone, I joined the club today with number 1500 delivered (le). I have a couple small issues and would appreciate our tips.
1. Ship vuk in rear seems to lose balls. I think the game is too steep and they aren’t falling into the vuk correctly?
2. Bp ship isn’t moving Much to the left side.
Thanks. Super excited

1 - Check the VUK coil power. It may need increasing. Mine runs at default.
2 - There is a pin that goes through the back of the playfield in a slot. Is it topping out or bottoming out against either extreme of the slot? If so, there is a metal bar behind the playfield with adjustment screws you can use to raise/shorten the control bar and stop hitting the slot. If it's not hitting the extremes of the slot it is probably fine. The ship has a list to one side most of the time.

#1207 6 months ago

It looks like I am starting to see a bit of wear on Tortuga so I'm going ahead and getting Cliffys.

For the folks who have installed them - did you remove any mylar before doing so? Would like more info.

#1210 6 months ago
Quoted from wesman:

I didn't, but I waited to install before playing. Not sure how the mylar that's down will affect things post play, but I had no issues.
It's a fairly easy installation, but try and get the hex key inside the barrel.

Oh I'm not worried about removing Tom. I've had him out a couple of times to tweak the Tortuga scoop.

#1229 6 months ago
Quoted from indypinhead:

I tried hitting the target manually during gameplay. Still doesn't work. However, I just played a game and was able to load and fire the cannon into the Dauntless.

Well there are two targets for loading the cannon. LOAD and CANNON (over on the right.)

I'm betting there is a broken wire on the LOAD target.

#1233 6 months ago
Quoted from indypinhead:

While I have the upper playfield removed, I guess I should take this opportunity to put some plastic wire loom protector in. Does anyone have a link on what size they used on their machine?

I used this:

amazon.com link »

Note that you don't actually have to remove the Pearl to add it. You just feed the wires into the open and and slide it up from under the playfield.

#1235 6 months ago

Picture of the stuff I used...it plugs that hole nicely.

IMG_0802 (resized).jpeg
#1238 6 months ago

It's one inch diameter, and no restriction of movement whatsoever.

#1274 6 months ago
Quoted from joseph5185:

AH! I MAY have started a game before it had a chance to release. I did not consider this...
Yes. Once. But IDK exactly what is happening that's why I think I need to capture the action...

That's almost definitely what is happening. If you start right away (which we all do because it's such an addictive game) the balls stay put. If you give it a minute to get through game over, they will drop.

Sounds like normal operation to me.

#1303 6 months ago
Quoted from gliebig:

My spotlight above Tortuga Tom always goes out. I've tried several bulbs. Any tricks for this?

I've been able to fix this 100%.

Pull out the bulb (straight out, do not twist.)

Straighten out the two wires and wrap e-tape around the base once, then fold them back.

They will stay in place and stay on.

#1305 6 months ago
Quoted from harryhoudini:

Were your bulbs not hot glued in? Usually JJP does this and combined with the legs being bent properly they seem to stay in place well (in fact, very hard to remove them to replace with others)

Yes they were but that wasn't enough to make the electrical connection stable. The e-tape fix was dead reliable. I forget which pinsider suggested it, it was someone else here.

#1384 6 months ago
Quoted from joseph5185:

I adjusted the flipper power before I realized the pitch was lower.
I appreciate the feedback. I would still like to know if it's "common" to have one flipper set higher in power than the other.
yelobird - Is the chest issue more so seen that you pretty much can't lock a ball ever?

My flipper powers are at defaults and IIRC yes the default has one higher than the other.

On my machine the chest shot is easier to make with the right flipper than the left, and I consider it part of the game design and challenge. It takes a really perfect shot to nail it from the left flipper.

Another example: maelstrom is easier from the right flipper, but -can- be backhanded from the left flipper with difficulty for me. I like having these options and risk/reward scenarios. Part of the amazing design.

#1386 6 months ago
Quoted from harryhoudini:

On the same note, can you make the chapter select with the right flipper?

Oh hell no. I can't do it with anything but the left.

#1392 6 months ago
Quoted from Maurice:

Quoting myself: has really nobody noticed this? No confirmation or whatsoever.
“Problem: inconsistent auto plunge shot which doesn’t make it to the left upper flipper.
I adjusted the coil strength from the shooter but that didn’t do the trick. I closely looked at the wireform and that has 3 horizontal metal “bars” at the underside (see pictures) which make the ball rattle.
Solution: use a dremel to grind some metal and let the ball pass without touching the metal bars. You need to remove the wireform to do this properly. The dremel I used had a curved shape, which I highly recommand.
Now every autoplunge makes it around to the upper left flipper. Coil strength at only 20”

I had autoplunge problems but not the same. The two rails in the shooter lane were not completely flat, and the slight height difference was enough to cause the ball to hit the post off autoplunges. Straightening the rails fixed it.

My issue did not involve the bars under the rails; manually rolling the ball it was smooth without clicking over them.

#1403 6 months ago

Ripping loops is super satisfying. I even like listening to my wife do it when she's playing and I'm on the couch doing other things.

#1406 6 months ago
Quoted from gumnut01:

Agree. Better than ripping farts on the couch. Seriously though it seems like the default action for that flipper. So easy to get the loops into muscle memory. Thank Eric for making this happen.

As I understand it, he spent quite a bit of time on whitewoods getting the feel of that shot just right. It shows.

#1432 6 months ago
Quoted from joseph5185:

Really quick...
Anyone experience an issue where the chest forks aren’t retracting down enough on the playfield which can cause the ball to get stuck back there?

I did. Fixed by adding one washer to one of the 5 chest fork mech screws. I think it’s in the index.

#1439 6 months ago
Quoted from joseph5185:

3) Ball getting trapped under the chest - found the Index - will investigate - possible it was an issue longer and the ball just didn't head that way.

Feel under the chest with your finger when the fork is down and the game is off. If you feel the tips above the playfield surface, you'll need the washer fix I used.

#1443 6 months ago
Quoted from joseph5185:

Yes. I think so? Looks like a gold screw. Also, the spring action is a bit lethargic when manually playing with it.
Edit: At the rest position, it's not resting against that screw. When I checked a few weeks back, I don't believe it was then either.

I messed with many screws on the chest mech - none affected that position. In fact messing with the ones that hold the solenoid in place caused MORE problems with the fork and the solenoid to overheat, until I moved things back as they were.

I just recommend the washer, it's a simple fix. I don't remember which screw but the post should say.

#1449 6 months ago
Quoted from joseph5185:

As a brief update ..
The forks are fine now. Just took the cover off and made a slight adjustment to them and as a bonus the chest seems to accepts balls even better now.I'm now perfectly comfortable with if the ball doesn't lock, the shot simply wasn't good enough.

What was the adjustment? You were able to fix the poking above ground without the washer?

#1477 6 months ago
Quoted from joseph5185:

Hey guys,
So my friend is playing the hell out of this game...which is awesome!
A couple new issues and I'm sure these are all documented, but I just like to note it:
1) The VUK sometimes isn't kicking the ball up to the ship.
2) The post has stopped working when starting a new chapter.
3) The BP stopped moving for a bit and then started again. This seemed to occur only once when he achieved a score of 600k so I'm not sure if this is by design as maybe it's overheating or idk.
Thanks guys! =)
Update:
1) The VUK is still doing this. Maybe 1/10 times.
2) The post magically started working again. Haha. Awesome!
3) There was only one occurrence of the BP stopping. What maybe interesting is that the lights on the pearl shut off when this happened.
Back to playing!!

1 - Turn it up. There’s been a lot of talk about this being turned down by people. Mine is default (which I believe is 32) and it has been fine.
Friend had the same problem on his CE and it went away when he turned it up. Default values on coils -unless there is a problem.-

2 - Check the nut on the chapter post, see if has spun down.

3 - Check the linkage in the back.

Most, if not all of this, is in the index btw!

#1496 5 months ago
Quoted from Zora:

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.
Any idea, what is going wrong here?

It sounds like the game thinks the ball left the Pearl, and possibly even thinks it hit the Dauntless.

In switch test are any switches reporting stuck closed? Or falsing if you bang on the play field?

#1498 5 months ago
Quoted from Zora:

I will check in the switch test. However, that would mean that the switches in the canon and in the Dauntless would be registering incorrectly, which does not seem to be probable.

I know, this is a weird one. But you're saying the playfield lights come back on and the movie 1 multiball light flashes, which is what it would do after making a successful shot into the Dauntless when the cannon is qualified.

#1500 5 months ago
Quoted from gumnut01:

You sure you have not advanced the Pearl by doing the BP skill shot? That advances the Multiball.

Good call, maybe it's as simple as that. Every time you skillshot the boat, it advances one step towards BPMB. Spinners, Load Cannon, and the shot itself.

However, the OP mentioned the load cannon arrow is lit, which it would not be if BPMB was qualified via skill shot.

#1503 5 months ago

AFAIK there are 3 ways to qualify BPMB:

1. Shoot the cannon and nail the Dauntless hole
2. Shoot the cannon and bang off the side of the Dauntless twice
3. Skill shot the Pearl with Load Cannon lit

#1505 5 months ago
Quoted from Zora:

Thanks for your thoughts. But in fact the cannon load arrow is flashing and then it disappears (while the ball is on the BP without getting into the cannon) and then the MB lights on the playfield (which means the pin thinks I have destroyed the Dauntless).

Yeah, gotta be a switch misfiring then. Maybe ltg has a suggestion?

#1523 5 months ago
Quoted from harryhoudini:

I can't see any real complaining about removing the BP.. took me like 2 minutes to get it off. Anyone who has an issue there should remove the castle playfield on WOZ.

Yeah, it's really not that bad. It is a bit daunting if you're not used to working on pins (which I wasn't before POTC.)

#1542 5 months ago
Quoted from Zora:

I can hardly close the lockdown bar. It is very tight. Is there a way to lock it more smoothly?

Loosen the two brass screws on the lockdown bar a bit.

#1560 5 months ago
Quoted from kcZ:

The spotlight for my Black Pearl was out. Swapped the bulb to a working one to diagnose it as a bad bulb. I grabbed an LED from my parts drawer put it in... Worked for a very short time. I assume that I did not use the correct bulb? Are these 12v lights?

So I've found the issue isn't so much the bulb as it is the connection to the socket.

I fixed this with the e-tape fix to the bulb which gave it a nice snug connection.

#1564 5 months ago
Quoted from kcZ:

I'll try again but I messed with the leads for the bulb the first time.

What you do is straighten the leads, wrap the base with e-tape, then fold the leads back down over the tape.

This gives more pressure in the socket and a reliable connection.

#1572 5 months ago

I found my wayward post at last! If you lose a part check the rail gaps.

B9D9E8ED-3D43-4A5B-A478-FCD0D3CA2B5E.jpeg
#1588 5 months ago

I had a ball tonight that was so magnetized it actually stuck to the left rail while rolling down, lol!
I have a big box of them from Titan so no biggie. I think this set has around 1000 plays on them.

How frequently are you guys changing your balls?

#1591 5 months ago
Quoted from joseph5185:

I was planning on changing every 500 games or so.
Too frequent?

Probably. Honestly every 1000 games is probably overkill too. I’m really only changing them when/if weird things start to happen.

#1609 5 months ago
Quoted from Blackzarak:

Any specific tweaks needed from a new out of box POTC that I need to do?

Having set up 3 of these things, these are the things I found need checking OOTB:

1. Adjust the Pearl ramp adjustment screw until the ball rolls off the top to the right. Stuck balls here are common until you do this. Do not over tighten.
2. Confirm the shooter is working cleanly and does not catch against the autoplunger. See index for fixes if so.
3. Go into switch test and hit all the switches, confirm none are stuck closed and none fail to fire when hit.
4. Run the ship test and confirm the Pearl runs freely without topping/bottoming the slot and gets down to a single digit score as its lowest value. See index for fixes if it’s not.
5. Clean the playfield (sometimes there’s a little shop dust.)

All this will take about 10 minutes. At this point just play and enjoy your new machine!
IF you run into issues, check the index on this thread for help.
I do not recommend reading every single item and worrying if you have the fault or not.

I also recommend two preventative maintenance items but you should NOT feel compelled to avoid playing on day one.
I didn’t do these items for months after unboxing.

1. Plastic wire loom on the wire behind the Dauntless (it can rub and cut)
2. Plastic wire loom on the wire under the Pearl (it can rub and cause a short)

#1613 5 months ago
Quoted from gumnut01:

zaphx why do you continue to tell people not to turn down the black pearl VUK? You have seen evidence that the default setting breaks the opto. Just because it has not for you does not mean it is not for others. The advice is to turn the pearls VUK to the lowest setting that reliably gets the ball onto the ship. If you set it too low and it doesn’t then turn it up until it does board successfully every time. Mine is set to 20, boards every time and does not leave dents in my upper deck nor smash into the optos anymore. Over 5 pinsiders have reported broken optos caused by the default VUK setting. But you continue to tell people not to turn it down. Why? Does not make sense.
If you need more proof here is a email from Steve:
“Might want to turn down the coil setting for the Black Pearl VUK as that seems to be breaking the opto housing when turned up too high according to the Design Team. Thanks, Steve”

I take the advice in the coil setting screen to heart “Do not change unless you have a problem.”

I’ve owned two machines left on default without having the problem. Then my buddy got a CE which had a lot of problems with the VUK failing and the ball going under the Pearl...UNTIL he turned it up to default. It was too low as shipped.

None of those 3 machines have broken optos yet. Maybe we’re just lucky though, I am definitely interested in the shield.

I would definitely listen to JJP/Steve over me on any of this! I’ll butt out.

#1618 5 months ago
Quoted from Trooper11040:

Took off my ship to fix the map t nut and on the back lane, I see this sticking out. This can’t be good?
[quoted image]
Edit: disregard. Ball doesn’t touch it. Sorry

Good troubleshooting! Not everything that looks like a problem actually is.

#1626 5 months ago
Quoted from Zora:

Why does the ball not touch it, is it at the bottom of the playfield? It looks like it is standing significantly into the ball movement.

Mine has the same protrusion and my orbits are smooth. If you roll a ball over it you'll see that the metal piece runs under the gap between the ball and rail when the ball is flush to the rail.

IMG_0955.jpeg
#1629 5 months ago
Quoted from wesman:

I've read pretty frequently from multiple forum vets on here 400-500 games. That basically replacing balls, and waxing are the two most important steps in longevity for a game.

I better buy more balls then I figure I need to do it monthly if that's the service interval. I already clean it a couple times per week, and wax it maybe twice a month.

#1645 5 months ago
Quoted from harryhoudini:

What's the problem you'll notice if the VUK is turned up too high? Do you wait for the opto to break?

Yeah yeah chill I already deferred on this.

#1658 5 months ago
Quoted from harryhoudini:

Ah, if you look at page C-130 in the manual all of the rubber parts are listed and there is not one there for that post. I haven't even figured out what that post is for... haven't pulled the ship or looked closely enough at that side of the playfield.

I always assumed it's to enforce the U-Turn, give the ball something to rocket around

#1665 5 months ago
Quoted from vireland:

Forget ugly silicone and use the electrical tape fix:
https://pinside.com/pinball/forum/topic/fixing-led-bulbs-flashers-that-fall-out-of-spotlights
Looks better and works great.

Can confirm, this tip fixed my flaky spots 100%.

#1667 5 months ago
Quoted from gumnut01:

Thanks. I tried this before and it lifted the ball launch wireform. Now I have launch issues for the first time. Ball hardly makes it around orbit.

I spent a lot of time (months) troubleshooting ball launch and autoplunger issues and finally resolved them 100%.

Here's what I did (and all of these had an effect):

1. Check your shooter tip and replace it if torn or flattened due to use.
2. Make sure the plunger doesn't contact the autoplunger. If it does, adjust the shooter housing down. Still doing it? Put some kind of padding under the playfield hooks. I used dense weatherstripping foam.
3. Make sure the shooter lane is aimed into the orbit just right. If it's too far left or right, you'll get a ball rattle that robs power.
4. Finally, make sure the shooter lane wireforms are even with each other. In my case, a slight "bump in the road" on one side was causing autoplunge failures even though manual plunges were fine.

After doing all of this, my plunges are lightning fast and rocket around the orbit - I have to use a very light touch now for the skill shot In addition, autoplunges are now 100% reliable.

#1671 5 months ago
Quoted from Soulrider911:

Question for you pirates. Has anyone noticed on their game that the ball sometimes does not make it up to the black pearl?
More specifically it would appear on mine sometimes the magnet may not be releasing the ball correctly and instead of rolling into the subway and into the VUK... ball just rolls around right side orbit

This is controversial since half the people in here preach to decrease it, but I'd try carefully increasing the VUK power until it stops happening.

#1673 5 months ago
Quoted from gumnut01:

Thanks zaphx it was simply the new tip I put on which was a beige colour so I could see it for skill shots. The tip is slightly pushed off centre. Rotated the rod and works fine now. Will keep an eye on it. May need to go for a more durable tip.

Sweet, it was the easiest of the 4 things!

#1694 5 months ago
Quoted from GnarLee:

Agree 100%
This was pretty much my list as well. I did shim my auto launcher to remove the play left and right.

Oh I forgot, I did that too! So 5 things. I used a washer.

#1715 5 months ago
Quoted from GnarLee:

YA Tortuga really needs loctite. This is the spot where I have significant chipping. In 1500 plays or so I have had to tighten tortuga scoop 3-4 times now. Every time it was tightened the gummy bear got worse. This last time a big chunk of it came off. Long story short im pretty sure every time i tightened the scoop it pushed more of the clearcoat out and less clearcoat under part means loose part.

I haven't had to adjust it since loctiting it. Fires into the top of the left flipper consistently. Up to around 3200 plays so far.

#1721 5 months ago
Quoted from harryhoudini:

If it isn't firing right you might also make sure you have the updated (longer) snubber bracket.

I have the shorter snubber...I need to request that longer one (which my Los Gatos machine had.) Also need to request the opto bash protector. Will get all this dealt with at some point, so far neither are causing me an issue though.

#1726 5 months ago

For the issue of the chest fork tips poking up through the playfield and catching balls - does anyone have a fix for this?

I decided the washer fix I implemented (and documented) was causing too many rejected shots. I removed it as a test and sure enough my scores improved...but the stuck balls came back also.

I think I remember someone doing something else to solve this?

#1728 5 months ago
Quoted from harryhoudini:

Could you remind me what symptoms you are seeing? I don't have any input, lol, just wondering what happens. When the forks are too high does the chest lane just kick the ball back instead of letting it through? And for the rejected shots, what happened? Did the ball travel up the forks and hit the gate or top of the curved guide?

The ball passes through fine, but sometimes if the shot is weak enough it gets trapped under the chest.

When it was rejecting heavily, it hits the forks and doesn't make it up, returning to the player. Always a possibility with a weak shot, but it was notably worse with the washer in place. It changed the angle of fork attack.

#1730 5 months ago
Quoted from harryhoudini:

Thanks. I had some issues when I replaced the chest bracket. Alignment of all of those parts is pretty key, it seems, for a reliable shot. Hopefully someone has a suggestion.

Maybe I just need to break the loctite on the forks and reposition them. I'll look at that.

#1732 5 months ago
Quoted from bgwilly31:

Maybe this has been addressed. I checked the initial post and didnt see this.
But CHAPTER 5 Select target in my chapter are is stuck closed. I removed the target and tried to get it to register it will not do anything.
Zach from Flipnout when i was there had this same issue on his.

Probably just need to gap that switch. What I'd do:

- Remove the screws for the offending switch from under the playfield
- Using a leaf switch adjustment tool, adjust the contacts from the base of the leaf until it's not stuck any more.
- Replace and test

Fortunately this is an easy fix, aside from needing the leaf tool (which is cheap.) Don't try to do it with needlenose, you will twist the switch. Trust me on this

#1734 5 months ago
Quoted from bgwilly31:

Thanks ZaphX but i did exactly that and couldnt get the switch to respond at all.... If thats the case where do i go from there. Every other chapter select and every other switch in that column is responding and working fine.

Stuck closed makes it sound like there is a short somewhere. If it's not the actual switch being pinched together, then maybe it is upstream somewhere.

If you follow the wires from the switch do you see anything unexpected?

Maybe LTG has an idea on how to troubleshoot further?

#1738 5 months ago
Quoted from KornFreak28:

Did you fix this?

Not yet, I’ve been all about Wonka!

#1761 5 months ago
Quoted from harryhoudini:

Does anyone have specific balls that can be used in magnet games? And is there any reason to not use whatever balls those are in other games? I'd like to just buy bulk one source if possible. I need about 25 balls to replace all games.

I got a box of like 50 of these:

https://www.titanpinball.com/index.php?route=product/product&path=57&product_id=69

1 week later
#1807 4 months ago
Quoted from rlslick:

Troubleshooting a VUK issue that is behind the black pearl that plunges the ball up onto the deck. The ball is shooting up but unable to get on the deck. After 2 attempts it exits to the side and back on the main playfield. It looks like there’s enough clearance at the top for the ball to land, not sure. Could it be a coil power issue that needs to be adjusted? Anyone have similar issues?
Also, gate 87 is stuck according to the test report. Where is this located?
Last issue...camera is not able to be found. Checked all the wiring and it seems to be OK. Could it just be the camera went bad??
Thanks in advance!

Increase VUK power on the Pearl VUK until the Pearl failures stop. You want to do as little as you can here, though my machine is at 32 (default.)

I think 87 is the Maelstrom ramp opto? If you go into switch test it will show you the switch location on the playfield.

On the camera, is the usb plugged into the motherboard for it? Try a different USB port if there is another free?

#1819 4 months ago
Quoted from gumnut01:

I just removed mine for first time today. Removing was fun. Getting back on was funner. I liked the buffalo video where his tip for getting it off was to “jiggle a bit”, followed by his tip to get back on was “I don’t have any tips to get it back on”.
Good luck!

Removing the Pearl is a rite of passage

It was designed for easy removal, but the first time is a little scary.

1 week later
#1863 4 months ago
Quoted from tgrinchy:

So I’m starting to experience intermittent stuck flipper on the right side of the BP.
Pressing the coil shaft all the way in with my finger causes some resistance and can stick if push in the full throw. Is lube a bad idea or what would be best route to address?

I had this exact issue. Loosen the pawl nut on the flipper and correct the vertical position of the flipper such that the coil moves freely, then re tighten.

3 weeks later
#1979 3 months ago
Quoted from Galooch:

Thank you again to all you have taken the time to respond and provide pictures to help with my cannon door. Super helpful! I think I have improved things but I have a few more tweaks to make. It isn't consistent enough yet. However, I now have a few other items that cropped up:
1. The left spinner on the BP is no longer spinning. I found that when I put back the top portion after tweaking the cannon door, it sits on top of the left side of the spinner. A quick search revealed this post from a few months ago (https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4984403) where joseph5185 successfully was able to put that piece back on at different angles. I have been trying to find that angle (not tightening the right-most bolt all the way too), but it consistently slides down and pins the spinner. Has anyone else encountered this issue and if so, how did you solve it? I really don't remember that part of the BP sitting crooked before taking it off.
2. It appears that I have my first switch issues. The Bonus (X) and Load switch on the BP are no longer registering. A quick inspection on the left side of the BP and I can see that all wires are firmly still attached. What else should I check? I'm hoping something simple that won't require me to remove the BP (haven't had to do it yet). I have not ordered the BP protector from Pinball Life yet and I'm wondering if a ball ricocheted and did some damage. Has anyone had those two switches go out at the same time?
Thanks.[quoted image]

In my experience when those switches go out, it’s a wire under the Pearl (Green/Brown if I remember correctly.)

We couldn’t find the break until we removed the Pearl; it looked OK from the side.

4 weeks later
#2103 77 days ago
Quoted from V4Vendetta:

My action button is sticking like everyone else. I saw a post with a link to a stern button that fixed this issue. Does anyone have the link by chance?

https://www.pinballlife.com/1-38-clear-pushbutton-for-stern-lockdown-bars.html

#2104 77 days ago
Quoted from Skipnatty:

Apologies as I couldn't find this while searching so if it's here, I missed it....anyone have issues with the fork mech where it will raise just fine but after making a lock which should lower the forks, they stay up?
On my game, occasionally the latch will release as expected but the forks don't actually lower. When I check the mech out, it just seems there is a ton of friction in trying to move the forks down but not necessarily up...they aren't travelling too far up from what I can tell because in the lock position they travel just above the latch that locks them in place.
Appreciate any thoughts. Thanks again.

When the mech lowers the fork, it first raises UP slightly to do so. I had the coil misaligned at one point (after messing with it, my own fault) and it was causing the forks to stick up as you describe. It became extremely hot while stuck in this way too, FYI.

3 weeks later
#2205 56 days ago
Quoted from MurphyPeoples:

Okay - for those guru's that guessed I had Magnetized Balls.... you are RIGHT! Every single ball is magnetized. Some balls only in ONE SPOT - which would
explain the randomness of the balls not draining in the trough. I don't know if I've solved it, as I have no "new balls". I'll be running by Marco Specialties after lunch tomorrow ( On Friday's I work about 5 miles from their shop). Should I just order a sleeve of their Standard Silver Jets? Or a Special ball of some type?
Here's the thing - I've got less than 100 plays on the machine. Weird that they would magnetize so quickly. Should I expect to have to change them every 100 games?
More to come tomorrow - after I load in 5 new ball! : )
Murphy[quoted image]

This game has at least two magnets that stick the ball behind the pearl and bounce it around the chapter select.

You cannot use chromed balls or silverjets, they will magnetize immediately.

#2211 55 days ago
Quoted from luckymoey:

My auto launcher is mis-firing a good bit during multi-ball and I'm stumped. It always works after a try or two. I've checked all the typical issues. It works perfect with the playfield down and apron on during the trough test mode - 30 for 30. Seems like the issue always, or almost always, occurs during multi-ball and not during ball save re-launch. The launch forks are centered on the ball. The shooter rod is slightly off center but has plenty of clearance from the auto-launcher. The machine is level top to bottom and sloped @ 6.5. The autolauncher has some side-to-side play but nothing unusual and still has good clearance even when pushed right or left. The coil settings are factory. It's also not an issue of the ball bouncing around in the shooter lane or hitting the small post rubber. I have the Koop shooter mod installed so cannot easily video during game play. Appreciate any other ideas?

How many plays do you have? Does increasing power to the shooter change the behavior? Might need to clean or replace the coil sleeve if it seems to have lost power. My main problem with the autoplunger was contacting the shooter due to the playfield sag, fixed by padding it.

#2214 55 days ago
Quoted from luckymoey:

Thanks. I did change the coil sleeve and cleaned up the stop which was still in good shape. Also increased coil power a few notches with no effect. I'll take a closer look at the wire form but it's well seated in the playfileld and the ball is only traveling several inches up during mis-fire. The baffling thing is that it works perfectly in test mode - dozens of times in a row. I even fed balls into the shooter lane quickly during test to try to replicate multi-ball. I may need to take the Koop gun barrel off to video.

If it only travels a few inches up, film it in slowmo and see if it's hitting the post. It may not be easily perceptible. If it is, the wireforms may not be true enough - in my case there was a slight speed bump I was able to flatten out.

#2230 52 days ago
Quoted from joseph5185:

Hey guys,
Long time...
I don't really want to be bothersome, but it looks like the stop post for start chapter area intermittently stops working. Was wondering how common this is or if there any easy quick fixes.
Thanks much.
If it's possible that this has been improved with code, then I should really get on that. My game is still on the original code as when I got it and has far under 1,000 plays to date.

See if the nut that holds it in place has spun down.

#2232 52 days ago
Quoted from joseph5185:

Sounds great!
Thanks again for the quick quick response!
I'll edit my OP when I have an update.
Did 1.0 ever release? How behind am I? Haha

0.99 is the latest! You haven't missed much. Glad you're still enjoying your game!

#2236 52 days ago