(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

8 months ago



Topic Stats

  • 2,377 posts
  • 140 Pinsiders participating
  • Latest reply 4 hours ago by kidchrisso
  • Topic is favorited by 99 Pinsiders

You

Linked Games

Topic Gallery

There have been 438 images uploaded to this topic. (View topic image gallery).

JJP Voltage conversion.jpg
Install_Picture_Kicktap_sml (resized).jpg
kicktap_sml (resized).jpg
Install_Picture_Kicktap (resized).jpg
JJP_mobo_buttons_sml (resized).jpg
fix-dead-jjpotc-H110_mobo (resized).jpg
fix-dead-jjpotc (resized).jpg
IMG_1901.jpeg
Screen Shot 2019-11-30 at 6.52.53 PM.png
1B7C8008-D057-4BB4-8D38-23634CFEAB94 (resized).jpeg
reset motherboard (resized).jpg
jumpstart (resized).jpg
20191128_210803 (resized).jpg
moboreset (resized).jpg
IMG_20191128_194814971 (resized).jpg
B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg

Topic index (key posts)

3 key posts have been marked in this topic

Post #306 Tip on removing the black pearl Posted by rs812 (7 months ago)

Post #501 More tips on removing black pearl mini playfield Posted by LTG (7 months ago)

Post #1776 Broken trunk mount bracket picture Posted by Soulrider911 (5 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider vireland.
Click here to go back to viewing the entire thread.

271 posts in this topic match your search for posts by vireland. You are on page 1 of 2.
25
#1 8 months ago

This thread is to share tips and solutions for Jersey Jack's pirates of the Caribbean. I'll curate it with an index more specific than key post listings.
DISCLAIMER: These fixes are shared in the interest of helping others correct issues. Performing any repair is at your own risk, and should be done by experienced and careful individuals only. Contact your distributor first for help, before filing JJP support tickets. They are there to help you and will generally respond quicker.
-----------------------------
INITIAL CHECKS
-----------------------------
Double check you got all the shipping foam out:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4933831

Installing two piece map cliffy:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4933795

Also installing the Mystery hole cliffy is the same as the deflector fix here:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934930

Chest rejects most/all shots for ball lock:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4933982

Black Pearl ramp has bump on the left side by the "P" in "Pearl":
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4935887

Tilt warnings double/triple fire, or phantom tilt for the next player following a tilt:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/2#post-4941249

Screen appears washed out and colors fail to pop
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941283

LE Toppers off-center from the factory
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941624

Machine is DOA or loses power
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4942240

Plunges or shots to the right orbit come around the top, pass the upper left flipper and go SDTM
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4942258

Sling posts are digging into playfield, bunching clearcoat, making deep impressions in it, or chipping it
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/7#post-4958109

Fix the T-Nut protruding into the MAP hole back side that may nick up your balls
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/10#post-4966440

-----------------------------
BOOTING ISSUES:
-----------------------------

Your jjPotC suddenly won't turn on. Red lights on the lower circuit board for the fuses are on, but no boot.

First, check the power cord to make sure it hasn't wiggled loose on the machine.

Then,
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/47#post-5329186

-----------------------------
SOUND ISSUES:
-----------------------------
Audio is popping
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/35#post-5066325

-----------------------------
SWITCH ISSUES:
-----------------------------
[Switch Name] is stuck or not working:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934031

Game reports stuck MAP targets:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934038

Problem: Game reports stuck GOLD targets
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934087

-----------------------------
SHOOTER/PLUNGER ISSUES:
-----------------------------
Manual shooter plunge is inconsistent and/or weak:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4933886

Another Manual shooter plunge issue that causes inconsistent/weak plunges:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/6#post-4954102

Metal rails in the shooter lane are malformed, causing bad plunges:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934023

Autoplunger is inconsistent and frequently fails to launch past the “hill.”
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941271

-----------------------------
SHIP RELATED PROBLEMS
-----------------------------
Video demonstrating black pearl removal:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934914

Black Pearl reporting stuck open switches
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934928

Black Pearl cannon access gate unexpectedly closes when hitting a flipper:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941255

Black Pearl Cannon is shooting to the right side of the "target" hole in the Dauntless, causing rejects:
https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/127#post-4908546

Balls getting stuck at the top of the Black Pearl ramp:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934019

Black Pearl rocking motion sometimes halts (in game) or struggles (in calibration):
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934020

"Target Ship" (Dauntless) switch errors:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4933955

Left Black Pearl flipper spring is stretching a lot or breaking frequently
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4942259

Dauntless sticking out too far, making the cannon destination hole too far forward:
https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/127#post-4908546

Balls getting stuck on the "Man Overboard" shelf over the right side of the Pearl (on the main PF):
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/23#post-5000822

Lanterns on ship are very dim/poorly lit:
https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/21#post-4693755

Load cannon door partially blocks shots to the 'LOAD' stand up target
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/31#post-5046699

Load cannon door doesn't fully open or close.
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/31#post-5046754

-----------------------------
Tortuga/Mystery saucer:
-----------------------------
Eject sending the ball SDTM
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934930

Saucer rejects/bounces out balls
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/15#post-4981904

-----------------------------
MISC PROBLEMS / MAINTENANCE
-----------------------------
Coils don't work on the coil test menu
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/2#post-4940537

Chapter Select or Left Orbit posts won't rise up
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934088

Spotlights flickering and/or going out
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934956

During multidrain in a multiball, a ball gets lost in the subway and eventually pops out of the The Depths during ball search
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941279

Ball sticking under chest
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4942244

Balls getting stuck in wiring hole under the Black Pearl
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4942267

Both barrels spinning the same direction bugs you. Make them spin opposite directions
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/6#post-4954781

What size is the rubber ring at [location]
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/8#post-4958386

Rubber in the star map / chapter select area at top of playfield is worn through
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4985183

#2 8 months ago

PROBLEM:Where the heck does the Map2 piece that comes with the jjPotC Cliffies go?

SOLUTION:When installing the cliffies, the MAP protector is a two-piece set. One protects most of the surface area around the hole and targets, and the other protects the back of the hole.

The map2 piece goes on the backside of the map hole to protect the back of the hole from ball hits. The goal is to try to keep the map 1 piece as flat as possible and then not torque too much pressure on it, so I put down map 1 (after wiping the area with the activator so the 3M adhesive for the front edge would stick well):

map1 (resized).jpg

...then put the map2 piece on top of that at the backside of the hole:

map2 (resized).jpg

...then put the ball guide on the right on top of that stack. Then I put in the post and screw to hold the deflector, paying attention not to tighten overly tight and also to orient the deflector to similar orientation to when I took it off.

map3 (resized).jpg

#4 8 months ago

PROBLEM:You're having problems putting your playfield back down that last 3/4"

SOLUTION:You may have forgotten to remove the last piece of shipping foam that's screwed to the back of the cabinet. From the manual:
potc-shipping-blocks (resized).jpg

#5 8 months ago

PROBLEM: The shooter plunge is inconsistent. Sometimes it can barely get the ball onto the playfield.

SOLUTION: Likely your playfield is hanging too low and the auto launch bracket has dropped very slightly into the path of the shooter rod, robbing it of energy, causing weak plunges. You can test for this by watching the window that lets you see the shooter tip and spring on the shooter rod.

The auto launch bracket is visible through this window on the top, running over the shooter rod. Do a full plunge and see if the auto launch bracket moves - it should not move at all. If it moves, even every few plunges but not all of them, then this is your problem and there are two ways to address it.

auto-launch bracket (resized).jpg

METHOD ONE: Shim the hooks where they connect to the playfield with a thin piece (1-2mm is plenty) of metal, plastic, or dense foam so it raises the playfield very slightly and in turn clears the path of the shooter rod again.

The yellow area is where you want to put the shim - it goes UNDER the hook ON EACH SIDE (to keep the playfield level), then the hook is put in place on top of it.

hook-shim-zone (resized).jpg

METHOD TWO: Bend the hooks slightly down where the connect to the playfield using a robo-grip pliers or something like that. Don't go crazy, a small bend is all you need.

If you do the bend method instead of shimming, bend the top part of the hook down A LITTLE (1-2 mm):
hook1 (resized).jpg

Then bend the end of the hook very slightly outward so it will go into the slot in the receiver easily
hook2 (resized).jpg

#6 8 months ago

PROBLEM: You see an error message when you go into the system menu like this:
error message (resized).png
(or your ship isn't registering "miss" hits or bullseye hits, or both)

SOLUTION: The EASY solution is to manually move the ship and hit the target using your hand. The software will report a problem if a switch is not activated within a certain number of balls, so it may just be that you haven't had a ball in the cannon in a while. Moving it manually will clear the error as long as the switches work.

If that's not it, one or both switches need to be adjusted. The switch for error 48 is BEHIND the backboard at the bottom, and activated with a lever attached to the ship. The bullseye (destroy) switch is inside the ship, but the wires run out through the back.
dauntless-switch (resized).jpg

Switch 48 is always ON and "activates" when the bar attached to the ship moves away allowing the switch to be released and in the "OFF" position (the reverse of what you would expect. First, examine the switch and tug carefully on the wires to make sure you don't have a broken wire.

If the wires are okay, go into switch test mode and make sure the ship moves freely, and that the switch activates when you move the ship by hand. If it doesn't watch the switch carefully to see if it opens enough to register, if not, loosen the switch and adjust the position or bend the leaf.

Dauntless Switch.gif

(Note the switch opening and closing with the movement of the arm attached to the ship out front)

#7 8 months ago

PROBLEM: Chest seems to reject shots that it should have captured.
SOLUTION: There are two possibilities. The forks may be loose, or the forks may be bent, directing the ball into the sides of the chest entrance and bouncing back.

FIX A
Check the forks first - remove the fork mech (the one that raises and lowers the forks) from under the playfield (5 screws.). Tighten the two screws for the fork which are likely loose. This is a common problem. Recommend loctite (blue) for a more permanent fix.

FIX B
If tightening the forks doesn't work, if you have a phone that will do slow-mo, record in that mode and have someone take the shots to the chest. Watch what the ball is doing. If it's not coming toward the chest opening in the center, take the fork mechanism off the bottom again and bend the fork tines (one or both, depending on what's needed) the direction that will guide the ball to the center of the opening in back. ADJUST A LITTLE AT A TIME AND ADJUST THE WHOLE FORK TINE, NOT JUST THE TIPS.

Note in this gif that the fork tines you can see through the opening are pointed to the left, and the ball is being thrown to the left side of the opening, then bouncing to the right and dropping back out. The fix here was to straighten the tines so it threw the ball towards the center of the opening.
chest_reject.gif

#9 8 months ago

PROBLEM: Balls getting stuck at the top of the Black Pearl ramp.
SOLUTION: Ensure the game is horizontally (left to right) level, measured at the playfield. Next, locate the screw to the right of the ramp which compresses a rubber crush washer. Tighten this screw clockwise until setting balls on the top of the ramp always makes them roll away right. Do not over-tighten or the screw can break in the post! If this fails to resolve the problem, remove the rubber entirely. If this still fails to resolve the problem, put a clear cabinet bumper under the Pearl ramp to lift the left side a bit. You want the ball to roll off to the right easily no matter how gently it is placed on top of the ramp. This is a very common issue and easily fixed.

#10 8 months ago

PROBLEM: The Black Pearl rocking motion sometimes halts (especially during the cannon shot) or otherwise seems to struggle in the calibration test.

SOLUTION: Put the playfield in the first service position, such that you can observe the motion of the arm. Run the ship calibration test. If the pin that controls the rocking of the Pearl contacts the top or bottom of the slot, loosen the two screws on the control arm and correct the height travel is unimpeded in both directions. This took a bit for me to find, but after correcting it the calibration was able to run all the way down to 4, and the ship rocking was much more playable.

#11 8 months ago

PROBLEM: The metal rails in the shooter lane are malformed, causing bad plunges

SOLUTION: Take pictures of the shooter lane before removal, noting the angle of attack into the right orbit. Remove the shooter lane. It has 3 connection points, one hex screw near the top, the “stack” which holds the right strobe, and a small black screw near the bottom. With the wireform removed, gently bend the bottom two forks such that they are slightly down and slightly apart. The goal here is to make them hug the shooter lane when reinserted. When reassembling, take care not to strip the black screw. I was advised to put the screw in and gently turn counterclockwise until it rises up, to ensure it hit the threads correctly on reinsertion. This fixed the problems with the shooter completely.

#12 8 months ago

PROBLEM: Switch (any switch) isn't registering.

SOLUTION: Activate/deactivate the switch while in switch test mode on the system menu and see if the switch works at all. If not, remove the switch and carefully examine the small plastic trigger at the end of the switch arm to see if it's stuck in the down (or up) position. If it's stuck, try to work it free. If you can get it moving, likely it will stay functional. Sometimes they come with a little extra plastic from the factory that prevents proper operation.

#13 8 months ago

PROBLEM: Game reports stuck MAP targets

SOLUTION: There are two possibilities.

FIX A
Targets under the ship may be mounted too close together, causing them to hang up on each other. Each has two screws holding it to the playfield. Loosening the screws (don't remove) under the playfield for the targets and re-set them slightly further apart.

FIX B
If the targets don't look too close together, the leaves for the switch may be too close together making the machine think the target is continuously being hit. Put the game in switch test mode and press each the M, then the A, then the P targets to see if any don't register. If you find one not registering, slightly PULL that target toward you and see if that causes the switch to register. If it DOES, power off and remove that switch from under the playfield and adjust the two leaves of the switch further apart so they're close but not touching. Re-assemble and test the switch by pressing it in switch mode.

#14 8 months ago

PROBLEM: Game reports stuck GOLD targets

SOLUTION: The L target may be getting caught under the wiring harness on the Pearl ramp. Loosen the target and press the harness up and out of the way, then reinstall. The Pearl ramp adjustment to stop the ball from sticking on the ramp also may help.

#15 8 months ago

PROBLEM: Chapter Select or Left Orbit posts fail to raise up

SOLUTION: Locate the post mechanism(s) under the playfield. Adjust the position with the screw and lock into place with the hex nut. Consider blue loctite to prevent recurrence.

#23 8 months ago

Yes. A lot of them are from the list he compiled. I invited him to post the info he had compiled and I'd link it, but he's burned out on PotC tech, so he said I could do it for him, which is fine. I just want to get all the info in one place and add pictures and video where possible.

#25 8 months ago
Quoted from MiamiRedSkin:

Curious - are there known build date ranges that are prone to more issues, or newer build dates that point to factory fixes for things. I am looking at a POTC new in box that was built 2/13/19 - is that any indication of QC?

It feels like they're rushing these out the door to get to Wonka with minimal QA (at least not the usual level of JJP QA I've known in the past), so I don't think the date helps much. The one we got was 2/11/19 and it had a bunch of issues to correct out of the box. Nothing hard, just a bunch of niggly things that would have been obvious if it had been played.

#26 8 months ago
Quoted from joseph5185:

Let's add the loose flippers for the Black Pearl as well.

I'll get there. It may take a week or so to get everything in, and maybe even longer if I take some illustrative pics or video to add to specific ones.

#32 8 months ago
Quoted from KevInBuffalo:

First off, kudos to vireland for the great thread, this is sure to be a great resource for all JJPOTC owners.
I noticed panzerfreak linked to Tuna's stream of taking the ship off, which is great (thank you!). Since VODs on Twitch disappear after a few weeks, I trimmed it up and posted it to YouTube to archive it and make it easier to get right into the good stuff. Here's the link:

Adjusted the ship removal link to this direct-link post instead. Thanks.

#34 8 months ago

PROBLEM: Black Pearl reporting stuck open switches

SOLUTION: Remove the Black Pearl and look for broken wires underneath. In one case, the green/brown wire at the Bonus target was broken off resulting in switches 9, 10 and 12 failing (because the switch wires are daisy-chained, one wire broken upstream can break everything after it on the chain). Resoldering broken wires corrects the problem.

#35 8 months ago

PROBLEM: Tortuga saucer sending the ball SDTM

SOLUTION: Most likely the ball deflector/guide at the back of the Tortuga saucer is loose or mis-aligned. Remove Tortuga Tom and loosen the pop bumper to gain access to the two phillips screws for the deflector that's slightly under the pop bumper skirt. Aim the guard a bit to the left. Test and ensure the scoop fires into the middle of the left flipper. Consider blue loctite to make the fix permanent.
Here's how you get the pop bumper apart to gain access to the two screws:

This is the deflector that you may need to tighten and/or adjust the direction it's pointing:
01- deflector location (resized).jpg
These are the screws you need to tighten once the deflector is where you want it:
02 - Tortuga Screw locations (resized).jpg

There's a single #1 phillips screw each at the front and back of the barrel you need to remove:
03-rear screw (resized).jpg
04 - front screw (resized).jpg

Once the barrel is off, you see a mounting plate, but the hex set screw that holds it on is hidden underneath it. Feel for it and use a hex wrench to loosen it, then slide the mounting plate up and off:
05 - plate removal (resized).jpg

This is a better look at the set screw once the plate is off:
06 - under plate (resized).jpg

There are now two motor screws to remove. READ THE NEXT STEP BEFORE DOING THIS ONE:
07 - motor screws (resized).jpg

Under each screw holding the motor on, there's a nylon spacer. Be careful to hold the spacer as you lift the screw out so you don't lose the spacer in the machine:
08 - spacers (resized).jpg

Lift the motor up a bit and set it to the side, which will expose the screws for the pop bumper. LOOSEN, DO NOT REMOVE THEM. Once loose, you can raise the skirt in the front where the two screws are for the deflector and tighten/adjust as-needed:
09 - bumper screws (resized).jpg

Reverse the process to put it all back together.

#36 8 months ago

PROBLEM: Spotlights flickering and/or going out.
SOLUTION: You may find that twisting or manipulating the spot brings it back. Avoid twisting it, as this will make the situation worse. Instead pull the bulb directly out. The diffuser cap may separate from the bulb housing, which is easily fixed with super glue.

Once the bulb housing is out, note the two wires folded up onto the base of the bulb. Smooth these out and make sure they are mostly straight and covering both sides of the edge. Reinstall, gluing the diffuser on if it separated.

Pinsider yelobird suggests this drop-in replacement bulb upgrade: https://www.cometpinball.com/product-p/opmax12v.htm

You can also avoid having to glue the spotlight bulbs in place to make sure they never fall out by doing this:
https://pinside.com/pinball/forum/topic/fixing-led-bulbs-flashers-that-fall-out-of-spotlights#post-4402506

#40 8 months ago
Quoted from zaphX:

Yeah, I'm struggling with this too. Things I have tried:
- Checking the alignment of the whole mech (seems fine)
- Checking the tightness of the coil in the mech
- Adding a washer so the autoplunger "forks" are consistent and toeing up the ball solidly
It still ends up failing fairly frequently.

When you say "failing" does that mean can't get it around the top of the playfield or can't get over the hump onto the playfield?

Have you slo-mo recorded the auto-launches to see if it reveals something robbing the energy from the launch?

#42 8 months ago
Quoted from joseph5185:

I don't suspect a Titan plunger could help in any way other than durability. Maybe it actually "feels" better?
lol

The auto-launch doesn't use a plunger, it's the two forks that are activated by the coil.

#47 8 months ago

PROBLEM: Screw on top of the post from the sling under the Black Pearl ramp is pushing into the ramp, deforming it with a dent. You can see it in this picture, just below the "P" in "Pearl," tearing the ramp sticker a little and pushing up deforming the ramp with a bump.

ramp-screw (resized).jpg

SOLUTION: The post in question really should have been a metal mini-post from the factory to allow proper clearance for the ramp above and still allow tension for the slingshot below. As it is now, you can back off the two #1 philips screws at the entrance to the ramp to release some of the tension on this screw, but not too much because you want the ramp to still be solidly connected to the playfield.

If you're feeling ambitious, you can try swapping in a mini-post instead.

Added 7 months ago:

EDIT: Messing with the bottom screw that is denting the ramp causes other problems because that is literally the only thing giving support to that side of the ramp. It's basically a terrible design with no left-side support. I'd leave it alone and deal with the sticker tearing and bump where the screw is pressing in.

#49 8 months ago
Quoted from BC_Gambit:

Has anybody done the mini post fix? I am not sure how well the metal bit that the screw goes through would then be connected to the playfield? Maybe I am picturing the wrong replacement part.
Does anybody have a link to the mini post they used? Is it a wood screw or a threaded base?
This was a great heads up, I was not aware of this screw being an issue.

I will probably try it, but I haven't removed that post yet to know if the existing plastic post/screw combo is going into a t-nut (machine threaded) or right into the wood (wood screw). The only thing that's dicey is that will make that small metal cover only connected on one end, so it will have to be very tight so it doesn't move. It's a bonus that it's not plastic, but even with it being metal, it can still swing around from hits and vibration. So that's a problem to solve. But I think a mini-post is the answer, I just have to figure out the details.

#51 8 months ago
Quoted from BC_Gambit:

Hmm... looking at the pick again I am thinking grinding the screw (or using a lower profile or smaller diameter head screw) would the way to go. If there is only the one post supporting that bracket, you may be trading a possible ramp dimple with a ramp hammer from the metal hammering the ramp from ball hits...

Actually a flat head machine screw instead of a pan head may do the trick. The top of the plastic post would have to be drilled out to handle the taper of the flat head screw, but this may be the best solution.

#54 8 months ago

Yeah, basically get an 8-32 flat head machine screw 1-1/2 or 1-3/4 and drill out the plastic post to allow for the tapered head to rest down in it and I think it'll be there. I'll try this tomorrow.

machine-screw-phillips-flat-dimensions (resized).png
#56 8 months ago
Quoted from joseph5185:

Hey guys,
Remember the whole “lose” flippers topic on the BP?
“Simply” loosen nut, let flipper rest against metal rail (right?) and tighten. Viola!
Nope.
I did this exactly and the pitch of the flipper is exactly the same.
Do I adjust the flipper pitch as I’m tightening? I almost think I have to.
I watched JJP’s videos on both flipper and pop bumper assembly. Fascinating and was an eye opener as far as learning things will break.
I can’t seem to locate a good enough response/video, etc to learn how to adjust this pitch and hopefully solve my issue.
Still not sure why my BP flipper (left) is dead/unresponsive, but I did watch the BP removal video and it was very informative. Probably a broke wire. Maybe I get lucky and it’s a lose wire. There’s a switch test for this left BP flipper specifically, right?
I’m kinda torn on removing the BP right now as I have the Cliffy’s on order and I know that I’ll have to remove to install.
But that could take months and in the meantime I pretty much have an unplayable CE (as sad as that sounds). I may really have no choice but to remove the BP multiple times.

If you don't take it out completely, but just lift it up and to the side, it's really not that hard at all. One screw, one cotter pin, and slide out a pin and you have enough to work with for most issues.

#57 8 months ago
Quoted from vireland:

Yeah, basically get an 8-32 flat head machine screw 1-1/2 or 1-3/4 and drill out the plastic post to allow for the tapered head to rest down in it and I think it'll be there. I'll try this tomorrow.[quoted image]

Okay, replying to myself on this one. I did this, and I would say the improvement is definite, but it's not really as much as it needs to be so I can't really recommend doing it. You don't have to drill out the plastic post because the piece on top is metal (forgot about that), so you end up having to bevel the hole so the flat screw rests lower, and even though you gain about 2mm and it's not pressing into the ramp as much, the edge of the metal top is still pressing on the back of the black pearl ramp. The ramp should have been further away from the metal top on that sling or the metal top should have been about 4mm further in.

So, I'm glad I did it, but I don't really recommend doing it, especially because you have to physically change the metal cover with the bevel to do it.

#59 8 months ago

Here's the height of the Black Pearl flippers at max extension on the one here. Measuring from the middle of the flipper bat tip to the edge of the plastic ramp.

bp_left_flipper_height (resized).jpgbp_right_flipper_height (resized).jpg

#60 8 months ago

PROBLEM: Coils don't work on the coil test menu

SOLUTION: You need to override the coil power safety cutoff while the coin door is open to be able to test coils with the coin door open. Here's where the service switch is that you can pull while the coin door is open to allow the coil safety power cut to be over-ridden and test coils while the coin door is open. Pull the post the green arrow is pointing to to bypass the safety and allow power to the coils for testing.
power-cutoff-switch (resized).jpg

#63 8 months ago
Quoted from joseph5185:

Okay... I can lean it pretty good when that rod is through the playfield. Just going to grab some painters tape or something so it doesn't accidentally slide back in.
I am NOT to take out the pivoting screw in the center right? .. Wouldn't think so..
Alright .. here's a screenshot from the left ... [quoted image]

Oh, your flipper linkage is apart - that's problem 1. The grey plastic with the hole should be connected to the metal shaft peeking out of the yellow coil. There's a pin that runs through it that holds it in place.
linkage (resized).jpg

Here's what the linkage you have in two pieces SHOULD look like when it's together:
flipper linkage (resized).jpg

And here's what the linkage should look like when it's on the flipper shaft ready to tighten down:
flipper assembly (resized).jpg

#65 8 months ago
Quoted from joseph5185:

Yea... I was just going to say that.
I don't know where that pin is...
I guess that's the first problem... =/

Can you post a higher-res picture of that coil area you just posted? Just select "original size" from the dropdown and it won't resize it if you have it larger...

That pin may have been your original problem. The pin that held that in was loose and eventually fell out. It should just be a small round springloaded cylinder, but it's pretty small, so get a bright flashlight and look in the cabinet bottom. It's what, 5am there? Maybe a project for tomorrow after some sleep...

#68 8 months ago
Quoted from joseph5185:

Oh thank God ...
It's actually hiding at the the top of where I need to connect the plastic.
Maybe it doesn't come out?
Working on it...

You'll need pliers to press it through once you get the plastic in place. Make sure you have it in the right orientation for the flipper direction (which way it's flipped makes it a right or left assembly, so you don't want another right orientation) before you press it through.

#70 8 months ago
Quoted from joseph5185:

Yea no doubt ... Easy enough to do that because you can see where the metal piece is swinging to make contact with the switch.
This is a bit uh precise stuff here...

I'd put the linkage on the flipper shaft first to make sure you have the orientation right before you lock down the plastic part with the press-in pin.

#72 8 months ago
Quoted from joseph5185:

Okay so this is kinda crazy...
It LEGIT looks like the pin was put in upside down?
Cause if you think about it ... if you were to rotate that .. the head of the pin would be at the bottom..
WOW!
My right flipper pin is orientated the correct way...
[quoted image]

Once it's pushed in, it doesn't matter. The only thing that matters is if you get the linkage that connects to that right so the EOS arm will activate the EOS switch properly.

#75 8 months ago
Quoted from joseph5185:

So this was likely an issue from the start?
Yea?
Can I pull that metal road out that the pin is attached to from the coil safely?
That pin doesn't want to budge a mm...

You can pull it out and assemble the linkage outside the machine, but you need to make sure that you have the orientation right when you put it together for a left assembly AND you may have to loosen the coil mounts to get the shaft back in the coil if it's attached to the rest of the linkage (you may not have room to fit the shaft in straight because of the extra stuff attached).

#76 8 months ago
Quoted from joseph5185:

Because now that I know how this works ... I could of taken off the nut entirely ... wouldn't have affected that pin. At least, you wouldn't think so...

Yes, it seems like that pin being loose and letting the linkage fall off may have been the problem from the beginning.

#79 8 months ago
Quoted from joseph5185:

I'm happy assembling under the BP. I just have to get the stupid pin out and I would prefer the pin fall to floor vs SOMEWHERE in the pinball machine because that could be a problem pretty fast if it fell into the MAP hole or something similar.

Assembling outside the machine will be easier, and probably faster.

#81 8 months ago
Quoted from joseph5185:

I can't get the rod out... It seems too long.

If you unscrew the two philips screws at the front of the coil you can raise the front of the coil, which will allow you to slide the shaft out.

#84 8 months ago
Quoted from joseph5185:

I'm going to have to... it's the only way I'm getting that pin out!

You don't need to remove that pin in the shaft, you need to line up the plastic part of the linkage with the pin and press it through to the other hole on the top of the shaft.

#86 8 months ago
Quoted from joseph5185:

Are you referring to the metal L bracket thing in front of the coil where the screws are on top?

Yes. Remove the two philips screws and that bracket can be lifted up with the coil, allowing the shaft to be pulled out of the coil at an angle.

#91 8 months ago
Quoted from joseph5185:

Actually, I just must be tired.
There's no "head" on the pin. It's just a circle on both sides.
Shouldn't I be concerned that this could happen again?
EDIT: I guess not. We don't know how it looked before...

Pressure holds the pin in. It doesn't have a head and neither end should be sticking out once it's pressed through.

#100 8 months ago

PROBLEM: Tilt warnings double/triple fire, or phantom tilt for the next player following a tilt.

SOLUTION: Stuff an earplug in the top of the tilt bob bracket. I used a tapered earplug that worked perfectly as-is. A non-tapered earplug may need to be cut in half or quarters to work as you want. This causes the tilt bobber to settle rapidly. You can still tilt, but the game won’t screw you over.

Tilt-Bob (resized).jpg
#101 8 months ago

PROBLEM: Black Pearl cannon access gate unexpectedly closes when hitting a flipper.

SOLUTION: The Pearl gate is designed to close when it senses a switch hit on the lower playfield outside of multiball. Somewhere a switch is likely gapped incorrectly causing a switch to activate when it should not. Go into switch test and create vibration on the playfield to see which one is misbehaving, and adjust the gap on the corresponding leaf. It is highly recommended to use a leaf switch adjustment tool for this and perform the adjustments as close to the switch base as possible. Using other tools may bend or twist the switch.

#102 8 months ago

PROBLEM: Autoplunger is inconsistent and frequently fails to launch past the “hill.”

SOLUTION: This may be one of a couple things.

First, observe how the ball is resting on the autoplunger. If it’s not resting centered or almost centered between the two uprights of the auto launch mechanism, there may be too much side-side play in the autoplunger. You can tweak this by adding a washer.

Second, check the vertical alignment of the rod going into the autoplunger coil. This should be entering the coil without an angle; if it’s slanted try slightly bending the metal bracket to bring it in line so it can move freely without friction.

Third, see if the ball moves freely through the metal ball guide that goes up and over onto the playfield. It may be making contact with a weld instead of riding only on the rail guides, robbing the ball of power.

Finally check the shooter lane rails, I found my right rail is ever so slightly lifted at the back of the lane, causing balls to contact the locker post and bounce back. Backing the autolaunch power down 2-3 points from default may make your auto-plunges consistent.

#103 8 months ago

PROBLEM: During multidrain in a multiball, a ball gets lost in the subway. Ball search happens and eventually the missing ball is released from The Depths.

SOLUTION: The plastic edge of the subway is a bit too wide. This is easily corrected by replacing a screw with a post to hold the edge in. Parts to fashion this post are easily found at hardware stores. Use a #8 2 inch screw, a 1 inch spacer and a 2 inch spacer. This has been fixed with a running change at the factory and is done on all machines assembled since approx mid-January 2019 already.

Post with detailed picture of the mod here: https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/50#post-4758736
subway-post (resized).jpg

subway-post2 (resized).jpg
#104 8 months ago

PROBLEM: Screen appears washed out and colors fail to pop.

SOLUTION: Remove the backbox glass. There are two wooden latches that hold the monitor in place; loosen and twist them out of the way. Then lift the metal latches to the left and right of the monitor to pull it out. It’s on a reticulating arm so this is simple. Monitor adjustment controls are on the back. On the brightness and contrast page set DCR to ON, and set the color page to sRGB.

This setting is not infallible, however. To get a good picture on another machine DCR had to be set to OFF, brightness to 50% and contrast to 100%. Color sRGB.

Pinsider ronaldvg found good manual settings:

"I tweaked the settings of the monitors (DCR Off, Brightness 41, Contrast 50, Color setting on USER R50, G50, B50) and they now look exactly the same, much less washed out. If you look in the attract mode of POTC there is a screen with just the number of the LE, rest is black. Make sure that screen looks as black and the lettering as white as possible."

#107 8 months ago
Quoted from BC_Gambit:

Bummer; I will keep my eye out for super low profile machine screws when I am out today, or early this week.

I got the one I used at Ace Hardware. It's hillman brand. Had to go 8-32 2" since they only had 1 1/2" and 2", no 1 3/4".

#109 8 months ago
Quoted from zaphX:

Just to update this, I just removed my shooter lane and gently bent the rails until they were true with each other. This appears to have resolved the issue at last!

When you say "bent the rails" are you talking about the auto launch forks or the guides on the habitrail?

#116 8 months ago
Quoted from zaphX:

Guides on the habitrail.

Can you take a picture and point out what area you adjusted?

#120 8 months ago

PROBLEM: Machine is DOA or loses power during gameplay
SOLUTION: Check the computer plug on the back of the machine (behind the safety plate if it's installed) and make sure it's firmly plugged in. If it's loose it can cut power to the machine.

#121 8 months ago

PROBLEM: Ball sticking under the chest
SOLUTION: Feel under the chest and see if the tips of the chest forks are above the playfield when retracted. Either adjust the screw on the bottom of the mechanism under the playfield so the forks sit lower, or add a washer below the chest mech at the lower left screw to adjust the angle just enough to correct the issue.

#122 8 months ago

PROBLEM: Plunges or shots into the right orbit go SDTM

SOLUTION: What you want here is that orbit to feed the right flipper. Adjust the upper flipper so when it's at rest it's out a few millimeters more than currently. Loosen the pawl nut, move it outward a few millimeters and tighten it back. Do not tighten so much that the two metal sides of the flipper bracket touch.

#123 8 months ago

PROBLEM: Left Black Pearl flipper spring is breaking or stretching frequently

SOLUTION: Check the wiring going up to the Pearl. In one case, wires were found to have rubbed off the insulation and grounded against metal which energized and destroyed the spring. Recommend plastic wire loom around this wiring to protect it.

#124 8 months ago

PROBLEM: Balls getting stuck in the round hole under the Pearl by the wiring harness

SOLUTION: Two possibilities for this.

Tip 1
Buy a plastic shield for the underside of the black pearl that prevents the ball from bouncing back and getting under the Black Pearl.

Tip 2
Bundling this wire loom plastic to gather the wires together will protect the wires from wear and possibly stop balls from getting stuck there.

This loom product on Amazon may help you achieve this:
amazon.com link »
Or this kind:
amazon.com link »

#136 8 months ago
Quoted from GnarLee:

Ok so I worked at addressing my inconsistent ball plunge issues, Dauntless all of a sudden getting stuck and ball getting stuck on devils triangle rollover. Rollover was bent down a bit so ball could not catch easy fix. Dauntless I found it was catching on the top deck. Removed deck added 4 #6 nylon washers between bracket and decking to raise it ~1mm problem solved. Ball plunge issue I found a different fix that didnt require me to raise playfield. So when I was looking at the whole mech I noticed quite a bit of play in the auto plunge left and right. Maybe 4-5 times out of 10 my plunge would be off. I saw that when the auto plunge was in the rightmost position it would hit somewhere. If I moved it to the left it did not hit plunger. Also the ball sat 2-3mm farther back in shooter lane with it to the left. So to fix I put 2 1/4" nylon washers on the pin on the right hand side to get rid of the play in the auto plunge. Have plunged maybe 50 balls since and had 1 bad plunge. will get a pic or 2 up shortly

That'd be great. I'll add it to the potential inconsistent auto plunge being inconsistent solutions.

#139 8 months ago
Quoted from Hogey:

Haven't seen this issue mentioned. Received my Pirates a week ago. Great game. Had a couple small issues that my distributor was all over and took care of. One issue I still have is the monitor not being level. After I "lock" the monitor in place (meaning the brackets on the left and right side are pushed down and engage the "posts" on the monitor), the monitor is not level (lower on the right side). There is "slop" or "play" if you will (meaning that the monitor can still move up and down and back and forth even though it is supposedly locked. I've tried to wedge some foam under the right side of the monitor to jack it up and that has helped some, but it's not right. Anyone else have this problem? A friend has a DI and advised that that monitor has 2 posts on each side that are engaged by the brackets, which alleviates the problem. Not sure what to do about it.
One other small issue, is that when my machine arrived, one of the lanterns on the mini ship deck was broken off and loose on the playfield. JJP sent me a new lantern, but the problem is that it broke off at the base (leaving the "peg" in the hole with no way to get it out). See pics. I removed the two screws on the plastic above it thinking this would remove it so I could get at it from below, but no such luck.
Thank you.
Hogey
[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

I'd carefully drill into the peg with a small bit, screw in a screw and use that to pull it out (assuming it's not glued in).

#142 8 months ago
Quoted from Clint12:

Man these machines are junk with a huge price tag

It could be worse. The cabinets could be splitting, the boards blowing up, and the playfield cratering all over the place. Those are MUCH worse issues, IMO, but the fact is, EVERY manufacturer, every pin, has its specific issues. ALL of them.

But, no other pin has the level of specific fix-it tips that jjPotC has in this thread to help owners navigate new ownership.

#143 8 months ago
Quoted from joseph5185:

Building the arsenal guys..
Picked up a Z-driver because that’s a thing?
A pick set.
A telescopic magnetic pick-up tool.
New hex set.
And some other goodies.
LET’S DO THIS!!!

Is your flipper working again yet?

#146 8 months ago
Quoted from zaphX:

And yet, the people who own them have them bolted to the floor and love them.

Still in the honeymoon period, but it impresses in some way every time so far, and that's a good sign. Unbelievably good machine with incredible production values. The video production and musical themes are much better than what I've seen of Wonka so far, and there's a great game under the glass to match.

#148 8 months ago
Quoted from zaphX:

I still love playing it every single day. I’m 4 months into ownership. The honeymoon on my first pin (Star Wars) sure wasn’t this long.

Heh, Munsters was 2 days. Dialed In was about a month before I knew it was too flawed to be long-term. Hobbit was about the same. Usually if you're still digging a pin after 2 months, you're safely out of the honeymoon period.

#170 8 months ago
Quoted from joseph5185:

What’s a habitrail?

In this case the shiny chrome guide rails that take the ball onto the playfield.

#199 7 months ago
Quoted from f3honda4me:

For dollar bill payment or ticket dispenser, etc.

And for the record, unlike Sterns, which are still 115v systems, the bill acceptor plug on JJP machines is 12v. Uses a totally different model bill acceptor.

#202 7 months ago
Quoted from Hogey:

I talked to Butch at JJP. My monitor sits a little low and the upper frame of the monitor shows through the glass. I was finally able to get it level after adjusting the screws on the back of the monitor, but the arm is the issue. He was very helpful and is sending out a new arm (four bolts to the backbox and four bolts to the back of the monitor.

I don't know why they don't stop messing with the clunky side mounts and just do a top mount instead that flips up to give access. They'd have to make a lower bracket to lock it in to when it's down, but it would eliminate sag since the weight bearing part would be centered over the monitor from the top. They'd have to modify it so it flips up instead of back, but this is not an engineering impossibility. 90% of the work is already done. Something like this:

amazon.com link »

#214 7 months ago
Quoted from joseph5185:

vireland
So I'm a little torn...but maybe not really.
The consensus seems to be in the "main" fan POTC thread to reach out to JJP and get a replacement flipper assembly and keep the other as a spare once I get it fixed.
Two issues:
1) I still have to remove the part where the spring is still under the BP.
2) More importantly, how LONG is that going to take to get a replacement?
Sure.. I can definitely let JJP Support know or w/e, but I think I just want to fix what I have anyways because I really don't want to wait.
I know... less typing and more fixing, but i just haven't had a lot of time lately and this isn't the "easiest" stuff to just do whenever.

Get a replacement. You have 90% of the work done to swap it. It will take maybe 10 minutes to put the new assembly in. I assume JJP will ship it out right away, but if they can't ask if they'll reimburse you if you just buy one from Marco (it's less than $10). Marco is literally only 3 hours from you so you should have it next day if you get it from them.

#216 7 months ago
Quoted from joseph5185:

Side note: I had no clue Marco was so close...

Yeah, I'm super-jealous of you living near Marco, and even closer to Kinston/Chef & the Farmer, which is on my bucket list of restaurants to try.

#229 7 months ago
Quoted from rj_tenn:

Installing the Cliffy kit. Can someone shed some light on where this protector goes? Thanks[quoted image]

It clips on to the hole on the far left at The Depths. You install it from the top side, no disassembly required.

#240 7 months ago

Okay, so following up on the screw making a bulge in the bottom of the Black Pearl and tearing the sticker.

DO NOT do the fix I did with the flatter screw top to stop the pressure on the underside of the BP ramp that's tearing the sticker!

It's become clear the BP ramp is a terrible design. There is no support on the left side of the ramp to hold it up. The screw bump and edge of the partial sling cover IS the support. Nevermind that it's tearing the ramp sticker underneath. The upshot of the change I made is the ramp now sags about 3mm to the left, which has the effect of dragging on the ship and causing slow balls to get stuck on the gate (because there's not enough of an angle to direct it to the right and down).

So I guess tomorrow I will work on designing a 3D printed support for the left side of the ramp that screws onto the back of the sling cover to gently support the ramp in a much better way.

#249 7 months ago
Quoted from zaphX:

Just stick a clear plastic cabinet bumper on top of the screw. Solves the sticker tearing -and- ensures the ramp has the right lean.

Probably okay in a pinch, but not a good long-term solution. I'm going to make a support in that fastens to the top screw and supports the width of the ramp bottom instead of concentrating all the force into one small contact point.

#257 7 months ago
Quoted from zaphX:

My wife just lost a ball. I checked the subway, Dauntless, under the Pearl...nowhere to be found. Then I finally found it -inside- the right sling.
That was the last straw for me, coupled with two “escaped kickers” on that sling. I replaced the rubbers with fresh ones and will report back how it behaves.

A slightly smaller ring might help with that by way of more tension. There might just be too much play in that ring.

#258 7 months ago

Okay, so I made a support for the left side of the ramp. Problem solved. Ball doesn't get stuck on the top gate anymore, and the flatter lower screw isn't pushing into the sticker under the ramp. So I don't recommend replacing that screw on the bottom that's pushing into the BP ramp unless you're prepared to make a support to replace the tension removing the screw took away on the left side of the ramp.

HOWEVER, if Jack ever re-runs this, that area ABSOLUTELY needs some attention. The ramp support design is ridiculously bad.

#262 7 months ago
Quoted from dgposter:

Are you going to be selling this part, Vic?

I wasn't planning on it. Just made a quick and dirty part to fix the problem I created by fixing JJP's mistake with the bracket and screw under the ramp. As long as you don't replace that screw, the ramp should be fine.

#263 7 months ago
Quoted from GnarLee:

Ok just ran in to a doosey. Mid game I seemed to be getting gold out of nowhere. Everytime I hit a flipper button gold would spawn. Drained ball started a new ball and problem was not there but noticed the spinning pop bumpers were spinning like crazy and not stopping. Only thing that was changed was I tried to install 5 ball for mom and sister to help them get higher scores. Going to go digging for a broken shorted wire. Nothing looked off when I went into switch tests.

Check the sling under the ramp. Go into switch test mode and press the rubber, then pause and lift the rubber off the sling.

Then stay in switch test mode and smack your palm on the playfield firmly different places and see if switches trigger. None should.

#265 7 months ago
Quoted from harryhoudini:

I noticed something yesterday. Ball was sitting in the launcher and everytime I flipped a flipper I got like 30 points or something. I have to assume this is a switch that is not adjusted correctly, so I'll look at that first. Not sure if this is anything known.

You just have a switch that's gapped too close. Go into switch test mode and smack your open palm on the playfield to see what switches trigger, then adjust that switch.

#267 7 months ago

PROBLEM: Manual shooter plunges lack energy and have a hard time getting around the orbit or even onto the playfield.

SOLUTION: Check your shooter tip alignment. It should be centered between the two chrome guide rods in the ball trough. If it's to the left or right of that, the steel washer behind the rubber tip may be hitting the auto-launcher on the left or right, robbing energy from the plunge.

This picture shows the shooter tip is not centered left to right. It needs to be adjusted so it's right in the middle.
shooter-tip (resized).jpg

Loosen these three screws from the shooter plate bracket, then slide shooter housing left or right as much as you think you need. Tighten the bottom screw so it stays put. Drop the playfield and check your work. If it's not right, loosen the bottom screw again and adjust again. Once you have it centered when the playfield is dropped, tighten all three screws again, check your work one last time, and enjoy!
shooter-plate (resized).jpg

#271 7 months ago
Quoted from dug:

No special tools... just gently wiggle as you are pulling them apart.

And DON'T PULL BY THE WIRES. Some of the molex connectors have clips you have to press to be able to separate them, others don't. For the ones that don't pliers can help you with your grip on one of them while you pull/wiggle the other side.

#277 7 months ago
Quoted from harryhoudini:

K, thanks.
Oh... anyone:
I just remembered, my rotating pirate on top of the pop bumper doesn't work. Tested it in the test menu and the other rotating pop topper works, just not the pirate one. I hear nothing when I activate it. Is it as simple as a bad motor or are there other things to test? I'll test for voltage at the motor, I suppose. Haven't popped it up to look yet.

What are your coil strength numbers for each flipper?

For the spinner, likely a loose connection or bad motor. I'd check for voltage at the connector first. I actually don't like that both the barrels spin the same way and will probably reverse the upper one this week for a little more visual variety.

On the map hole, a common mistake with the cliffies is torquing the posts or screws that hold it too hard, tweaking the metal so it doesn't lay flat. Does the circle in front of the hole lay flat? Did you use the activator to clean the pf there before you put it down? Did you take off the backing to the 3M adhesive on the underside of the cliffy before you put it on? Of course, none of this would be a problem if JJP would just install these necessary protectors at the factory, at least on the LEs and/or CEs.

If all that checks out, you may have rotated the deflector a little too much when you put it back together, creating ball rejects instead of dropping the balls that hit it into the hole.

#280 7 months ago
Quoted from f3honda4me:

He was asking about the Mystery hole, tortuga. Not the map hole.

Heh, the MAP hole is a mystery, too, until the spin. I was confusified.

On the Tortuga hole, wiggle the deflector and make sure that it's screwed on tight. It was loose out of the box on the one we got here, which made it hard to hit until I tightened it.

#287 7 months ago
Quoted from harryhoudini:

Thanks. I didn't install the cliffy, previous owner did. Another le played without protector didn't seem as hard. I'll investigate if it's laying flat. Maybe flipper is too strong.

What are all your flipper setting numbers on the menu?

#291 7 months ago

PROBLEM: It bugs you that the barrels both turn the same direction.

SOLUTION: Reverse the connectors on the plug under the playfield for the upper barrel so it turns the opposite direction from the lower spinning barrel bumper.

Here's the connector:
barrell1 (resized).jpg

Connector taken out of the female housing:
barrel2 (resized).jpg

Use pin extractor (tool is available on Amazon amazon.com link » and at tool stores) to remove the pins and swap their position:
barrel3 (resized).jpg

Put the connectors back together and enjoy!
spinning-barrels.gif

#310 7 months ago
Quoted from f3honda4me:

Off the top of my head I've used it to cut bolts/nails, cut chain link for lights, cut/sand small areas of wood for some remodeling, sand down metal parts on pinball machine, sand my son's pinewood derby car, fix door jamb areas, and more I'm sure I'm forgetting.

I used it to get a mushroomed shooter rod off a route pin I bought by cutting the mushroomed end off. NEVER imagined it would one day be used for that, but it worked great.

#324 7 months ago
Quoted from harryhoudini:

I really can't see how mylar is going to protect anything. I guess maybe it can prevent a chip from starting but unless you're really easy on how much tension you put on those posts they will dig in to the playfield, probably pop the mylar up and won't really have any protection from the tension from the screws. Clear lexan PETG washers are pretty thick, which seems an issue. Might just have to go solid metal washers that are just a bit larger than the star posts.

Actual mylar (not hobby store cling) will protect the playfield fine and likely do less potential damage than a washer or post because the thickness of the mylar will absorb the torque and pressure of the post. All the washers are doing is spreading the torque over a wider surface area and changing the height of the sling rubber. These fragile playfield finishes are a drag. The better they look, the more fragile they are. Bring back diamondplate and just give everyone a respirator.

#325 7 months ago
Quoted from rj_tenn:

Help - How do you install the Cliffy at the Mystery hole? Do you need to remove the jet bumper wafer that's half blocking screws? If so, how the heck do you remove the jet bumper components?
Thanks

Check the index at post 1. Same process for fixing a loose or mis-aligned deflector:

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934930

#346 7 months ago

PROBLEM: Sling thin posts or even replacement star posts are digging into the clear on the playfield (sometimes chipping it).

SOLUTION: Remove post, install thin washer or 1.125" mylar disc. Reinstall post, gently tighten, do not torque.

Remove sling nuts using 11/32 socket.
remove-sling-nuts (resized).jpg

Remove post with 5/16" deep socket. Breathe deeply and often when you see the deep marks in the clear already where the post was. It will all be okay.
post-marks (resized).jpg

Wipe area with 90% rubbing alcohol on microfiber cloth to clean well. Make sure area is dry before proceeding.
Install mylar disc or THIN clear or steel washer. Reinstall post, tightening GENTLY. Reinstall sling plastic and nut.

Here's 1.25" mylar disc (too large, I've dialed mine back to 1.125") installed with off-angle light - almost invisible
mylar-on-post (resized).jpg

Here's the same disc lit:
mylar-on-post-2 (resized).jpg

#350 7 months ago
Quoted from joseph5185:

So that I'm clear (no pun intended), the game does not have star posts by default, right? My game doesn't appear to.
I'm considering green star posts since CE. Thoughts? Or should I just do clear since it will better match the sling rubber?

Green or blue would look good, I think. I ALMOST did blue, and may still.

#356 7 months ago
Quoted from GnarLee:

Speaking of color changes. After 1000 plays my flipper rubbers were toast. Did yellows on main flippers (always yelling at me about gold) and did blue for the inner loop flipper. Looks pretty good imo

Yeah, whatever rubber put on the flippers from the factory was trash. I hated the way the looked and felt. They came off in the first couple days. Yuck.

#357 7 months ago

If that chip grows or threatens to, use some clear nail polish to arrest it.

#360 7 months ago
Quoted from joseph5185:

When you say “pop” ... you mean like break completely or?
I’ve had the sling rubber come off or rather the plastic thingy got exposed somehow..
But I’m guessing that’s different?
Also, what are the size rubbers for the “other” slings if that makes any sense?

Page 222-223 of the manual has all the rubber locations and sizes.

rubber rings (resized).jpg
#367 7 months ago
Quoted from fossmin:

My Black Pearl seemed to be acting weird last night. During game play it would only tilt to the left and then back to home. No tilt to the right. I check it in the test and it moves to the right in test mode. I also recalibrated it, but it didn't change the game play. Any ideas?
Thanks
Gerry

In test mode is the opto for the right triggering from a wire or something? You can see it flicker before it's right if it is. That flicker will fool the game into thinking it's all the way right and start it back to the left before it's really right.

#374 7 months ago
Quoted from harryhoudini:

Welp, switch #48 decided to die to today. Luckily I had a few, easy swap and it's back to good. Seems pretty short lifespan for a switch.
In other news, trying to figure out what is wrong with the spinny pirate. I pulled the figure off but can't quite figure out how to get to the motor. The motor is held in to the bracket with 2 screws and the bracket into the pop bumper assembly with 2 screws but neither sets of screws are accessible. There are two holes in the mounting plate but they don't line up with either set of screws. I assume it's this motor that is bad but once I get access I'll test power to it. Also I noticed the motor mounting to the bracket was VERY loose. Might want to check these in your games, not sure they are supposed to be loose.
https://photos.app.goo.gl/sDsTaKL4HeKVjQBX9
[quoted image][quoted image]

It's in the post #1 index for the instructions on how to adjust the Tortuga/mystery hole.

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934930

#375 7 months ago
Quoted from harryhoudini:

I assume I am going to put it in to test mode and hook up a DMM to the leads and see if any power is hitting it. I thought it was in the coil tests, but I don't recall, however I know it's there as I tested the other one. Not sure what power it should be getting, but I'm assuming as long as there is some sort of AC or DC voltage there then it is likely the motor. Looks like a small DC motor from hobbying stuff so probably can easily test it with a 9v battery.

The coil to the motor is in the coil tests. You have to select it and hit START to goose it with momentary power, then watch your meter as you do. (Oh, and make sure the white post inside the open coin door is pulled so you have coil power) You might want to test some other coils first to make sure the test is working.

Going from the other connector to the motor, you can definitely put a 9V battery on it and see if the motor spins for a quick and dirty motor test.

#393 7 months ago
Quoted from Axl:

The balls get stuck here often.
[quoted image]
It looks like the ramp is bent out of shape.
[quoted image]
As I see it I have two options.
Either put a washer on the foxing on the post by the pirate lanes, or try to bend the wire forms back to shape. Very reluctant to do any bending.
Any other suggestions?

I'd go with the washer(s). Ball doesn't stick there on the one we have here, so it has to be the wireform (or a magnetized ball?).

#422 7 months ago
Quoted from LTG:

Stick a small blob of hot glue on the bottom of the push button so it's a little larger and won't get stuck on anything.
LTG : )
Disclaimer : That style of switch has side to side play.

This has been a problem since Hobbit. I don't know why they don't use a non-contact opto interruptor style there. Seems like it would be way more reliable.

#460 7 months ago
Quoted from lexi:

Hi I have the ball getting stuck in the chest and it is not releasing. There is a rubber pad at the back of the chest, is this supposed to be there?
When the game ends the pin tries to release the ball and hunts around the game to find the ball stuck in the chest etc.
Any ideas on this?[quoted image]

In coil test mode, does that flap at the left side of the chest move when you fire that coil? (make sure the white post on the inside left of the coin door opening is pulled so you have power to the coils)

It's either a bend needed in that metal flap or your coil to move the flap isn't firing.

#463 7 months ago
Quoted from lexi:

Hi thanks for the feedback, the flap moves but too quick and pushed the ball to the right so by the time the ball gets back to the flap it is closed so it cant escape. Sorry I have no idea what you mean by coils etc and what this issue has to do with the coin door and white posts?
I have a video of what is going on here so hopefully this will help you see what is happening.
Thanks also for the post reply.

That's ball search, which isn't helpful because the actual coil release time may be longer in the test or in game.

But it does establish that the coil works.

You probably just need to carefully bend that tab holding the ball on the left OUTWARD a little so when the coil moves it there's more space for the ball to escape.

I have no idea why JJP didn't use a sideways post here. This mechanism is very unreliable IMO.

#471 7 months ago
Quoted from lexi:

Thanks again, you may have to help me out, the game is new out of the box today, so I am not sue about things like test mode or any other mode. I have set it up myself rather than the dealer etc so am not 100% sure etc. This is my first JJP pin..
Are you saying that to fix the problem on a new 10k pin that I have to actually bend a piece of metal on a brand new machine?
Has anyone else had this type of issue and is this a common issue??
Jeez..........

Get used to it. ALL pins need dialing in to play at optimal levels.

I didn't know there was a fire time option on the menu. I would definitely start there.

Open the coin door
press the menu button on the inside of the coin door to get to the system menu
go to settings
go to coil settings
move down on the list until you get to the VERTICAL UP KICKERS, then continue a little more to "Chest Fire Release Time" and increase that by 1

#478 7 months ago
Quoted from AUKraut:

Reinstalled the BP, hooked up the wires and tightened everything up. Everything tested perfect! Grabbed the playfield glass with gloves on, and without the glass touching a thing, only my hands, it did this:
[quoted image]
I have handled playfield glass thousands of times, and now this.......Scheiße!!!!

Only takes ONE time to increase your respect 1000% for tempered glass when handling it. I always pooh-poohed the glass breaking from literally being touched - until it happened to me.

Wouldn't the MAP2 metal piece of the Cliffy set have covered that T-nut protrusion anyway?

#488 7 months ago
Quoted from apinballwiz:

I don't understand how this could have happened? Certainly not by touching it "wrong". I can see this happening if the corners of the glass were chipped, doesn't seem like the case here.

Temperature change (cold room, warm hands, or vice versa) or even the slight torque from picking it up. It's definitely a thing. Only happened to me once so far, but I don't put glass on a cold cement floor anymore. Always put cardboard or something else under it.

#504 7 months ago
Quoted from joseph5185:

That's all well and good once I actually get the ship off.
I can't get to the coil stops otherwise.

You don't need to get to the coil stop to change the linkage. Take off the plate (4) at the front of the flipper coil by removing the two philips screws (9). A 90 degree angle screwdriver would be helpful here, but you can use a racheted 1/4" wrench and a philips bit in a pinch. Slide the coil (18) forward a bit to get it off the coil stop at the other end and angle it, letting you get the linkage (2) shaft into the coil (through the plate, you still need the plate in the chain), then slide the coil back onto the stop, slide the plate back into place, and secure the two screws again. The feed the bracket on the linkage onto the flipper post, adjust and tighten.
flipper-linkage (resized).jpg

#513 7 months ago
Quoted from joseph5185:

Yea I STILL can't get the flipper assembly rod inside the coil.
I removed the two screws for the metal coil stop ... makes little difference.

If you're actually taking off the coil stop, you're on the wrong end of the coil for this job.

#518 7 months ago
Quoted from joseph5185:

This is what I was referring to for the coil stop:[quoted image][quoted image]

This is a coil stop. It's on the other end of the coil:
https://www.marcospecialties.com/pinball-parts/A-12390

#525 7 months ago
Quoted from joseph5185:

Just kidding...
I think this is what you are referring to...
OF COURSE the side I need to get to is completely obstructed...[quoted image][quoted image]

The coil should just slide forward off the coil stop as it is.

If it's too tight, just clip off the zip tie going over the coil which will let you slide the coil forward and then get the shaft for the linkage into the coil, then put a new zip tie on.

#529 7 months ago
Quoted from joseph5185:

I disconnected the spring just to rule that out.
As you can see in the photo I'm pressing with my thumb on that right flipper and I can't push it anymore. SOMETHING is preventing it from having more travel.
I'm going to be REALLY HAPPY once I solve this.
But I think i had enough for tonight.
Good night!

You just need to adjust the rod connection to the linkage. Basically it's coming to rest on the top before the linkage travels all the way back to the rubber stopper underneath. So loosen the linkage on the flipper shaft *just a little* so there still some resistance, then rotate the flipper within the linkage until when you let go, when the flipper is at rest the linkage is touching the rubber stopper on the underside like you have on the other side. When you have that set, tighten the linkage to the flipper shaft again.

#535 7 months ago
Quoted from rs812:

Looking back at your post #2 in this thread, if that is your game it also has the exposed t-nut issue.[quoted image]

Yeah, I checked, it does. Looking at where it's drilled, all the jjPotC have to be the same way.

#564 7 months ago
Quoted from LTG:

This is easy, don't over think it.
LTG : )

Get a T-Shirt made with this.

#580 7 months ago
Quoted from joseph5185:

For my own understanding ...
If this is NOT a coil stop, then what is it?
A coil start? haha .. A coil plate/opening?
[quoted image]

Manual calls it a "Flipper Coil Centering Bracket"

#597 7 months ago
Quoted from AncasterStan:

Newbie to the Pinball Forum posts world...hi everyone! Just got my POTC LE delivered last week...great game overall but from the very first play I have been having issues with the balls getting stuck in the subway after going in the Map Hole and the Bayou Hole and not being ejected out of the Depths. Machine has to cycle through a few times before the ball is finally ejected out of the Depths. It is especially frustrating when this occurs during the Multiball segments. I posed this question to JJP Support and received the reply of "please see if your game has the blue post pressing up against the subway like in the attached picture." After checking the underside of my playfield I noted that I have a similar post as shown in the JJP photo but mine is clear. The JJP Support response to that was, "I'll alert this to Frank and Steve to see if there is a better answer." Is anyone else experiencing this issue and are there any solutions out there? I made sure the machine is level as per JJP instructions. Thanks in advance for any advice given...
Stan (Ancaster, ON)
[quoted image]

What is the pitch of your playfield (check it with the glass off and a level phone app, or take a picture of the bubble level by the shooter lane).

#658 7 months ago
Quoted from zaphX:

It is one of the best technical manuals for a product I’ve seen. Butch Peel deserves as much credit for the thorough manual as Eric does for the excellent game design.

100% JJP has the best manuals in pinball. NO ONE comes anywhere CLOSE. A great resource. Stern has basically given up on providing even halfway good manuals.

#662 7 months ago
Quoted from joseph5185:

I’m just trying to get it as tight and amazing as the right flipper.
Is there anything that can be done for tightness besides turning that pawl nut?

As long as the flipper shaft isn't moving out of adjustment, it's tight enough. Tightening it beyond that point has zero practical value.

You can open it by backing the nut off and putting a sturdy flathead screwdriver between the two halves that are almost touching or touching and rotate the screwdriver to spread the gap again.

#685 7 months ago
Quoted from harryhoudini:

What's the situation with the audio clipping? Is it simply an issue of the mix volume or is there more to it? I do recall some posts about wire positioning or some adjustments in the cabinet. I ask because I get something similar but not exactly what he is describing. I'll work on the level adjustments, just looking for all the info.

Yeah, I don't think there's very good normalization in the mixed output, so if you have one of the component volumes too loud, it can push the total volume over the top and clip it. It's been a problem since at least Hobbit. I don't recall it being an issue on WoZ, but I haven't played with volumes on that in a LONG time, so maybe I just didn't run across it.

#724 7 months ago
Quoted from gumnut01:

Just bought an LE. Blown away. Awesome game. Have an issue with dauntless not sitting correctly, and cannon not hitting hole. I know this has been brought up before and Yelobird posted a photo of the assembly behind the play field. Mine looks different as I do not have a nut. But when I look in the manual it does not have a nut either. Anyway here is my out of whack dauntless and the bottom of the assembly. Any ideas on how to fix. I shall contact support. [quoted image][quoted image]

The dauntless pic is too close, I don't know what I'm looking at. Can you do a wider shot? How do you know the dauntless is the problem and not the black pearl cannon alignment?

#744 7 months ago
Quoted from JustLikeMe:

My LE was delivered to a friends house last week and I’m moving it to mine this weekend. Very excited but he’s noticed a few issues whilst ‘testing’ it for me:
1. Shots to The Devils Triangle don’t seem to register at all.
2. The gate to access the cannon shot on the Pearl doesnt open properly, although we managed to get it in once.
3. 90% of the shots to the Maelstrom ramp end up in the bowl even if the multiball isn’t lit.
4. With the lockbar fully secured, the action button is closed. We had to play with the lockbar slightly loose for the action button to register.
5. The action button is getting stuck a little.
6. Upper left flipper is temperamental.
7. Chest ball release got stuck once.
8. Ball occasionally jumps out of left ramp if hit hard
9. Ball occasionally gets stuck above the light on the right of the playfield.
I’m sure most of these are minor issues and I do plan on reading through this thread, but if anyone has experienced any of the above issues and can point me in the right direction I’d appreciate it!

You don't have to read the whole thread. Just scan the index on post 1 and follow the links to the issues that yours has.

#761 7 months ago
Quoted from wesman:

It's weird, I've gotten recommendations to trim that t-nut, and also to not trim.
How many plays are you at Joseph?
I assume nearly all tables have this issue, though zaphx said one of his friend's or his, didn't. But I'd figure these balls would all be chewed up otherwise, on location or not.
vireland did you trim yer nut? (So personal, I know!)

Nah. I left it. I don't think the ball is actually hitting that protruding part that often. But if it is, it'll become clear over time.

#820 7 months ago
Quoted from harryhoudini:

Those are just nuts, my man... bolts are male.

Any other conversation, female nuts would be very confusing.

#861 7 months ago
Quoted from harryhoudini:

Unless really jostled to the right mine almost always sits on the left and that is where the STDM almost always, if not always, happens from. I was pondering something several posts back about putting something there and your concept seems like it could have some legs.

Maybe try a star post on the left side to force it to rest on the right side.

#891 7 months ago
Quoted from harryhoudini:

I would if I could...Looks like that might be another change from earlier games (sigh.. JJP, COMEON). And I'm missing a subway screw, it seems. So.. now the question is, is the post necessary?
[quoted image]

As I understand it, the post just helps keep balls from getting backed up and one or more lost in there during multiball.

#901 7 months ago
Quoted from Psw757:

Well son of a bitch!
Was poking around the game today after putting about 50 games on it and what do I discover? Lower left sling post chipping has begun.
What’s the safest bet here for minimizing further? I have 3/4” semi clear washers as recommended earlier and Mylar.
Thoughts?
I can live with a chip but don’t want the whole area flaking up.
Pisses me off!

Mylar, IMO. I don't think the washers will solve the problem.

I punched out my own that were slightly bigger than the star post base (after estimating WAY off on the initial try). These are adhesive and have the best chance of holding everything together.

star-post-mylar (resized).jpg
#904 7 months ago
Quoted from harryhoudini:

I'd suggest it's the other way around, personally. Mylar is an extremely thin piece of plastic... the original narrow star posts have a sharp lip on the bottom, how is mylar going to protect from that? Unless someone is balking at the look, I'd suggest what I did in my post, linked above. That way you have an entirely flat, large surface area of PETG washer at the bottom which spreads the load, stops further pressure from the narrow post and prevents more cracking, I'd say.
*Edit--- Now that you edited,lol... you don't have any cracking. Why would mylar help those with cracking/divoting? Not only that, I bet the mylar puffs up at the edges over time as the post settles in, more so if the mylar is closer cut to the post. Also, were your narrow posts sharp on the bottom?

How much experience do you have with mylar on playfields? My experience with it is much different than your assertion. Not saying you're wrong, just that I haven't seen the issues you're talking about when using it.

With the method you're talking about, you're spreading the pressure out, but the PETG disc still has a sharp edge unless you're beveling them by hand. That will dig over time.

#939 7 months ago
Quoted from Lermods:

I tried searching, but not getting good results. Can someone please point me to the install instructions for the cliffys? Looks like the pop bumper has to come out for the mystery hole and the ship out for the map hole. Have two smaller cliffys, not sure where they go.
Thx
[quoted image]

There's no install instruction for the lower one, it just snaps on from the topside of the playfield to The Depths kickout. The other one is the MAP2 protector that is part of the map protector. It's one of the first entries on the index in post 1 of this thread.

#940 7 months ago

Mylar ring sets if you have two star posts on each sling are in the pinmonk store on pinside. Two large rings, one small ring per sling. I'll be adding an all-slim set once I get enough punched out. The small ones are harder to make due to the size.
PotC mylar rings_pic (resized).jpg

#942 7 months ago
Quoted from harryhoudini:

HA nice. Can you post a picture of yours all installed?

They're clear so it's really hard to see them once installed, but I took a picture of a star post without the paper backing removed from the ring to give an idea of the coverage.

EDIT: If you look at the narrow post above the star post, the angle lighting is good enough that you can see the clear mylar on it.

PotC Mylar Ring Clearance (resized).jpg

#944 7 months ago
Quoted from dgposter:

Perfect timing Pin Monk! I installed some clear rubber washers from Amazon under all my star posts on my TNA and they damaged the star posts. See my post here https://pinside.com/pinball/forum/topic/total-nuclear-annihilation-cluball-welcome/page/107#post-4988908
I know some fellow POTC owners have used these as well, so make sure to check your game if you have!

Wow, that's crazy. Definitely looks like some kind of chemical reaction with the disc and the star post plastic. I stuck with time-tested mylar because I've used it for decades in many kinds of applications on playfields and never had a problem, plus for this specific case, you're basically trying to protect from cutting and hold chips together, which mylar is perfect for.

#947 7 months ago
Quoted from zaphX:

Well between this and my escaping sling kicker I'm ready to switch to mylar circles.
Do you have any that are the size of the star posts? I really don't want a visible ring around them if I can help it.

You won't see them unless you're really looking since they're very hard to see installed, especially if you smooth them to your playfield with a fingernail when installing to remove any hint of air.

I originally made them MUCH bigger (See original post here: https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/7#post-4958109), then made them exactly the size of the star post base, but that posed a problem because you're trying to protect the edges from cutting and chipping and the star post plastic can shift about a mm on the metal post, which shifts it OFF the mylar, so then I settled on this size which gives enough of a buffer that the edges can't get off the mylar, even if the star post shifts a little any direction.

#949 7 months ago
Quoted from Psw757:

Why not put star posts on all three?
You going to make a set with 6 of the larger Mylar washers?

My personal preference is to leave the back alone since you don't really see it. But once I get better at making the small ones and have more of the big ones left, I'll probably make 3 or 4 variant sets and you can just get the one you want.

#951 7 months ago
Quoted from Psw757:

These look much thinner than most of the lexan and nylon washers, is this the case?

It's 3 mil thick mylar, which is thinner than any of the disc solutions, but it's pretty tough material. It's also on the lip of the Black Pearl. I was going to make a piece there because of the chipping danger and realized when I went to measure that there's already one there from the factory.

#959 7 months ago
Quoted from harryhoudini:

Yeah, I was specifically wanting to see them without the backing on the larger star posts, lol.

I'll take a picture of that then, but I don't think you will be able to see much - they're transparent!

EDIT: I just realized that on the one where I left the paper on the star post, the slim post above it already has the mylar ring on, and the angle is good enough that it shows up pretty well. Have a look at the slim post in that pic!

#960 7 months ago
Quoted from Psw757:

Decisions decisions....
I’m thinking if you already have a chip thicker might be better but if doing preventative the Mylar would be the way to go.

If you're chipping, a washer isn't going to hold anything together.

#965 7 months ago
Quoted from tomdotcom:

Mylar didn't work well on the TNA starposts, it would just end up moving or bunching up. You may have better results with Pirates...

Did you clean with 90%+ rubbing alcohol before putting down the mylar to give it the best chance of adhering?

I've had mylar on the Pirates here for almost 3 weeks, and it still is great. Granted that was the larger discs, but I guess having one side with larger and one side with smaller ones is a good experiment...

#969 7 months ago
Quoted from tomdotcom:

Yes it was clean, and there are multiple reports of this happening on TNA, which is why people switched to the thicker poly discs...

Did anyone post pictures? I'd like to see what happened on TNA. Also, were they using hobby store vinyl cling, or actual pinball mylar? The ones I installed on Pirates haven't budged in almost 3 weeks, so it seems weird.

#972 7 months ago
Quoted from f3honda4me:

A correction on this. You do not need to remove the #1 philips screws as a first step in order to remove Tom. There is a hole in the side of his barrel you can stick a hex wrench or driver through to get at the hidden hex.

Unfortunately there's no way to edit these posts, I can only add to them. I'm going to see if I can get some kind of a code or something from Robin to be able to edit these after the fact.

#975 7 months ago
Quoted from tomdotcom:

I used proper mylar on mine. Check in the later pages of the photo gallery....probably some there...
https://pinside.com/pinball/forum/topic/total-nuclear-annihilation-cluball-welcome

The only one I saw was one with the size mylar I rejected because there wasn't enough space around the star post (and star posts do move a little, so issues with that size are to be expected:

https://pinside.com/pinball/forum/topic/total-nuclear-annihilation-cluball-welcome/page/75#post-4654312

Are there any TNA ones with the larger mylar discs?

#1004 7 months ago
Quoted from Lermods:

Can someone point me to the instructions to remove the ship to Install the cliffy for the map hole?
Does the pop bumper need to come out to Install the mystery hole cliffy?

Tortuga hole cliffy:
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues#post-4934930

Also, skip taking the two screws out of the top of the barrel and jump to using an allen wrench through the little hole on the side of the barrel to remove the whole barrel at once.

#1017 7 months ago
Quoted from GnarLee:

So havnt played a ton of games on .99 but have noticed a weird issue starting multiballs. On occasion the game is kicking a ball out but not auto launching it. Literally watched it kick 3 balls out and the launcher not go off once. After 3 balls were there it started trying to get all the balls out. Have noticed during several games since update I have had multiple ball pushed/stuck in shooter lane. I still have not done any troubleshooting on it as I have order from jjp coming wednsday that is going to require me to remove BP. Going to all maintenance when that comes in including waxing and installing mylar at chapter select area.

Check the shooter lane switch with a ball (not your finger). Put it in switch test mode, manually put a ball into the shooter lane and see if the shooter lane switch registers.roll it off the switch then let it roll back on and see if the switch activates freely. If it doesn't, just adjust the switch until it registers.

#1037 7 months ago
Quoted from harryhoudini:

My spots also don't flicker (of course the BP lanterns do) but
my topper flickers like the dickens and I have it set to max
brightness and the attract mode off. Not sure if there is any other
change to do.

WoZ topper flickers, too. It seems like they just need to read up on how to drive the LEDs smoothly. If LED OCD can do it, they can, too. The LED OCD board has excellent, smooth LED fades in and out.

#1056 7 months ago
Quoted from Asael:

On my PotC the GI and Insert LEDs connected to the P9 board are out. The LED on the board is red. So I contacted my distributor and he did send me a new P9 Board (Pinball Universe, Realy good support so far!!!). I put it in and have the same failure. Just the GI and Insert LEDs are out and only the ones that are connected to P9. Everything else works right. The distributor is cluesless too and wants to contact JJP.
Has anybody an idea what is wrong?

Wow, your distributor is really on the ball with that swapout! Shame it didn't fix it...
That power connector for the board is daisy chained. I'd unplug it and use a multimeter to check what (if any) voltage it's delivering. Maybe the connector is broken.
Also, it's bound pretty tightly at a harsh angle by a ziptie, so maybe one of the wires to the power connector had broken off inside the insulation from being bound too tightly and then bend hard to make the board connection. Try cutting it out from that ziptie and then wiggling the wire with the power on and see if the board indicator goes green (even briefly).

#1058 7 months ago
Quoted from harryhoudini:

Could it be the cat5 cable?

I don't know enough about how the 2.0 lighting system works to say absolutely no, but since ALL the lights on that board are out it makes me think it's power related rather than control related.

#1073 7 months ago
Quoted from Schabs81:

So noticed my map cliffy is raised any ideas on fixing with out removing BP again ?
[quoted image]

Did you wipe the playfield well with the activator and let it dry before installing?

If you did and it's still doing that, you may have tightened the connectors too hard at the back which tweaks the thin metal.

#1075 7 months ago
Quoted from Asael:

Thanks for your help. I checked the connector with a multimeter and have 4,5 volt there. That's ok? Wiggling on the wires does not help. Today I send one of the two P9 boards back to my distributor he wants to check if it's still working or not.
I have no clue what could be wrong.

I don't know enough about how those work to know what else might be wrong. Since the power connectors are daisy-chained, check the voltage at other boards and see if that 4.5v is right. It seems like it should be higher, but I dunno.