(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

8 months ago



Topic Stats

  • 2,337 posts
  • 135 Pinsiders participating
  • Latest reply 2 hours ago by vireland
  • Topic is favorited by 98 Pinsiders

You

Linked Games

Topic Gallery

There have been 435 images uploaded to this topic. (View topic image gallery).

installed_final (resized).jpg
JJP_mobo_buttons_sml (resized).jpg
fix-dead-jjpotc-H110_mobo (resized).jpg
fix-dead-jjpotc (resized).jpg
IMG_1901.jpeg
Screen Shot 2019-11-30 at 6.52.53 PM.png
1B7C8008-D057-4BB4-8D38-23634CFEAB94 (resized).jpeg
reset motherboard (resized).jpg
jumpstart (resized).jpg
20191128_210803 (resized).jpg
moboreset (resized).jpg
IMG_20191128_194814971 (resized).jpg
B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg

Topic index (key posts)

3 key posts have been marked in this topic

Post #306 Tip on removing the black pearl Posted by rs812 (7 months ago)

Post #501 More tips on removing black pearl mini playfield Posted by LTG (7 months ago)

Post #1776 Broken trunk mount bracket picture Posted by Soulrider911 (5 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider gumnut01.
Click here to go back to viewing the entire thread.

#723 7 months ago

Just bought an LE. Blown away. Awesome game. Have an issue with dauntless not sitting correctly, and cannon not hitting hole. I know this has been brought up before and Yelobird posted a photo of the assembly behind the play field. Mine looks different as I do not have a nut. But when I look in the manual it does not have a nut either. Anyway here is my out of whack dauntless and the bottom of the assembly. Any ideas on how to fix. I shall contact support.

0467C080-4F21-4497-920C-F9D8A9D33B1F (resized).jpeg7A403BFC-6FD6-42A7-9C8A-4B29055BF925 (resized).jpeg
#725 7 months ago

I showed the dauntless from above to point out that it juts forward compared to the fixed deck, whereas other people seem to have the hull and the deck aligned. Here are other photos including the cannon alignment. I searched for any posts on cannon alignment or fixing the position of the dauntless but could not find anything. As stated Yelobird's photo of the mechanism for the dauntless has an extra nut which I do not have and is not shown in the manual.

IMG_1018.jpgIMG_1019.jpgIMG_1021.jpg
#728 7 months ago

As others have stated grabbing a 5/16" thickness may be difficult, but since it is only 1 1/4" long, maybe 1/4" thickness would suffice? Anyway, I will grab what I can in that length, try it and report back.

#731 7 months ago

Thanks Spidey! Good to know!

Thanks Gliebig, the wires seem to be pretty loose and has play. Will check again.

#756 7 months ago
Quoted from harryhoudini:

It's not really higher, per say.. it's longer. Meaning the tip of the scoop is closer to the front of the tortuga hole. It may be a hair taller but I made sure and it fits under the wireform easily.

Huh. I think mine came with your new scoop. So maybe not all will have this problem. Built 28/8/2018, so I guess mine is quite an early build?

09FF3E71-081C-4415-9B6A-F3E402EC83A3 (resized).jpeg
#768 7 months ago

Action button getting stuck. I guess just ask for a new one from Jack? Also thanks to all the posters who helped with the shorter hex spacers. Great fun shooting the bullseye. Damn difficult to do during black pearl Multiball. Anyone else resolved the sticking action button?

#770 7 months ago

Thanks zaphx. I tried silicon lubricant. It did not do much. I think this button has a few burrs on it that are catching. I wonder if it is because the angle is different to a normal flipper button and that it gets pounded.

#779 7 months ago
Quoted from zaphX:

I've seen that. Try lightly sanding the button shaft.

Thanks, will give it a go.

#780 7 months ago
Quoted from LTG:

Getting stuck on the switch ? Put a dab of hot glue on the bottom to give it a wider footprint.

I think I did see you mention this before but forgot. So many posts, sorry. Shall look into this as well. Thanks.

#843 7 months ago

Yes mine is level. It does not always go sdtm after star map but it happens often enough that it can ruin a game. It happened on my highest scoring game to date. Unlike a kick out, there is no deflector to adjust. There is no tinkering that can solve. I have a digital calibrated level. Game is 6.55 and level from side to side. Please people that do not have this happening, do not brush aside and say it’s not a problem. It is enough of a problem that multiple people have reported it. A configurable 2 second ball save is not going to affect you people who swear it never happens. You can have it turned off and not be affected. I have posted Keith but he has not responded. I hope this can be resolved. It’s not a deal breaker, just takes a bit of a shine off when it happens. Lyman knew this would happen during strobe Multiball in AFM so he added it. Sorry for going on, but it is disheartening to report something and then have it discounted by others.

#849 7 months ago
Quoted from rs812:

Agree 1000%!!! This is exactly why I have in the past week ceased from sharing the problems and solutions I have encountered

See rs812, the target audience is going to ignore my post anyway. I think I will stop posting as well. Thanks for the acknowledgement. Enjoy this great game!!

#862 7 months ago
Quoted from zaphX:

No, don’t stop posting. You’re absolutely right that if it’s a problem for you, an optional ball save would be a fair solution.

Thanks zaphX. You sir, are a gentleman. It was me feeling small fry amongst the big trouser wearing boys. You have helped many people who jump to the conclusion that something is a huge issue when in fact there is a simple explanation which will resolve it. You try to illustrate that the simple explanation should be attempted first. And you help heaps of people. I feel now I should apologise (starting to choke up a bit!)

I looked at the plastic removal over the star map and thought you might be able to loosen the top nut and sneak the rubber under as well. Alas, that causes the problem you mentioned.

The sdtm problem is just every now and again, but it would be great if it could be fixed.

#864 7 months ago
Quoted from Yelobird:

Just a thought and attempt to help those frustrated.

Thank you Yelobird. You did not have to analyse this for a solution. Thank you for taking the time. I can’t say which side of the post causes the problem more. When I look at it, a totally random element is at play with the magnet. This tries to simulate a missed shot going up the play field which has hit something and deflected. Most of the time it works. Not sure if the starting position for a random force would change behaviour, but I will give it a go when I need to access that part of the machine. Because it’s random I may not experience it for a day. Other days I have had it happen in 2 games in a row.

I have admired your mods. The wife and I are very interested. We will decide on a few in a couple of weeks. Still coming to terms with this awesome machine. Pity the Aussie dollar tanks so bad.

#865 7 months ago
Quoted from zaphX:

I didn’t grok that until I was already too far into mistakes.

My best decisions are always made after the wrong choice...

#866 7 months ago
Quoted from harryhoudini:

Unless really jostled to the right mine almost always sits on the left and that is where the STDM almost always, if not always, happens from. I was pondering something several posts back about putting something there and your concept seems like it could have some legs.

Thanks for your help on this as well! I’m glad your Tortuga hole is working now. Mine kicks to the tip of my left flipper. I’ve gotta be ready for it. Now and again I’m too slow and it drains. But I’m cool with that, that’s my fault.

#917 6 months ago

After struggling with Multiballs ever since I set this game up I thought “screw it” and lowered the pitch from a whopping 6.55 to 6.5. The nose of the bubble used to be just above the second line, now it just meets it. Night and day. Multiballs so much more manageable. Easier BP. Less drains when going for Jack in the star map. Less drains going for Devil’s Triangle. More fun. No other game has changed this much from such a small adjustment. Really advise people to take the pitch down a little if the balls are feeling too heavy during Multiballs.

On another note, not only is my action button sticking, but so is left flipper. Pretty crap. I am actually going to change both flippers to single leaf switches. I know this means each button will now fire all flippers on either side with no independent flipper control. But don’t give a rats, I need to save my tennis elbow. The double leaf switches are way to firm for me. Yeah I’m a wimp.

Lastly, on pressing the start button the game rebooted today. I know I need to check power cable as posted, but this is the first time in 80 games. On .99 will advise if it reoccurs.

Got my first pirate hat and eyepatch today!!! Woohoo! Sorry... I meant AAAARRRRRR!!

#935 6 months ago

Thanks zaphX on your flipper advice. Will see if I can change buttons and or bend the contacts slightly to make it a lighter feel.

Great to see agreement about pitch. I was loving it but was getting a bit frustrated.

#936 6 months ago

The other benefit to independent flippers I guess is being able to activate bottom left whilst not activating flipper over the depths. Many times I hold the flipper down too long all the way only to have some of my shots from left flipper to chest hit the top left flipper. Very hard to tell my brain to touch and caress the button lightly when I’m so god damn excited.

#937 6 months ago

Maybe I need to learn to move like Lyman to calm me down!

#985 6 months ago

Solved my flipper buttons being too stiff. Used my leaf switch bending tool, and bent the leaf closest to the button so that it is almost vertical. Before it had a very aggressive bend towards the flipper button. WOW what a difference. So much easier to use, and can easily activate both upper and lower flipper independently now. New action button also installed. Very happy.

#987 6 months ago

Thanks for your advice on not ripping out the layered leaf switches and replacing with a single switch. You made me realise what a bad decision that was!

#1085 6 months ago

My right BP opto stayed on last night making the game think I had boarded the BP on ball launch. I checked it and the opto bracket was bent. I sort of bent it back but you can see it’s still a bit malformed. It’s the one on the right:

AD174068-A3AE-4320-BE2F-F610D3B48657 (resized).jpeg

#1087 6 months ago

Damn. Broken opto. See bit of plastic sticking out. Still works. Maybe i should just tape it back down with black electrical tape...

09A03E18-EBE0-46FE-8B7A-FFA249576EE7 (resized).jpeg
#1088 6 months ago

Yep, broken on both sides. Should’ve been made in China, then it would have lasted.

277C4CD2-6264-4FF1-B372-C351EBE298BC (resized).jpeg
#1090 6 months ago

Thanks but JJP can send me one. I’m not paying for it! Wasn’t broken by a ball. It would have been snapped on delivery. Just out of alignment now. Problem was I lost one of the screws. Bloody pest.

#1093 6 months ago

Good idea! I'll try that!

#1139 6 months ago

Hi indypinhead, in the owners thread, last page coindropper has a fix with a washer

#1157 6 months ago

Found out why my opto was broken on the BPs right spinner.

The VUK comes out right next to it and the playfield underneath is completely hammered. No Mylar! I would have thought this would be standard here. I did search for this, apologies if my search skills have failed.

Anyway have not put down Mylar yet. Not sure if possible after this much dimpling.

To resolve for now I have turned the BPs VUK strength down to 20. Now ejects up to black pearl nicely without the customary “THUNK” that I thought was normal.

9EFC4DDD-FE18-415D-B38F-565D524E4E7B (resized).jpeg
#1159 6 months ago
Quoted from harryhoudini:

DUDE.. thank you for posting that! My right opto is also broken (have two new ones to install) and the thunk kills me every time. Going to turn vuk down and see about the mylar as well. Funny, cause there is mylar on the castle playfield on WOZ where the ball thunks down.

Yeah, it’s one of those things you see and you think “Naaahhhhhh!”

I wondered why we both had this opto broken. Mine is just hanging together with duct tape on the middle and I lost the bottom screw. Works though.

Going to miss the “THUNK” it sounded like a real pirate boarding! Arrrrrrrrr!

#1173 6 months ago

Yes I have had the problem happen out of the depths. Almost made me want to take the gate off. It’s not attached to any switch. Might make saves a bit too easy!

Anyway for levelling, I personally feel that a phone is not reliable no matter what the app. I think it’s too small. I found a 25cm digital level which can be calibrated and is cheap. Here is the one in Australia, US eBay should have an equivalent.

ebay.com link

#1174 6 months ago

Here is a pic. 25cm is long enough to give a truer reading but short enough to fit on most parts of playfield.

382E74EB-EF68-41ED-BFA1-EF2889FAB187 (resized).jpeg
#1183 6 months ago

Attention all people with new games!

Turn down power of Black Pearl ship VUK to 20 or whatever is the lowest setting to be able to board the BP. If you don’t your orbit at the back of the Pearl behind the spinners will look like the moon. It can also break the opto next to the VUK exit.

Turn down slings to 16. And also take a couple of points of both lower flippers. You will have a lot less playfield damage if you do this.

Install some Mylar at the back of the Pearl as shown. Clean with medical rubbing alcohol first. The little medi swabs are ideal.

Photos show before Mylar, my cut out and after. It may slow down the orbit behind the spinners. Most of the area needs to be covered since the ball lands left and right of VUK since the Pearl rocks.
F5309A2B-9B19-47CC-B552-51FB19A82F49 (resized).jpeg31C4545E-8FDF-4373-8A4D-414DC05B4C8D (resized).jpeg184BE30D-4C37-4F75-B64C-76BBAB0D68DD (resized).jpeg

#1185 6 months ago
Quoted from wesman:

I think my Pearl had some mylar just under the VUK. Yours seemingly.....didn't?

No it did not. If I’m the only one without it, then that’s a good thing. I guess it’s best to check. I mean the damage is hidden, but best to avoid. But both Harry and I had broken opto from a over excited VUK.

#1190 6 months ago

I sent them an email letting them know it is a problem. Hopefully they take note and turn it down in the next s/w release. Did you have the Mylar installed under the VUK?

#1191 6 months ago

Left beacon flasher next to maelstrom just stopped working. Sigh..... checked wiring underneath. Looks like I have to remove whole left ramp. Happy days.

#1203 6 months ago
Quoted from TZBen:

HI everyone, I joined the club today with number 1500 delivered (le). I have a couple small issues and would appreciate your tips.
1. Ship vuk in rear seems to lose balls. I think the game is too steep and they aren’t falling into the vuk correctly?
2. Bp ship isn’t moving Much to the left side.
Thanks. Super excited

Yes you need it levelled for the ship VUK to work. I had that problem. A bit steeper would be ok. But I find the game is too hard greater than 6.5. Nose of bubble on 2 nd line.

#1249 6 months ago
Quoted from harryhoudini:

Replace it. No question. The button JJP used is shit.

I thought this and had a new one sent. The one in there is the same as this. I could not find a different clear flipper button.

2nd one I received started doing the same thing.

Solution. Take button out, and remove screw at bottom. Hold outer casing and bash the center lightly from the bottom of the button. the inside will come out. Find any burrs, they are usually on the side of the button that sticks out where we bash. File these down smooth with a small nail file. I just polished mine off. All fixed. Gunk can also get in there from time to time. This will fall out when you take it apart. I don't think you will find a flipper button with 0 maintenance. They were never designed to face straight up. Angle is slightly different, so any burrs are noticeable and gunk will get in there.

#1253 6 months ago
Quoted from harryhoudini:

Are you talking one from JJP sent? Because the JJP part is not the Stern part, the Stern part is noticeably better. Not just the "getting stuck" issue but the overall action of the button. Maybe it's the spring, but it sure feels like a better part overall. It's not a question in my mind to replace it, just like if you are having whining noises replace the inline ground loop isolator with a $9 part from Amazon. I don't know if JJP is cheaping out on the parts (these two things and the posts with the sharp bottoms) but those things aren't right.

Fair enough. I stand corrected. My replacement was sent by my Australian distributor. Did not realise there are 2 different buttons out there. Mine is working fine now that I removed the small burr. As for the action of this other button, it costs $15 AUD to get it. I have repaired mine and they work. Will see how they go.

#1258 6 months ago
Quoted from Lazar:

An issue crept up tonight with the right flipper registering as a spinner on the pearl. Every time the right flipper is pressed, it scores points and progresses toward the pearl cannon (as the spinner would). Has anyone seen this or have an idea what’s going on? Thank you for your time and any advice.

Check your right opto on the right spinner on the pearl. Mine was broken and any vibration would set it off. I was boarding all day. It's the VUK behind it that's the culprit. It smashes balls into the opto. Turn it down to 20. I have a temporary fix for my opto, I just twisted the bottom until it was aligned.

#1259 6 months ago
Quoted from vireland:

Sounds like a vibration issue and maybe a broken opto. Put it in switch test mode and smack the mini PF firmly and see if anything triggers.

too quick!!

#1280 6 months ago
Quoted from Maurice:

Regularly I get the “boarding party” message across the display, but no ball enters the mini playfield. In test with the glass of I cannot find yet the switch that triggers this unwanted behaviour.
I suspect a overly sensitive spinner opto.
Any suggestions?
2. I lowered the power of the BP VUK from 32 to 18 and it still lanches the ball perfectly onto the deck. I recommend this adjustment, since the stock setting is 32!!!! Which is way to hard.

Check the right spinner opto, 3 of us have had ours snapped in the middle. If it is, Twist the bottom half so it is aligned correctly.

Here was mine.

And yes, the powerful VUK broke it.

6E9FBD88-C707-4F4E-9D3F-C9D2CFC7D048 (resized).jpegD4AFBA50-F075-4FA0-B635-AF1B04FBF283 (resized).jpeg
#1314 6 months ago
Quoted from wesman:

Mine was very firmly jammed in there. Definitely didn't just slide up and out. I assume due to shifting during shipping.

Mine is clunky also.

I don't know about the inner loop. If I hit it right mine goes around like a dream! If I'm a bit off, I guess it goes clunk and then falls down to the pops or somewhere else. I get the ship magnet taking it sometimes at weird moments.

But if it goes around nicely 3 - 4 times, and then I get a clunky shot.... isn't it me sucking more than anything else? I mean I'm the king of getting it to bounce around under the chest or piddling around in the star map area without doing anything.

One thing that does confuse me is how it determines if I get a map award on launch, sometimes I do a crappy loop first and it gives it to me, other times I do an awesome loop and into the map and nothing! Maybe these are the inconsistencies that Keefer is going to adjust.

I guess for me if I'm playing well, the inner loop is spot on, if I'm not it's clunky as hell. But I find this also for the chest, star map..... Some games I curse at the maelstrom.... just cant seem to hit it!

On a side note, I have had the maelstrom switch seem to trigger when I get the devils triangle. Will check my switches.

#1318 6 months ago
Quoted from harryhoudini:

Well, this isn't right. I went to start taking off parts to replace the rubber in the starfield and notice that the chest is really loose. Looking down behind it I can see the wood screw that holds it to the playfield isn't tight at all. This isn't the first loose thing I've found, sadly. I figured no problem, tighten it back down and be good. Once I did that the chest still moved and that's when I noticed the crack.[quoted image]

Ouch! Have you been stowing too much treasure??? You naughty pirate!!

#1321 6 months ago

You should be covered by warranty. If not, an angle and some rivets! So easy for a spot weld to break like that. Yep, getting me some perfectplays.

#1322 6 months ago
Quoted from harryhoudini:

Heh... too much booty.
Don't forget to inspect and replace your rubbers.[quoted image]

Wish I could get me some booty...

11
#1324 6 months ago

Just worked out why I had a few issues.

C3B4AD54-60F0-459D-9857-390B21AE06BC (resized).jpegF1C7062A-FF29-4476-9B15-44A0C0C6B4A0 (resized).jpeg
#1338 6 months ago
Quoted from gliebig:

Catapult mod?

Quoted from joseph5185:

Pretty cat! =)

Yep, it’s been fully accepted by the whole family now. Brothers, Australian Spotted Mist. Charlie, the lighter one, always gets up on top of the glass at an inopportune moment. Likes to have his but on the glass during multiballs. Best place to sit right on top of the flippers.

#1343 6 months ago
Quoted from Yelobird:

You need to tell him puss-n-boots was a buccaneer from a different movie stay off POTC! Lol

Don’t give Jjp any ideas! Incredibles or Megaminf I could handle. I know wrong thread!!!

#1402 6 months ago
Quoted from zaphX:

My flipper powers are at defaults and IIRC yes the default has one higher than the other.
On my machine the chest shot is easier to make with the right flipper than the left, and I consider it part of the game design and challenge. It takes a really perfect shot to nail it from the left flipper.
Another example: maelstrom is easier from the right flipper, but -can- be backhanded from the left flipper with difficulty for me. I like having these options and risk/reward scenarios. Part of the amazing design.

Agree. It’s always good to have certain shots that are only achievable from a certain flipper but at the same time have certain shots shareable and most importantly equal importance of each flipper. Nothing worse than having a redundant flipper in a game. I think Eric did a great job. I like having enough outside tip shots for both flippers Devil’s Triangle and depths vs tortuga and extra ball. Then still some challenging closer shots for each flipper, maelstrom and open sea. I still find the left ramp cannot be taken for granted. Then the two easy shots port royal and the BP ramp. I love port royal. Unless that damn post is up. Always a surprise when you hit it for the first time. Like WTF! But in a good way.

Chest is far easier from right, but if I’m concentrating can be flipped from left - just need to clear the upper flipper. I always feel like such a dick when I hit it. Side note bayou is easiest left ball cradled and just keep flipper held up. Pirate target is deadly. Chest as discussed narrows so anything but a sweet spot will bounce around in there and lose momentum. Star map is one of the easiest, as it should be. But needs a good hit or it will not register. Can only be done with left flipper or sometimes top flipper.

Upper flipper is unreal. Eric’s game really shines here. Inner loop, map and gold targets. So much to do and so fun to shoot. Much prefer it to TSPPs. I need to practice getting enough loops going and then hold open to automatically hit lots of gold. HAHAAAA GOLD!!!!

So going back to symmetry great how there’s 2 good ways to feed to the upper flipper during OST Multiball. Chest shot and open sea. One for each flipper. Chest shot I find easier to feed upper flipper. Or just get it somewhere up there and hope upper flipper can reach (not as satisfying).

Black pearl flippers. Loading cannon I mainly use left but do get it with right when I can see sway of ship and movement of ball is all aligned. I do find the only load cannon I can use is the target on the left, while cradling with the left. It does seem to hit the cannon door a lot. Not sure if this will cause maintenance problems later on. I think the load on the right is too hard to hit and mine seems to lack sensitivity. I need to adjust. Cotton is harder to hit than Marty. I need to hit the spot gold and bonus x targets more I seem to ignore these. Sinking ships too much fun. I think the cannon door is meant to be closed even after the load until you hit the cannon door again?

Oh and if I have to collect anyone in the open sea, sometimes I cheat and just let it fall overboard to trigger. Hopefully they don’t remove this cheat in a code update. Shhhhhh.

My pitch is 6.5, did not like steeper due to all balls draining during Multiball. I suck. Both flippers taken down by 2 from default.

No other game has me thinking about how to feed flippers like this one.

#1405 6 months ago
Quoted from zaphX:

Ripping loops is super satisfying. I even like listening to my wife do it when she's playing and I'm on the couch doing other things.

Agree. Better than ripping farts on the couch. Seriously though it seems like the default action for that flipper. So easy to get the loops into muscle memory. Thank Eric for making this happen.

#1407 6 months ago
Quoted from harryhoudini:

****IGNORE THIS... guess what, the USB drive broke off in the port. I didn't even notice as it's one of those retractable ones. When I went to put it back in I noticed it had no connector anymore. The room was all dark so I didn't notice it in the socket. Pulled it out and game is all good, that one's going in the trash. ******
Anyone experienced a boot loop doing the update? Let me say right up front, I just did an update on two WOZ successfully using the exact same procedure so I am fairly sure I am doing it properly. What happened is that I did the update like normal, system said it was done and I turned the game off. Removed the USB drive and switched on. It looks like it's booting up normal but then I get the *nix boot menu as if I had the USB drive in and the system then goes and updates itself again (same procedure as if the drive were plugged in). I let it finish and turned the game off, waited and then turned it back on, same situation.
I'm waiting for it to finish again and then I am going to put the drive in and see if I will update from the drive and maybe a "redo" will fix it. If not, I will extract the ISO to the same USB drive I used for WOZ to eliminate that. There were no specific errors or issues I saw, it appeared to complete without issue all 3 times it ran the update procedure. Worst case, I'll download the ISO again and re-try. I followed the updating procedures per the website as well.

Thanks for destroying the momentum of discussing awesome flipper and flow design Harry. How dare you bring up issues in the troubleshooting thread!!! Sigh.

#1411 6 months ago
Quoted from harryhoudini:

Yeah, now there is definitely something wrong with the launch. Coil is turned up to 32 now and it barely makes it off the ramp. Seems to have gotten progressively worse. Looking at the ramp I don't think the bottom cross pieces are hitting the ball, but I'll check that out. Any suggestions as to why it may have gotten worse over time? A month ago it was shooting fine, looping around to the left upper flipper no problem. Can't be coil sleeve already, can it? I'm going to inspect the wireform after dinner.

Bon appetit!

#1412 6 months ago

Trying to decide between kraken blades from Tilt vs pirate blades from pingraffix. I think the kraken ones look a bit moodier. The pingraffix might be too bright, too much yellow?

https://www.pingraffix.com/product-page/pirates-of-the-caribbean-pinblades-jersey-jack-pinball

https://www.tiltgraphicsinc.com/product-page/jjp-pirates-of-the-caribbean-the-kraken-gameblades

Thoughts?

#1414 6 months ago
Quoted from Psw757:

I went with the Kraken

happy??

#1420 6 months ago
Quoted from Psw757:

I’m very happy with them.

I'm leaning to it as well. I think the Pingraffix one is fantastic the way it ties in with the apron, has the sea at the height of the playfield, and probably looks good at the front of the cabinet. But it is a lot of yellow. Maybe they should have transitioned it to stormy weather near the back. I think the kraken is nice and moody.

Will let the wife decide.

#1423 6 months ago
Quoted from GnarLee:

Stock flipper power I believe its 22 left and 25 right. Works perfect for me

My ball was escaping the maelstrom. If your's never escapes the ramp then you're good to go. Took both of mine down because of the ramp escapes.

#1426 6 months ago
Quoted from GnarLee:

6.5
edit* anything above stock I had malestrom escapes. At 25 on the right (stock) It rarely happens like maybe 1 time in 100 games which im fine with. To be honest that 1% is way better than when you get 5 balls going and shit is bouncing all over the place. I did try lowering the right flipper power but you lose the ability to hit a backhand boarding shot if you lower it.

I will check my backhanding up the pearl.

Quoted from joseph5185:

Damn! Do you know what your pitch is set at?

It’s not just different pitch, I believe control of flipper strength was mainly put in due to voltage or ampage (I always get it mixed up) variations that can happen from area to area. This was explained to me. Maybe someone smarter can shed some light. Just check when you can make all shots without the ball escaping ramps etc. there is no one setting for the same pitch for all locations.

#1428 6 months ago
Quoted from GnarLee:

6.5
edit* anything above stock I had malestrom escapes. At 25 on the right (stock) It rarely happens like maybe 1 time in 100 games which im fine with. To be honest that 1% is way better than when you get 5 balls going and shit is bouncing all over the place. I did try lowering the right flipper power but you lose the ability to hit a backhand boarding shot if you lower it.

Thank you sir!!

I could no longer backhand it. Took it up one notch. Works a treat!

#1446 6 months ago
Quoted from vireland:

PROBLEM: Ball sticking under the chest
SOLUTION: Feel under the chest and see if the tips of the chest forks are above the playfield when retracted. Either adjust the screw on the bottom of the mechanism under the playfield so the forks sit lower, or add a washer below the chest mech at the lower left screw to adjust the angle just enough to correct the issue.

Mine was sticking out a bit too. As I was putting two thin washers underneath the lower left, I noticed this extra hole. Do you think this was used for opening and closing the chest? Sorry if this has been pointed out before.

6E7C3361-1BDE-4048-A9E5-49960CDA2192 (resized).jpeg
#1457 6 months ago

Just had a ripper of a game where the slings propelled the ball over into the dreaded “I” lane. Anyway not the first time this has happened. Fixed it. Don’t care if it looks ugly.

824631FC-32C3-4B7C-AF6A-B84B133F528C (resized).jpegimage (resized).jpg
#1458 6 months ago

Also noticed that you can’t see the shooter tip. Changed it. Now I can.

07A91331-0BA6-43DE-8B03-BC2F1C55C089 (resized).jpegC9F89022-B7A9-4941-80D1-B955305F22CA (resized).jpeg
#1460 6 months ago
Quoted from GnarLee:

You can make that bracket look good easy (does noty look bad) mount one of the gold coins or get a small toy to put on it problem solved
*edit Be prepared to get a ball stuck in those spotlights one day. Happened to me other day and couldnt believe it.

Yeah me too!!

I changed the lights to point more infield. They were quite loose.

Liked the idea about the toy.

F930DE1D-46D7-4A38-B9AF-EE572DCA2025 (resized).jpeg
#1480 5 months ago

I was trying to resolve my SDTM drains after star map chapter selected and the post drops. As others have noted it happens when the ball is stuck between the retractable post and the post to the left. My ball was wedged so close to the front it was almost escaping the star map. Other have stated this happens as the rubber wears. Mine is not that worn. Anyway did some investigating. The post to the left of the star map with the sling rubber was not tightened. At all. Moved the post over as much to the right as it would go and tightened up. Seems better now. Ball does not get wedged as much. Still a bit dangerous there. Maybe to resolve this in coding, rather than a ball save which seems contentious with other owners, the magnet could start kicking the ball around a bit sooner before the post drops. That means the ball is being affected by the magnet for a longer time before it is let go. Currently it’s just a small pulse which is not always sufficient to move the ball far enough. This small pulse just lifts the wedged ball slightly before it drains SDTM. This wedging of the ball between the posts will happen more as the sling rubber wears. I have requested JJP to add this extra magnet time. Not sure if it will be ignored.

If you’re finding the ball is getting wedged at the front left, check that the post is tightened down and not loose. Also double check levels. I found to get a straight level section, the word “CHEST” is the only reference point which is straight. Line you spirit level up with the top of these letters.

#1486 5 months ago
Quoted from Maurice:

To solve the sdtm drain from the map hole: replace the 4 posts near/in the map room with 4 double starposts. Rubbers will wear less and the ball cannot get stuck between the post and the rubber.
Only downside to this is that the open space between the posts becomes smaller and therefore entering the map hole area becomes slightly more diffult.

I was close to doing this. Then I realised it would make the star map entrance 8mm narrower. Stuff that!! It is a solution though. Could be done just on the front left like I was thinking, but still 4mm narrower. Ever played golf where you think to yourself “now just miss that small tree in front, you have all that space on either side....”. I hit the tree every time.

#1488 5 months ago

Not sure if I have a problem with my Maelstrom Diverter. I have noticed the spring does not always pull it up to the top rest spot. Sometimes it’s a few millimetres down. When the ball hits the ramp, most times it pushes the diverter up as it does around. But if it’s a weak ball, it seems to knock it into the depths. Not all the time, but it does happen. Also, I tried to put on the Kraken mod and it pushes the diverter down so that the diverter is no longer at maximum height. With the Kraken on, the ball does not have enough clearance underneath. I could try to move the whole diverter down a few mill but this may cause other problems. Bit stumped.

Can send pictures later. Playing now. Without the kraken.

#1490 5 months ago

Just checked with ship not attached to motor. Ball on my magnetic thing does not touch said bracket. Why are you pushing against rail? There is no give in mine whilst installed with plastic on top.

056FFA43-0A69-4431-9E7D-939858C3EDE8 (resized).jpeg
#1492 5 months ago
Quoted from harryhoudini:

Hum, I'll put plastic on and check. I'm pushing like I think the ball would. The ball guide is pretty thin compared to my Jurassic Park, for example. It's not supported in the middle so it flexes. I'll see if plastic changes it.

Nope plastic does nothing. But there is a screw in the rail about 2 inches before it. You must be pressing pretty hard. Also inner loop misses that spot. Only hit from open sea or port royal.

image (resized).jpg
#1494 5 months ago
Quoted from GnarLee:

Kicking the ball around sooner will not solve the issue. It will make it less likely to happen yes, but the whole game is based around doing chapters. You should NEVER be punished for a shot that is required for progression when you have to hit the shot 25 times in one game (to complete all chapters). It is not like it is a risk vs reward thing. The risk vs reward is the qualifying of chapter. Some that come to mind bricking malestrom shot or DT and hitting 4x and goining straight down I lane. Trying for left flipper chest shot hitting right lock stand up and sdtm. Tortuga can be risk reward as anything up in the pop can go bad quickly. Even if they decided they wanted to compensate by making the chapters harder by adding more characters to them there needs to be an optional ball save on starting chapters. Its not a tight shot but not sure i want to make it smaller either. Its such an easy fix

I agree! Was just trying to find alternatives as there are a few on pinside who keep telling me it never happens and/or ball save is not necessary. Good to see someone talk some sense into me. Ok back to a ball save, just like we have for Multiball. Thank you!!

#1499 5 months ago
Quoted from Zora:

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.
Any idea, what is going wrong here?

You sure you have not advanced the Pearl by doing the BP skill shot? That advances the Multiball.

#1501 5 months ago

To tell you the truth I have not used that skill shot for ages, so my memory is a bit rusty. Just remember I used to not be able to hit the dauntless until I changed the hex spacers. Until then I think I was confused how I was starting the BP Multiball without sinking the dauntless. It could be this simple or something else.

#1508 5 months ago
Quoted from harryhoudini:

Following up on this, here it is with plastic in place (does nothing) and with very little pressure. The ball hits the bracket just slinging it along on its own. I tried to move the ball guide as far out as possible and it still hits. This seems VERY likely to be the reason why the ball diverts into the BP on clean, strong shot.
Video https://photos.app.goo.gl/Y3DggZhyeBHzHexA6
Anyone want to comment? I am going to remove the bracket and dremel off the tip (moyle!) when I do the same to the t-nut in the map hole today.
[quoted image]

Mine was already slightly ground. Whether that was from the ball hitting it!

As I said I don’t think this affects inner loop shots just the 2 orbits.

#1513 5 months ago

Will definitely do it later on. May even be able to get to it without stripping down completely. Will check when replace rubber in star map.

Quoted from wesman:

I have to think this is a solid chance of many having hit issues. I know I've always heard a click on the loop shot, and felt momentum gets lost some. This would completely explain that.
I noticed the tnut when I'd installed my Cliffys, wondered what that was, didn't catch this one at all.
This is genuinely starting to get very, very unpleasant....

Just be clear, this does not affect inner loop. Just open sea and port royal. It could be yours never hits, it may be a case by case. Mine looked like it was ground already. It is probably a good idea to grind it down like Harry has when working under the pearl.

#1514 5 months ago
Quoted from harryhoudini:

Did you give the ball some pressure (the momentum it would have when hit with a flipper)? The ball guide easily deforms, the ball's inertia surely is enough to deform it enough to hit the bracket. There is no other explanation I can find as to why solid hits on an outer loop ball go in to the BP when they aren't supposed to.

Yeah, does not affect the inner loop. Still not sure what the issue is there.
Ground down... https://photos.app.goo.gl/KaoNooQpQG1LWWQi6[quoted image][quoted image]

Well the other explanation is s/w! What shot do you believe it is Open Sea or Port Royal? It is more the inner loop that goes to the pearl more than I think it should. And I think Keefer is adjusting this in code?

Port royal does go up there a lot by design and I think the force of the ball would be lessened at this point being near the end of the loop. Also the inertia would mean it would have to bounce backwards. Just thinking a strong ball on that trajectory if it was strong enough to deform the metal is not going to do a 90 degree turn into that hole. I have had the diverter down on the maelstrom and when the ball is strong enough it happily runs along it, skips across the hole to the other side and continues down the ramps wireform.

I think a small protrusion like this is going to nick the ball and divert slightly of its course then back onto the orbit. Don’t think it would make it do a 90 degree turn. For either outer orbit.

Think it’s software.

Agree to grind the bracket down whilst you’ve got the pearl off.

#1515 5 months ago
Quoted from gumnut01:

Well the other explanation is s/w! What shot do you believe it is Open Sea or Port Royal? It is more the inner loop that goes to the pearl more than I think it should. And I think Keefer is adjusting this in code?
Port royal does go up there a lot by design and I think the force of the ball would be lessened at this point being near the end of the loop. Also the inertia would mean it would have to bounce backwards. Just thinking a strong ball on that trajectory if it was strong enough to deform the metal is not going to do a 90 degree turn into that hole. I have had the diverter down on the maelstrom and when the ball is strong enough it happily runs along it, skips across the hole to the other side and continues down the ramps wireform.
I think a small protrusion like this is going to nick the ball and divert slightly of its course then back onto the orbit. Don’t think it would make it do a 90 degree turn. For either outer orbit.
Think it’s software.
Agree to grind the bracket down whilst you’ve got the pearl off.

#1518 5 months ago
Quoted from GnarLee:

Nice work gumnut. I have noticed the same thing on inner loop shots. Good ones getting sucked to bp or coming out with no speed. I’ll bet I have the same issue.

Not me! I think you mean Harry. He has been a busy boy at the moment.

#1520 5 months ago

There’s one on the black pearl rod that sticks out the back of the playfield. Just before the pin goes in from the vertical straight that comes from the motor. All behind the playfield. Probably dropped off the rod when you took the black pearl out.

Let me know if you need me to pull the playfield forward and take a photo.

#1534 5 months ago
Quoted from jarozi:

Problem: Load cannon door doesn't fully open or close. When closed, some shots still go into cannon while some shots are rejected when door is 'open'. The difference between open and closed was so subtle on mine that I didn't notice the door opens only when the ball is on the upper playfield and closes when it leaves.
Solution: Bend cannon door up-stop up to allow greater range of movement (see pic). You'll have to play with it a bit to find the right spot for an improved range of movement.
[quoted image]
Here are some pics after making this tweak...
[quoted image][quoted image]

Awesome! Thank you so much! Just thought this was normal.

#1570 5 months ago
Quoted from kcZ:

Thanks... Explains why the 6.3v light that I swapped in popped so quickly. Now to find a 12v bulb in my stash.. That and make darn sure the original was bad but I'm awfully sure it was.

I did that. It smells nice doesn’t it!

#1585 5 months ago
Quoted from Trooper11040:

I lifted my PF up and noticed this little piece of wood is missing on the left side. Is that normal?[quoted image][quoted image]

I have that too. I thought “huh?” Maybe it was something that got dropped from then prototype.

#1586 5 months ago
Quoted from JustLikeMe:

2. The left ramp is kinda clunky - even with the lower right flipper power down, at least 50% of shots hit the diverter even when it is in the up position and go into the whirlpool. When the diverter is down for multiball start, the ball goes into the whirlpool but at an angle so it doesn’t really spin like it should, which leads me to think they I need to adjust the position of the diverter mount. Could anyone share a top down pic of their maelstrom diverter so I can compare?

Is your table levelled? Also make sure a ball can fit under the diverter so it is touching the wall of the maelstrom all the way round. If you have the kraken mod you may need to pack it up slightly so the ball will be able to clear.

#1587 5 months ago

Installed my pearl opto shield supplied by JJP!

672EC60E-A7ED-49B2-9FDF-500B8709EE95 (resized).jpeg
#1603 5 months ago
Quoted from Soulrider911:

gumnut01 I’ll see your opto shield and I’ll raise u an old Disneyland hotel room key and some target foam, granted yours is much more professional
[quoted image][quoted image][quoted image]

Nice!!!!!! Yours is definitely more special!

Quoted from Trooper11040:

I tried to remove the ship and had a tough time lol...might have to try again tomorrow...

My t nut is only showing a bit through the wood on the wall. Nothing extending under playfield and the deflector seems to hit first as you say. My balls are nice and shiny!!! Definitely think it will depend on how you nut sits.

#1604 5 months ago
Quoted from Blackzarak:

Any specific tweaks needed from a new out of box POTC that I need to do?

Make sure no sdtm on ball launch. Adjust upper left flipper if it does so that ball launch will hit middle of right lower flipper. Turn down ship VUK to about 20 to protect your optos and or make a nice protector like other poster. Make sure everything level and at 6.5.

If you struggle sinking ships you may need to add shorter hex spacers. Anyway check the start of the troubleshooting thread. vireland has a great index going.

#1606 5 months ago
Quoted from Schabs81:

I just changed my balls out after about 400 plays looked pretty rough might have to address that tnut in map hole as well

Also the washer on launch and the orbit has an angle that sticks out a bit.

#1608 5 months ago

Yes they sent me a new opto and the protector. I think you are about the seventh person on pinside to report it. Everyone turn their black pearl VUK down. Ask for a shield as well

#1610 5 months ago
Quoted from zaphX:

There is a lot of hysteria on here about the map hole nut. I personally would not mess with it, risking messing up a 10k game over a 50 cent ball.
I also don’t recommend changing any coil power from default (including the Pearl VUK) -unless- you discover a problem during gameplay.
Having set up 3 of these things, these are the things I found need checking OOTB:
1. Adjust the Pearl ramp adjustment screw until the ball rolls off the top to the right. Stuck balls here are common until you do this. Do not over tighten.
2. Confirm the shooter is working cleanly and does not catch against the autoplunger. See index for fixes if so.
3. Go into switch test and hit all the switches, confirm none are stuck closed and none fail to fire when hit.
4. Run the ship test and confirm the Pearl runs freely without topping/bottoming the slot and gets down to a single digit score as its lowest value. See index for fixes if it’s not.
5. Clean the playfield (sometimes there’s a little shop dust.)
All this will take about 10 minutes. At this point just play and enjoy your new machine!
IF you run into issues, check the index on this thread for help.
I do not recommend reading every single item and worrying if you have the fault or not.
I also recommend two preventative maintenance items but you should NOT feel compelled to avoid playing on day one.
I didn’t do these items for months after unboxing.
1. Plastic wire loom on the wire behind the Dauntless (it can rub and cut)
2. Plastic wire loom on the wire under the Pearl (it can rub and cause a short)

zaphx why do you continue to tell people not to turn down the black pearl VUK? You have seen evidence that the default setting breaks the opto. Just because it has not for you does not mean it is not for others. The advice is to turn the pearls VUK to the lowest setting that reliably gets the ball onto the ship. If you set it too low and it doesn’t then turn it up until it does board successfully every time. Mine is set to 20, boards every time and does not leave dents in my upper deck nor smash into the optos anymore. Over 5 pinsiders have reported broken optos caused by the default VUK setting. But you continue to tell people not to turn it down. Why? Does not make sense.

If you need more proof here is a email from Steve:

“Might want to turn down the coil setting for the Black Pearl VUK as that seems to be breaking the opto housing when turned up too high according to the Design Team. Thanks, Steve”

#1611 5 months ago

Other coils to adjust:

1) if your slings are causing air balls turn them down to minimum setting. Particularly if you are now using star posts around your slings.
2) if a kick out from the depths is getting caught on the “I” lane, turn it down 1 point. Just be careful that it still kicks out.
3) if your balls are launching out of the maelstrom you may want to turn down flipper strength by a point. Be careful as you still want to be able to backhand to the pearl.

I understand zaphX’s sentiment that if it ain’t broke don’t fix it. Changing these coils for no reason by large amounts will make the game play differently than it was intended. As mentioned though even JJP admit that the default setting for the BP VUK is too high in most instances and is causing upper playfield and component damage.

#1648 5 months ago

Funny thing while we are mentioning what we do and don’t do. Have not waxed since I own the game. AFM waited a year until I did it. Other games maybe once a year. Don’t see the need.

#1659 5 months ago

I’m struggling with this spotlight. It is either pushing up the launch ramp if too far to the right or trapping balls beside tortuga Tom. And it goes out all the time from the vibrations. I think I need to take launch ramp off and bend the angle plus maybe put some washers underneath.

This is the culprit. Anybody else had similar issues?

FFC7D8FB-2F8A-4F73-82F2-C86418ADAF1C (resized).jpeg
#1661 5 months ago

bloody stupid place for a spot.

#1666 5 months ago
Quoted from Yelobird:

That was the First issue I had out of the box. Ball got stuck every hit towards the spot lamp. I ended up rotating it full towards the back and the plastic slightly lifts it up and no longer a ball catch. Its the simple things that can be frustrating. lol

Thanks. I tried this before and it lifted the ball launch wireform. Now I have launch issues for the first time. Ball hardly makes it around orbit.

#1669 5 months ago
Quoted from zaphX:

I spent a lot of time (months) troubleshooting ball launch and autoplunger issues and finally resolved them 100%.
Here's what I did (and all of these had an effect):
1. Check your shooter tip and replace it if torn or flattened due to use.
2. Make sure the plunger doesn't contact the autoplunger. If it does, adjust the shooter housing down. Still doing it? Put some kind of padding under the playfield hooks. I used dense weatherstripping foam.
3. Make sure the shooter lane is aimed into the orbit just right. If it's too far left or right, you'll get a ball rattle that robs power.
4. Finally, make sure the shooter lane wireforms are even with each other. In my case, a slight "bump in the road" on one side was causing autoplunge failures even though manual plunges were fine.
After doing all of this, my plunges are lightning fast and rocket around the orbit - I have to use a very light touch now for the skill shot In addition, autoplunges are now 100% reliable.

Thanks zaphx. Did not think I had an issue until this damn light but maybe I do. Will check. Auto plunge is quick.

Quoted from tgrinchy:

When I moved that light straight back, the ball would hit the top of the lamp under the wire form so I moved it back to stock position. interestingly enough, I haven’t had a ball get stuck there (yet)

Yep. That’s what happened to me. But also I get the stuck ball when move it back. Funny watching it go out every time a ball would shoot past it. I have not experienced that many problems really, but I think JJP could have put better spots in. Just my opinion.

#1672 5 months ago

Fixed the spot. Just got my long nose pliers and bent the thing up a bit. Now in the right spot and does not hinder the ball. Also light is not touching ramp. No more flickering and turning off.

Thanks zaphx it was simply the new tip I put on which was a beige colour so I could see it for skill shots. The tip is slightly pushed off centre. Rotated the rod and works fine now. Will keep an eye on it. May need to go for a more durable tip.

Love the game. Makes me cranky when something goes wrong with it though!!!

Here’s a picture of the bent spot mount. Only needs a little. I think it’s good mounted pointing towards Tortuga. Otherwise it’s pointing into open sea. I like that to stay dark and mysterious!

4D6D6007-30BF-4E60-89D8-099B0B57BD92 (resized).jpeg
#1675 5 months ago
Quoted from zaphX:

This is controversial since half the people in here preach to decrease it, but I'd try carefully increasing the VUK power until it stops happening.

Sounds like it’s not even getting to the VUK as soulrider911 would hear it fire. But I agree with you. Don’t want it too low or no black pearl action. It’s finding the spot between boarding successfully and not bashing into stuff up there.

I have had large delays on rare occasions when it is not boarding or doing anything. This happened all the time when I first got the game because it was not levelled correctly. Too high a pitch will mean that the subway to the black pearl does not work. I have to check whether I have anything that could stop it rolling in the subway.

Yours sounds like it isn’t even making it into the subway. Like the magnet is catching and then releasing back to the open sea. How are your levels? How often does it happen? Would be good to see if you can replicate it.

They definitely do need to adjust how that magnet works in terms of affecting inner loops.

#1676 5 months ago
Quoted from harryhoudini:

I think he's saying that the magnet in the loop doesn't drop the ball directly down to the BP VUK, almost like it misses the VUK and rolls around the inner loop. It doesn't sound like the ball makes it to the VUK coil. I've had that happen on mine when it is was down too low and you can definitely hear the VUK "bang" when it kicks the ball, but it doesn't make it to the top, comes back down and hits the gate and rolls out the loop. If that is what is happening, yeah, increase the VUK power. If not, that'd be a different issue.
And yeah, the issue I brought up prior was the ball getting kicked in to the BP but (what I feel) is without the magnet grabbing it (just getting directed to the VUK by some other force). I could very well be wrong, hard to know exactly and I've found what it seems like could be a few culprits (backboard bracket, opto cutouts, maybe a flexible ball guide, maybe too much flipper power, etc) could be my inexperience. It seems I am in the way minority, so likely either me or an isolated case.

Damn. You beat me to it.

#1678 5 months ago

Just changed my isolator. Made things worse. Now I get a high pitched whine when it starts up. And the pops during gameplay are still there. Would be great if this clipping or popping could be fixed. Alas I don’t think there is any solution.

Here is where I put the isolator. If anyone can tell me what I’m doing wrong, appreciated. At the bottom of cpu box going in green socket . At the top of the box going into purple socket . I think this is for speakers. Or am I doing the head phone one?

Before, isolator behind right speaker
0D9B35EB-336F-4926-95D3-775BB1B51453 (resized).jpeg
After
02617897-9FC0-4276-B814-664EDB960DC4 (resized).jpeg
Where I am plugging from, then to green socket at bottom of cpu
380ED8AB-C478-43AC-91F5-9505A3C26932 (resized).jpeg

#1680 5 months ago
Quoted from vireland:

Which ground loop isolator is that?

Mpow. I thought the one that came with it might be responsible for the clipping. About to change back unless I’m plugging into wrong spots for speakers. Never use headphones.

#1681 5 months ago

The one it came with is this

image (resized).jpg
#1683 5 months ago

Bugger. Will put the other back. This new one added whine that was not there. Was hoping it would fix clipping in game. Shame to have this happen during one of the best game soundtracks ever. It’s like putting shitty frosted glass over a Monet.

Anyway, is the green socket the right one? Can someone confirm?

#1685 5 months ago

Thanks Harry. Can Jjp do anything to clean up musical score? So no clipping I mean.

#1687 5 months ago

He loves his pinball! The other day he was walking across my other 3 pins upstairs. Walking confidently on the glass he did not realise Simpson’s in the middle did not have the glass on. Funny seeing a cat get a shock when they “miss the last stair” sort of thing. Cats are funniest when they’re not composed.

#1689 5 months ago
Quoted from vireland:

Yes, just manually re-balance the levels between music, fx, and speech so if all are going at the same time it won't clip.
One day JJP will do this in software-it's relatively trivial, but maybe there's some linux-specific programming hurdles I don't know about. It's shocking clipping is still a problem on game 4.

Ok will play with. Did a search can’t see anybody has found a sweet spot like you posted with the lcd contrast levels. If someone had some settings they used would be great to post. Should be the same from game to game. It at least a starting point.

#1691 5 months ago
Quoted from vireland:

PROBLEM: Screen appears washed out and colors fail to pop.
SOLUTION: Remove the backbox glass. There are two wooden latches that hold the monitor in place; loosen and twist them out of the way. Then lift the metal latches to the left and right of the monitor to pull it out. It’s on a reticulating arm so this is simple. Monitor adjustment controls are on the back. On the brightness and contrast page set DCR to ON, and set the color page to sRGB.
This setting is not infallible, however. To get a good picture on another machine DCR had to be set to OFF, brightness to 50% and contrast to 100%. Color sRGB.
Pinsider ronaldvg found good manual settings:
"I tweaked the settings of the monitors (DCR Off, Brightness 41, Contrast 50, Color setting on USER R50, G50, B50) and they now look exactly the same, much less washed out. If you look in the attract mode of POTC there is a screen with just the number of the LE, rest is black. Make sure that screen looks as black and the lettering as white as possible."

Well you were the one who posted this. I found it useful. So I have to choose which to sacrifice music, effects or speech. Ok will give it a go. Sort of sucks.

Sorry. Not being unappreciative, I know it is a personal thing as to what to sacrifice. And I need to work it out myself. Just don’t want to sacrifice anything!!

#1695 5 months ago
Quoted from vireland:

If you balance the sound, it's no sacrifice. Just takes time to get it all balanced just right and it still sounds great.
When this thread started, I posted about 20 or so tech issues that were just collected from the input of others, so even though it shows I posted the screen tip, it's not my tip for most of the "starter" ones that I bulk dumped to get this party started.

Turned music down to 50 and everything else down to 20. Still pops and crackles at specific times. Especially during bonus screen after ball is drained. Volume also only on 20.

I don’t understand. Maybe what I am experiencing is not clipping.

So I don’t have an answer. Will contact JJP support and let you know what they say.

#1698 5 months ago
Quoted from vireland:

Something else is going on. Your levels are way below what I have here. I don't think it's clipping.

So no one else has the pops and crackles (like small little interrupt hiccups) happening at certain times in the audio?

#1700 5 months ago

Here is the audio pops. Music 50. Everything else 20.

<iframe width="560" height="315" src="https://www.youtube.com/embed/DsRvb9iHVTY" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

#1701 5 months ago

Here are my audio pops. Music 50 all mix levels 20.

#1703 5 months ago

I tried to test also using the headphone jack at the front and only getting left channel. Maybe I knocked a wire out near the coin door. Normal iPhone headphones should work shouldn’t they?

#1705 5 months ago

Yep I will try. Hey thanks so much for listening to my pops and crackles Harry. Good to know it’s not normal. Hope I get a reply from Jjp soon. Will let u know what I find out when I use the connection to the green socket.

#1708 5 months ago
Quoted from Mr_G_Hosting:

I did have the frustrating audio pops.
Solved it by unplugging this connector.
My headphones don’t work anymore but the sound over the speakers is crystal clear now.[quoted image]

Thank you!!! Just finished doing this same fix that Steve from support sent me. Thank you for posting. Sounds so good now!!!!

I guess I have no headphones either now..... oh well. Will let you know if they send me something to fix the headphones.

#1710 5 months ago

Since I adjusted my tortuga scoop, it seems to be going back to closer to between the flippers rather than middle of left flipper. I think the problem is you can’t get the deflector down tight enough. Took it off, and noticed rippling around the metal plate. Now a cliffy May resolve all this, but I hopefully solved the moving tortuga once and for all.

1. 2 neoprene washers to grip to the playfield and cover my ripples
2. 2 m6 star washers under the screws to stop them from loosening and the plate from moving

I do have a bit of the washers showing now, but if my tortuga kickouts don’t creep over time, I’m happy!

053321BB-6A53-4553-A3B0-D57850F9DC9E (resized).jpeg1D81D8EE-319B-4C9C-BF13-306960626AB4 (resized).jpeg85B20700-9EAF-480C-A841-DADFACC36DAA (resized).jpegD1BA5434-9F9B-498A-9BE0-B0C9D03D26B5 (resized).jpeg
#1712 5 months ago

Yep it sticks to the middle of the left for now. If it progresses back to the very tip, I will let you know. Hopefully the rubber pushes the wave down a bit and stops it from chipping. Maybe star washers alone will fix your diverter from creeping, your cliffys should protect what’s happened to me I guess.

#1723 5 months ago
Quoted from wesman:

I only heard about that opto protector after picking up HH's wicked Pearl door. Figure I'll use that instead.
It looks good, doesn't it zaphX?

Huh. Harry has favourites. I see.

#1750 5 months ago

Noticed that ramps are attached by screws but not at the bottom of the ramp. So where screws are there is space between ramp plastic and playfield. Would have thought this creates stress on plastic since it is being pulled down by screws but not being supported at that point. Has anyone added support under ramp where screws are?

image (resized).jpg
#1752 5 months ago

I dunno. All the ramps on my other games, the screw is right at the end of the ramp. Not 10-15mm from the bottom. Maelstrom only has one screw. Anyway.

#1774 5 months ago
Quoted from jarozi:

Not sure if it correlates to score at all, but when I set the GC score at just over 2M points, I got the hat and patch on my pic. Just a coincidence I think as I haven’t seen anyone else mention that. Only time I’ve gotten both.

Nope had shit scores with both. Have not seen a parrot. Or a carrot.

#1787 5 months ago
Quoted from harryhoudini:

It's not a wear issue, it's a design issue. If the latch keeps hitting the opto it's going to break. The latch shouldn't hit the opto. No one should need to make a replacement part for a part that gets hit with a latch that shouldn't hit it.
Open
[quoted image]
BANG Closed
[quoted image]

Have you reported to JJP?

1 week later
#1818 4 months ago
Quoted from Heater:

yay!......again

I just removed mine for first time today. Removing was fun. Getting back on was funner. I liked the buffalo video where his tip for getting it off was to “jiggle a bit”, followed by his tip to get back on was “I don’t have any tips to get it back on”.

Good luck!

#1827 4 months ago
Quoted from 3pinballs:

getting it back on so that both pins go through the holes is done by making sure the playfield is parallel with the lower playfield....then it goes in pretty easily.

I found I had to remove the ramp as well, the front right plastic of my pearl sticks out some what. The VUK doesn’t make it easy either. It scratches up against my opto shielding. Another reason why people may have damaged opto wires.

#1829 4 months ago
Quoted from Heater:

Awesome response by JJP. New opto being mailed. Anyone have any tips on replacing it?

I haven’t done it was able to save what I had. The plastic was broken not the wiring. Yours comes with a plug. Basically go into your switch tests and the manual and identify which colour the faulty one goes into on the opto board. Mark that colour on your replacement plug. Then try doing this:

Remove any upper deck mod and unscrew the broken opto. Cut any cable ties on the wiring harness. Attach new opto plug to broken opto with tape. Feed broken opto with new plug attached through the playfield from bottom helping to feed it by checking under pearl.

Hopefully you can get the new opto through without taking BP OFF. Plug in the new one into the colour you looked up. otherwise remove BP. make sure you put another cable tie on.

#1831 4 months ago
Quoted from harryhoudini:

Mine were cable-tied between the BP and under the playfield. Hence having to remove the BP.

Thought you could snip from the left side. That’s why I said see if you can remove them. If not then yeah remove the BP.

#1847 4 months ago
Quoted from statsdoc:

Interesting. I never had this problem until I replaced the posts with star posts from JJP's replacement kit, which I think are thicker than the original posts. Might need to just try to stretch them out a bit.

I documented in the chipping thread. Besides using double star posts you need to dremmel the lower groove of the post so that the rubber will sit nearly the same distance from the bolt as the original post. I have not had it happen again. You also need to do this on the side facing the “A” lane or the ball can be hindered by the star post and that stupid big rubber post. It’s a bit of a pest, but the sling covers the alterations to the post.

#1849 4 months ago

Change the rubber to left post or remove altogether.

1 week later
#1876 4 months ago
Quoted from vireland:

The pirate hat and patch seems to be reliant on the shape of the face in the picture. I've NEVER got it with my rounder face, but people angular faces and faces with chin down a bit seem to get them more frequently.

I have a t-shirt with Jermaine’s face from Fotc. The game once put a hat and patch on him. Missed my face altogether. Maybe it’s done on beauty?

#1898 4 months ago

People will start posting their BP removal times rather than their HS.

#1921 4 months ago
Quoted from 3pinballs:

My left slingshot twice now has had the rubber go over top where the slingshot is stuck on outside of rubber......any idea how to fix this or is your nut inside sleeve work for this.

Stock posts or star?

#1923 4 months ago

Hmmmm. Ok. Try turning slings down to minimum and put the replacement titan slings on. Maybe yours have been stretched. Also try perfectplays.

#1925 4 months ago
Quoted from 3pinballs:

My wife was playing and ball got stuck on upper playfield.. after looking it was the spotlight that was hitting the ball and top or the right flipper.
So added a lock washer with Blue Loctite, then still had to bend up the metal so that it didn't hit. I added the washer as to not have to bend the light up too high where it didn't hit the back of upper playfield...so now light is still directed down like it was intended to.[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

You threw me with the WOZ photo

#1934 3 months ago

There is a problem with multiple balls going into the depths. They get stuck because the subway plastic before the depths kicker is stretched by all the balls in there and they block each other’s entrance to the kicker metal enclosure. They get stuck. So you need to narrow the plastic subway slightly, by adding a post next to the subway pushing the walls in slightly.

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/3#post-4941279

I actually just asked JJP support for the post and screw. They know if this problem.

1 week later
#1986 3 months ago
Quoted from splitcms:

I’m not even sure if the VUK is the issue. The ball is just going there and not doing anything. I have a feeling that the ball shouldn’t even be going there because it happens at the start of a game when I shoot the left orbit. Instead of going around to the right orbit and back down, it’s falling into where the VUK hole is and not doing anything

Check your pitch. The subway does not work if the pitch is too steep. Happened to me when first got the game when pitch was about 8. Take it down to 6.5 and it should work.

#1998 3 months ago
Quoted from vireland:

You put mylar over mylar? There's already mylar on the Black Pearl there from the factory...

Mine didn’t.

#2003 3 months ago
Quoted from vireland:

The problem is, that contact point is one of the supports for the ramp. Without it, you're putting much more pressure on the connector on the opposite side near the top. I ended up 3D printing a support to help the left side. The support system for that ramp is really poorly designed IMO.

Do you sell this? My ramp was cracking, so I removed the metal plate underneath and fitted a gummy on top of screw. Could not wedge gummy in whilst decal metal was there. Now I am getting the odd airball off the entry gate at top of ramp. Not sure why, flipper power, me removing the plate and adding gummy or tightening down screw on right side. It is a crap design and JJP need to send out a support fix to everyone. Maybe I will raise it....

#2004 3 months ago
Quoted from bigd1979:

You think im stupid lol.. it didn't have any there which i thought was odd considering everywhere else did and that area gets hit alot.

Yep I was dumbfounded when I didn’t have it either. Was the same time I discovered that the VUK was breaking everyone’s optos.

#2006 3 months ago

I would be interested. As long as it does not change the dynamics of the ramp, sounds like a winner.

#2012 3 months ago
Quoted from cheshirefilms:

Those factory metal washers aren't a good idea and are known to cause ripples. Switch them out to the service pack ones when you have a chance.

Be careful. Sometimes the metal washers have set into the clear, unless they come up freely, leave them alone.

#2016 3 months ago

These spots are really annoying. I have tried the electrical tape fix. I have tried taking them out and putting them back. Still they go on and off all the time. Really annoying. My distro sent some other 12v bulbs to try. Will give them a go. Can’t understand why they could not get the spots to work. The hot glue they used makes things worse.

#2017 3 months ago

Replaced them. They were falling apart in my hand. The new ones seem ok. Think this is the only solution. Pretty rotten the spots they used.

#2020 3 months ago

My shooter was losing power, the old auto plunger collision. So I had to shim the playfield up a bit. Why all of a sudden has my playfield sunk? Is this playfield too heavy and is it going to sunk again? Now after raising by a mm, the lockdown bar is becoming super stiff. This machine is constant fun....

#2022 3 months ago
Quoted from PinballTilt:

I'm confused. If it's the auto plunger shimming wouldn't help as the auto plunger is attached to the playfield and would sink with it. If you're talking the regular shooter, perhaps your receiver screws aren't tight to the cabinet. Or the shooter screws aren't tight. This game isn't exponentially heavier in the lower right corner to make me think it's different than any other game

The auto plunger on the playfield is lower so it hits the plunger. Raising the playfield slightly lifts the auto plunger out of the way. There is a fix in this thread. There is no movement in the plunger and I never had this problem until now. Maybe lifting and lowering playfield so much has bent the metal tabs, I’m not sure. Anybody else had this start to happen when it did not happen originally?

#2032 3 months ago
Quoted from vireland:

The hang brackets bent just a little on our jjPoTC causing this. Same problem as on Dialed In and Hobbit, too, but much less frequent. Supposedly the brackets were harder for jjPotC, but they still seem to bend. I wonder why they don't have supports on the inside of the playfield to help bear some of the weight? Maybe those would damage the cabinet? I dunno...

Thanks Vireland. Hopefully does not drop further down again.

#2036 3 months ago

Can you send a photo?

Promoted items from the Pinside Marketplace
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 28.00
Playfield - Toys/Add-ons
The MOD Couple
$ 25.00
Playfield - Protection
Pinball Mod Co.
Wanted
Machine - Wanted
Flagstaff, AZ
$ 28.75
Playfield - Toys/Add-ons
The MOD Couple
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 38.00
Playfield - Decals
Pinball Mod Co.
Wanted
Machine - Wanted
Flagstaff, AZ

You're currently viewing posts by Pinsider gumnut01.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside