(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

8 months ago



Topic Stats

  • 2,349 posts
  • 135 Pinsiders participating
  • Latest reply 14 minutes ago by vireland
  • Topic is favorited by 98 Pinsiders

You

Linked Games

Topic Gallery

There have been 437 images uploaded to this topic. (View topic image gallery).

Install_Picture_Kicktap_sml (resized).jpg
kicktap_sml (resized).jpg
Install_Picture_Kicktap (resized).jpg
JJP_mobo_buttons_sml (resized).jpg
fix-dead-jjpotc-H110_mobo (resized).jpg
fix-dead-jjpotc (resized).jpg
IMG_1901.jpeg
Screen Shot 2019-11-30 at 6.52.53 PM.png
1B7C8008-D057-4BB4-8D38-23634CFEAB94 (resized).jpeg
reset motherboard (resized).jpg
jumpstart (resized).jpg
20191128_210803 (resized).jpg
moboreset (resized).jpg
IMG_20191128_194814971 (resized).jpg
B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg

Topic index (key posts)

3 key posts have been marked in this topic

Post #306 Tip on removing the black pearl Posted by rs812 (7 months ago)

Post #501 More tips on removing black pearl mini playfield Posted by LTG (7 months ago)

Post #1776 Broken trunk mount bracket picture Posted by Soulrider911 (5 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider eaglepin.
Click here to go back to viewing the entire thread.

#414 7 months ago
Quoted from doghouse:

I thought I had seen this mentioned on one of the JJP forums, but now can't find it. Does anyone else have an issue with their lockbar gold button getting stuck? Makes getting gold in the game almost impossible as it seems to happen about 30% of the time for me.
Definitely the switch is the culprit. As you can see in this video (https://www.dropbox.com/s/xohn5il2rdjvpk2/JJP-PiratesLockbarButtonSwitch%20-%201.m4v?dl=0) the switch has side-to-side slop which causes it to bind up on the button's activator tip (i.e. the Philips head screw). Do you think JJP will replace the switch for free? Or is it better to replace with a more robust one? The existing switch seems way too flimsy for the duty cycles it's going to get from the lockbar button.
[quoted image]

I had the exact same issue. Here's a link to my post about it. I like the glue idea from LTG though. Seems like that would eliminate the side to side play causing the narrow switch metal to catch on the screw head.

https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/133#post-4919171

3 weeks later
#1094 6 months ago

Anyone know the correct/safe way to remove these rubbery connectors on the plastic protector that's over the starmap running alongside the chest? I'm trying to put in the PinballLife ship protector to keep balls from getting trapped under the Pearl, but I'm not seeing how to correctly remove these two rubber connectors and I don't want to force anything and break them. Thanks.

POTC Plastic Protector (resized).jpg
#1110 6 months ago

Anyone have an issue with this washer on their shooter lane? I did a cleaning yesterday and for the first time noticed this washer sits on the wireform and is pretty chewed up from balls launching. My wires & launcher have always been straight so I'm thinking this is likely the reason auto launches have sometimes lost momentum and not made it out to the playfield. I think they're hitting this washer, hopping up & hitting the top of the wireform, and then stalling. I'm thinking about just removing the washer now.

POTC Shooter Lane Washer (resized).jpg
#1112 6 months ago
Quoted from Axl:

Just loosen up the nut underneath a bit, then move the washer to the left. Problem solved.

Ha ha!!! You mean do it the easy way? I'm kicking myself for not thinking of that on my own. Thanks!

#1115 6 months ago
Quoted from Yelobird:

Or, you can start a catastrophe washer thread with thousands of the same solution! lol JK!

Dang it!!! I already went ahead and slid the washer over. A new thread would have been much more interesting and fun

#1122 6 months ago
Quoted from wesman:

I don't have one either.
[quoted image]

Thanks for posting that picture. That's interesting, the artwork is a circle around that area like they're expecting a washer to be there but obviously they've changed their minds. Mine was built in Nov. I thought about removing my washer, but the risk/reward to doing that seems too high. I'd think the likelihood of having that ball guide dig into the playfield would be higher than any issue from having the washer nudge into the shooter lane. I was able to scoot my washer/ball guide over just a fraction of an inch so it seems like it's clear enough of the shooter rail now and the good news is it hasn't prevented Davey Jones Locker saves from happening.

#1217 6 months ago
Quoted from zaphX:

It looks like I am starting to see a bit of wear on Tortuga so I'm going ahead and getting Cliffys.
For the folks who have installed them - did you remove any mylar before doing so? Would like more info.

Has anyone tried using nail polish hardener to prevent chipping at scoops and holes? I remember a post from the club thread a long time ago and I've had it in the back of my mind for awhile. I'm thinking of applying some around the edges of the map hole and Torguga scoop to prevent chipping. Just wondering if anyone has experience with it and if it works. Here's the post from awhile back:

https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/35#post-4733211

2 weeks later
#1479 6 months ago
Quoted from joseph5185:

Hey guys,
So my friend is playing the hell out of this game...which is awesome!
A couple new issues and I'm sure these are all documented, but I just like to note it:
1) The VUK sometimes isn't kicking the ball up to the ship.
2) The post has stopped working when starting a new chapter.
3) The BP stopped moving for a bit and then started again. This seemed to occur only once when he achieved a score of 600k so I'm not sure if this is by design as maybe it's overheating or idk.
Thanks guys! =)
Update:
1) The VUK is still doing this. Maybe 1/10 times.
2) The post magically started working again. Haha. Awesome!
3) There was only one occurrence of the BP stopping. What maybe interesting is that the lights on the pearl shut off when this happened.
Back to playing!!

The fact that the lights went out at the same time means it could just be that COTBP multiball was qualified when the ball went up to the ship. For example, if the load cannon arrow is already flashing and you hit the BP skill shot (which advances COTBP multiball progression to the next step), then the lights go out on the Pearl and it calms down a bit because you've just qualified the multiball (the insert by the flippers will then be flashing to show COTBP MB is ready). I think COTBP MB can also be advanced/qualified after a certain number of boardings also, but I'm not sure. Just an idea, but it's definitely possible that's what happened so no servicing needed.

2 months later
#1946 3 months ago
Quoted from Maide:

I'm having an issue with my Load Cannon door not opening. If I manually push on the metal flap the coil connects to, it moves fine and will work for a bit, but then it'll get stuck again at some point. I've also had the spring that attaches to the gate come off twice now, which might be related?
I've tried manually triggering the Cannon Door coil in the tests and it does not open until I push it myself, and then it works fine for a while. Stealing the image from another post in here, the red square is the part that I can push on to make it work for a while, and the blue square is the where the spring is falling off (from the top).
All the parts here seem to move freely when I touch them, and since it works fine after I touch it, it's been really hard to debug. Has anyone had a similar problem or have any insights into what could be going wrong? This has been happening on/off since I got the game. I originally thought it was the metal gate getting caught on the left plastics, and that was a problem until I put a washer in, from the tip in post #1531, but now it's definitely not hitting that.
[quoted image]

I had to do work on my door since it wasn’t closing at all out of the box. I had to bend the main metal arm (that connects from the coil to the spring at the door) to a different angle and I put a washer on, but I put the washer on the right hand side (looking from the front of the machine). Mine was getting hung up only on that right hand side. If your washer is on the left, maybe try moving it to the right? One other thing I found on mine was that the roof above the door was also causing it to stick for some reason. I’m still not sure why or how. All I know is I made my adjustments to bend the arm and add the washer with the roof off and got it working 100%, then when I put the roof back on it would get stuck open again.

I took the roof on and off a few times to retest, and the only difference between sticking and not sticking was the roof being on. So I finally put the roof back on, but didn’t push it down all the way and just lightly put the nuts back on. I set it in with the front of the roof a little higher than the back and it’s worked 100% since then. If your issue isn’t the coil or the angle of the main arm, maybe switching washer sides and/or letting the front of the roof sit just a bit higher could work. Hope this helps.

#1950 3 months ago
Quoted from Galooch:

I think I'm dense with this cannon door thing. I think I'm seeing similar issues but for some reason, I'm not sure. How do I know if the door is working properly? My only clue is that my ball sometimes squeezes under it before "light fuse" is lit and the ball sort of tumbles out of the cannon. Obviously, that can't be right. My door "sort of" has three positions. All the way up (which seems to work most of the time it should, when "light fuse" is lit), partway closed (which is where it lives the majority of my games and when the ball can squeeze under it or get stuck for a moment), and all the way down (which I rarely, if ever see). Is the cannon door supposed to have that full range of motion or should it be in that half-way state? Once I wrap my head around that, I can better piece together what parts I'm supposed to swivel/bend etc.

I think in a perfect world it’s supposed to be all the way down until the load cannon target is activated and then once it’s activated the door would go all the way up to let the ball go into the cannon. In reality I wasn’t able to get it to that point. I spent a bunch of time on the arm that connects the coil to the door spring trying to slightly bend it in different spots and different amounts. Finally I just went with a result that had the door resting down enough where it definitely blocks the ball when it’s supposed to and it lifts up just barely enough for the ball to pass under without making contact. Not 100% ideal but functional. Here’s a picture of my door closed.

4AEC6D45-6650-4469-A70F-6D569136C8CB (resized).jpeg
#1959 3 months ago
Quoted from Galooch:

Thanks for that confirmation. Judging by your picture, it looks like that arm ended up bent further down and to the right (towards the Marty lane). Is that right? And by bending it that way you keep that spring loop on the front edge of that arm? Do you think spring location is the key?

Ditto what Harry said. It’s kind of a mix of getting everything lined up so it works. Not a super well designed mech. I think for me the main factor was getting the slight bend of the arm into a functional position. I found I was really able to get the arm to bend the way I needed it by putting needle nose pliers under it and gently pressing. Here are a couple pictures of my arm and what I mean by using the pliers.

840DB85A-3DBF-413A-B856-B48BEB7FC421 (resized).jpegCF9C487F-F8F1-4851-8AE8-E84FDE9172DF (resized).jpegF44850D4-1A13-4FF1-BB8F-D47BE016CF20 (resized).jpeg
#1963 3 months ago
Quoted from GnarLee:

This. A pic is wortha thousand words. See how his arm is directly in between the 2 lanes. Swivel your arm so it looks like that and you cannon door should work properly. why he has the pliers in there like he is bending something idk. Move arm to middle first then if it still is sticking I guess try to bend.
Edit* His actually looks like it could swivel left a bit. Probly why he resorted to bending the arm

The arm on mine was bent too far down so the door was always open. Pliers over or under the arm created a ledge so I could bend the arm in the middle to adjust it to a spot where it worked. First I put the pliers over it to bend the end up but I did it too much, then had to put the pliers under it to nudge it back down a bit.

#1971 3 months ago
Quoted from jeffspinballpalace:

Having undefined issues with JJPOTC and can't figure out what to adjust. Issues can be added to game log.
Problem 1 - when locked in star map area, a ball rests against up post and leans left or right. When it leans left and the up post is dropped, ball often drains down the middle without touching anything. Hoping code would have addressed this possibility and still pulling for a software fix, but what can I try now?
Approach 1 - first thought is to lower right rear leg leveler, causing back part of game to lean ever so slightly to the right. See if this snags ball on way down.
Problem 2 - ball passing through I-inlane drains 99% of time. Player should be able to nudge ball occasionally to flip into the left flipper lane, but nothing works.
Approach 2 - ball needs to catch the edge of metal guide in order to be diverted into flipper lane. Needs to Unscrew something, add something and make it happen. Really don't have any ideas.

Here’s an idea for your SDTM issue.

https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/227#post-5094603

After I put the sleeve on the left post my instances of STDM from that area went way down. Still happens some times if the magnet kick off the back of the star area sends it just right, but it’s not happening near as much for me anymore. Added bonus of having the post sleeve there is it protects the rubber ring on it from direct hits. It is a challenge getting access to put the sleeve on though. I did it when I had the Pearl off. I might be wrong, but I think the Pearl has to come off in order to remove the plastic above the post and put the sleeve on.

Here’s a link to the post sleeve I used:

https://www.marcospecialties.com/pinball-parts/38-5151

#1980 3 months ago
Quoted from Galooch:

Thank you again to all you have taken the time to respond and provide pictures to help with my cannon door. Super helpful! I think I have improved things but I have a few more tweaks to make. It isn't consistent enough yet. However, I now have a few other items that cropped up:
1. The left spinner on the BP is no longer spinning. I found that when I put back the top portion after tweaking the cannon door, it sits on top of the left side of the spinner. A quick search revealed this post from a few months ago (https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4984403) where joseph5185 successfully was able to put that piece back on at different angles. I have been trying to find that angle (not tightening the right-most bolt all the way too), but it consistently slides down and pins the spinner. Has anyone else encountered this issue and if so, how did you solve it? I really don't remember that part of the BP sitting crooked before taking it off.
2. It appears that I have my first switch issues. The Bonus (X) and Load switch on the BP are no longer registering. A quick inspection on the left side of the BP and I can see that all wires are firmly still attached. What else should I check? I'm hoping something simple that won't require me to remove the BP (haven't had to do it yet). I have not ordered the BP protector from Pinball Life yet and I'm wondering if a ball ricocheted and did some damage. Has anyone had those two switches go out at the same time?
Thanks.[quoted image]

I had to play with how the top roof sits so it wouldn't make my cannon door stick. I settled on putting it on straight, but with the back of it sitting down a bit farther than the front. To do that I placed it in the position that was going to work, then just tightened the nuts down to that level without the nuts getting turned too far and pushing the roof down further than I wanted it.

For the Bonus and Load switch, I think it's 99% likely there is a broken wire somewhere. I've had them out twice and both times was due to a broken wire. The wiring for switch #9, #10, and #12 is daisy chained together, so depending on where the wire is broken it can cut off 1, 2, or all 3 targets. Most likely it's the green wire with a brown stripe that's broken. Follow that wire around and I'm guessing you'll find a spot where it's broken or where an end is no longer connected to a switch. If it's not the green/brown wire then check the others. The wires are pretty stiff and don't just dangle down when they break, so it can definitely look like they're connected when they really aren't. On mine they still were pretty much in the same position they were in when they were connected, but had just separated a little bit.

1 week later
#2018 3 months ago
Quoted from gumnut01:

Replaced them. They were falling apart in my hand. The new ones seem ok. Think this is the only solution. Pretty rotten the spots they used.

Seems like this would be a good moment to make a joke about Jack's spotty service.

3 weeks later
#2123 79 days ago
Quoted from V4Vendetta:

My chest won't release the balls when the multiball starts. Sometimes it release 1 ball but gets stuck but most of times, all 3balls are stuck in the chest.
I've changed the chest release time from 3 to 5 and it still doesn't work. Does anyone know how to fix this?

Have you tried adjusting (very slightly bending) the metal tab that blocks the balls in the chest so it will open up a bit more? It could be that when the coil pulls back the metal arm that blocks the balls it's not quite moving out of the way enough for the balls to pass by. So you may need to just very, very slightly bend that arm back a bit to give more clearance for the balls to pass by when the arm is pulled back by the coil.

Or could the balls be magnetized?

#2127 78 days ago
Quoted from Rdoyle1978:

All right ... I am having an issue with the Pearl losing all lights periodically. I re-inserted the Cat5 cable but didn't remove the Pearl completely, just tried to re-seat the cable. It worked for about half a game then went out again.
I'm reasonably sure this is just the cable, but has anyone else dealt with this?

Is this happening only when Curse of the Black Pearl (movie 1) mulitball has been qualified? Any time the yellow movie 1 multiball insert by the flippers is flashing ready the lights on the Pearl playfield will be out. Just making sure that's not what your seeing because in the past several other people have thought the Pearl's lights were malfunctioning when it was happening by design because that multiball was qualified

1 week later
#2157 70 days ago

Had another occurrence of wires breaking under the Black Pearl mini playfield. I’ve got to give a big thank you to Kurt hemispheres Amusements for going above and beyond again to help me. Met me at his shop way outside normal business hours to solder them for me and then took a lot of extra time to come up with an idea to help bulletproof it to lessen the chance of it happening so often. He took an old standoff post from a parts playfield, attached it to the underside, and zipped the horizontal part of the wiring harness to it to keep those wires from moving & breaking again. Idea being if he can stabilize those wires to hold them still while the section of harness dropping through the playfield can still move up and down with the rocking it should reduce the chance for the wires to break from the solders. Now when you tug on that lower section the wires attached to the switches don’t move at all, so the Pearl will rock with the connections staying secure. He also ran the wires through a large rubber sleeve to have the sleeve remain at the hole in the playfield to for smooth travel back and forth with the rocking. Very nice to have Kurt’s experience on my side! He and Mark at Hemispheres have been invaluable to this rookie owner. Here are a couple pictures.

F3DB1BA4-4850-4328-A505-97AA67959360 (resized).jpegFBFDC4C9-CCB9-4D47-BE05-13BB49ED4CF9 (resized).jpeg
#2159 70 days ago
Quoted from KornFreak28:

Nice! Did he drill holes on the bottom to install this post?

The base of the standoff post takes a single screw, so he used a very short hex head screw through that spot to attach it. Here’s a picture.

BBB8D562-2524-412D-9813-46226CCFA037 (resized).jpeg
1 week later
#2215 59 days ago
Quoted from luckymoey:

Thanks. I did change the coil sleeve and cleaned up the stop which was still in good shape. Also increased coil power a few notches with no effect. I'll take a closer look at the wire form but it's well seated in the playfileld and the ball is only traveling several inches up during mis-fire. The baffling thing is that it works perfectly in test mode - dozens of times in a row. I even fed balls into the shooter lane quickly during test to try to replicate multi-ball. I may need to take the Koop gun barrel off to video.

I’ve always had the same symptoms you’re describing, including it working well in test and happening more often in multiball. I haven’t taken the time to check it out though (sometimes I’m relieved to have a couple extra seconds before adding the ball). I’ve suspected the washer on the ball guide screw that overlaps into the shooting lane is interfering with it based on the wear on the washer, but now I have another idea too. Here’s a link to a post with a picture of the washer I made about this a few months ago.

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/23#post-5001025

I’ll take a look at it this weekend. A similar thing started happening on my JP2 and I figured it out a bit so I want to see if the same thing is happening on my POTC. After about 150 plays of JP2 not missing an auto launch it started missing somewhat frequently. I started checking it out at the start of a new ball. I realized that most of the time the ball came to rest with both sides of the auto launch touching each side of the ball, but sometimes one side of the auto launch would be slightly off the ball.

That game can launch a ball with the action button, so I started looking at how the ball was resting on the auto launch fork and then using the action button to fire it to see if there was a correlation. It seems pretty certain there is. I’ve been able to predict pretty reliably prior to launching whether or not it’ll get through the flip ramp based on whether or not both sides of the auto launch fork are touching the ball. There must be just a very slight amount of play in the launch fork that causes it to have both sides touching sometimes but not other times. I’m thinking that could be going on for POTC too, so I’m going to see if there’s a way to tighten it up slightly.

#2217 59 days ago
Quoted from luckymoey:

This is the problem. I took a slo-mo vid and it's occasionally hitting the post rubber, and the wire form is slightly tilted up in the playfield groove. In the process of taking the wireform off to see if I need to slightly manipulate. Thanks for all the help!

The post at the Escape the Locker save entrance? I’ll have to check that on mine. Can the rubber just be trimmed enough to get it to pass by? Thanks.

Off topic, but I just saw a couple weeks ago that “Escape the Locker” was originally “Escape the Hangman” on the prototype.

3 weeks later
#2246 34 days ago
Quoted from EaglePin:

Had another occurrence of wires breaking under the Black Pearl mini playfield. I’ve got to give a big thank you to Kurt hemispheres Amusements for going above and beyond again to help me. Met me at his shop way outside normal business hours to solder them for me and then took a lot of extra time to come up with an idea to help bulletproof it to lessen the chance of it happening so often. He took an old standoff post from a parts playfield, attached it to the underside, and zipped the horizontal part of the wiring harness to it to keep those wires from moving & breaking again. Idea being if he can stabilize those wires to hold them still while the section of harness dropping through the playfield can still move up and down with the rocking it should reduce the chance for the wires to break from the solders. Now when you tug on that lower section the wires attached to the switches don’t move at all, so the Pearl will rock with the connections staying secure. He also ran the wires through a large rubber sleeve to have the sleeve remain at the hole in the playfield to for smooth travel back and forth with the rocking. Very nice to have Kurt’s experience on my side! He and Mark at Hemispheres have been invaluable to this rookie owner. Here are a couple pictures.[quoted image][quoted image]

I think the bulletproofing done on my underside Pearl wiring by Kurt hemispheres saved me from another broken wire last night. Went overboard off the Pearl, hit on the very edge of the Man Overboard sign & ball guide, and bounced over the Open Seas orbit lane to get stuck underneath. Here’s a pic of where it ended up. And after noticing how scraped the ball was in the pic I changed them out. Hadn’t been very long since my last change.

20DECB30-95A9-498D-B6B3-68B2C079BFD4 (resized).jpeg
#2251 33 days ago
Quoted from GnarLee:

Talking of crazy shots. I managed to get the dauntless to shoot back at the black pearl (kinda). Got a multiball going. Ball coming in hot from inlane and loses no momentum on flip. Up maelstrom ramp hit diverter and had so much speed it went Over the top and hit bp

Nice! What if they’d built it so cannons were on both the Pearl and Dauntless to load and fire at each other? Have them both rocking and fire at the same time at each other with a big jackpot if both shots hit the bullseye.

4 weeks later
#2329 4 days ago
Quoted from vireland:

So after the "dead pin" issues two pinsiders had this week and me saying for like the 30th time that JJP should include a momentary switch with their pins since this is not an isolated problem, I decided to stop complaining and just make one for me that covered the power kickstart AND the CMOS clear (for when the CMOS is corrupted, which also prevents booting). It turned out very nice - too nice - so I've decided to add it to the products in the Pin Monk store and sell the kit. It uses one of the three unused cutouts on the CPU box in the JJP backbox to mount to the bottom outside of the CPU box and is totally reversible.
The bracket kit includes 2 momentary switches with color-coded buttons, a housing bracket, top bracket cover, two screws, and an instruction sticker to place above the buttons on the case. I *believe* it will work on all JJP pins using the CPU box in the head (because I am using the unused HDMI cutout in the case, so they need to have this), but working to verify that now. It definitely works with jjPotC, since that's what I developed it on. DEFINITELY improves the process and speed of getting a machine up again where the "boot on power" function of the motherboard has failed since the cover of the CPU case doesn't even have to be removed once this is installed.
Though it technically works for WoZ or Hobbit if you plug it in, there's no proper mounting for it (yet) because the case is different and in the cabinet, but I'll see what I can do about modifying it for those machines with the CPU in the cabinet rather than the head. I should have it in the store next week once I have the costs nailed down and set a price.
[quoted image]

Nice! You should try to protect this idea/design if you can and charge JJP a royalty if they ever want to do something like it in their original builds.

Promoted items from the Pinside Marketplace
$ 29.95
Gameroom - Decorations
Pinball Photos
10,500 (Firm)
Machine - For Sale
San Mateo, CA
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 65.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 233.10
Cabinet - Sound/Speakers
PinWoofer
Wanted
Machine - Wanted
Flagstaff, AZ

You're currently viewing posts by Pinsider eaglepin.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside