New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

1 year ago



Topic Stats

  • 3,259 posts
  • 180 Pinsiders participating
  • Latest reply 18 days ago by LTG
  • Topic is favorited by 119 Pinsiders

You

Linked Games

Topic Gallery

There have been 586 images uploaded to this topic. (View topic image gallery).

5258D7D2-B8C9-42A3-A03B-B82C55418C05 (resized).jpeg
2511CD88-92CC-4232-9297-41521BE4A42E (resized).jpeg
C7AD0C17-4B1A-43A6-81A2-D5F9F21BD5E9 (resized).png
01038AA0-7F1D-4444-85DC-08CFB831C0E3 (resized).jpeg
14D80B87-5A3F-4D7F-86AC-337AB1DD7738 (resized).png
Capture (resized).JPG
1F155917-E301-41E4-9EAA-658124DEB7C3 (resized).jpeg
20200816_211254 (resized).jpg
20200815_121318 (resized).jpg
image (resized).jpg
image (resized).jpg
1502CDCB-97F5-46E2-95B8-D911B686CB2A (resized).jpeg
12377B7F-8F26-468C-A67C-5C772763ECC8 (resized).jpeg
D26CD690-134D-49FD-B990-060514A2F6BE (resized).jpeg
20200805_233727 (resized).jpg
9B664106-1BDA-4479-9CB3-1ACA84C582A4 (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic

Display key post list sorted by: Post date | Keypost summary | User name

Post #306 Tip on removing the black pearl Posted by rs812 (1 year ago)

Post #501 More tips on removing black pearl mini playfield Posted by LTG (1 year ago)

Post #1776 Broken trunk mount bracket picture Posted by Soulrider911 (1 year ago)

Post #2470 JJP kit information for doing 220v to 110v conversion. Posted by Vitty (9 months ago)

Post #2844 Auto-launch misfire adjustment. Posted by Yelobird (6 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider Zora.
Click here to go back to viewing the entire thread.

#1495 1 year ago

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.

Any idea, what is going wrong here?

#1497 1 year ago
Quoted from zaphX:

It sounds like the game thinks the ball left the Pearl, and possibly even thinks it hit the Dauntless.
In switch test are any switches reporting stuck closed? Or falsing if you bang on the play field?

I will check in the switch test. However, that would mean that the switches in the canon and in the Dauntless would be registering incorrectly, which does not seem to be probable.

#1504 1 year ago
Quoted from zaphX:

Good call, maybe it's as simple as that. Every time you skillshot the boat, it advances one step towards BPMB. Spinners, Load Cannon, and the shot itself.
However, the OP mentioned the load cannon arrow is lit, which it would not be if BPMB was qualified via skill shot.

Thanks for your thoughts. But in fact the cannon load arrow is flashing and then it disappears (while the ball is on the BP without getting into the cannon) and then the MB lights on the playfield (which means the pin thinks I have destroyed the Dauntless).

#1539 1 year ago

I can hardly close the lockdown bar. It is very tight. Is there a way to lock it more smoothly?

#1541 1 year ago
Quoted from KornFreak28:

Did this happen right out of the box?

Yes

1 week later
#1622 1 year ago
Quoted from Trooper11040:

Took off my ship to fix the map t nut and on the back lane, I see this sticking out. This can’t be good?
[quoted image]
Edit: disregard. Ball doesn’t touch it. Sorry

Why does the ball not touch it, is it at the bottom of the playfield? It looks like it is standing significantly into the ball movement.

#1633 1 year ago
Quoted from Trooper11040:

The back rail keeps it from touching the actual t nut. Kinda odd but the shape of the ball works to the advantage of the rail lol

Quoted from zaphX:

Mine has the same protrusion and my orbits are smooth. If you roll a ball over it you'll see that the metal piece runs under the gap between the ball and rail when the ball is flush to the rail.[quoted image]

Thank you for your feedback. Good to know that no fix is needed. I already feared that I had to remove the BP. Keep that removal for the future.

#1635 1 year ago
Quoted from Trooper11040:

Then hardest part of taking off the black pearl in my opinion is the VUK, and putting the wiring back in after you have it off lol. It was honestly a pretty easy process

That gives me hope, thank you

#1660 1 year ago
Quoted from gumnut01:

I’m struggling with this spotlight. It is either pushing up the launch ramp if too far to the right or trapping balls beside tortuga Tom. And it goes out all the time from the vibrations. I think I need to take launch ramp off and bend the angle plus maybe put some washers underneath.
This is the culprit. Anybody else had similar issues?[quoted image]

I have the ball traps as well.

2 months later
#2043 1 year ago

When powering the pin it sometimes (not often, but regurlarly) happens to me that the complete GI is out and not working. Switching off and starting again normally solves the issue, but does not explain the reason. Any experience in this regard?

#2048 1 year ago
Quoted from Slapfighter:

Exactly the same lighting problem here.
Switching off and on and all is ok. This happens not often but sometimes it does.
Also sometimes i have to switch off and on twice, before it's running normal.
I own a Pirates SE.

Ok, thanks for your feedback, seems we are in the same boat. I own a LE. Obviously no sever problem and if no single case, we can ignore it hopefully unless it happens more often.

5 months later
#2581 8 months ago
Quoted from harryhoudini:

I was thinking of belt drive. It's on my list to take a look at, I am also annoyed by the sound even with the dampening kit. It made a difference but it's still an annoying sound.
On another note, I came here to post that my game just rebooted. Anyone else have that happen? It was sitting in attract mode (been on for a day or so) and I heard an electrical noise through the speakers (sort of a little pop or what you hear when you reboot a computer). All of the playfield light were stuck on a yellow color and the screen went black. Then it came back on and went through the boot sequence. Weird.

I had a reboot last week during a game. Screen and playfield went black/lights out and the pin booted after a while. No idea what caused that.

4 months later
#3117 3 months ago
Quoted from swampy:

The front of my dauntless jams against the back of the Maelstrom ramp, and this prevents free movement of the ship (so even the 'miss' doesn't register). On top of that I have never been able to get a BP cannon shot to directly hit. Therefore, I will be buying the shorter hex spacers and trying these. A (possibly dumb) question - how on earth do you remove the top part of the Dauntless?!! Thanks in advance.
[quoted image]

Pull out the playfield. At the back of the backboard are 3 screes that fix the top deck.

#3119 3 months ago
Quoted from swampy:

Yes I've done this but then cannot lever the loose part out.

As far as I remember the screws hold a metal plate which goes through the backboard. Should be easy to pull that out?

2 weeks later
#3145 88 days ago

I had a strang behaviour of the pin several times now. During multiball the point count goes wild (counts points very fast up to several millions), the sound makes a repeating tone (difficult to describe) and the shaker is on continously. That does not stop until you drop all balls. Next ball everything is fine. There is no bad switch in switch test.

Any ideas? Please do not comment that I should be glad to have a chance to increase my high scores in this way

#3151 87 days ago
Quoted from LTG:

You bang on the playfield to see if vibration is setting any off ?
LTG : )

Problem is that I cannot reproduce the problem, happens from time to time. I don‘t think that banging will be successful, because the shaker is working the time producing enough vibrations. Nevertheless, thank you for your comment.

Quoted from EaglePin:

Might not be a bad switch but it could be an opto or another switch that's out of alignment so it's continually registering. Did you try going into the switch test menu to see if any switch is registering when it shouldn't be?

I have looked for a red marked switch as bad switch. How can I see in the switch test that a switch is registering when it should not? Thanks to you as well.

#3153 87 days ago
Quoted from EaglePin:

Here’s a picture of what my switch matrix looks like when I first turn the game on. See if yours shows the same color in each box.
If one of your switches is showing different than mine, then that’s probably the switch that needs adjustment.
If your switch matrix does look the same as mine, then you might want to take the glass off and do as LTG suggested and bump areas of the playfield with your hand while the switch matrix is showing on screen. If a switch registers from vibration it will beep and the switch that registered will flash green. That will probably be the switch that needs adjustment. [quoted image]

Perfect description, thank you so much! You are helping a lot of pinsiders highly appreciated.

#3154 87 days ago

So, the switch matrix looks the same.

I will try the playfield vibration method tomorrow. Possibly, it is a dirty opto at the entrance of the lane under the black pearl right beside the map targets, because this opto activates the shaker, which is working in may problem case as well. So the bad switch must have a connection to the shaker.

#3157 87 days ago
Quoted from LOTR_breath:

Another easier way to find this issue. Next time it happens, stop playing and go into switch history, or whatever it's called. It will show you the most recent 50 or 100 switches and that should surely show you which switch is acting up. Gotta be a switch associated with a jackpot I would think.

@ LOTR_breath: Thank you so much! I did not even know that there is a kind of switch history. Makes perfectly sense and I will try that.

@ MarZ_78: thank you to your comment as well. But I will not use the bad switch to produce unbeatable high scores Cheating myself is not the way to go.

#3159 87 days ago
Quoted from MarZ_78:

Sometimes it's difficult to pick up on the in this forum... To be clear I was joking.

I know don't worry

2 weeks later
#3205 69 days ago
Quoted from LOTR_breath:

Another easier way to find this issue. Next time it happens, stop playing and go into switch history, or whatever it's called. It will show you the most recent 50 or 100 switches and that should surely show you which switch is acting up. Gotta be a switch associated with a jackpot I would think.

Got this issue today again. It seems it always during multiball. It is the switch 72 inner loop entry. Problem is that this is not a stuck switch, but opto. Can an opto get stuck? If it is dirty and is registering due to dirt, it should happen all the time during gameplay and not during MB only. Any ideas how to solve this issue? New opto necessary?

#3206 69 days ago

Small correction: it is not only during MB, because I remember that before the MB I got tons of gold, which should be due to the opto, which seems to indicate to the pin that I made a lot of inner loop rounds, what did not actually happen.

#3209 69 days ago
Quoted from EaglePin:

The opto switch is made of two parts. One part is the emitter that sends the beam of light across the playfield. The other is the receiver that detects the beam of light from the emitter. The switch is designed to always be receiving the light and then register when the pinball blocks the light for a very short time when the ball rolls across the beam. If an opto switch is continually registering, these are some common reasons for it:
1) The light beam is not aimed properly so the receiver isn't receiving it.
2) The receiver is broken.
3) The emitter is broken.
4) The board the opto is connected to is broken.
Try looking at the emitter first to see if the opto light beam is working. You can see if the emitter light is working by using the camera on your mobile phone. Your eyes can't detect the glow of the emitter, but the phone camera screen will show it. With the machine on, point the camera at the emitter and look at it through your phone screen. If the light is working you should see it glowing in the camera view on your phone. If you use the phone camera to first look at a different opto emitter that you know is working then you will see what the glow looks like and you will know what to look for on the orbit opto that isn't working.

Thank you very much for your comments. I will try to check to check the optos with the mobile phone. However, it,is strange that the optos work during gameplay and the issue appears after 20-30 minutes. So it seems that it is not a question of working or not, but what the reason for the sudden change is.

1 month later
#3234 32 days ago
Quoted from EaglePin:

Someone had an issue awhile back and I recall one of the ways to go about diagnosing it was to view the switch history in the menu. That logs each shot, so you should be able to see which switch was registering when it shouldn't.

That was me. The hint to the switch history worked pretty well. When the error occurs, immediately drain the ball and view the switch history. You can identify the bad switch by the huge number it was hit. In my case it was an opto.

#3236 31 days ago
Quoted from JustLikeMe:

Thanks, really appreciate it. I'll try to recreate the issue and then check the switch history. I think the original error mentioned an opto too - I just wish I'd paid more attention. Did you end up replacing the opto or was it a faulty connection?

I de installed the opto, cleaned it and put it back again. Seemed to be some dirt, which caused the ongoing counting. No issue after that.

#3244 28 days ago
Quoted from JustLikeMe:

Ok, I managed to work out what was going on last night thanks to eaglepin and zora, and thought I’d post here just in case anyone else has a similar problem in the future.
I started a game and all was fine until I started a couple of multiballs together, at which point my score started increasing rapidly again. As suggested I quickly went into the service menu to have a look at the switch history, which made the problem pretty obvious:
[quoted image]
Out of curiosity I restarted the game which caused the error to return on startup:
[quoted image]
Checked the manual and worked out this was the opto pair at the top of the Black Pearl access ramp - had a look and the transmitter on the left had come away from the ramp and was hanging by its wires. Obvious from a side angle but invisible from the player position. Clicked it back in and everything is working perfectly again.

Congratulation. Happy to help. I am very thankful to the help I get from the forum here. I am not very skilled from a technical perspective, but like to share what I know. So enjoy the game again.

Promoted items from the Pinside Marketplace
From: $ 12.00
Playfield - Toys/Add-ons
The Art of Pinball
$ 48.25
Playfield - Toys/Add-ons
The MOD Couple
$ 18.95
$ 259.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 7.50
Playfield - Protection
Pin Monk
13,500 (OBO)
Machine - For Sale
Jacksonville, FL
$ 28.25
Playfield - Toys/Add-ons
The MOD Couple
$ 29.95
Cabinet - Other
Pin Monk
From: $ 255.00
Playfield - Toys/Add-ons
Pinball Mod Co.
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods

You're currently viewing posts by Pinsider Zora.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside