(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech

By PinMonk

5 years ago


Topic Heartbeat

Topic Stats

  • 3,540 posts
  • 200 Pinsiders participating
  • Latest reply 4 hours ago by tgrinchy
  • Topic is favorited by 125 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

fuse-chart (resized).jpg
20230513_093432 (resized).jpg
20230513_093525 (resized).jpg
20230512_223441 (resized).jpg
20230512_223449 (resized).jpg
image (resized).jpg
image (resized).jpg
A96280E7-6037-4CDA-947A-4E847A983A5B (resized).jpeg
8D49233D-E7BC-4D21-B620-430C8D783A7C (resized).jpeg
8A79C258-2737-4892-A6D4-1D5066382A11 (resized).jpeg
D2C5269F-CC9C-4059-B008-7183A9656384 (resized).jpeg
19CB3A9A-2767-4CD7-AA0D-2EAC9D4E8C1B (resized).jpeg
AD9CE6FE-FBDD-40E0-A404-AF37E2A257CD (resized).jpeg
no light 2 (resized).jpg
no light (resized).jpg
IMG_20220709_120144 (resized).jpg

Topic index (key posts)

29 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 3,540 posts in this topic. You are on page 71 of 71.
#3501 1 year ago

Hi guys, I have the strangest issue with my game. I know this game has its fair share of issues or things that go wrong but this one has me baffled for last 3 hours trying to figure this out. We decided to move the game upstairs in our house and we were super careful with it and the move went smooth (with 4 guys) and today I went to put the legs on and get it hooked up and everything works fine except none of the playfield lights will light up. I figured a wire came loose but I checked everywhere and it all looks fine. The game plays fine and even the spot light work but nothing on the playfield will light up. I run a switch test, all comes back fine. Something somewhere must have came loose but if anyone has any ideas on where to look, please let me know! Thanks so much!

#3502 1 year ago
Quoted from jeff1978:

none of the playfield lights will light up.

Corner of the B.A.G. board under the playfield. The mini USB cable, plug it in the mini USB port on that board.

Then call jjp and tell them to get LTG : ) Back.

#3503 1 year ago

Thank you! Where is the BAG board if you don't mind? I am still learning..

#3504 1 year ago
Quoted from jeff1978:

Where is the BAG board if you don't mind? I am still learning..

Page E-7 in the manual. You can download it from here - jerseyjackpinball.com under Support - Pirates.

Turn game off. Lift playfield up, pull out to lock, and lean back.

B.A.G. board is hanging from the underside of the playfield. Lower left corner area.

LTG : ) Former jjp tech and pinball ambassador.

#3505 1 year ago

Does anyone have the latest beta code that I can download and install via a USB drive?

#3506 1 year ago

Unfortunately that isn’t it. Everything is connected. Really puzzling! Any other areas to check?

8A79C258-2737-4892-A6D4-1D5066382A11 (resized).jpeg8A79C258-2737-4892-A6D4-1D5066382A11 (resized).jpeg8D49233D-E7BC-4D21-B620-430C8D783A7C (resized).jpeg8D49233D-E7BC-4D21-B620-430C8D783A7C (resized).jpegA96280E7-6037-4CDA-947A-4E847A983A5B (resized).jpegA96280E7-6037-4CDA-947A-4E847A983A5B (resized).jpeg
#3507 1 year ago

BAG board seems fine..

image (resized).jpgimage (resized).jpgimage (resized).jpgimage (resized).jpg
#3508 1 year ago
Quoted from jeff1978:

Unfortunately that isn’t it. Everything is connected.

Did you try unplugging it and shove it back in hard ?

Measure voltage to the LED boards ?

LTG : )

#3509 1 year ago

Hello,

It’s been a little while since I have posted on here. I hope everyone is doing well!

I really need help with my plunger issue. I may have a successful plunge 1/10 times.

Is there anyone by chance that is in the Raleigh area? Feel free to PM me.

Thanks so much!

2 months later
#3510 1 year ago

need help people. noticed some funky behaviour and have some switch issues:

left & right chapter select show as trigger together
pearl load cannon left and right trigger together
(M)ap, 3x & shooter lane don't register (all on same row but not together so not common off)
peark VUK opto not working
Chest ball 1 lock not working

it was saying io board error but that seems ok now.

if I need the small boards under playfield where do I get them from? Can't see any shops carrying them

#3511 1 year ago
Quoted from epotech:

(M)ap, 3x & shooter lane don't register (all on same row but not together so not common off)

These switches are in a row. "3-ball lock forks up" is likely also out but you just aren't aware. Since the switches are daisy-chained together, it's most-likely a broken wire on the Black pearl cannon target switch, or maybe the (M) target in MAP. Pull on the wires a little if it's not obvious one has come off. If all the wires feel good and still are daisy chained, it may be a dead switch diode. You'll need a soldering iron to fix it, and maybe a diode if there's no detached wire found in the switch daisy chain.

Someone in the GnR thread literally had this exact problem a few hours ago.

#3512 1 year ago
Quoted from PinMonk:

These switches are in a row. "3-ball lock forks up" is likely also out but you just aren't aware. Since the switches are daisy-chained together, it's most-likely a broken wire on the Black pearl cannon target switch, or maybe the (M) target in MAP. Pull on the wires a little if it's not obvious one has come off. If all the wires feel good and still are daisy chained, it may be a dead switch diode. You'll need a soldering iron to fix it, and maybe a diode if there's no detached wire found in the switch daisy chain.
Someone in the GnR thread literally had this exact problem a few hours ago.

turns out it was a common wired to the wrong row and also the wrong side of the diode! Some pretty funky behaviour ensued! Think that's the last operator bodge that was remaining. Thanks all.

#3513 1 year ago
Quoted from epotech:

turns out it was a common wired to the wrong row and also the wrong side of the diode! Some pretty funky behaviour ensued! Think that's the last operator bodge that was remaining. Thanks all.

Thanks for the follow up post on the solution. Operators will be operators. No surprises there.

1 month later
#3514 1 year ago

Evening everyone!
Well, it finally happened to me. Went to boot up my machine and was met with "alloc magic is broken at 0x95b92460: 6db08f24 Aborted. Press any key to continue" That was a new one to me. Rebooted and it bricked. Did the short procedure and cleared the CMOS. Reboot and it comes up with the JJP screen and locks on that display. Would love any ideas on where to start.

#3515 1 year ago
Quoted from Heater:

Would love any ideas on where to start.

http://store.jerseyjackpinball.com/Support-Form/ or (630) 830-5225

LTG : )

#3516 1 year ago
Quoted from Heater:

Evening everyone!
Well, it finally happened to me. Went to boot up my machine and was met with "alloc magic is broken at 0x95b92460: 6db08f24 Aborted. Press any key to continue" That was a new one to me. Rebooted and it bricked. Did the short procedure and cleared the CMOS. Reboot and it comes up with the JJP screen and locks on that display. Would love any ideas on where to start.

Sounds like bad memory stick or corrupted/failing SSD. I'd put in a ticket with JJP.

#3517 1 year ago
Quoted from PinMonk:

Sounds like bad memory stick or corrupted/failing SSD. I'd put in a ticket with JJP.

Looks like I'm going to have to. I just tried rebooting one more time and got a new message: "error: font characters not in ascending order: 22423 <= 55"

#3518 1 year ago
Quoted from Heater:

Looks like I'm going to have to. I just tried rebooting one more time and got a new message: "error: font characters not in ascending order: 22423 <= 55"

If your hard drive has an error, sometimes doing a fresh code install will get you back up and running.

3 weeks later
#3519 1 year ago
Quoted from Betelgeuse:

If your hard drive has an error, sometimes doing a fresh code install will get you back up and running.

This is true but I would probably just replace it to error on the side of caution.

1 month later
#3520 1 year ago

Few things, as just got my first JJP POTC has any one seen this and seems like something wrong but ball guide looks like it shoud however ball cannot get over it and gets stuck here?

20230512_223441 (resized).jpg20230512_223441 (resized).jpg20230512_223449 (resized).jpg20230512_223449 (resized).jpg
#3521 1 year ago

can see the rail would never let the ball go over it without a ton of juice?

#3522 1 year ago

other problem is the disk is not spinning but was to late to get into it last night. Any obvious help would be appreciated gonna check for wires etc as could be loose from travel!

#3523 1 year ago
Quoted from wcbrandes:

Few things, as just got my first JJP POTC has any one seen this and seems like something wrong but ball guide looks like it shoud however ball cannot get over it and gets stuck here?

The shooter lane rail is stopping the ball? This should sit slightly lower than the playfield surface. I think something looks off about the wood in your shooter lane. Maybe someone had touched it up or added a veneer layer to it? Otherwise, that rail just may just need to be bent down.

The disc issue could be a lot of things, but check for loose set screws in the gear on the motor and that the motor tightened down in the right position to turn the disc.

#3524 1 year ago

as said the guide should be below the playfield, also mine doesn't have rubbers on those posts, works fine though.

#3525 1 year ago
Quoted from Betelgeuse:

The shooter lane rail is stopping the ball? This should sit slightly lower than the playfield surface. I think something looks off about the wood in your shooter lane. Maybe someone had touched it up or added a veneer layer to it? Otherwise, that rail just may just need to be bent down.
The disc issue could be a lot of things, but check for loose set screws in the gear on the motor and that the motor tightened down in the right position to turn the disc.

Yes the guide is more than the thickness of rail above the shooter lane preventing ball going there. Even if push right flat it won't clear and it looks new and nothing there on playfield or shooter lane.

20230513_093432 (resized).jpg20230513_093432 (resized).jpg20230513_093525 (resized).jpg20230513_093525 (resized).jpg
#3526 1 year ago

Thanks to the pinsiders that called and walked me through. had to take apart and put back together properly and now works. also resolved other issues. thanks for the help!

#3527 1 year ago
Quoted from wcbrandes:

Yes the guide is more than the thickness of rail above the shooter lane preventing ball going there. Even if push right flat it won't clear and it looks new and nothing there on playfield or shooter lane. [quoted image][quoted image]

FYI. Make sure you loosen that screw up and move that ball rail all the way to the top because if not, you may get an air ball that will jump that rail. I had this happen and the ball got stuck between the apron and the glass, pain in the ass.

1 week later
#3528 1 year ago

anyone know of any lollipop side rails for the LE ? Want to powder coat my trim and hopefully get a pair of these before doing so

2 weeks later
#3529 11 months ago

I had a problem with my forks not dropping a few weeks ago and none of the solutions here fixed the issue. All I need to do was put a little white lithium grease on the solenoid mech (metal part) that drops the forks back down after they are raised.

I have played countless games since then with no issues.

2 months later
#3530 8 months ago

Hello, my spinning map doesn’t spin anymore this morning. Anyone had that before? I don’t see it in the first page list

#3531 8 months ago
Quoted from etien:

Hello, my spinning map doesn’t spin anymore this morning. Anyone had that before? I don’t see it in the first page list

Check fuses F713 and F714 with a multimeter (outside the machine) to make sure they have continuity first.

If they do, put them back in and look for a broken wire at the wheel motor.
fuse-chart (resized).jpgfuse-chart (resized).jpg

#3532 8 months ago

Thanks for that! Will do

3 months later
#3533 4 months ago

hello,

I have a small issue with my POTC. sometimes when i have a few balls in the chest the release doesnt happen like it should. That means the ball is stuck in the chest. Sometimes after a few ball searches the ball will be released.

Someone had this issue before?

#3534 4 months ago
Quoted from NielsR:

hello,
I have a small issue with my POTC. sometimes when i have a few balls in the chest the release doesnt happen like it should. That means the ball is stuck in the chest. Sometimes after a few ball searches the ball will be released.
Someone had this issue before?

Common problem. If you keyword search for “chest” “release” this forum or the owners forum you’ll see a lot of info. Often the solution is to slightly adjust how the arm that gets pulled by the magnet is bent. Could also be that the software setting needs to be adjusted though. Here’s one post about it.

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/50#post-5433533

#3535 4 months ago
Quoted from etien:

Hello, my spinning map doesn’t spin anymore this morning. Anyone had that before? I don’t see it in the first page list

It might be the relay board, part 15-000009-00. http://store.jerseyjackpinball.com/Parts/Wizard-of-Oz-Parts/Motor-Relay-Bd.html

I've heard of them failing from time to time. You could swap it with the one that runs the rocking ship to isolate, as it's the same board.

2 weeks later
#3536 4 months ago

Anyone have an upper playfield laying around they would like to sell? Have a NIB main for my LE and would like to send to cruzman and would like to send both together before taking out of the machine. Cheers Bill

2 months later
#3537 43 days ago

OMG, I am new to POTC and this thread is crazy good and also scares the shit out of me. This reminds me of TZ as it sounds like stuff breaks a lot on this game. I am okay with that because I am fairly handy (most of the time), but man there are a lot of areas that can break.

Well it is what it is. Working on my upper playfield now, but am taking on a larger project to do some preventative work while I do that. It seems the machine I just got was never really modified at all. It is an LE with very low plays and no visible playfield wear.

To do's:

- Cliffy's (already ordered)
- Get some star posts and replace the skinny posts
- I see some people have black things under their star posts. What are those? Good idea?
- Going to get a set of Clear titan's and replace all of them at the same time
- Get a couple capacitors for the I/O board. I did this on my GnR and TH. Was worth it. Fairly easy too.
- Need to replace the action button switch. It is not working all the time.
- Working on printing some coral for the cabinet. I am playing around with different options. I will post when I think I have something worth sharing.

Mods:

This is where I get a little confused. I think I am going to take a vid of my machine to see a) what mods do I have and b) what mods make sense to get now

Any other ideas/feedback appreciated.

Thanks in advance folks. Love this site btw. Very helpful and witty peeps on here!

Dave

#3538 43 days ago
Quoted from iamabearsfan:

OMG, I am new to POTC and this thread is crazy good and also scares the shit out of me. This reminds me of TZ as it sounds like stuff breaks a lot on this game. I am okay with that because I am fairly handy (most of the time), but man there are a lot of areas that can break.
Well it is what it is. Working on my upper playfield now, but am taking on a larger project to do some preventative work while I do that. It seems the machine I just got was never really modified at all. It is an LE with very low plays and no visible playfield wear.
To do's:
- Cliffy's (already ordered)
- Get some star posts and replace the skinny posts
- I see some people have black things under their star posts. What are those? Good idea?
- Going to get a set of Clear titan's and replace all of them at the same time
- Get a couple capacitors for the I/O board. I did this on my GnR and TH. Was worth it. Fairly easy too.
- Need to replace the action button switch. It is not working all the time.
- Working on printing some coral for the cabinet. I am playing around with different options. I will post when I think I have something worth sharing.
Mods:
This is where I get a little confused. I think I am going to take a vid of my machine to see a) what mods do I have and b) what mods make sense to get now
Any other ideas/feedback appreciated.
Thanks in advance folks. Love this site btw. Very helpful and witty peeps on here!
Dave

This is what you want under your new slingshot star posts. I went with double star posts and I ended up getting some airballs in the slings when using clear titan rubbers. I changed to black perfect plays from PBL and the airballs mostly went away.
https://www.titanpinball.com/index.php?route=product/product&product_id=154&search=silicon+washers

One of the only must have mods is the Cliffy on the Tortuga scoop. Sounds like you have that on order.

I will NOT be doing the cap mod. My flippers are turned up in adjustments, not even maxed, and they are plenty powerful to make the ramps and the chest lock.

3 weeks later
#3539 19 days ago

Minor annoyance: my auto launcher sometimes fires before the ball has completely settled in the shooter lane so it misfires and the ball will shoot half way up the ramp, come back down into the shooter lane hitting the switch again and then the auto launcher fires again but because the ball has not settled, it misfires again ... It clears when the ball has had enough time to stop moving in the shooter lane before the auto launcher goes off.

Is there a way to add time between the switch being activated and the auto launch firing?

2 weeks later
#3540 4 hours ago

Having an issue installing latest update - over WiFi it downloads ok but am getting the error “failed to decompress update.” I’m currently on beta5. Any ideas? Maybe a space issue? I swear I read some others having this issue at one point but can’t seem to find it…

Promoted items from Pinside Marketplace and Pinside Shops!
Wanted
Machine - Wanted
Coos Bay, OR
$ 43.00
Playfield - Toys/Add-ons
The MOD Couple
 
$ 28.75
Playfield - Toys/Add-ons
The MOD Couple
 
$ 38.75
Playfield - Toys/Add-ons
The MOD Couple
 
$ 24.95
Cabinet - Shooter Rods
Hookedonpinball.com
 
$ 20.50
Playfield - Toys/Add-ons
The MOD Couple
 
20,000
Machine - For Sale
San Diego, CA
$ 35.00
Playfield - Protection
Pinball Mod Co.
 
$ 110.00
Cabinet - Shooter Rods
Super Skill Shot Shop
 
From: $ 91.00
From: $ 75.00
Playfield - Other
Pinball Mod Co.
 
From: $ 30.00
Cabinet - Other
Rocket City Pinball
 
$ 29.00
Gameroom - Decorations
Pinball Photos LLC
 
From: $ 5.99
Playfield - Plastics
The Pinball Scientist
 
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
 
$ 8.00
Cabinet - Other
Side Gig Studios
 
18,200
Machine - For Sale
Greenville, SC
From: $ 65.00
Lighting - Other
Pinball Mod Co.
 
$ 29.00
Gameroom - Decorations
Pinball Photos LLC
 
$ 30.00
Cabinet - Other
Rocket City Pinball
 
22,000
Machine - For Sale
Smithtown, NY
$ 19.25
Playfield - Toys/Add-ons
The MOD Couple
 
From: $ 12.00
Flipper Parts
Precision Pinball prod.
 
From: $ 355.00
Playfield - Toys/Add-ons
Pinball Mod Co.
 
From: $ 38.00
Playfield - Decals
Pinball Mod Co.
 
There are 3,540 posts in this topic. You are on page 71 of 71.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/71 and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.