(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

7 months ago



Topic Stats

  • 2,273 posts
  • 133 Pinsiders participating
  • Latest reply 4 days ago by koops
  • Topic is favorited by 97 Pinsiders

You

Linked Games

Topic Gallery

There have been 423 images uploaded to this topic. (View topic image gallery).

B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg
9F1B9D3E-F2D5-4E3E-9AEB-3BD0EED68DBF (resized).jpeg
D314C715-D0E4-4264-A44C-CCCAFB4066F5 (resized).jpeg
IMG_0802.jpeg
B54426A1-4B7B-4C6F-8CA3-CBC7D3C9489B (resized).jpeg
20DECB30-95A9-498D-B6B3-68B2C079BFD4 (resized).jpeg
88B6CE6D-1F73-4804-9327-DCA782201677 (resized).jpeg
E13BC387-2C81-4667-AFE4-B77BE147AFA9 (resized).jpeg
F99E00F1-EA3D-4E2E-A5D3-CA5E3E8FF874 (resized).jpeg
4590a30276ddbd055d7cb18b5fb5b0b71bc8871a.jpeg (resized).jpg
6EE11557-4A73-4D3A-9A09-C9276DC7B526 (resized).jpeg
IMG_4015 (resized).JPG
IMG_4015 (resized).JPG

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 2273 posts in this topic. You are on page 6 of 46.
#251 7 months ago

Anybody ever have their slings arm get pushed "outside" of the flipper rubber? I have had that happen a few times on each sling; not sure if changing to white rubbers would help or if there is another fix.

#252 7 months ago
Quoted from BC_Gambit:

Anybody ever have their slings arm get pushed "outside" of the flipper rubber? I have had that happen a few times on each sling; not sure if changing to white rubbers would help or if there is another fix.

Smaller rubber ring. Or try new ones.

LTG : )

#253 7 months ago
Quoted from BC_Gambit:

Anybody ever have their slings arm get pushed "outside" of the flipper rubber? I have had that happen a few times on each sling; not sure if changing to white rubbers would help or if there is another fix.

Funny you mention that, as it happened to me twice today. Maybe it's time for new sling rubber for me. I do have the star post + washer mod which I was blaming for it, but maybe it's just worn slings.

#254 7 months ago
Quoted from zaphX:

I do have the star post + washer mod which I was blaming for it,

That might hold the rubber ring a bit too high.

LTG : )

#255 7 months ago
Quoted from LTG:

Smaller rubber ring. Or try new ones.
LTG : )

Thank you. I will give new rings a try!

#256 7 months ago
Quoted from BC_Gambit:

Thank you. I will give new rings a try!

My wife just lost a ball. I checked the subway, Dauntless, under the Pearl...nowhere to be found. Then I finally found it -inside- the right sling.

That was the last straw for me, coupled with two “escaped kickers” on that sling. I replaced the rubbers with fresh ones and will report back how it behaves.

#257 7 months ago
Quoted from zaphX:

My wife just lost a ball. I checked the subway, Dauntless, under the Pearl...nowhere to be found. Then I finally found it -inside- the right sling.
That was the last straw for me, coupled with two “escaped kickers” on that sling. I replaced the rubbers with fresh ones and will report back how it behaves.

A slightly smaller ring might help with that by way of more tension. There might just be too much play in that ring.

#258 7 months ago

Okay, so I made a support for the left side of the ramp. Problem solved. Ball doesn't get stuck on the top gate anymore, and the flatter lower screw isn't pushing into the sticker under the ramp. So I don't recommend replacing that screw on the bottom that's pushing into the BP ramp unless you're prepared to make a support to replace the tension removing the screw took away on the left side of the ramp.

HOWEVER, if Jack ever re-runs this, that area ABSOLUTELY needs some attention. The ramp support design is ridiculously bad.

#259 7 months ago
Quoted from BC_Gambit:

Anybody ever have their slings arm get pushed "outside" of the flipper rubber? I have had that happen a few times on each sling; not sure if changing to white rubbers would help or if there is another fix.

Yes... right sling. Once!

#260 7 months ago
Quoted from vireland:

Okay, so I made a support for the left side of the ramp. Problem solved. Ball doesn't get stuck on the top gate anymore, and the flatter lower screw isn't pushing into the sticker under the ramp. So I don't recommend replacing that screw on the bottom that's pushing into the BP ramp unless you're prepared to make a support to replace the tension removing the screw took away on the left side of the ramp.
HOWEVER, if Jack ever re-runs this, that area ABSOLUTELY needs some attention. The ramp support design is ridiculously bad.

Are you going to be selling this part, Vic?

#261 7 months ago

Ok just ran in to a doosey. Mid game I seemed to be getting gold out of nowhere. Everytime I hit a flipper button gold would spawn. Drained ball started a new ball and problem was not there but noticed the spinning pop bumpers were spinning like crazy and not stopping. Only thing that was changed was I tried to install 5 ball for mom and sister to help them get higher scores. Going to go digging for a broken shorted wire. Nothing looked off when I went into switch tests.

#262 7 months ago
Quoted from dgposter:

Are you going to be selling this part, Vic?

I wasn't planning on it. Just made a quick and dirty part to fix the problem I created by fixing JJP's mistake with the bracket and screw under the ramp. As long as you don't replace that screw, the ramp should be fine.

#263 7 months ago
Quoted from GnarLee:

Ok just ran in to a doosey. Mid game I seemed to be getting gold out of nowhere. Everytime I hit a flipper button gold would spawn. Drained ball started a new ball and problem was not there but noticed the spinning pop bumpers were spinning like crazy and not stopping. Only thing that was changed was I tried to install 5 ball for mom and sister to help them get higher scores. Going to go digging for a broken shorted wire. Nothing looked off when I went into switch tests.

Check the sling under the ramp. Go into switch test mode and press the rubber, then pause and lift the rubber off the sling.

Then stay in switch test mode and smack your palm on the playfield firmly different places and see if switches trigger. None should.

#264 7 months ago

I noticed something yesterday. Ball was sitting in the launcher and everytime I flipped a flipper I got like 30 points or something. I have to assume this is a switch that is not adjusted correctly, so I'll look at that first. Not sure if this is anything known.

#265 7 months ago
Quoted from harryhoudini:

I noticed something yesterday. Ball was sitting in the launcher and everytime I flipped a flipper I got like 30 points or something. I have to assume this is a switch that is not adjusted correctly, so I'll look at that first. Not sure if this is anything known.

You just have a switch that's gapped too close. Go into switch test mode and smack your open palm on the playfield to see what switches trigger, then adjust that switch.

#266 7 months ago
Quoted from harryhoudini:

I noticed something yesterday. Ball was sitting in the launcher and everytime I flipped a flipper I got like 30 points or something. I have to assume this is a switch that is not adjusted correctly, so I'll look at that first. Not sure if this is anything known.

Like @vireland said...I’ll bet you it’s the ‘Chapter Select Left Rubber 63’. Mine was not properly gapped at the factory. You will see random 30 point increments scored for the tiniest vibrations to the machine (unless of course you’ve got sort of multiplier going at the time’).

This happens to also be the #1 reason you can’t keep the cannon door open once qualified as it’s any activated switch on the lower playfield that shuts the cannon door.

#267 7 months ago

PROBLEM: Manual shooter plunges lack energy and have a hard time getting around the orbit or even onto the playfield.

SOLUTION: Check your shooter tip alignment. It should be centered between the two chrome guide rods in the ball trough. If it's to the left or right of that, the steel washer behind the rubber tip may be hitting the auto-launcher on the left or right, robbing energy from the plunge.

This picture shows the shooter tip is not centered left to right. It needs to be adjusted so it's right in the middle.
shooter-tip (resized).jpg

Loosen these three screws from the shooter plate bracket, then slide shooter housing left or right as much as you think you need. Tighten the bottom screw so it stays put. Drop the playfield and check your work. If it's not right, loosen the bottom screw again and adjust again. Once you have it centered when the playfield is dropped, tighten all three screws again, check your work one last time, and enjoy!
shooter-plate (resized).jpg

#268 7 months ago
Quoted from zaphX:

My wife just lost a ball. I checked the subway, Dauntless, under the Pearl...nowhere to be found. Then I finally found it -inside- the right sling.
That was the last straw for me, coupled with two “escaped kickers” on that sling. I replaced the rubbers with fresh ones and will report back how it behaves.

That happened to me in my first day or two... I looked everywhere, listened for a ball rolling, I was stumped.... I had actually looked at the slings earlier as my STTNG sling had eaten a ball years ago, but I missed it the first time.

Hopefully the white rubbers I just put on stop that and keep the sling arm from kicking through...

#269 7 months ago

Alright here I go with another silly question.

Any tools or tricks to pull apart molex connectors more easily?

#270 7 months ago
Quoted from joseph5185:

Alright here I go with another silly question.
Any tools or tricks to pull apart molex connectors more easily?

No special tools... just gently wiggle as you are pulling them apart.

#271 7 months ago
Quoted from dug:

No special tools... just gently wiggle as you are pulling them apart.

And DON'T PULL BY THE WIRES. Some of the molex connectors have clips you have to press to be able to separate them, others don't. For the ones that don't pliers can help you with your grip on one of them while you pull/wiggle the other side.

#272 7 months ago
Quoted from vireland:

And DON'T PULL BY THE WIRES. Some of the molex connectors have clips you have to press to be able to separate them, others don't. For the ones that don't pliers can help you with your grip on one of them while you pull/wiggle the other side.

Of course not...

I was a Wireman in the Marines
And I’m an IT guy.

But I appreciate the concern all the same.

#273 7 months ago

LOL, Marine almost as bad as the Navy, Always pulling on thing's

#274 7 months ago

I've had way more flying balls in this game than many other games I've played. Many hop up and land in the right side wire ramp. Had many fly over the slingshots, crazy.

First pic, ball has gotten stuck here twice. When you shoot the left orbit too hard and it makes the turn it can fling over here.

Second pic, rubber is almost broken. Seems to get a lot of wear there. Have all new titan rings on the way.

I set the right flipper back to original power (it was turned up a bit) and that has kept the ball from flying out of the maelstrom for the most part but when the ball has some good momentum before it is hit with the flipper it can still pop out. Seems like there needs to be something to keep it in.

Not sure if it is just me or if it is the cliffy but the mystery hole is hard as hell to get in to.

0421191250 (resized).jpg0421191301 (resized).jpg
#275 7 months ago

Turn flippers and slings down if you’re getting so many air balls.

#276 7 months ago
Quoted from f3honda4me:

Turn flippers and slings down if you’re getting so many air balls.

K, thanks.

Oh... anyone:

I just remembered, my rotating pirate on top of the pop bumper doesn't work. Tested it in the test menu and the other rotating pop topper works, just not the pirate one. I hear nothing when I activate it. Is it as simple as a bad motor or are there other things to test? I'll test for voltage at the motor, I suppose. Haven't popped it up to look yet.

#277 7 months ago
Quoted from harryhoudini:

K, thanks.
Oh... anyone:
I just remembered, my rotating pirate on top of the pop bumper doesn't work. Tested it in the test menu and the other rotating pop topper works, just not the pirate one. I hear nothing when I activate it. Is it as simple as a bad motor or are there other things to test? I'll test for voltage at the motor, I suppose. Haven't popped it up to look yet.

What are your coil strength numbers for each flipper?

For the spinner, likely a loose connection or bad motor. I'd check for voltage at the connector first. I actually don't like that both the barrels spin the same way and will probably reverse the upper one this week for a little more visual variety.

On the map hole, a common mistake with the cliffies is torquing the posts or screws that hold it too hard, tweaking the metal so it doesn't lay flat. Does the circle in front of the hole lay flat? Did you use the activator to clean the pf there before you put it down? Did you take off the backing to the 3M adhesive on the underside of the cliffy before you put it on? Of course, none of this would be a problem if JJP would just install these necessary protectors at the factory, at least on the LEs and/or CEs.

If all that checks out, you may have rotated the deflector a little too much when you put it back together, creating ball rejects instead of dropping the balls that hit it into the hole.

#278 7 months ago
Quoted from vireland:

What are your coil strength numbers for each flipper?
For the spinner, likely a loose connection or bad motor. I'd check for voltage at the connector first. I actually don't like that both the barrels spin the same way and will probably reverse the upper one this week for a little more visual variety.
On the map hole, a common mistake with the cliffies is torquing the posts or screws that hold it too hard, tweaking the metal so it doesn't lay flat. Does the circle in front of the hole lay flat? Did you use the activator to clean the pf there before you put it down? Did you take off the backing to the 3M adhesive on the underside of the cliffy before you put it on? Of course, none of this would be a problem if JJP would just install these necessary protectors at the factory, at least on the LEs and/or CEs.
If all that checks out, you may have rotated the deflector a little too much when you put it back together, creating ball rejects instead of dropping the balls that hit it into the hole.

He was asking about the Mystery hole, tortuga. Not the map hole.

#279 7 months ago
Quoted from f3honda4me:

He was asking about the Mystery hole, tortuga. Not the map hole.

Hmm... did you have issues hitting the Mystery shot BEFORE installing Cliffy's?

I haven't had issues with it...

#280 7 months ago
Quoted from f3honda4me:

He was asking about the Mystery hole, tortuga. Not the map hole.

Heh, the MAP hole is a mystery, too, until the spin. I was confusified.

On the Tortuga hole, wiggle the deflector and make sure that it's screwed on tight. It was loose out of the box on the one we got here, which made it hard to hit until I tightened it.

#281 7 months ago
Quoted from vireland:

Heh, the MAP hole is a mystery, too, until the spin. I was confusified.
On the Tortuga hole, wiggle the deflector and make sure that it's screwed on tight. It was loose out of the box on the one we got here, which made it hard to hit until I tightened it.

Deflector?

How about I just pretend I don't know that exists unless I have an issue .. =P

#282 7 months ago
Quoted from vireland:

PROBLEM: Manual shooter plunges lack energy and have a hard time getting around the orbit or even onto the playfield.
SOLUTION: Check your shooter tip alignment. It should be centered between the two chrome guide rods in the ball trough. If it's to the left or right of that, the steel washer behind the rubber tip may be hitting the auto-launcher on the left or right, robbing energy from the plunge.
This picture shows the shooter tip is not centered left to right. It needs to be adjusted so it's right in the middle.
[quoted image]
Loosen these three screws from the shooter plate bracket, then slide shooter housing left or right as much as you think you need. Tighten the bottom screw so it stays put. Drop the playfield and check your work. If it's not right, loosen the bottom screw again and adjust again. Once you have it centered when the playfield is dropped, tighten all three screws again, check your work one last time, and enjoy!
[quoted image]

Absolute easiest fix for an issue I figured would be another pain. Thanks so much for spreading the good word!

#283 7 months ago
Quoted from wesman:

Absolute easiest fix for an issue I figured would be another pain. Thanks so much for spreading the good word!

Maybe some thread locker for this particular fix?

What do you think?

#284 7 months ago
Quoted from wesman:

Absolute easiest fix for an issue I figured would be another pain. Thanks so much for spreading the good word!

If you want to PM me a list of issues you have had with your NIB, I wouldn't mind. You were definitely hit with many it feels like.

#285 7 months ago
Quoted from vireland:

Heh, the MAP hole is a mystery, too, until the spin. I was confusified.
On the Tortuga hole, wiggle the deflector and make sure that it's screwed on tight. It was loose out of the box on the one we got here, which made it hard to hit until I tightened it.

Thanks. I didn't install the cliffy, previous owner did. Another le played without protector didn't seem as hard. I'll investigate if it's laying flat. Maybe flipper is too strong.

#286 7 months ago
Quoted from harryhoudini:

Thanks. I didn't install the cliffy, previous owner did. Another le played without protector didn't seem as hard. I'll investigate if it's laying flat. Maybe flipper is too strong.

Ah. Got it!

#287 7 months ago
Quoted from harryhoudini:

Thanks. I didn't install the cliffy, previous owner did. Another le played without protector didn't seem as hard. I'll investigate if it's laying flat. Maybe flipper is too strong.

What are all your flipper setting numbers on the menu?

#289 7 months ago

It looks like a deflector

I didn't even know that was there!

Haha thanks man!

#290 7 months ago

Where are you guys at with your Plunder settings?

Mine is stock -- like everything else in this game... but if I were to make any change it would probably be this.

Just curious...

#291 7 months ago

PROBLEM: It bugs you that the barrels both turn the same direction.

SOLUTION: Reverse the connectors on the plug under the playfield for the upper barrel so it turns the opposite direction from the lower spinning barrel bumper.

Here's the connector:
barrell1 (resized).jpg

Connector taken out of the female housing:
barrel2 (resized).jpg

Use pin extractor (tool is available on Amazon amazon.com link » and at tool stores) to remove the pins and swap their position:
barrel3 (resized).jpg

Put the connectors back together and enjoy!
spinning-barrels.gif

#292 6 months ago
Quoted from vireland:

PROBLEM: It bugs you that the barrels both turn the same direction.
SOLUTION: Reverse the connectors on the plug under the playfield for the upper barrel so it turns the opposite direction from the lower spinning barrel bumper.
Here's the connector:
[quoted image]
Connector taken out of the female housing:
[quoted image]
Use pin extractor (tool is available on Amazon amazon.com link » and at tool stores) to remove the pins and swap their position:
[quoted image]
Put the connectors back together and enjoy!
[quoted image]

Nice one!!

#293 6 months ago

It doesn't bug me.. =P

I didn't even realize it.. haha

#294 6 months ago
Quoted from vireland:

PROBLEM: It bugs you that the barrels both turn the same direction.
SOLUTION: Reverse the connectors on the plug under the playfield for the upper barrel so it turns the opposite direction from the lower spinning barrel bumper.
Here's the connector:
[quoted image]
Connector taken out of the female housing:
[quoted image]
Use pin extractor (tool is available on Amazon amazon.com link » and at tool stores) to remove the pins and swap their position:
[quoted image]
Put the connectors back together and enjoy!
[quoted image]

Very cool!

I just found my round pin extraction tool so this is tempting

#295 6 months ago
Quoted from joseph5185:

Where are you guys at with your Plunder settings?
Mine is stock -- like everything else in this game... but if I were to make any change it would probably be this.
Just curious...

bedlam.....hgh as it goes. even get to steal a ball from someone if u lucky.

#296 6 months ago
Quoted from thc666:

bedlam.....hgh as it goes. even get to steal a ball from someone if u lucky.

Ah okay.

It’s not “too” excessive?

#297 6 months ago

Any recommendations on which dremel to buy?

#298 6 months ago
Quoted from joseph5185:

Any recommendations on which dremel to buy?

amazon.com link »

#299 6 months ago
Quoted from joseph5185:

Any recommendations on which dremel to buy?

the one linked above is good....Depends really on how much you plan to use it. If you plan on using it a good bit one linked is good. If your only planning to use it very little the next step down would be fine amazon.com link » I have even had some wireless ones over the years that were pretty decent.

#300 6 months ago

Thanks for the advice. I’ll probably go with the nicer one. It’s in a nice concealed case. Things like that matter to me.

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Flagstaff, AZ
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 29.25
Playfield - Toys/Add-ons
The MOD Couple
$ 29.95
Gameroom - Decorations
Pinball Photos
From: $ 18.00
Apparel - Men
Pinside Shop
There are 2273 posts in this topic. You are on page 6 of 46.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside