New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

1 year ago



Topic Stats

  • 3,297 posts
  • 182 Pinsiders participating
  • Latest reply 26 minutes ago by LOTR_breath
  • Topic is favorited by 121 Pinsiders

You

Linked Games

Topic Gallery

There have been 599 images uploaded to this topic. (View topic image gallery).

E8A7731E-BD3A-4853-92DD-4DD485FF0EC0 (resized).jpeg
6C6B827B-F3DB-48FF-A1B1-52959781888B (resized).jpeg
E2D82214-DA31-4599-AF17-4A60EE299AA4 (resized).jpeg
B9DEF292-98C5-4AB2-91C6-CDD75BA9E0B2 (resized).jpeg
C167D4C0-98C4-4C44-BC79-CFEBD054CE4A (resized).jpeg
pasted_image (resized).png
Screenshot 2020-11-07 112522 (resized).png
Screenshot 2020-11-07 112503 (resized).png
Screenshot 2020-11-07 112432 (resized).png
Screenshot 2020-11-07 112642 (resized).png
Screenshot 2020-11-07 112622 (resized).png
20201107_152624 (resized).jpg
20201107_153000 (resized).jpg
5258D7D2-B8C9-42A3-A03B-B82C55418C05 (resized).jpeg
2511CD88-92CC-4232-9297-41521BE4A42E (resized).jpeg
C7AD0C17-4B1A-43A6-81A2-D5F9F21BD5E9 (resized).png

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 3297 posts in this topic. You are on page 60 of 66.
#2951 6 months ago
Quoted from KornFreak28:

Does the BP always sway at the same speed or does the speed change depending on what’s going on in the game?

If I remember the rules correct every time you board the bp it gets a little faster. It also gains speed every time the spinners on bp trigger. Resets on multiball

#2952 6 months ago

The washer on the minipost next to tortuga seems to be destroying my balls. Think I need to replace with a rubber one or dremmel it.

424F2DC0-2EEB-4E31-8A95-14578960F139 (resized).jpeg
#2953 6 months ago
Quoted from gumnut01:

The washer on the minipost next to tortuga seems to be destroying my balls. Think I need to replace with a rubber one or dremmel it. [quoted image]

Dremmel it

#2954 6 months ago
Quoted from gumnut01:

The washer on the minipost next to tortuga seems to be destroying my balls. Think I need to replace with a rubber one or dremmel it. [quoted image]

Not only that, but that post keeps coming unscrewed on mine and affecting kick outs. I don’t have a tool that can really get in there to screw it in tight enough either. It’s like the wire forms and pop bumpers were placed just for the purpose of making that post harder to tighten. Sockets aren’t deep enough and the handle of pliers hits the things around it. So frustrating.

#2955 6 months ago
Quoted from JamCat:

Not only that, but that post keeps coming unscrewed on mine and affecting kick outs. I don’t have a tool that can really get in there to screw it in tight enough either. It’s like the wire forms and pop bumpers were placed just for the purpose of making that post harder to tighten. Sockets aren’t deep enough and the handle of pliers hits the things around it. So frustrating.

Did you try a 3/16” open end wrench?

#2956 6 months ago
Quoted from JamCat:

Not only that, but that post keeps coming unscrewed on mine and affecting kick outs. I don’t have a tool that can really get in there to screw it in tight enough either. It’s like the wire forms and pop bumpers were placed just for the purpose of making that post harder to tighten. Sockets aren’t deep enough and the handle of pliers hits the things around it. So frustrating.

Yep. Pest with all these t-nuts. I guess only option is to remove Tom and the deflector. Always fun.

#2957 6 months ago
Quoted from Yelobird:

Ok unless I read that wrong it Seems like you are going the wrong direction. You adjusted your game pitch from 5.9 (way to low in my opinion) Up to 6.5 (I prefer 6.8) and Then reduced the flipper power?? When you increase the incline you need to also (most times) Increase the flipper power or I suspect you will never hit that chest. Go up and continue to go up until it goes in. Make sure your not flying off ramps and you should be good to go.

Did you ever fix this? I'm having the same problem now.

Last week I realized that there was very slight damage happening beside MAP, and decided now was as good a time as ever to put the Cliffy on! (the previous owner installed all the other ones but not this one).

So I took the Pearl off, gave the game a good cleaning, put it back on and now.... the ball #1 won't lock. I'm puzzled.

I have done all the tests I could think of and everything seems to be fine. Switch locks 1,2,3 fire off every ball fired (very rapidly), but it just won't lock. It doesn't even try. I can throw the ball up the ramp and it won't work either.. I sit beside it and watch... If I put the ball inside the chest and let it roll, it will lock it. So duh, obviously, it's something to do with it coming in fast.... but I just don't know how I would change that, and why it would have been working the last year (all the issues I've had with this, this is the first "chest" issue).

Anyone encountered this? I have looked at the whole mechanism and got to know it pretty good. It looks like the last owner put a screw that wasn't the right size - it's too long - it sticks out a bit - in the very back (the one that holds the coil), but it's nice and tight.... I couldn't see why this would be the issue? Obviously having the right size screw will make it look aesthetically pleasing but I don't see how this could be the issue..

I saw other people saying to bend the metal piece that locks it....I'm a little hesitant going down that road... I could see it having trouble releasing balls after as the ball release is only a slight coil tick.... Why do they have to make this thing so **** precise. I can see why they wouldn't make it again though honestly....all the dialing in I've done on this bitch. I was done....I *was* done...

I can't even have a game now ugh :/

#2958 6 months ago

edit. I think it's just a bad ground loop iso. Talked with Barry @ JJP. Hooked up my phone to the game w/out the g loop and listened to a GD concert while having lunch. All seemed fine.

#2959 6 months ago

Have been working on my coil settings. Again.

I have at last turned my slings down rather than up which I did before because I’m a dumb shit.
Thought 16 was low, but that’s the highest. Now set it to 27. A bit lethargic but at least no airballs.

Tortuga is now 19 to stop huge rebound of flipper. Ship VUK 20 to protect the back of the pearl.

Flippers is a weird one. My left flipper is only slightly raised at 23 or else I get airballs if post targets if I go any higher. Right flipper has to be around 30 though or I don’t make chest. And now I can no longer back flip and pearl easily. Annoying. Maybe my flipper is binding. I did adjust the left flipper recently so maybe I need to do this to the right.

Does anyone else have trouble backflipping the pearl?

Depths is 15, but only because I have packed behind the solenoid to stop the I lane drains. Depths is now a bit slow in kicking out.

Pitch is 6.7.

Curious to know if others are finding similar behaviour. Especially with the flipper disparity.

And also want to know if anyone made the stupid mistake of thinking a low number for slings meant less power..... how hard would it be to have added a comment in the manual or in the settings.

#2960 6 months ago

So I do have an LE model and I was wondering if somebody could tell me if it is normal that the topper light flickers during the gameplay. Seems to be flickering every time I hit one of the flipper buttons or during gameplay in general when things are happening. Just wondering if I need to look further in to that or if that is how it is supposed to be. Thank you!

#2961 6 months ago
Quoted from MountZion:

So I do have an LE model and I was wondering if somebody could tell me if it is normal that the topper light flickers during the gameplay. Seems to be flickering every time I hit one of the flipper buttons or during gameplay in general when things are happening. Just wondering if I need to look further in to that or if that is how it is supposed to be. Thank you!

Pretty sure that’s a feature setting.

#2962 6 months ago
Quoted from Yelobird:

Pretty sure that’s a feature setting.

Thank you - I appreciate it

#2963 6 months ago

Just put on new audio cable and ground loop. Audio still going in and out. Board issue?

#2964 6 months ago
Quoted from gliebig:

Just put on new audio cable and ground loop. Audio still going in and out. Board issue?

Have you checked the cable going into the audio amp yet? Is it fully seated?

#2965 6 months ago
Quoted from zaphX:

Have you checked the cable going into the audio amp yet? Is it fully seated?

Just played 2 games with no sound problems. I slid the playfield out a little and must have jostled something. No idea what but seems ok for now.

Thanks for your help and suggestions.

#2966 6 months ago

If in doubt, give it a whack.

Hope your sound problems are sorted. I was frustrated with my sound clipping for the first 3 months.

#2967 6 months ago
Quoted from gliebig:

Just played 2 games with no sound problems. I slid the playfield out a little and must have jostled something. No idea what but seems ok for now.
Thanks for your help and suggestions.

Don't you just love pinball sometimes?!

#2968 6 months ago

My POTC: The ball gets hung up somewhere on the under ramp that makes the ball roll up into the Black Peal upkicker for the upper pf. Anyone have this issue? My game goes into ball search.
thanks

#2969 6 months ago
Quoted from surfsled:

My POTC: The ball gets hung up somewhere on the under ramp that makes the ball roll up into the Black Peal upkicker for the upper pf. Anyone have this issue? My game goes into ball search.
thanks

The vertical upkick? You could try raising the power of the VUK coil to the Pearl.

#2970 6 months ago
Quoted from wesman:

The vertical upkick? You could try raising the power of the VUK coil to the Pearl.

It gets stuck on the subway ramp on the way to the vertical upkick.. Upkick is great and powerful once it makes it into the VUK hole. I am trying different solutions right now. Thanks for your input tho!!

#2971 6 months ago
Quoted from surfsled:

It gets stuck on the subway ramp on the way to the vertical upkick.. Upkick is great and powerful once it makes it into the VUK hole. I am trying different solutions right now. Thanks for your input tho!!

Here's a post that discussed this issue also:

https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/56#post-5551557

#2972 6 months ago
Quoted from Yelobird:

Thats the one. Remove and mend if needed the Clear plastic trough. When removed you will see the long flap that is sometimes bowed up holding the ball. Also (again) you need to know the pitch of your playfield. As the ball is trying to roll to the Back of the playfield it will have trouble if your playfield is set to 8 degrees pitch or more. I am at 7.3 ish and it works fine. Good luck.

So you can't make the game tournament difficult? too bad. I don't to play a slow game.

#2973 6 months ago
Quoted from surfsled:

So you can't make the game tournament difficult? too bad. I don't to play a slow game.

Nope one of the features still missing. I act find it funny people say that you only do well because your game is set up easy when in fact we only have default settings. I would love to play on hard settings. With that being said I’ve started playing my machine again. Still brutal

#2974 6 months ago

Seems I have a lowered skirt on my upper middle pop bumper, causing the switch to remain open, and score points when vibrated gameplay wise.

Any ideas on how to adjust this? Doesn't seem to do anything simply by touching it.

20200515_232118 (resized).jpg20200515_233612 (resized).jpg
#2975 6 months ago
Quoted from wesman:

Any ideas on how to adjust this?

Adjust the leaf blade switch for it below the playfield.

Turn the game off. Lift playfield up and lean back. See the leaf blade switch ? The long one with the plastic spoon is pushed by a plastic rod coming down from the pop bumper skirt. This plastic spoon should be clean, ( not worn on older games ) well centered on the rod, just resting on it, not pushing it up. The shorter lower leaf blade switch should be close enough so the slightest ball hit triggers it yet vibration doesn't set it off. A little adjusting/tweaking, and you'll be fine.

LTG : )

#2976 6 months ago
Quoted from LTG:

Adjust the leaf blade switch for it below the playfield.
Turn the game off. Lift playfield up and lean back. See the leaf blade switch ? The long one with the plastic spoon is pushed by a plastic rod coming down from the pop bumper skirt. This plastic spoon should be clean, ( not worn on older games ) well centered on the rod, just resting on it, not pushing it up. The shorter lower leaf blade switch should be close enough so the slightest ball hit triggers it yet vibration doesn't set it off. A little adjusting/tweaking, and you'll be fine.
LTG : )

Thank you again Lloyd!

Sounds like a simple issue! I've watched some tear down videos on pop bumpers here and there, I think Butch did one even, and hopefully this is a quick and simple fix for me!

#2978 6 months ago

Yeah, I was just watching that a bit ago. Damn fine video, really makes a guy like me, or anyone, understand how and why these things work.

Really amazing to see mechanical structures function.

Thanks again Lloyd!

Screenshot_20200516-141415_YouTube (resized).jpg
#2979 6 months ago
Quoted from surfsled:

My POTC: The ball gets hung up somewhere on the under ramp that makes the ball roll up into the Black Peal upkicker for the upper pf. Anyone have this issue? My game goes into ball search.
thanks

Butch’s answer:

First of all, make sure that your playfield is set up for the proper pitch angle, front-to-back, of approximately 6.5 degrees. If you set the game up with all four leg levelers screwed all the way in, you'll be pretty close (if your floor is level). If the playfield is too steep, it can make the problem with your Black Pearl Access VUK subway worse.

Next, use a torpedo level and make sure your playfield is perfectly level, side-to-side, at both the top and bottom of the playfield. Place your torpedo level directly on the playfield when you make the level measurement - on top of the glass is not good enough.

If the ball still gets hung up, I've solved the issue in the past by making a modification to the clear plastic subway piece (circled in red below).

I solved it by fixing picth Angle 6,5, changed the balls that had magnetized, and i also cut the subway as Butch had suggested to me. Problem fix. I also suggest to you to buy Ball Trough Protector / Anti-magnetize shim Williams/Bally upgrade
F28224D8-C3FE-4BD3-8A47-FEE0C04B50E5 (resized).png

77D16165-F6B7-4502-83C9-1C37DBFB97CB (resized).jpeg
#2980 6 months ago
Quoted from gumnut01:

Have been working on my coil settings. Again.
I have at last turned my slings down rather than up which I did before because I’m a dumb shit.
Thought 16 was low, but that’s the highest. Now set it to 27. A bit lethargic but at least no airballs.
Tortuga is now 19 to stop huge rebound of flipper. Ship VUK 20 to protect the back of the pearl.
Flippers is a weird one. My left flipper is only slightly raised at 23 or else I get airballs if post targets if I go any higher. Right flipper has to be around 30 though or I don’t make chest. And now I can no longer back flip and pearl easily. Annoying. Maybe my flipper is binding. I did adjust the left flipper recently so maybe I need to do this to the right.
Does anyone else have trouble backflipping the pearl?
Depths is 15, but only because I have packed behind the solenoid to stop the I lane drains. Depths is now a bit slow in kicking out.
Pitch is 6.7.
Curious to know if others are finding similar behaviour. Especially with the flipper disparity.
And also want to know if anyone made the stupid mistake of thinking a low number for slings meant less power..... how hard would it be to have added a comment in the manual or in the settings.

Hmm. Reading from awhile back, you were at 6.5. What caused you to change?

#2981 6 months ago

whats the best way to remove an optic? My left opto on the right ramp feeding the BP, i need to put some silicone on it so that it stays flush to the ramp so that it registers.

Don't want to break it when removing as there are I believe tabs that fit into the ramp to secure it....it's just the bottom part where wires enter the opto is not flush to ramp causing it not to register.

#2982 6 months ago
Quoted from wesman:

Seems I have a lowered skirt on my upper middle pop bumper, causing the switch to remain open, and score points when vibrated gameplay wise.
Any ideas on how to adjust this? Doesn't seem to do anything simply by touching it.
[quoted image][quoted image]

From the looks of the skirt it seems that maybe its just the pin is stuck on the spoon or possibly slid off of the spoon. The switch itself wouldnt cause that problem that I know of.

*Just noticed I'm a day late and dollar short. Hopefully you got it all fixed up

#2983 6 months ago
Quoted from wesman:

Hmm. Reading from awhile back, you were at 6.5. What caused you to change?

The floor moving with the weather changing......

Just noticed the inner loop is easier to make with a slightly steeper pitch. Could be drinking at the time that affected this theory.

#2984 6 months ago

Just thought I would throw this fix out there in case anyone else has the same issue. I’ve been fighting the issue of my chest forks not lowering all the way and causing rejected shots at the Pass-Through and also the forks sometimes not locking in the upright position if I light the lock during multiball. I tried all sorts of advice I got on here such as adjusting the rollers, pressure plate, hooks, using lithium grease etc. They helped a bit but still didn’t fix it completely.

I finally took the entire assembly off (with some help from the cat) and sat at the table with it. I took it apart and found that the roll pin had partially come out of the plunger shaft and was catching on the coil sleeve! As soon as I hammered that back in and undid all of the other Jerry rigging I had done over the last few months, it works even better than new. Hopefully no one else will have to struggle as long as I did with this one.

5EBAA649-EB8D-4D20-93FA-5CC611AADB72 (resized).jpegABB3FE66-E517-48D0-A6A9-0AE449C236C7 (resized).jpeg
#2985 6 months ago
Quoted from JamCat:

Just thought I would throw this fix out there in case anyone else has the same issue. I’ve been fighting the issue of my chest forks not lowering all the way and causing rejected shots at the Pass-Through and also the forks sometimes not locking in the upright position if I light the lock during multiball. I tried all sorts of advice I got on here such as adjusting the rollers, pressure plate, hooks, using lithium grease etc. They helped a bit but still didn’t fix it completely.
I finally took the entire assembly off (with some help from the cat) and sat at the table with it. I took it apart and found that the roll pin had partially come out of the plunger shaft and was catching on the coil sleeve! As soon as I hammered that back in and undid all of the other Jerry rigging I had done over the last few months, it works even better than new. Hopefully no one else will have to struggle as long as I did with this one.
[quoted image][quoted image]

It’s always good to have a helper. Well done fixing your forks.

B0AE901A-40CF-4145-A44C-7D0DD3E9C991 (resized).jpeg
#2986 6 months ago
Quoted from LTG:

Adjust the leaf blade switch for it below the playfield.
Turn the game off. Lift playfield up and lean back. See the leaf blade switch ? The long one with the plastic spoon is pushed by a plastic rod coming down from the pop bumper skirt. This plastic spoon should be clean, ( not worn on older games ) well centered on the rod, just resting on it, not pushing it up. The shorter lower leaf blade switch should be close enough so the slightest ball hit triggers it yet vibration doesn't set it off. A little adjusting/tweaking, and you'll be fine.
LTG : )

Quoted from GnarLee:

From the looks of the skirt it seems that maybe its just the pin is stuck on the spoon or possibly slid off of the spoon. The switch itself wouldnt cause that problem that I know of.
*Just noticed I'm a day late and dollar short. Hopefully you got it all fixed up

Spot on guys!

I put it back in place, but it popped out again promptly when the skirt was hit on the left side. Had a feeling it might...

Any ideas on the next approach?

20200517_232353 (resized).jpg
#2987 6 months ago
Quoted from wesman:

Spot on guys!
I put it back in place, but it popped out again promptly when the skirt was hit on the left side. Had a feeling it might...
Any ideas on the next approach?
[quoted image]

After reinstalling the skirt. Make sure the point is Exactly centered on the spoon. Its very possible the switch (connected to the spoon) may need to be adjusted. If the spoon is centered And the gap is correct I suspect you will be good to go.

#2988 6 months ago
Quoted from Yelobird:

Make sure the point is Exactly centered on the spoon. Its very possible the switch (connected to the spoon) may need to be adjusted. If the spoon is centered And the gap is correct I suspect you will be good to go.

The switch is mounted to a bracket held to the playfield by a couple screws. You can loosen them and turn a bit if needed and retighten.

LTG : )

#2989 6 months ago
Quoted from Yelobird:

After reinstalling the skirt. Make sure the point is Exactly centered on the spoon. Its very possible the switch (connected to the spoon) may need to be adjusted. If the spoon is centered And the gap is correct I suspect you will be good to go.

Quoted from LTG:

The switch is mounted to a bracket held to the playfield by a couple screws. You can loosen them and turn a bit if needed and retighten.
LTG : )

Thanks guys!

When I was centering it last night, it seemed slightly off, more than the other's were anyway. So maybe loosening those screws and adjusting as so, will pop this popper back into place!

1 week later
#2990 6 months ago
Quoted from vireland:

PROBLEM: Black Pearl reporting stuck open switches
SOLUTION: Remove the Black Pearl and look for broken wires underneath. In one case, the green/brown wire at the Bonus target was broken off resulting in switches 9, 10 and 12 failing (because the switch wires are daisy-chained, one wire broken upstream can break everything after it on the chain). Resoldering broken wires corrects the problem.

I just found this issue on my LE. Exactly those wires broken at the solder joint on the BONUS stand up. Is a complete removal of the BP necessary to fix this? Or can I partially remove? I've had a distributor tell me this is a common problem and a couple of extra zip ties on these wires may prevent it from occurring again.

#2991 6 months ago
Quoted from swampy:

I just found this issue on my LE. Exactly those wires broken at the solder joint on the BONUS stand up. Is a complete removal of the BP necessary to fix this? Or can I partially remove? I've had a distributor tell me this is a common problem and a couple of extra zip ties on these wires may prevent it from occurring again.

Yep. It's not that bad.

#2992 6 months ago
Quoted from swampy:

Or can I partially remove?

Lay a towel on the main playfield. Disconnect the metal bar hooking motor to rocking playfield. Remove the allen head bolt between the rocking playfield and rear wall of the game. Slide the rocking playfield back and lift off of the two pivot points. Set on it's side on the towel.

Fix what needs fixing. Reassemble.

LTG : )

#2993 6 months ago
Quoted from LTG:

Lay a towel on the main playfield. Disconnect the metal bar hooking motor to rocking playfield. Remove the allen head bolt between the rocking playfield and rear wall of the game. Slide the rocking playfield back and lift off of the two pivot points. Set on it's side on the towel.
Fix what needs fixing. Reassemble.
LTG : )

Exactly what we did to fix the exact same issue.

IMG_0509 (resized).jpeg
#2994 6 months ago
Quoted from swampy:

I just found this issue on my LE. Exactly those wires broken at the solder joint on the BONUS stand up. Is a complete removal of the BP necessary to fix this? Or can I partially remove? I've had a distributor tell me this is a common problem and a couple of extra zip ties on these wires may prevent it from occurring again.

Yeah, you need to get the Black Pearl at least on its side to make the repair. It's really not a difficult process.

#2995 6 months ago

My LCD on the apron has failed, someone thought where to look.
Everything seems normal at sight.

Thanks
May

#2996 6 months ago
Quoted from May:

where to look.

Cables to it, and to motherboard in the backbox.

Same screen as used in book on Hobbit and phone on Dialed In.

LTG : )

#2997 6 months ago

MY lcd failed as well a year back. Make sure all cables, power and vga are securely plugged in. Check for power at the connector, if that is good use a spare vga cable and double check by hooking the monitor vga output to the small lcd and see if you get anything.
Also when you unplug the vga from the small lcd and turn on pin it will make the large monitor a smaller frame. I could never figure out why it does this.

#2998 6 months ago
Quoted from LTG:

Lay a towel on the main playfield. Disconnect the metal bar hooking motor to rocking playfield. Remove the allen head bolt between the rocking playfield and rear wall of the game. Slide the rocking playfield back and lift off of the two pivot points. Set on it's side on the towel.
Fix what needs fixing. Reassemble.
LTG : )

Thanks Lloyd and all. Did the repair today. Removed some zip ties and placed new ones in to help prevent too much stretching on the wires of the Bonus, X and Load targets. I found I was able to move the wires through the loom a little to free them up.

#3000 6 months ago

Hello all from a relatively new owner. Does anyone's auto plunger actually make it all the way around the back? Mine will get the ball out but rarely even makes it to the ship. It does seem as though both sides of the auto plunger are in contact with the ball.

I need to take my ship off. I am getting an EOS error for the left mini flipper.

Going to be installing the disk silencer kit this weekend.

I have discovered the "switch history" screen and it is awesome for tracking down phantom switches! I wish all modern games had this feature.

I have version .98 on the game. Is it worth updating to .99 or would you just wait until the new version comes out supposedly soon?

Thanks!

Promoted items from the Pinside Marketplace
From: $ 12.00
Playfield - Toys/Add-ons
The Art of Pinball
$ 24.00
Cabinet - Shooter Rods
The MOD Couple
$ 18.95
From: $ 7.50
Playfield - Protection
Pin Monk
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 81.00
There are 3297 posts in this topic. You are on page 60 of 66.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside