(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

1 year ago



Topic Stats

  • 2,989 posts
  • 165 Pinsiders participating
  • Latest reply 6 days ago by wesman
  • Topic is favorited by 115 Pinsiders

You

Linked Games

Topic Gallery

There have been 541 images uploaded to this topic. (View topic image gallery).

20200517_232353 (resized).jpg
B0AE901A-40CF-4145-A44C-7D0DD3E9C991 (resized).jpeg
5EBAA649-EB8D-4D20-93FA-5CC611AADB72 (resized).jpeg
ABB3FE66-E517-48D0-A6A9-0AE449C236C7 (resized).jpeg
77D16165-F6B7-4502-83C9-1C37DBFB97CB (resized).jpeg
F28224D8-C3FE-4BD3-8A47-FEE0C04B50E5 (resized).png
Screenshot_20200516-141415_YouTube (resized).jpg
20200515_232118 (resized).jpg
20200515_233612 (resized).jpg
424F2DC0-2EEB-4E31-8A95-14578960F139 (resized).jpeg
20200502_074517 (resized).jpg
IMG_2954 (resized).JPG
FFC3A08F-FED3-441F-906E-C407F6912C41 (resized).jpeg
B8E3FB09-6BCC-48BE-8C91-6C12C385E4FF (resized).jpeg
image (resized).jpg
8F70A134-9013-412B-B195-1C6A94E222B2 (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 2989 posts in this topic. You are on page 54 of 60.
#2651 3 months ago
Quoted from vireland:

Try lengthening the amount of time the chest gate release is open to give the balls more time to come out.
Also, are the optos registering in test in the right ORDER? If they're out of order, that could cause what you're seeing.

It appears the gate is not opening up wide enough to release the ball. It makes a couple attempts and ball rolls to drop, but doesn't clear the gate. After a ball search and a couple tries, it appears the gate opens wider. Is that possible?

#2652 3 months ago
Quoted from fossmin:

It appears the gate is not opening up wide enough to release the ball. It makes a couple attempts and ball rolls to drop, but doesn't clear the gate. After a ball search and a couple tries, it appears the gate opens wider. Is that possible?

Yes. You need to gently and slightly bend the metal piece that hovers over the coil post back toward the mini coil post a little more. The problem is it's too far away for the coil magnet to "grab" it reliably. Pretty sure there's an solution entry for this in the index on post 1 of this thread that says the same thing.

EDIT: Yes, there's a link in the first post for this problem https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/50#post-5433533

#2653 89 days ago
Quoted from vireland:

PROBLEM: Tortuga saucer sending the ball SDTM
SOLUTION: Most likely the ball deflector/guide at the back of the Tortuga saucer is loose or mis-aligned. Remove Tortuga Tom and loosen the pop bumper to gain access to the two phillips screws for the deflector that's slightly under the pop bumper skirt. Aim the guard a bit to the left. Test and ensure the scoop fires into the middle of the left flipper. Consider blue loctite to make the fix permanent.
Here's how you get the pop bumper apart to gain access to the two screws:
This is the deflector that you may need to tighten and/or adjust the direction it's pointing:
[quoted image]
These are the screws you need to tighten once the deflector is where you want it:
[quoted image]
There's a single #1 phillips screw each at the front and back of the barrel you need to remove:
[quoted image]
[quoted image]
Once the barrel is off, you see a mounting plate, but the hex set screw that holds it on is hidden underneath it. Feel for it and use a hex wrench to loosen it, then slide the mounting plate up and off:
[quoted image]
This is a better look at the set screw once the plate is off:
[quoted image]
There are now two motor screws to remove. READ THE NEXT STEP BEFORE DOING THIS ONE:
[quoted image]
Under each screw holding the motor on, there's a nylon spacer. Be careful to hold the spacer as you lift the screw out so you don't lose the spacer in the machine:
[quoted image]
Lift the motor up a bit and set it to the side, which will expose the screws for the pop bumper. LOOSEN, DO NOT REMOVE THEM. Once loose, you can raise the skirt in the front where the two screws are for the deflector and tighten/adjust as-needed:
[quoted image]
Reverse the process to put it all back together.

Awesome post thanks so much

#2654 88 days ago

After tweaking the ball deflector and adding loctite I would still get balls SDTM out of the tortuga saucer. Added pad to the coil stop as well to no avail. I then adjusted the coil power down 2 clicks from default and it has been rock solid since for about a dozen games - zero STDM's!

#2655 88 days ago

Have a few acres they showed up on playfield they look like they are from under ship. There are threaded. Any thoughts would be great? Also there are upgraded star posts? Where is the best place to get them? Need to stop the chippin and have seen posts they look like they will help make them more stable?

Also load ball to ship is inconsistent Any thoughts as to what is causing this?

Thanks for help

#2656 87 days ago

Picked up a LE I am the 2nd owner.

Seems like daily I have a switch stuck open or closed. Ship Bullseye stuck Closed, or canon switch.

Off the top of my head it's 48, 79 and sometimes the ship get stuck to the left.

Anyone else having these issues. I recall one being an opto and I just have to drop the ball into the ship.

#2657 87 days ago
Quoted from IdahoRyan:

Seems like daily I have a switch stuck open or closed. Ship Bullseye stuck Closed, or canon switch.

Play it more. Hit more stuff. Errors will go away.

If the tech alert and red dot bother you on power up, turn them off in settings. Then if you want to check for errors, with the game turned on, open coin door, hit the enter button, if any they will be on the screen.

LTG : )

#2658 87 days ago

My shooter rod washer near the rubber tip keeps hitting my auto plunger top. I have adjusted the shooter rod as low as it will go which helps but I still get the occasional al plunge that will graze the top of the auto plunger. Any Suggestions?

#2659 87 days ago
Quoted from Vitty:

Any Suggestions?

Playfield hangers bent and not straight up and down ?

LTG : )

#2660 87 days ago

Any tips for installing side art and not having it get ripped? I just had my kraken side art get chewed up so bad I had to throw it away

#2661 87 days ago
Quoted from LTG:

Play it more. Hit more stuff. Errors will go away.
If the tech alert and red dot bother you on power up, turn them off in settings. Then if you want to check for errors, with the game turned on, open coin door, hit the enter button, if any they will be on the screen.
LTG : )

Wife and I literally play minimum 6 games everyday on the machine LOL

#2662 87 days ago
Quoted from delt31:

Any tips for installing side art and not having it get ripped? I just had my kraken side art get chewed up so bad I had to throw it away

I use pinball universe side blade protectors. I bought them from Mezel Mods. They are a must to not scratch the art while working on it!

0D1D925D-33BA-48B2-B809-8DAE3BD8F6BE (resized).jpeg895FC3D1-EC69-45A1-8998-4153D2842B9B (resized).jpeg
#2663 87 days ago

I like it. I'll get some. thanks!

#2664 87 days ago
Quoted from IdahoRyan:

Wife and I literally play minimum 6 games everyday on the machine LOL

You can go into Tests - Switches - Matrixed, and push any switch to see if it works or not. If it works, it will clear the error.

LTG : )

#2665 87 days ago
Quoted from IdahoRyan:

Picked up a LE I am the 2nd owner.
Seems like daily I have a switch stuck open or closed. Ship Bullseye stuck Closed, or canon switch.
Off the top of my head it's 48, 79 and sometimes the ship get stuck to the left.
Anyone else having these issues. I recall one being an opto and I just have to drop the ball into the ship.

If it’s the ship bullseye, the switch position may need to be adjusted, or the ship may be getting hung up on the post at the top of the loop behind it or on the stationary ship deck preventing it from going back far enough to activate the switch. The switch is behind the back panel and is designed to be adjusted. You can put it in switch test and move the ship manually with the playfield partially out to see what is going on. If it’s the post, you can just remove it with no real effect on the shot.

#2666 87 days ago
Quoted from Vitty:

My shooter rod washer near the rubber tip keeps hitting my auto plunger top. I have adjusted the shooter rod as low as it will go which helps but I still get the occasional al plunge that will graze the top of the auto plunger. Any Suggestions?

I had to put some thin strips of adhesive backed magnet (about 1/16” thick) on the lock bar under the playfield hangers to get it to clear. Better than bending the hangers IMO.

#2667 86 days ago

Thanks all - bent the hangers a bit more downwards and that solved it! Funny thing is both my wonka and pirates were fine and seemed to have developed this same thing over time.

#2668 85 days ago

My left flippers don't seem as "snappy" as they should be. For instance, it is extremely difficult to hit the chapter start shot on my game on the fly. Every other pirates I have played makes that shot on the fly with authority almost always without even really trying. I almost always have to trap up to hit it or the shot will be late and hit the map targets. I rebuilt the flipper (new coil sleeve and plunger) and it is still an issue. The power of the flipper is great, no problems at all hitting the Tortuga ramp, it's just for lack of a better word not as snappy as it should be. I'm thinking maybe be a spring issue?

I have a similar issue with my upper left flipper. I rebuilt that one too in the same way and it is better (got a new loop champ last night) but still I will have flips where the ball seems to just come off the flipper weak instead of a normal flip like you would expect and kind of float into the gold targets or pop bumpers.

Anyone have any ideas or seen something similar on their games? Any help appreciated, thanks!

#2669 85 days ago
Quoted from LesManley:

My left flippers don't seem as "snappy" as they should be. For instance, it is extremely difficult to hit the chapter start shot on my game on the fly. Every other pirates I have played makes that shot on the fly with authority almost always without even really trying. I almost always have to trap up to hit it or the shot will be late and hit the map targets. I rebuilt the flipper (new coil sleeve and plunger) and it is still an issue. The power of the flipper is great, no problems at all hitting the Tortuga ramp, it's just for lack of a better word not as snappy as it should be. I'm thinking maybe be a spring issue?
I have a similar issue with my upper left flipper. I rebuilt that one too in the same way and it is better (got a new loop champ last night) but still I will have flips where the ball seems to just come off the flipper weak instead of a normal flip like you would expect and kind of float into the gold targets or pop bumpers.
Anyone have any ideas or seen something similar on their games? Any help appreciated, thanks!

The spring is only about returning the flipper to the original position. Since you already changed the sleeve and plunger:

- When you manipulate the flipper by hand, does it move freely or does it feel like it's binding/catching?
- Is the flipper lined up with the ball guide, or too low/high?

Everything you need to know about flippers:

#2670 85 days ago
Quoted from zaphX:

The spring is only about returning the flipper to the original position. Since you already changed the sleeve and plunger:
- When you manipulate the flipper by hand, does it move freely or does it feel like it's binding/catching?
- Is the flipper lined up with the ball guide, or too low/high?
Everything you need to know about flippers:

It moves free. It's lined up with the ball guide. I actually used a small wooden block from my kids toy to keep it lined up in place and level with the guide while I tightened the bolt. I'll take a look at the video, thanks.

#2671 85 days ago
Quoted from LesManley:

It moves free.

Look at the mech as a whole under the playfield. Lined up straight ? Coil stop and front bracket holding coil, lined up straight. Not leaning in or out. Then look over the pawl/plunger movement. Nice straight plane it moves on ? And the pawl not too high or low on the flipper shaft ? ( flipper spacer gauge isn't always accurate for an issue like this ). And coil can turn a tiny bit, but not be loose.

Last but not least. Swap left and right flipper button leaf blade switches. I've had a few that just didn't work good. See if problem moves. Poor connection on the blade to the point, or the self cleaning ridge not smooth. If that ridge on the leaf blade that contacts the other ridge on the leaf blade, isn't smooth. I have filed them to a smooth ridge. I know not supposed to file lower power leaf blade switches. But I want stuff working. This is assuming your leaf blades have the self cleaning ridge and not points that look like a smooth rivet. No telling what is in your game without looking.

LTG : )

#2672 85 days ago
Quoted from zaphX:

The spring is only about returning the flipper to the original position. Since you already changed the sleeve and plunger:
- When you manipulate the flipper by hand, does it move freely or does it feel like it's binding/catching?
- Is the flipper lined up with the ball guide, or too low/high?
Everything you need to know about flippers:

Quoted from LTG:

Look at the mech as a whole under the playfield. Lined up straight ? Coil stop and front bracket holding coil, lined up straight. Not leaning in or out. Then look over the pawl/plunger movement. Nice straight plane it moves on ? And the pawl not too high or low on the flipper shaft ? ( flipper spacer gauge isn't always accurate for an issue like this ). And coil can turn a tiny bit, but not be loose.
Last but not least. Swap left and right flipper button leaf blade switches. I've had a few that just didn't work good. See if problem moves. Poor connection on the blade to the point, or the self cleaning ridge not smooth. If that ridge on the leaf blade that contacts the other ridge on the leaf blade, isn't smooth. I have filed them to a smooth ridge. I know not supposed to file lower power leaf blade switches. But I want stuff working. This is assuming your leaf blades have the self cleaning ridge and not points that look like a smooth rivet. No telling what is in your game without looking.
LTG : )

I appreciate when guys like yourselves, and
vireland yelobird and many others race each other to help out folks.

It's so much nicer than when people reply only with snark and quips.

I appreciate this board for the tech help quite a bit! The postering and ego maneuvering, less so.

#2673 85 days ago
Quoted from wesman:

It's so much nicer than when people reply only with snark and quips.

Well LesManley lives in my area. I have to be nice to him. He could get me.

LTG : )

#2674 85 days ago
Quoted from Vitty:

Thanks all - bent the hangers a bit more downwards and that solved it! Funny thing is both my wonka and pirates were fine and seemed to have developed this same thing over time.

Playfields are heavy and JJP playfield brackets are not quite hard enough so some sag over time. It's been a problem almost from the start on JJP machines. JJP packs a LOT on a playfield and it makes them very heavy for those two hanging points. They basically just need to use a steel alloy with better yield strength (which is the kind of strength that resists deforming) to solve the problem, but I don't know if anyone at JJP is working on it. They SHOULD though. Unless they do that, it's not going to go away unless they start cutting crap off the playfield to lighten it, and we don't want that.

#2675 85 days ago
Quoted from vireland:

Playfields are heavy, playfield brackets are not quite hard enough and some sag over time. It's been a problem almost from the start on JJP machines. JJP packs a LOT on a playfield and it makes them very heavy for those two hanging points. They basically just need to use a steel alloy with better yield strength (which is the kind of strength that resists deforming) to solve the problem, but I don't know if anyone at JJP is working on it. They SHOULD though. Unless they do that, it's not going to go away unless they start cutting crap off the playfield to lighten it, and we don't want that.

I remember reading Eric state on at least one occasion that they switched to stronger hooks for Pirates....but then again, my hooks and receiver were so not friendly, that I have no idea if the issue was resolved fully.

That said, I was reading through the Hobbit thread from 3 years back, and holy shit....there were two poor souls that made back to back posts regarding their really, really busted up hooks...maybe due to shipping or who knows really.

#2676 85 days ago
Quoted from wesman:

I remember reading Eric state on at least one occasion that they switched to stronger hooks for Pirates....but then again, my hooks and receiver were so not friendly, that I have no idea if the issue was resolved fully.
That said, I was reading through the Hobbit thread from 3 years back, and holy shit....there were two poor souls that made back to back posts regarding their really, really busted up hooks...maybe due to shipping or who knows really.

Fact is if you look at how the traditional playfield hook is used technically in transport on its backside the playfield is basically Hanging from these little hooks. Compound that with a freight truck finding ever pot hole on the interstate and basically that’s a 700lb force yanking those hooks down all the way to your house. They try to add foam additional support in the back of the playfield but it’s never going to fully keep this from happening. Make them to strong and they crack.

#2677 85 days ago
Quoted from Yelobird:

Fact is if you look at how the traditional playfield hook is used technically in transport on its backside the playfield is basically Hanging from these little hooks. Compound that with a freight truck finding ever pot hole on the interstate and basically that’s a 700lb force yanking those hooks down all the way to your house. They try to add foam additional support in the back of the playfield but it’s never going to fully keep this from happening. Make them to strong and they crack.

I am constantly in awe that any game arrives anywhere in any form other than a pile. I can't even believe the glass doesn't break!

As particular as I am about NIB game condition, I'm really pretty flabbergasted they arrive often intact. Now if they cost much less....I'd be more forgiving with the end result from shipping.

Just popping these babies up, I'm still amazed at how much tech, parts, and overhead go into a machine!

Loving the Hobbit so far....such a lovely game, and the code and immersion is so spectacular!

#2678 84 days ago

What a difference the flipper rebuild has made already. Today's games were successful. I got a bunch of individual mode high scores and 3 wizard modes in my best game. Not my best ever scores JJP Pirates, but best on my specific machine. With Raghetti i never even used his add a ball advantage either, i only chose him because his high score was the lowest of all the characters at the time. Drained with 6x playfield and an extra ball on the board too. Such an amazing game, it truly doesn't get old to me even after blowing it up. And there's still a code update coming too...awesome.
IMG_20200301_171543 (resized).jpg

#2679 83 days ago
Quoted from VolunteerPin:

That is a great idea also. I'll contact JJP first and find out if they will fix/verify. If they will not, I'll PM you and get your shipping info.
Thank you VERY much for the offer!

Hey #Volunteerpin just wanted to let you know your motor relay board arrived on Friday. Well I have some good news and some Not so good news. Took my game down and tested both the relay firing as well as the motor operation and the board is perfectly fine. The bad news is you need to keep looking for your issue. But again, at least your not SOL waiting for the relay boards to come back in! I will wrap it back up and ship it back to you tomorrow. Sorry was hoping this was the issue for you or at least try to fix it but it appears the issue is still at your end. I still say Double Triple check the fuses. That is the Same thing that happened on mine and it oddly ended up being a fuse I assumed was fine. Good luck to you!

#2680 81 days ago
20200129_162035 (resized).jpg20200129_162218 (resized).jpg20200129_162134 (resized).jpg20200129_164500 (resized).jpg20200129_163930 (resized).jpg20200129_163205 (resized).jpg
#2681 81 days ago

Hello pinball pirates. Have an on going issue I need help with. My small display in the apron flickers on/off at times. This is more notable when the machine is under play and the flippers are in use. Thinking a grounding issue, short and/or cold solder connection. Upon removing the apron the power wires were damaged some. I fixed the wires and reflowed the power connections, but the issue continues to persist.
Your thoughts on what to do next.

#2682 81 days ago

Did you check the vga plug on both ends?

I'd test a replacement cable.

#2683 81 days ago

Thanks Houdini I will try that and follow up with how it goes.

#2684 79 days ago

So I was in a chapter that had Tia Dalma as one of the characters. I also had 2X bonus lit. I hit 2X bonus and it collected Tia at the same time. Is that expected?

#2685 79 days ago
Quoted from harryhoudini:

So I was in a chapter that had Tia Dalma as one of the characters. I also had 2X bonus lit. I hit 2X bonus and it collected Tia at the same time. Is that expected?

it would if you were using Norrington since you don't have to hit the target itself, just around it

#2686 79 days ago

Oh shit, no kidding. I really need to read up on the characters. I have just been playing whatever random character I get since it doesn't even matter that much. I have all the high scores in my family and I'm just playing to get better at shots and traps and such. I printed out that comparison sheet someone (maybe zaph) made a while back but never studied it, lol.

Thanks!

#2687 79 days ago

The characters do matter. And if you set up your strategy after the characters you unlock pure awesomeness in the game.

Remember that you can hold left flipper button to get the + and - traits of the characters.

Have a look at the videos from Karl at the IE pinball YouTube channel to see how it’s done.

https://www.youtube.com/user/IEPinball

#2688 79 days ago

Heh, yeah the problem is they really don't matter the way I play. I'm just trying to make shots consistently here, never mind doing anything great. So yeah, I mean I take advantage of some of the traits sure but in the grand scheme it isn't going to change my score a whole lot. I'm happy to lite up and hit every multiball once in a game.

#2689 78 days ago

Hi guys, my game arrives this week but I still haven't received the 220 to 110 conversion kit from JJP. Looking at the manual, it doesn't look that hard to do myself (page D-94). 0.084" pin extractor, move some connections, put in a jumper, and done. Looks like the power supply can remain with these simple changes. Thanks for any input!

#2690 78 days ago
Quoted from dts:

Thanks for any input!

For those doing the 220v to 110v conversion, here is all you need: JJP Part #99-000139-00 (Power Box Assy, USA)
The official JJP USA Power Cable is also part #19-009000-00 (Line Power Cable, USA SJT 18 AWG)

It is a complete power wire harness plus outlet/switch cover that will replace the original. For swapping the easiest thing to do is to start by replacing the 220v outlet/switch cover with the new one and then work towards the back of the machine and finally up into the head. As you go, its easiest to remove the old harness connections and immediately replace with the new. Takes about 30 minutes in total.

LTG : )

#2691 78 days ago

They recommend changing a couple parts out as well as the change in the manual to ensure proper safety protection. The recommendation is to just get the conversion kit to make it easier. I can't recall which parts they were though...

#2692 78 days ago
Quoted from Vitty:

I can't recall which parts they were though...

Read post 2690 in this thread.

LTG : )

#2693 78 days ago

Has anyone had the left scoop at the depths too weak to return the ball all of a sudden?

#2694 77 days ago
Quoted from Outlanes:

Has anyone had the left scoop at the depths too weak to return the ball all of a sudden?

I have only seen that happen during multiball when there are two in there at once. It sometimes takes a few tries before it makes it way out.

#2695 77 days ago
Quoted from Yelobird:

Hey #Volunteerpin just wanted to let you know your motor relay board arrived on Friday. Well I have some good news and some Not so good news. Took my game down and tested both the relay firing as well as the motor operation and the board is perfectly fine. The bad news is you need to keep looking for your issue. But again, at least your not SOL waiting for the relay boards to come back in! I will wrap it back up and ship it back to you tomorrow. Sorry was hoping this was the issue for you or at least try to fix it but it appears the issue is still at your end. I still say Double Triple check the fuses. That is the Same thing that happened on mine and it oddly ended up being a fuse I assumed was fine. Good luck to you!

Well, that is good to know. So, checking continuity of wire between the relay board wires and J109. Here are my results:

YEL-BLU: continuous
YEL-VIO: continuous
YEL power continuous: but this was odd maybe? when I had the meter probe in the YEL at the molex which connects to the motor relay board and checked continuity with all the pins at J109, it WAS CONTINUOUS with pins 1-3 (YEL power, YEL-BLK and YEL-BRN) but not with any of the other pins. I would have thought it would only be continuous with itself at pin 1. Could this finding have anything to do with my issue?

I'm not great with some of this electrical stuff. Here is a snip from the manual showing J109 on the the I/O board:

Also, I had checked fuses F714 and F709 and both were fine. Makes sense that they are as my spinning barrel, spinning pirate, all 3 ramp leds and spotlights are working which are all controlled by J109.

Any additional direction and thoughts are great appreciated.

J109 POTC (resized).JPG
#2696 77 days ago

Any word on when the code update will be released?

#2697 77 days ago
Quoted from catchtds:

Any word on when the code update will be released?

You just won joke of the day!!!

#2698 77 days ago
Quoted from VolunteerPin:

Well, that is good to know. So, checking continuity of wire between the relay board wires and J109. Here are my results:
YEL-BLU: continuous
YEL-VIO: continuous
YEL power continuous: but this was odd maybe? when I had the meter probe in the YEL at the molex which connects to the motor relay board and checked continuity with all the pins at J109, it WAS CONTINUOUS with pins 1-3 (YEL power, YEL-BLK and YEL-BRN) but not with any of the other pins. I would have thought it would only be continuous with itself at pin 1. Could this finding have anything to do with my issue?
I'm not great with some of this electrical stuff. Here is a snip from the manual showing J109 on the the I/O board:
Also, I had checked fuses F714 and F709 and both were fine. Makes sense that they are as my spinning barrel, spinning pirate, all 3 ramp leds and spotlights are working which are all controlled by J109.
Any additional direction and thoughts are great appreciated.[quoted image]

Not an expert and haven’t looked at the manual so take my advise with a grain of salt. I’d move the meter from continuity to ohms and recheck the pins. If the resistance between yellow and the yellow-color wires is 0 or very low you have a problem. This is unlikely since the fuses are fine.

#2699 77 days ago

Hello...i have a problem with the chest
I lock first ball then continue playing and release the ball...
I lock second ball and the same
Why release the ball?

Thanks

#2700 77 days ago
Quoted from Hunico:

Why release the ball?

Balls magnetized and not rolling in the chest right ? Optos in the chest not working ? Not the correct number of balls in the game, too many or one stuck somewhere ?

LTG : )

Promoted items from the Pinside Marketplace
$ 89.95
Cabinet - Shooter Rods
Hookedonpinball.com
$ 24.95
Cabinet - Shooter Rods
Hookedonpinball.com
Wanted
Machine - Wanted
Laredo, TX
Wanted
Machine - Wanted
Lehigh Valley, PA
$ 38.75
Playfield - Toys/Add-ons
The MOD Couple
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 38.00
Playfield - Decals
Pinball Mod Co.
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
There are 2989 posts in this topic. You are on page 54 of 60.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside