(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

7 months ago



Topic Stats

  • 2,273 posts
  • 133 Pinsiders participating
  • Latest reply 2 days ago by koops
  • Topic is favorited by 97 Pinsiders

You

Linked Games

Topic Gallery

There have been 423 images uploaded to this topic. (View topic image gallery).

B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg
9F1B9D3E-F2D5-4E3E-9AEB-3BD0EED68DBF (resized).jpeg
D314C715-D0E4-4264-A44C-CCCAFB4066F5 (resized).jpeg
IMG_0802.jpeg
B54426A1-4B7B-4C6F-8CA3-CBC7D3C9489B (resized).jpeg
20DECB30-95A9-498D-B6B3-68B2C079BFD4 (resized).jpeg
88B6CE6D-1F73-4804-9327-DCA782201677 (resized).jpeg
E13BC387-2C81-4667-AFE4-B77BE147AFA9 (resized).jpeg
F99E00F1-EA3D-4E2E-A5D3-CA5E3E8FF874 (resized).jpeg
4590a30276ddbd055d7cb18b5fb5b0b71bc8871a.jpeg (resized).jpg
6EE11557-4A73-4D3A-9A09-C9276DC7B526 (resized).jpeg
IMG_4015 (resized).JPG
IMG_4015 (resized).JPG

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 2273 posts in this topic. You are on page 40 of 46.
#1951 3 months ago
Quoted from vireland:

The pirate hat and patch seems to be reliant on the shape of the face in the picture. I've NEVER got it with my rounder face, but people angular faces and faces with chin down a bit seem to get them more frequently.

I finally got one by really leaning in towards the camera while finishing my initials.

#1952 3 months ago

Hi there,

Anyone got a video to how remove the chest, my treasure lane opto somehow was removed from his spot, and i dont see any other way to put it back on without removing the chest...

Or some pictures to see which screw i need to remove to get to the opto spot

Thank you

#1953 3 months ago
Quoted from paynemic:

I finally got one by really leaning in towards the camera while finishing my initials.

It definitely has something to do with the geometry of the face. I've been able to get a patch or hat and patch more reliably now that I know what I'm aiming to achieve for the camera.

#1954 3 months ago
Quoted from EaglePin:

I spent a bunch of time on the arm that connects the coil to the door spring trying to slightly bend it in different spots and different amounts.

Thanks for that confirmation. Judging by your picture, it looks like that arm ended up bent further down and to the right (towards the Marty lane). Is that right? And by bending it that way you keep that spring loop on the front edge of that arm? Do you think spring location is the key?

#1955 3 months ago
Quoted from Galooch:

Thanks for that confirmation. Judging by your picture, it looks like that arm ended up bent further down and to the right (towards the Marty lane). Is that right? And by bending it that way you keep that spring loop on the front edge of that arm? Do you think spring location is the key?

Everything is key with that little door. The direction of the spring, making sure all the screws that are holding the mechs down are tight, the several bends of that arm, the door hinge and spacers. It's a bit precarious in design. I designed a bit of an update to it but haven't produced it yet. It makes the door swing much more fully and completely, and it looks like a cannon loading door.

#1956 3 months ago

Has anyone seen this issue before with the chest slowly releasing the balls or not releasing at all? It seems like it keeps clicking and nudging the ball slowly until it comes out or into the ball search. Any help is greatly appreciated.

#1957 3 months ago
Quoted from splitcms:

Has anyone seen this issue before with the chest slowly releasing the balls or not releasing at all? It seems like it keeps clicking and nudging the ball slowly until it comes out or into the ball search. Any help is greatly appreciated.

Really common, search if you want more details but the gist is either the balls are magnetized and/or the release arm needs to be adjusted. First, in coil test make sure the arm actually is getting pulled all the way back by the solenoid. Then using very light pressure just bend the arm a bit back or a bit open depending on what looks to be catching the ball. You just need it to hold the balls in enough that 3 of them don't push it open. If you are in test mode the chest will automatically open if there is a ball in there so you can easily test by dropping balls in. You can also adjust the speed of the opening cycle in the menu so check that out.

#1958 3 months ago
Quoted from splitcms:

Has anyone seen this issue before with the chest slowly releasing the balls or not releasing at all? It seems like it keeps clicking and nudging the ball slowly until it comes out or into the ball search. Any help is greatly appreciated.

Most likely the timing of the release needs to be adjusted on the settings menu.
Second most likely the arm is too far away from the coil in the back and needs to be tweaked a little closer so the coil opens the arm more solidly
Last most likely is the balls are magnetized, but if that were the case, you'd likely be having ball trough issues, too.

#1959 3 months ago
Quoted from Galooch:

Thanks for that confirmation. Judging by your picture, it looks like that arm ended up bent further down and to the right (towards the Marty lane). Is that right? And by bending it that way you keep that spring loop on the front edge of that arm? Do you think spring location is the key?

Ditto what Harry said. It’s kind of a mix of getting everything lined up so it works. Not a super well designed mech. I think for me the main factor was getting the slight bend of the arm into a functional position. I found I was really able to get the arm to bend the way I needed it by putting needle nose pliers under it and gently pressing. Here are a couple pictures of my arm and what I mean by using the pliers.

840DB85A-3DBF-413A-B856-B48BEB7FC421 (resized).jpegCF9C487F-F8F1-4851-8AE8-E84FDE9172DF (resized).jpegF44850D4-1A13-4FF1-BB8F-D47BE016CF20 (resized).jpeg
#1960 3 months ago

Just wanted to say thank you to all the folks who chimed in! Somehow I missed that this coil was a magnet entirely. I've got a good idea of what needs done now, thanks!

#1961 3 months ago

Thanks to all that keep chiming in to answer people's questions, even though some of the questions have been repeated multiple times. I'm getting my game this week and with all the tweaks and issues this game has, I'm sure I'll have to ask for help eventually too. Supposedly the factory installed all the fixes they know about and play tested it, so we'll see how much I need to do

#1962 3 months ago
Quoted from EaglePin:

Ditto what Harry said. It’s kind of a mix of getting everything lined up so it works. Not a super well designed mech. I think for me the main factor was getting the slight bend of the arm into a functional position. I found I was really able to get the arm to bend the way I needed it by putting needle nose pliers under it and gently pressing. Here are a couple pictures of my arm and what I mean by using the pliers.[quoted image][quoted image][quoted image]

This. A pic is wortha thousand words. See how his arm is directly in between the 2 lanes. Swivel your arm so it looks like that and you cannon door should work properly. why he has the pliers in there like he is bending something idk. Move arm to middle first then if it still is sticking I guess try to bend.

Edit* His actually looks like it could swivel left a bit. Probly why he resorted to bending the arm

#1963 3 months ago
Quoted from GnarLee:

This. A pic is wortha thousand words. See how his arm is directly in between the 2 lanes. Swivel your arm so it looks like that and you cannon door should work properly. why he has the pliers in there like he is bending something idk. Move arm to middle first then if it still is sticking I guess try to bend.
Edit* His actually looks like it could swivel left a bit. Probly why he resorted to bending the arm

The arm on mine was bent too far down so the door was always open. Pliers over or under the arm created a ledge so I could bend the arm in the middle to adjust it to a spot where it worked. First I put the pliers over it to bend the end up but I did it too much, then had to put the pliers under it to nudge it back down a bit.

#1964 3 months ago
Quoted from EaglePin:

The arm on mine was bent too far down so the door was always open. Pliers over or under the arm created a ledge so I could bend the arm in the middle to adjust it to a spot where it worked. First I put the pliers over it to bend the end up but I did it too much, then had to put the pliers under it to nudge it back down a bit.

Luckily it's pretty soft metal and easy to bend. I grabbed mine with the pliers and bent it but I also removed it a few times to tweak. It's a pain to remove because you have to loop that lower spring back on. I ended up removing more of the junk around it so I could get pliers in there to attach it.

#1965 88 days ago

I’m having major issues with the chest forks not retracting more than half way. I can’t find any other posts on it. Surely others are having this issue? The magnet does release the tabs but it seems to have a lot of friction holding the assembly at least half way up. It screeches when I push it back down manually. Is that assembly supposed to magnetize back down into the coil sleeve? Or is the weight of the assembly and gravity relied on to put it back down? If it’s supposed to magnetize back down then that is not working. There is some left to right play within the sleeve but I can’t see any adjustment that would make a difference. I might have to get JJP to help with this one. Just thought I’d see if anyone else had the issue.

#1966 88 days ago
Quoted from JamCat:

I’m having major issues with the chest forks not retracting more than half way. I can’t find any other posts on it. Surely others are having this issue? The magnet does release the tabs but it seems to have a lot of friction holding the assembly at least half way up. It screeches when I push it back down manually. Is that assembly supposed to magnetize back down into the coil sleeve? Or is the weight of the assembly and gravity relied on to put it back down? If it’s supposed to magnetize back down then that is not working. There is some left to right play within the sleeve but I can’t see any adjustment that would make a difference. I might have to get JJP to help with this one. Just thought I’d see if anyone else had the issue.

I managed to make it a little better at least but it’s not 100%. Apparently there is a single loop tab in the center of the pressure plate that governs how far out it can go. It had gotten bent out over time allowing the plate to put too much pressure on the fork assembly. So when the tabs were released the plate was still wedging the whole assembly so it couldn’t slide on the track easily. It still stays up a little, but the next shot pushes it down now so at least it’s functional. I’ll have to tinker more later to get it working perfectly.

#1967 87 days ago

If you slide the forks up and down with your hand under the game do they move freely? I found mine even needed a bit of dry lube as the tracks are sharp and the nylon bushings can get a bit hung up on them. There is definitely room for adjustments in there to make everything fit well.

#1968 87 days ago
Quoted from JamCat:

I’m having major issues with the chest forks not retracting more than half way. I can’t find any other posts on it. Surely others are having this issue? The magnet does release the tabs but it seems to have a lot of friction holding the assembly at least half way up. It screeches when I push it back down manually. Is that assembly supposed to magnetize back down into the coil sleeve? Or is the weight of the assembly and gravity relied on to put it back down? If it’s supposed to magnetize back down then that is not working. There is some left to right play within the sleeve but I can’t see any adjustment that would make a difference. I might have to get JJP to help with this one. Just thought I’d see if anyone else had the issue.

I have had this same issue twice, the first time I was checking to see if things were binding and I ended up making some mechanical adjustments. After a while, the problem returned but at this time I just used a small amount of white lithium grease on the bushings in the tracks to help them move more freely and that has solved the issue for now. Pretty handy stuff.

#1969 87 days ago

Having undefined issues with JJPOTC and can't figure out what to adjust. Issues can be added to game log.

Problem 1 - when locked in star map area, a ball rests against up post and leans left or right. When it leans left and the up post is dropped, ball often drains down the middle without touching anything. Hoping code would have addressed this possibility and still pulling for a software fix, but what can I try now?

Approach 1 - first thought is to lower right rear leg leveler, causing back part of game to lean ever so slightly to the right. See if this snags ball on way down.

Problem 2 - ball passing through I-inlane drains 99% of time. Player should be able to nudge ball occasionally to flip into the left flipper lane, but nothing works.

Approach 2 - ball needs to catch the edge of metal guide in order to be diverted into flipper lane. Needs to Unscrew something, add something and make it happen. Really don't have any ideas.

#1970 87 days ago
Quoted from jeffspinballpalace:

Having undefined issues with JJPOTC and can't figure out what to adjust. Issues can be added to game log.
Problem 1 - when locked in star map area, a ball rests against up post and leans left or right. When it leans left and the up post is dropped, ball often drains down the middle without touching anything. Hoping code would have addressed this possibility and still pulling for a software fix, but what can I try now?
Approach 1 - first thought is to lower right rear leg leveler, causing back part of game to lean ever so slightly to the right. See if this snags ball on way down.
Problem 2 - ball passing through I-inlane drains 99% of time. Player should be able to nudge ball occasionally to flip into the left flipper lane, but nothing works.
Approach 2 - ball needs to catch the edge of metal guide in order to be diverted into flipper lane. Needs to Unscrew something, add something and make it happen. Really don't have any ideas.

Dialed in had an issue where ball would go sdtm from the theater. Fix was to raise the back right leg three or four turns and it would fall to the left flipper, it worked. Maybe code can pulse the magnet as it releases or add a short ball save if raising back leg doesn’t work. It’s rare mine goes sdtm, but it does happen.

For problem 2, very tough to save it on my game. I try to nudge before it gets into the I lane, have more success with that than once it goes into the lane.

#1971 87 days ago
Quoted from jeffspinballpalace:

Having undefined issues with JJPOTC and can't figure out what to adjust. Issues can be added to game log.
Problem 1 - when locked in star map area, a ball rests against up post and leans left or right. When it leans left and the up post is dropped, ball often drains down the middle without touching anything. Hoping code would have addressed this possibility and still pulling for a software fix, but what can I try now?
Approach 1 - first thought is to lower right rear leg leveler, causing back part of game to lean ever so slightly to the right. See if this snags ball on way down.
Problem 2 - ball passing through I-inlane drains 99% of time. Player should be able to nudge ball occasionally to flip into the left flipper lane, but nothing works.
Approach 2 - ball needs to catch the edge of metal guide in order to be diverted into flipper lane. Needs to Unscrew something, add something and make it happen. Really don't have any ideas.

Here’s an idea for your SDTM issue.

https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/227#post-5094603

After I put the sleeve on the left post my instances of STDM from that area went way down. Still happens some times if the magnet kick off the back of the star area sends it just right, but it’s not happening near as much for me anymore. Added bonus of having the post sleeve there is it protects the rubber ring on it from direct hits. It is a challenge getting access to put the sleeve on though. I did it when I had the Pearl off. I might be wrong, but I think the Pearl has to come off in order to remove the plastic above the post and put the sleeve on.

Here’s a link to the post sleeve I used:

https://www.marcospecialties.com/pinball-parts/38-5151

#1972 87 days ago

I assume when ball comes down the P lane its getting caught by the gate and draining in I lane? If this is what you meant mine does the same thing when machine is slightly off level. Its also not bulletproof I.E. every now and again it will just happen nothing can be done. But ya if its happening a lot look at your level left right. Could also help with the SDTM from chapter select. I did replace my rubbers in chapter select area with some perfectplay and sdtm has been happening alot less. I think the rubber is just a tad thicker or maybe my old rubber was starting to stretch but there was less SDTM affter replacing rubbers up there

#1973 87 days ago

Rubber sleeve looks like the way to go and I’ll also try adjusting levelers.

Quoted from EaglePin:

Here’s an idea for your SDTM issue.
https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/227#post-5094603
After I put the sleeve on the left post my instances of STDM from that area went way down. Still happens some times if the magnet kick off the back of the star area sends it just right, but it’s not happening near as much for me anymore. Added bonus of having the post sleeve there is it protects the rubber ring on it from direct hits. It is a challenge getting access to put the sleeve on though. I did it when I had the Pearl off. I might be wrong, but I think the Pearl has to come off in order to remove the plastic above the post and put the sleeve on.
Here’s a link to the post sleeve I used:
https://www.marcospecialties.com/pinball-parts/38-5151

#1974 87 days ago
Quoted from JamCat:

I’m having major issues with the chest forks not retracting more than half way. I can’t find any other posts on it. Surely others are having this issue? The magnet does release the tabs but it seems to have a lot of friction holding the assembly at least half way up. It screeches when I push it back down manually. Is that assembly supposed to magnetize back down into the coil sleeve? Or is the weight of the assembly and gravity relied on to put it back down? If it’s supposed to magnetize back down then that is not working. There is some left to right play within the sleeve but I can’t see any adjustment that would make a difference. I might have to get JJP to help with this one. Just thought I’d see if anyone else had the issue.

I found the roll pin connecting the solenoid plunger in the coil sleeve was hanging up and scoring the coil sleeve .
It took a couple of us to pull the mechanism off the playfield and tap the roll pin in to center.

#1975 86 days ago

Thank you again to all you have taken the time to respond and provide pictures to help with my cannon door. Super helpful! I think I have improved things but I have a few more tweaks to make. It isn't consistent enough yet. However, I now have a few other items that cropped up:

1. The left spinner on the BP is no longer spinning. I found that when I put back the top portion after tweaking the cannon door, it sits on top of the left side of the spinner. A quick search revealed this post from a few months ago (https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4984403) where joseph5185 successfully was able to put that piece back on at different angles. I have been trying to find that angle (not tightening the right-most bolt all the way too), but it consistently slides down and pins the spinner. Has anyone else encountered this issue and if so, how did you solve it? I really don't remember that part of the BP sitting crooked before taking it off.

2. It appears that I have my first switch issues. The Bonus (X) and Load switch on the BP are no longer registering. A quick inspection on the left side of the BP and I can see that all wires are firmly still attached. What else should I check? I'm hoping something simple that won't require me to remove the BP (haven't had to do it yet). I have not ordered the BP protector from Pinball Life yet and I'm wondering if a ball ricocheted and did some damage. Has anyone had those two switches go out at the same time?

Thanks.

IMG_2196 (resized).JPG
#1976 86 days ago

I was looking for the solution to the ball getting stuck under the Dauntless. I found several posts reporting it but not the solution. Does anyone know where it's at or what to do?
Thanks!!

#1977 86 days ago
Quoted from Heater:

I was looking for the solution to the ball getting stuck under the Dauntless. I found several posts reporting it but not the solution. Does anyone know where it's at or what to do?
Thanks!!

You mean in the subway? Or the ball not coming out when you hit into the Dauntless with the cannon?

#1978 86 days ago

It must be getting stuck coming out of the Dauntless. Attach is the pict Zaphx took with the same problem #2994 in the Offical Owner thread

pasted_image (resized).png
#1979 86 days ago
Quoted from Galooch:

Thank you again to all you have taken the time to respond and provide pictures to help with my cannon door. Super helpful! I think I have improved things but I have a few more tweaks to make. It isn't consistent enough yet. However, I now have a few other items that cropped up:
1. The left spinner on the BP is no longer spinning. I found that when I put back the top portion after tweaking the cannon door, it sits on top of the left side of the spinner. A quick search revealed this post from a few months ago (https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4984403) where joseph5185 successfully was able to put that piece back on at different angles. I have been trying to find that angle (not tightening the right-most bolt all the way too), but it consistently slides down and pins the spinner. Has anyone else encountered this issue and if so, how did you solve it? I really don't remember that part of the BP sitting crooked before taking it off.
2. It appears that I have my first switch issues. The Bonus (X) and Load switch on the BP are no longer registering. A quick inspection on the left side of the BP and I can see that all wires are firmly still attached. What else should I check? I'm hoping something simple that won't require me to remove the BP (haven't had to do it yet). I have not ordered the BP protector from Pinball Life yet and I'm wondering if a ball ricocheted and did some damage. Has anyone had those two switches go out at the same time?
Thanks.[quoted image]

In my experience when those switches go out, it’s a wire under the Pearl (Green/Brown if I remember correctly.)

We couldn’t find the break until we removed the Pearl; it looked OK from the side.

#1980 86 days ago
Quoted from Galooch:

Thank you again to all you have taken the time to respond and provide pictures to help with my cannon door. Super helpful! I think I have improved things but I have a few more tweaks to make. It isn't consistent enough yet. However, I now have a few other items that cropped up:
1. The left spinner on the BP is no longer spinning. I found that when I put back the top portion after tweaking the cannon door, it sits on top of the left side of the spinner. A quick search revealed this post from a few months ago (https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/17#post-4984403) where joseph5185 successfully was able to put that piece back on at different angles. I have been trying to find that angle (not tightening the right-most bolt all the way too), but it consistently slides down and pins the spinner. Has anyone else encountered this issue and if so, how did you solve it? I really don't remember that part of the BP sitting crooked before taking it off.
2. It appears that I have my first switch issues. The Bonus (X) and Load switch on the BP are no longer registering. A quick inspection on the left side of the BP and I can see that all wires are firmly still attached. What else should I check? I'm hoping something simple that won't require me to remove the BP (haven't had to do it yet). I have not ordered the BP protector from Pinball Life yet and I'm wondering if a ball ricocheted and did some damage. Has anyone had those two switches go out at the same time?
Thanks.[quoted image]

I had to play with how the top roof sits so it wouldn't make my cannon door stick. I settled on putting it on straight, but with the back of it sitting down a bit farther than the front. To do that I placed it in the position that was going to work, then just tightened the nuts down to that level without the nuts getting turned too far and pushing the roof down further than I wanted it.

For the Bonus and Load switch, I think it's 99% likely there is a broken wire somewhere. I've had them out twice and both times was due to a broken wire. The wiring for switch #9, #10, and #12 is daisy chained together, so depending on where the wire is broken it can cut off 1, 2, or all 3 targets. Most likely it's the green wire with a brown stripe that's broken. Follow that wire around and I'm guessing you'll find a spot where it's broken or where an end is no longer connected to a switch. If it's not the green/brown wire then check the others. The wires are pretty stiff and don't just dangle down when they break, so it can definitely look like they're connected when they really aren't. On mine they still were pretty much in the same position they were in when they were connected, but had just separated a little bit.

#1981 84 days ago

I’m sure this has been discussed before but I don’t feel like digging through posts. My VUK to the pearl ship seems to not be working anymore. Ill shoot the left orbit and it will go into the hole and just sit there until it goes into ball search mode. Does anyone know the cause and fix for this? Thank you.

#1982 84 days ago
Quoted from splitcms:

I’m sure this has been discussed before but I don’t feel like digging through posts. My VUK to the pearl ship seems to not be working anymore. Ill shoot the left orbit and it will go into the hole and just sit there until it goes into ball search mode. Does anyone know the cause and fix for this? Thank you.

Whatever senses the ball in there isn't working or needs re-ajusted.... its eaither a opto or a switch

#1983 84 days ago

I’m not even sure if the VUK is the issue. The ball is just going there and not doing anything. I have a feeling that the ball shouldn’t even be going there because it happens at the start of a game when I shoot the left orbit. Instead of going around to the right orbit and back down, it’s falling into where the VUK hole is and not doing anything

#1984 84 days ago
Quoted from splitcms:

I’m not even sure if the VUK is the issue. The ball is just going there and not doing anything. I have a feeling that the ball shouldn’t even be going there because it happens at the start of a game when I shoot the left orbit. Instead of going around to the right orbit and back down, it’s falling into where the VUK hole is and not doing anything

If you go into switch test mode and manually activate the switch at the bottom of the vuk, does it register?

#1985 84 days ago

Was getting random pieces of 8 without hitting the shot. Friendly reminder to every now and again clean your optos. Problem was dirty opto not giving a good signal little vibration and switch would go off. cleaned with q-tip and a little bit of alcohol.

#1986 84 days ago
Quoted from splitcms:

I’m not even sure if the VUK is the issue. The ball is just going there and not doing anything. I have a feeling that the ball shouldn’t even be going there because it happens at the start of a game when I shoot the left orbit. Instead of going around to the right orbit and back down, it’s falling into where the VUK hole is and not doing anything

Check your pitch. The subway does not work if the pitch is too steep. Happened to me when first got the game when pitch was about 8. Take it down to 6.5 and it should work.

#1987 83 days ago

Hey Folks, Just finished reading the first 20 pages of this POTC Tips thread. I'm also 40 pages into the 253 page "Owners" thread. I unpacked my NIB LE yesterday and it's has played wonderfully out of the box. Built 2/22/2019.

I have a question which I've not come across yet in all my reading.... I'm not thrilled with the way the ball lands on the PF from the Shooter wireform. Has anyone developed a Mod for this? I don't understand why JJP would just throw a metal ball onto a wooden table. Mylar isn't going to help in the long run it would seem?

Thanks in advance.
Murphy

#1988 83 days ago
Quoted from MurphyPeoples:

Hey Folks, Just finished reading the first 20 pages of this POTC Tips thread. I'm also 40 pages into the 253 page "Owners" thread. I unpacked my NIB LE yesterday and it's has played wonderfully out of the box. Built 2/22/2019.
I have a question which I've not come across yet in all my reading.... I'm not thrilled with the way the ball lands on the PF from the Shooter wireform. Has anyone developed a Mod for this? I don't understand why JJP would just throw a metal ball onto a wooden table. Mylar isn't going to help in the long run it would seem?
Thanks in advance.
Murphy

There's already Mylar on the playfield in the landing zone.

The green on this pic from page 220 of the manual is where the mylar is...

jjPotC-Mylar (resized).jpg
#1989 83 days ago
Quoted from vireland:

There's already Mylar on the playfield in the landing zone.
The green on this pic from page 220 of the manual is where the mylar is...[quoted image]

Thank you for the quick response! How is this area holding up for "high game count" owners?

I changed all 6 Sling Posts to Star Posts with the Marco thin rubber washers before playing game 1. Just trying to protect my investment, though I
can't ever seeing us selling this game! Love it!

#1990 83 days ago
Quoted from MurphyPeoples:

Thank you for the quick response! How is this area holding up for "high game count" owners?
I changed all 6 Sling Posts to Star Posts with the Marco thin rubber washers before playing game 1. Just trying to protect my investment, though I
can't ever seeing us selling this game! Love it!

We have it on route and it seems fine in that area. The only area that isn't protected that should be IMO is the place where the forks come up. The jjPotC here chipped there within the first week. I made a custom mylar to protect it after that happened and no problems since.

#1991 82 days ago
Quoted from vireland:

The only area that isn't protected that should be IMO is the place where the forks come up. The jjPotC here chipped there within the first week.

PinMonk can you please post a picture of this area you mention? I'm trying to figure out "where the forks come up". Sorry to be a Nube about this game.
Thanks for putting up with my questions. - Murph

#1992 82 days ago
Quoted from MurphyPeoples:

I'm trying to figure out "where the forks come up".

Under the chest. Two slots.

Ball rolls under the chest and if the two forks are up, the ball hops up into the trunk. If the two forks are down, the balls keeps rolling through.

LTG : )

#1993 82 days ago
Quoted from LTG:

Under the chest. Two slots.
Ball rolls under the chest and if the two forks are up, the ball hops up into the trunk. If the two forks are down, the balls keeps rolling through.
LTG : )

Excellent! Thanks Lloyd!

#1994 82 days ago
Quoted from MurphyPeoples:

PinMonk can you please post a picture of this area you mention? I'm trying to figure out "where the forks come up". Sorry to be a Nube about this game.
Thanks for putting up with my questions. - Murph

What lloyd said. The protector I made to stop further damage looks like this:

mylar-protector-sml (resized).jpg
#1995 82 days ago
Quoted from splitcms:

I’m not even sure if the VUK is the issue. The ball is just going there and not doing anything. I have a feeling that the ball shouldn’t even be going there because it happens at the start of a game when I shoot the left orbit. Instead of going around to the right orbit and back down, it’s falling into where the VUK hole is and not doing anything

As mentioned by gumnut01 there is a very good chance it’s your pitch. Bring it down to 6.5 Degrees and you could also add a washers at the end of the mini subway right before it goes into the VUK.

To confirm it’s your pitch you can do this very carefully when it happens; I have had to do this occasionally.
Lift the front of the machine up about 1-2” , the ball will then roll into the VUK and will be kicked up into the BP.

Be very careful lifting; use your legs! And make sure you have enough room behind the machine so the back of the head doesn’t hit anything when it tilts. Don’t lift anymore than 1-2”.

#1996 82 days ago
Quoted from vireland:

We have it on route and it seems fine in that area. The only area that isn't protected that should be IMO is the place where the forks come up. The jjPotC here chipped there within the first week. I made a custom mylar to protect it after that happened and no problems since.

Also where the vulk shoots the ball to the upper playfield...i put mylar there

#1997 82 days ago
Quoted from bigd1979:

Also where the vulk shoots the ball to the upper playfield...i put mylar there

You put mylar over mylar? There's already mylar on the Black Pearl there from the factory...

#1998 82 days ago
Quoted from vireland:

You put mylar over mylar? There's already mylar on the Black Pearl there from the factory...

Mine didn’t.

#1999 82 days ago
Quoted from gumnut01:

Mine didn’t.

Monday assembly date?

#2000 82 days ago
Quoted from vireland:

PROBLEM: Screw on top of the post from the sling under the Black Pearl ramp is pushing into the ramp, deforming it with a dent. You can see it in this picture, just below the "P" in "Pearl," tearing the ramp sticker a little and pushing up deforming the ramp with a bump.
[quoted image]
SOLUTION: The post in question really should have been a metal mini-post from the factory to allow proper clearance for the ramp above and still allow tension for the slingshot below. As it is now, you can back off the two #1 philips screws at the entrance to the ramp to release some of the tension on this screw, but not too much because you want the ramp to still be solidly connected to the playfield.
If you're feeling ambitious, you can try swapping in a mini-post instead.

Added 123 days ago: EDIT: Messing with the bottom screw that is denting the ramp causes other problems because that is literally the only thing giving support to that side of the ramp. It's basically a terrible design with no left-side support. I'd leave it alone and deal with the sticker tearing and bump where the screw is pressing in.

I know this is old but I assume that was the last update for this issue?

I checked mine tonight and found I had the same thing. I could see very fine plastic cracks so I had to do something about it.

I solved it by sanding 5mm off the offending post itself. I also trimmed the switch while I was there and put washers under the posts.

Screwed down the lowest one and then the star post so that they had even pressure now they have that uneven metal cover.

Heaps of space now!

77C4799F-FEBC-43AF-8C3F-99AB6738BD25 (resized).jpeg1E5A43B6-C705-4B95-B725-EED513C273C4 (resized).jpeg

Was able to adjust the angle that it hits the ship with by playing with the screw that goes into the hex bolt. It’s now smoother than factory

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Flagstaff, AZ
Wanted
Machine - Wanted
Lincoln, NE
From: $ 255.00
Playfield - Toys/Add-ons
Pinball Mod Co.
Wanted
Machine - Wanted
Flagstaff, AZ
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 175.00
Gameroom - Decorations
Pinball Photos
There are 2273 posts in this topic. You are on page 40 of 46.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside