(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

7 months ago



Topic Stats

  • 2,273 posts
  • 133 Pinsiders participating
  • Latest reply 8 days ago by koops
  • Topic is favorited by 97 Pinsiders

You

Linked Games

Topic Gallery

There have been 423 images uploaded to this topic. (View topic image gallery).

B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg
9F1B9D3E-F2D5-4E3E-9AEB-3BD0EED68DBF (resized).jpeg
D314C715-D0E4-4264-A44C-CCCAFB4066F5 (resized).jpeg
IMG_0802.jpeg
B54426A1-4B7B-4C6F-8CA3-CBC7D3C9489B (resized).jpeg
20DECB30-95A9-498D-B6B3-68B2C079BFD4 (resized).jpeg
88B6CE6D-1F73-4804-9327-DCA782201677 (resized).jpeg
E13BC387-2C81-4667-AFE4-B77BE147AFA9 (resized).jpeg
F99E00F1-EA3D-4E2E-A5D3-CA5E3E8FF874 (resized).jpeg
4590a30276ddbd055d7cb18b5fb5b0b71bc8871a.jpeg (resized).jpg
6EE11557-4A73-4D3A-9A09-C9276DC7B526 (resized).jpeg
IMG_4015 (resized).JPG
IMG_4015 (resized).JPG

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 2273 posts in this topic. You are on page 30 of 46.
#1451 5 months ago

Does anyone know how to remove the Black Pearl lamps? I have one that doesn't illuminate very well, I think it's not in contact with the LED below it very well. This is the lamp I'm talking about, not mine, from the internet...
map (resized).jpg

#1452 5 months ago
Quoted from jarozi:

Does anyone know how to remove the Black Pear l lamps? I have one that doesn't illuminate very well, I think it's not in contact with the LED below it very well.

This is explained in this thread somewhere.

You need to remove the wall, remove the LED, make the hole bigger, mount the LED back in better.

LTG : )

#1453 5 months ago

The LEDs under there need to be pointed straight up the channel at the lantern. The lantern is just a decoration above it. If the LED is angled a bit below the decoration the light will be dimmer than it otherwise could be.

#1454 5 months ago
Quoted from jarozi:

Does anyone know how to remove the Black Pear l lamps? I have one that doesn't illuminate very well, I think it's not in contact with the LED below it very well. This is the lamp I'm talking about, not mine, from the internet...
[quoted image]

Quoted from jarozi:

Does anyone know how to remove the Black Pear l lamps? I have one that doesn't illuminate very well, I think it's not in contact with the LED below it very well. This is the lamp I'm talking about, not mine, from the internet...
[quoted image]

You need to remove the plastic right next to flipper.

I had to drill my hole for led out a bit. Wasn’t lighting much at all, it fixed the issue.

#1456 5 months ago

Updated the index with an entry for this problem and a link to the solution. Thanks!

#1457 5 months ago

Just had a ripper of a game where the slings propelled the ball over into the dreaded “I” lane. Anyway not the first time this has happened. Fixed it. Don’t care if it looks ugly.

824631FC-32C3-4B7C-AF6A-B84B133F528C (resized).jpegimage (resized).jpg
#1458 5 months ago

Also noticed that you can’t see the shooter tip. Changed it. Now I can.

07A91331-0BA6-43DE-8B03-BC2F1C55C089 (resized).jpegC9F89022-B7A9-4941-80D1-B955305F22CA (resized).jpeg
#1459 5 months ago

You can make that bracket look good easy (does noty look bad) mount one of the gold coins or get a small toy to put on it problem solved

*edit Be prepared to get a ball stuck in those spotlights one day. Happened to me other day and couldnt believe it.

#1460 5 months ago
Quoted from GnarLee:

You can make that bracket look good easy (does noty look bad) mount one of the gold coins or get a small toy to put on it problem solved
*edit Be prepared to get a ball stuck in those spotlights one day. Happened to me other day and couldnt believe it.

Yeah me too!!

I changed the lights to point more infield. They were quite loose.

Liked the idea about the toy.

F930DE1D-46D7-4A38-B9AF-EE572DCA2025 (resized).jpeg
#1461 5 months ago

Ok, so how does one replace the pop bumper skirts? Do I really have to cut all of the lighting wires to release the skirt? I assume I'll have to desolder the motors from the spinning mechs, not entirely that bad but the lighting has 4 wires and not easy to get at. The other end is a plug I don't think I have tools to de-pin.

0607191344 (resized).jpg
#1462 5 months ago
Quoted from harryhoudini:

Ok, so how does one replace the pop bumper skirts? Do I really have to cut all of the lighting wires to release the skirt? I assume I'll have to desolder the motors from the spinning mechs, not entirely that bad but the lighting has 4 wires and not easy to get at. The other end is a plug I don't think I have tools to de-pin.[quoted image]

What's wrong with that skirt? It looks fine to me...

Isn't there a plug under the playfield to release the light and pull it up through the top? Same with the motor. There's definitely a plug for that, I reversed it on one of them to make it spin the other way.

#1463 5 months ago
Quoted from vireland:

What's wrong with that skirt? It looks fine to me...
Isn't there a plug under the playfield to release the light and pull it up through the top? Same with the motor. There's definitely a plug for that, I reversed it on one of them to make it spin the other way.

That one is ok, but two others are wrecked so I was going to just pop on new ones I had. There is a plug.... but as with all pop bumpers there are two holes to thread the wires through and then those wires are joined at a plug. Even with a plug, there is no way to get that plug up through those holes. With normal pop bumpers you have to desolder or cut those wires to get them through the hole. Fine with 2 wires, but sucky with 4 wires. I'm guessing that is the only real option (other than de-pinning the plug).

#1464 5 months ago
Quoted from harryhoudini:

Ok, so how does one replace the pop bumper skirts? Do I really have to cut all of the lighting wires to release the skirt? I assume I'll have to desolder the motors from the spinning mechs, not entirely that bad but the lighting has 4 wires and not easy to get at. The other end is a plug I don't think I have tools to de-pin.[quoted image]

Im betting you have to desolder them from the bottom like a traditional pop bumper. Even if there was a plug I highly doubt its small enough to fit through the 1/8" holes in the pop body.

#1465 5 months ago
Quoted from Yelobird:

Im betting you have to desolder them from the bottom like a traditional pop bumper. Even if there was a plug I highly doubt its small enough to fit through the 1/8" holes in the pop body.

Nothing to desolder from except the light circuit board... seems sketchy.

#1466 5 months ago
Quoted from harryhoudini:

That one is ok, but the other two are wrecked so I was going to just pop on new ones I had. There is a plug.... but as with all pop bumpers there are two holes to thread the wires through and then those wires are joined at a plug. Even with a plug, there is no way to get that plug up through those holes. With normal pop bumpers you have to desolder or cut those wires to get them through the hole. Fine with 2 wires, but sucky with 4 wires. I'm guessing that is the only real option (other than de-pinning the plug).

FYI please I Hoping your doing a different color so I can get motivated to do mine. I SO think black would have looked better then the white they used.

#1467 5 months ago
Quoted from harryhoudini:

Nothing to desolder from except the light circuit board... seems sketchy.

But those wires have to go somewhere under the playfield. Maybe a simple pin extractor to pull them from the molex plug below.

#1468 5 months ago
Quoted from harryhoudini:

That one is ok, but two others are wrecked so I was going to just pop on new ones I had. There is a plug.... but as with all pop bumpers there are two holes to thread the wires through and then those wires are joined at a plug. Even with a plug, there is no way to get that plug up through those holes. With normal pop bumpers you have to desolder or cut those wires to get them through the hole. Fine with 2 wires, but sucky with 4 wires. I'm guessing that is the only real option (other than de-pinning the plug).

You can just mark the wires and use a molex pin remover to pop the pin out of the connector, then it should easily side up and out the top.

Here's the one where I reversed the connectors for the barrels - it shows the molex pin remover.
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/6#post-4954781

If you don't have one and you're patient, you can use a small flat jeweler's screwdriver to push the pins holding the molex connector in the connector so you can slide it out.

#1469 5 months ago
Quoted from vireland:

You can just mark the wires and use a molex pin remover to pop the pin out of the connector, then it should easily side up and out the top.
Here's the one where I reversed the connectors for the barrels - it shows the molex pin remover.
https://pinside.com/pinball/forum/topic/jjpirates-of-the-caribbean-troubleshooting-tips-issues/page/6#post-4954781
If you don't have one and you're patient, you can use a small flat jeweler's screwdriver to push the pins holding the molex connector in the connector so you can slide it out.

It's not a normal size molex, it's the size of the lighting board connectors. I'll investigate some more on the connector, I need to raise the playfield all the way up to get to it and I have a bunch of crap floating on it.

Quoted from Yelobird:

FYI please I Hoping your doing a different color so I can get motivated to do mine. I SO think black would have looked better then the white they used.

Heh... don't ruin the surprise!

#1470 5 months ago
Quoted from harryhoudini:

It's not a normal size molex, it's the size of the lighting board connectors. I'll investigate some more on the connector, I need to raise the playfield all the way up to get to it and I have a bunch of crap floating on it.

If it's the really small connectors that the RC cars use (some Japanese company, I forget the name), there are pin removers for those, too, but I've found that paperclips work pretty well in a pinch.

#1471 5 months ago
Quoted from vireland:

If it's the really small connectors that the RC cars use (some Japanese company, I forget the name), there are pin removers for those, too, but I've found that paperclips work pretty well in a pinch.

Thanks, I'll take a look.

#1472 5 months ago

OMG! This is really embarrassing. My upper barrel has never spun since I got it in January and never knew it was supposed to. Going to have to look and see why. Wow, I'm a winner!

#1473 5 months ago
Quoted from Heater:

OMG! This is really embarrassing. My upper barrel has never spun since I got it in January and never knew it was supposed to. Going to have to look and see why. Wow, I'm a winner!

Likely the setscrew in the top edge came loose. Good luck.

#1474 5 months ago
Quoted from Yelobird:

Likely the setscrew in the top edge came loose. Good luck.

Or a broken wire to the motor, which is what I had.

#1475 5 months ago

Hey guys,

So my friend is playing the hell out of this game...which is awesome!

A couple new issues and I'm sure these are all documented, but I just like to note it:
1) The VUK sometimes isn't kicking the ball up to the ship.
2) The post has stopped working when starting a new chapter.
3) The BP stopped moving for a bit and then started again. This seemed to occur only once when he achieved a score of 600k so I'm not sure if this is by design as maybe it's overheating or idk.

Thanks guys! =)

Update:
1) The VUK is still doing this. Maybe 1/10 times.
2) The post magically started working again. Haha. Awesome!
3) There was only one occurrence of the BP stopping. What maybe interesting is that the lights on the pearl shut off when this happened.

Back to playing!!

#1476 5 months ago
Quoted from Heater:

OMG! This is really embarrassing. My upper barrel has never spun since I got it in January and never knew it was supposed to. Going to have to look and see why. Wow, I'm a winner!

Wow, I would like to nominate myself for the Pinball Genius Award. The wire ramp above the pop spinner was too low and catching the barrel spinner. So all this time I didn't realize it was suppose to spin! I stand before you all a broken man!!!

#1477 5 months ago
Quoted from joseph5185:

Hey guys,
So my friend is playing the hell out of this game...which is awesome!
A couple new issues and I'm sure these are all documented, but I just like to note it:
1) The VUK sometimes isn't kicking the ball up to the ship.
2) The post has stopped working when starting a new chapter.
3) The BP stopped moving for a bit and then started again. This seemed to occur only once when he achieved a score of 600k so I'm not sure if this is by design as maybe it's overheating or idk.
Thanks guys! =)
Update:
1) The VUK is still doing this. Maybe 1/10 times.
2) The post magically started working again. Haha. Awesome!
3) There was only one occurrence of the BP stopping. What maybe interesting is that the lights on the pearl shut off when this happened.
Back to playing!!

1 - Turn it up. There’s been a lot of talk about this being turned down by people. Mine is default (which I believe is 32) and it has been fine.
Friend had the same problem on his CE and it went away when he turned it up. Default values on coils -unless there is a problem.-

2 - Check the nut on the chapter post, see if has spun down.

3 - Check the linkage in the back.

Most, if not all of this, is in the index btw!

#1478 5 months ago
Quoted from davisjl1979:

I'm having issues with the black pearl. It was moving fine and then it stopped. Now it does not move at all.
When the game starts the ship goes down on the left side and stays there.
The ship moves freely when not connected to the motor.
I think this is an opto calibration issue. The disk that runs through the optos had a good bit of play left and right.
The Boat test menu has the motor green.

I have resolved this issue. I learned a lot about how the ship rocking operates.

Issue: Ship no longer rocks back and forth.

Diagnosis:

Disconnect the bar that connects the motor from the ship first to determine if that is causing the issue.

If the motor does not move at all then check voltage. Easy place to check the voltage is at the connector that goes from the relay board to the motor. You should be getting + and - 13VDC during ship test depending on the direction you choose. If you are not getting voltage then check the fuses. If you are only getting one voltage then it may be the relay.

If you are getting proper voltage and the motor still does not work as intended, power down the game and attempt to rotate the disc that is mounted onto the motor. If it cannot rotate all the way around in either direction then it may be that the gears in the motor are binding.

Solution: I disassembled the motor and reassembled. I'm guessing this aligned the gears properly and allowed the motor to fully rotate as it should. If your game is under warranty, I would try to get a new motor (see warning).

Warning: The motor's gears have a lot of little parts and spacers that you don't want to lose. Disassemble this VERY carefully.

#1479 5 months ago
Quoted from joseph5185:

Hey guys,
So my friend is playing the hell out of this game...which is awesome!
A couple new issues and I'm sure these are all documented, but I just like to note it:
1) The VUK sometimes isn't kicking the ball up to the ship.
2) The post has stopped working when starting a new chapter.
3) The BP stopped moving for a bit and then started again. This seemed to occur only once when he achieved a score of 600k so I'm not sure if this is by design as maybe it's overheating or idk.
Thanks guys! =)
Update:
1) The VUK is still doing this. Maybe 1/10 times.
2) The post magically started working again. Haha. Awesome!
3) There was only one occurrence of the BP stopping. What maybe interesting is that the lights on the pearl shut off when this happened.
Back to playing!!

The fact that the lights went out at the same time means it could just be that COTBP multiball was qualified when the ball went up to the ship. For example, if the load cannon arrow is already flashing and you hit the BP skill shot (which advances COTBP multiball progression to the next step), then the lights go out on the Pearl and it calms down a bit because you've just qualified the multiball (the insert by the flippers will then be flashing to show COTBP MB is ready). I think COTBP MB can also be advanced/qualified after a certain number of boardings also, but I'm not sure. Just an idea, but it's definitely possible that's what happened so no servicing needed.

#1480 5 months ago

I was trying to resolve my SDTM drains after star map chapter selected and the post drops. As others have noted it happens when the ball is stuck between the retractable post and the post to the left. My ball was wedged so close to the front it was almost escaping the star map. Other have stated this happens as the rubber wears. Mine is not that worn. Anyway did some investigating. The post to the left of the star map with the sling rubber was not tightened. At all. Moved the post over as much to the right as it would go and tightened up. Seems better now. Ball does not get wedged as much. Still a bit dangerous there. Maybe to resolve this in coding, rather than a ball save which seems contentious with other owners, the magnet could start kicking the ball around a bit sooner before the post drops. That means the ball is being affected by the magnet for a longer time before it is let go. Currently it’s just a small pulse which is not always sufficient to move the ball far enough. This small pulse just lifts the wedged ball slightly before it drains SDTM. This wedging of the ball between the posts will happen more as the sling rubber wears. I have requested JJP to add this extra magnet time. Not sure if it will be ignored.

If you’re finding the ball is getting wedged at the front left, check that the post is tightened down and not loose. Also double check levels. I found to get a straight level section, the word “CHEST” is the only reference point which is straight. Line you spirit level up with the top of these letters.

#1481 5 months ago

Anyone develop issues with the Tortuga VUK arm's rubber tip developing wear? Mine was one hundred percent same kickout for first couple months of ownership. Now, it seems to spray the ball all over the place. I inspected closely and it seems to have deformed. I have the gen 2 bracket.

#1482 5 months ago

Does anyone have a 3d model (STL) file of a block to fix the monitor sag? Or the measurements for the proper height of a supporting block?

I contacted JJP support, they said I didn't have the defective mount, yet the top edge of my monitor shows through the backglass when seated fully on the mounting pins. That was after leaning it left on the mount to compensate for sagging to the right.

It looks like my monitor came loose during shipping, backglass is also scratched where the corner of the monitor scraped the art. Thanks!

#1483 5 months ago

To solve the sdtm drain from the map hole: replace the 4 posts near/in the map room with 4 double starposts. Rubbers will wear less and the ball cannot get stuck between the post and the rubber.
Only downside to this is that the open space between the posts becomes smaller and therefore entering the map hole area becomes slightly more diffult.

#1484 5 months ago
Quoted from Maurice:

To solve the sdtm drain from the map hole: replace the 4 posts near/in the map room with 4 double starposts. Rubbers will wear less and the ball cannot get stuck between the post and the rubber.
Only downside to this is that the open space between the posts becomes smaller and therefore entering the map hole area becomes slightly more diffult.

I like this. Have it mostly apart already to replace my chest bracket and BP opto, might as well try this out. Double star post probably doesn't matter here but might look weird with the higher rubber.

#1485 5 months ago

Anyone else have a ball rest on the roll over button? Ya know, the thing that increases Tortuga mystery.

It’s not a big deal. It’s only happened like twice in the hundreds of games that have been played.

Probably a quick clean/wax makes it so this isn’t possible.

#1486 5 months ago
Quoted from Maurice:

To solve the sdtm drain from the map hole: replace the 4 posts near/in the map room with 4 double starposts. Rubbers will wear less and the ball cannot get stuck between the post and the rubber.
Only downside to this is that the open space between the posts becomes smaller and therefore entering the map hole area becomes slightly more diffult.

I was close to doing this. Then I realised it would make the star map entrance 8mm narrower. Stuff that!! It is a solution though. Could be done just on the front left like I was thinking, but still 4mm narrower. Ever played golf where you think to yourself “now just miss that small tree in front, you have all that space on either side....”. I hit the tree every time.

#1487 5 months ago
Quoted from gumnut01:

I was close to doing this. Then I realised it would make the star map entrance 8mm narrower. Stuff that!! It is a solution though. Could be done just on the front left like I was thinking, but still 4mm narrower. Ever played golf where you think to yourself “now just miss that small tree in front, you have all that space on either side....”. I hit the tree every time.

I shoot pool. I very well know the feeling. Haha

Fortunately, I own a nice table so trying to get better.

#1488 5 months ago

Not sure if I have a problem with my Maelstrom Diverter. I have noticed the spring does not always pull it up to the top rest spot. Sometimes it’s a few millimetres down. When the ball hits the ramp, most times it pushes the diverter up as it does around. But if it’s a weak ball, it seems to knock it into the depths. Not all the time, but it does happen. Also, I tried to put on the Kraken mod and it pushes the diverter down so that the diverter is no longer at maximum height. With the Kraken on, the ball does not have enough clearance underneath. I could try to move the whole diverter down a few mill but this may cause other problems. Bit stumped.

Can send pictures later. Playing now. Without the kraken.

#1489 5 months ago

So I think I may have found part of the issue why sometimes the ball going around the right orbit is diverted into the BP when it should not be, or at least doesn't make it all the way around the loop. While doing some work and having removed the BP I noticed the angle bracket is suspiciously close to the ball guide. Sure enough, if the ball presses up against the guide enough it bends and the ball hits the angle bracket.

I suppose a quick fix is putting a small L bracket to support the ball guide to prevent it from bending and keeping the ball from hitting the angle bracket.

Anyone else see this?

Video: https://photos.app.goo.gl/BCn4MrcdQx1LD3bc6

#1490 5 months ago

Just checked with ship not attached to motor. Ball on my magnetic thing does not touch said bracket. Why are you pushing against rail? There is no give in mine whilst installed with plastic on top.

056FFA43-0A69-4431-9E7D-939858C3EDE8 (resized).jpeg
#1491 5 months ago

Hum, I'll put plastic on and check. I'm pushing like I think the ball would. The ball guide is pretty thin compared to my Jurassic Park, for example. It's not supported in the middle so it flexes. I'll see if plastic changes it.

#1492 5 months ago
Quoted from harryhoudini:

Hum, I'll put plastic on and check. I'm pushing like I think the ball would. The ball guide is pretty thin compared to my Jurassic Park, for example. It's not supported in the middle so it flexes. I'll see if plastic changes it.

Nope plastic does nothing. But there is a screw in the rail about 2 inches before it. You must be pressing pretty hard. Also inner loop misses that spot. Only hit from open sea or port royal.

image (resized).jpg
#1493 5 months ago
Quoted from gumnut01:

I was trying to resolve my SDTM drains after star map chapter selected and the post drops. As others have noted it happens when the ball is stuck between the retractable post and the post to the left. My ball was wedged so close to the front it was almost escaping the star map. Other have stated this happens as the rubber wears. Mine is not that worn. Anyway did some investigating. The post to the left of the star map with the sling rubber was not tightened. At all. Moved the post over as much to the right as it would go and tightened up. Seems better now. Ball does not get wedged as much. Still a bit dangerous there. Maybe to resolve this in coding, rather than a ball save which seems contentious with other owners, the magnet could start kicking the ball around a bit sooner before the post drops. That means the ball is being affected by the magnet for a longer time before it is let go. Currently it’s just a small pulse which is not always sufficient to move the ball far enough. This small pulse just lifts the wedged ball slightly before it drains SDTM. This wedging of the ball between the posts will happen more as the sling rubber wears. I have requested JJP to add this extra magnet time. Not sure if it will be ignored.
If you’re finding the ball is getting wedged at the front left, check that the post is tightened down and not loose. Also double check levels. I found to get a straight level section, the word “CHEST” is the only reference point which is straight. Line you spirit level up with the top of these letters.

Kicking the ball around sooner will not solve the issue. It will make it less likely to happen yes, but the whole game is based around doing chapters. You should NEVER be punished for a shot that is required for progression when you have to hit the shot 25 times in one game (to complete all chapters). It is not like it is a risk vs reward thing. The risk vs reward is the qualifying of chapter. Some that come to mind bricking malestrom shot or DT and hitting 4x and goining straight down I lane. Trying for left flipper chest shot hitting right lock stand up and sdtm. Tortuga can be risk reward as anything up in the pop can go bad quickly. Even if they decided they wanted to compensate by making the chapters harder by adding more characters to them there needs to be an optional ball save on starting chapters. Its not a tight shot but not sure i want to make it smaller either. Its such an easy fix

#1494 5 months ago
Quoted from GnarLee:

Kicking the ball around sooner will not solve the issue. It will make it less likely to happen yes, but the whole game is based around doing chapters. You should NEVER be punished for a shot that is required for progression when you have to hit the shot 25 times in one game (to complete all chapters). It is not like it is a risk vs reward thing. The risk vs reward is the qualifying of chapter. Some that come to mind bricking malestrom shot or DT and hitting 4x and goining straight down I lane. Trying for left flipper chest shot hitting right lock stand up and sdtm. Tortuga can be risk reward as anything up in the pop can go bad quickly. Even if they decided they wanted to compensate by making the chapters harder by adding more characters to them there needs to be an optional ball save on starting chapters. Its not a tight shot but not sure i want to make it smaller either. Its such an easy fix

I agree! Was just trying to find alternatives as there are a few on pinside who keep telling me it never happens and/or ball save is not necessary. Good to see someone talk some sense into me. Ok back to a ball save, just like we have for Multiball. Thank you!!

#1495 5 months ago

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.

Any idea, what is going wrong here?

#1496 5 months ago
Quoted from Zora:

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.
Any idea, what is going wrong here?

It sounds like the game thinks the ball left the Pearl, and possibly even thinks it hit the Dauntless.

In switch test are any switches reporting stuck closed? Or falsing if you bang on the play field?

#1497 5 months ago
Quoted from zaphX:

It sounds like the game thinks the ball left the Pearl, and possibly even thinks it hit the Dauntless.
In switch test are any switches reporting stuck closed? Or falsing if you bang on the play field?

I will check in the switch test. However, that would mean that the switches in the canon and in the Dauntless would be registering incorrectly, which does not seem to be probable.

#1498 5 months ago
Quoted from Zora:

I will check in the switch test. However, that would mean that the switches in the canon and in the Dauntless would be registering incorrectly, which does not seem to be probable.

I know, this is a weird one. But you're saying the playfield lights come back on and the movie 1 multiball light flashes, which is what it would do after making a successful shot into the Dauntless when the cannon is qualified.

#1499 5 months ago
Quoted from Zora:

I have an issue with the start of the black pearl multiball. The ball is on the BP deck on the ship, spinners and lock button is finalized, the cannon load light is blinking. When fighting with the ball to get into the cannon, the cannon light goes out and the MB light on the main playfield starts blinking, without any cannon load or shot.
Any idea, what is going wrong here?

You sure you have not advanced the Pearl by doing the BP skill shot? That advances the Multiball.

#1500 5 months ago
Quoted from gumnut01:

You sure you have not advanced the Pearl by doing the BP skill shot? That advances the Multiball.

Good call, maybe it's as simple as that. Every time you skillshot the boat, it advances one step towards BPMB. Spinners, Load Cannon, and the shot itself.

However, the OP mentioned the load cannon arrow is lit, which it would not be if BPMB was qualified via skill shot.

Promoted items from the Pinside Marketplace
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 29.95
Gameroom - Decorations
Pinball Photos
Wanted
Machine - Wanted
Manchester Township, NJ
Wanted
Machine - Wanted
Redmond, WA
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 38.75
Playfield - Toys/Add-ons
The MOD Couple
Wanted
Machine - Wanted
Manchester Township, NJ
There are 2273 posts in this topic. You are on page 30 of 46.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside