(Topic ID: 240503)

jjPirates of the Caribbean Troubleshooting/Tips/Issues jjPotC Tech


By vireland

8 months ago



Topic Stats

  • 2,343 posts
  • 135 Pinsiders participating
  • Latest reply 1 day ago by vireland
  • Topic is favorited by 98 Pinsiders

You

Linked Games

Topic Gallery

There have been 435 images uploaded to this topic. (View topic image gallery).

Install_Picture_Kicktap (resized).jpg
JJP_mobo_buttons_sml (resized).jpg
fix-dead-jjpotc-H110_mobo (resized).jpg
fix-dead-jjpotc (resized).jpg
IMG_1901.jpeg
Screen Shot 2019-11-30 at 6.52.53 PM.png
1B7C8008-D057-4BB4-8D38-23634CFEAB94 (resized).jpeg
reset motherboard (resized).jpg
jumpstart (resized).jpg
20191128_210803 (resized).jpg
moboreset (resized).jpg
IMG_20191128_194814971 (resized).jpg
B99E03FD-39F2-4491-8F13-8BA420927388 (resized).jpeg
09CE1A4E-ED6C-45ED-A548-DD8D9DCA6299 (resized).jpeg
E18935C3-8E26-4528-96E9-81005FB9532D (resized).jpeg
D803EF1F-0507-40D3-8E5C-1B7FA6FE24BA (resized).jpeg

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 2343 posts in this topic. You are on page 23 of 47.
#1101 6 months ago
Quoted from EaglePin:

Anyone know the correct/safe way to remove these rubbery connectors on the plastic protector that's over the starmap running alongside the chest? I'm trying to put in the PinballLife ship protector to keep balls from getting trapped under the Pearl, but I'm not seeing how to correctly remove these two rubber connectors and I don't want to force anything and break them. Thanks.[quoted image]

I installed the ship protector I ordered without removing the ship and without removing those rubber things. They were flexible enough I was able to just tip that upper plastic a bit and do the work I needed to do.

#1102 6 months ago
Quoted from harryhoudini:

Personally, I licked my finger and then rubbed the nub... but to each their own

I hope there was at least BBQ sauce on there first!

#1103 6 months ago

PROBLEM: Balls getting stuck on the "Man Overboard" self by the Pearl
SOLUTION: There is a clear cabinet bumper there to prevent this; it may be installed in the wrong place. I had two machines, one which was having this problem and one which was not. I carefully removed the bumper and relocated it to match the good machine and I've never had the problem recur.

Here is the location that seems to work perfectly. (Note the position relative to the text as well as the position of the shooter lane wireform.)

IMG_0998 (resized).jpeg
#1104 6 months ago

I had that problem as well with ball getting stuck at man overboard. I added an extra clear bumper between the screw and the current bumper. Ball has not got stuck since. On a side note got my replacement wireform a in. The shooter lane wireform fixed the last of my inconsistent ball shooter. The ball travel up the lane is soo much smoother now and the ball exits like a rocket. The bp exit ramp is still not level with the outlane but it was close enough that I could bend it and make it right. Now if I could only get jjp to send me the correct part for this last led that doesn’t work.

#1105 6 months ago
Quoted from GnarLee:

The ball travel up the lane is soo much smoother now and the ball exits like a rocket.

I’m curious what that looks like.

I feel my ball plunges aren’t all that powerful.

#1106 6 months ago
Quoted from zaphX:

PROBLEM: Balls getting stuck on the "Man Overboard" self by the Pearl
SOLUTION: There is a clear cabinet bumper there to prevent this; it may be installed in the wrong place. I had two machines, one which was having this problem and one which was not. I carefully removed the bumper and relocated it to match the good machine and I've never had the problem recur.
Here is the location that seems to work perfectly. (Note the position relative to the text as well as the position of the shooter lane wireform.)[quoted image]

Can you put an arrow on that pic? I am not sure what specifically I am looking at.

#1107 6 months ago
Quoted from harryhoudini:

Can you put an arrow on that pic? I am not sure what specifically I am looking at.

IMG_0998 (resized).jpeg
#1109 6 months ago
Quoted from GnarLee:

On a side note got my replacement wireform a in. The shooter lane wireform fixed the last of my inconsistent ball shooter. The ball travel up the lane is soo much smoother now and the ball exits like a rocket.

Glad to hear it! My autoplunger is 100% now as well after straightening mine. Really happy to get these little adjustments sorted out, the game is so much fun!

#1110 6 months ago

Anyone have an issue with this washer on their shooter lane? I did a cleaning yesterday and for the first time noticed this washer sits on the wireform and is pretty chewed up from balls launching. My wires & launcher have always been straight so I'm thinking this is likely the reason auto launches have sometimes lost momentum and not made it out to the playfield. I think they're hitting this washer, hopping up & hitting the top of the wireform, and then stalling. I'm thinking about just removing the washer now.

POTC Shooter Lane Washer (resized).jpg
#1111 6 months ago
Quoted from EaglePin:

I'm thinking about just removing the washer now

Just loosen up the nut underneath a bit, then move the washer to the left. Problem solved.

#1112 6 months ago
Quoted from Axl:

Just loosen up the nut underneath a bit, then move the washer to the left. Problem solved.

Ha ha!!! You mean do it the easy way? I'm kicking myself for not thinking of that on my own. Thanks!

#1113 6 months ago
Quoted from EaglePin:

Ha ha!!! You mean do it the easy way? I'm kicking myself for not thinking of that on my own. Thanks!

Or, you can start a catastrophe washer thread with thousands of the same solution! lol JK!

#1114 6 months ago
Quoted from EaglePin:

Anyone have an issue with this washer on their shooter lane? I did a cleaning yesterday and for the first time noticed this washer sits on the wireform and is pretty chewed up from balls launching. My wires & launcher have always been straight so I'm thinking this is likely the reason auto launches have sometimes lost momentum and not made it out to the playfield. I think they're hitting this washer, hopping up & hitting the top of the wireform, and then stalling. I'm thinking about just removing the washer now. [quoted image]

I just recived my POTC LE 2 days ago. My machine doesn't have that washer.

#1115 6 months ago
Quoted from Yelobird:

Or, you can start a catastrophe washer thread with thousands of the same solution! lol JK!

Dang it!!! I already went ahead and slid the washer over. A new thread would have been much more interesting and fun

#1116 6 months ago
Quoted from EaglePin:

Dang it!!! I already went ahead and slid the washer over. A new thread would have been much more interesting and fun

so i want to fix mine too. can someone explain to me how to remove the bp, then the backbox and every post to get to it
jk!

#1117 6 months ago

I looked and I’m pretty sure my CE does not have that washer either.

When I looked at your photo that washer seven being there in the first place didn’t seem necessary.

#1118 6 months ago
Quoted from joseph5185:

I looked and I’m pretty sure my CE does not have that washer either.
When I looked at your photo that washer seven being there in the first place didn’t seem necessary.

It’s actually Very necessary. If you think a post can dig in wait till you tighten a stainless guide with no washer. It will shear through like a guillotine. You need a washer there.

#1119 6 months ago
Quoted from Yelobird:

It’s actually Very necessary. If you think a post can dig in wait till you tighten a stainless guide with no washer. It will shear through like a guillotine. You need a washer there.

I don't have one either.

20190519_004937 (resized).jpg
#1120 6 months ago

Regarding the audio clipping ..

Here is what my mix was set at. Curious if this is what others have:

...

My button is starting to stick out of nowhere. It's okay. I think it's just bad karma for not playing for so long. I might just try lubing it like someone else says and see if that works without replacing.

i feel like there are certain shots that should be locking in the chest. Just to confirm: With the balls not locking in the chest, was that like 100% of the time or just most of the time?

That's it for now.. =)

Edit: Yea I don't think those levels are the issue. Just to illustrate how bad it is. I can basically just hold down the button as the numbers go down and hear static the whole time. I'm definitely going to unplug in the 10 pin in the connector.

This game will be on another level once I get this audio sorted..

Edit: I went ahead and checked those two screws and they were tight. If I still have issues, I'll have to do the slow-motion thing and go from there.

pasted_image (resized).png

#1121 6 months ago
Quoted from joseph5185:

Regarding the audio clipping ..
Here is what my mix was set at. Curious if this is what others have:
...
My button is starting to stick out of nowhere. It's okay. I think it's just bad karma for not playing for so long. I might just try lubing it like someone else says and see if that works without replacing.
i feel like there are certain shots that should be locking in the chest. Just to confirm: With the balls not locking in the chest, was that like 100% of the time or just most of the time?
That's it for now.. =)
[quoted image]

Edit: Yea I don't think those levels are the issue. Just to illustrate how bad it is. I can basically just hold down the button as the numbers go down and hear static the whole time. I'm definitely going to unplug in the 10 pin in the connector.

This game will be on another level once I get this audio sorted..

#1122 6 months ago
Quoted from wesman:

I don't have one either.
[quoted image]

Thanks for posting that picture. That's interesting, the artwork is a circle around that area like they're expecting a washer to be there but obviously they've changed their minds. Mine was built in Nov. I thought about removing my washer, but the risk/reward to doing that seems too high. I'd think the likelihood of having that ball guide dig into the playfield would be higher than any issue from having the washer nudge into the shooter lane. I was able to scoot my washer/ball guide over just a fraction of an inch so it seems like it's clear enough of the shooter rail now and the good news is it hasn't prevented Davey Jones Locker saves from happening.

#1123 6 months ago
Quoted from joseph5185:

Edit: Yea I don't think those levels are the issue. Just to illustrate how bad it is. I can basically just hold down the button as the numbers go down and hear static the whole time. I'm definitely going to unplug in the 10 pin in the connector.
This game will be on another level once I get this audio sorted..

Have you tried replacing the ground loop isolator?
https://pinside.com/pinball/forum/topic/does-anyone-else-have-this-hissing-whining-on-boot-on-any-jjp-game#post-4998295

Apparently the ones JJP uses are not good? That's all I can determine since I used two, from two different machines, didn't solve the whining/hissing on boot and the cheapo one from Amazon did. Maybe it will solve your issue as well.

The POTC one is in the backbox, in the silver PC box.

#1124 6 months ago

Caught the ball skipping over the chapter select plastic. I don't know if you can get a good sense from the video, but it seems clear that the opto sensor is not the culprit. I can tell you the shot was fairly hard but clean. I can't tell precisely why it is riding up the ball guide. It obviously rides up and over the guide hits the star map and shoots back over the chapter select plastic. I can probably get this to happen once or twice a game. Any suggestions? I am guessing this isn't going to be good long term.

Skip ahead to like 1:19
https://photos.app.goo.gl/nKYfw8x7YGtg7cSz9

#1125 6 months ago
Quoted from harryhoudini:

Have you tried replacing the ground loop isolator?
https://pinside.com/pinball/forum/topic/does-anyone-else-have-this-hissing-whining-on-boot-on-any-jjp-game#post-4998295
Apparently the ones JJP uses are not good? That's all I can determine since I used two, from two different machines, didn't solve the whining/hissing on boot and the cheapo one from Amazon did. Maybe it will solve your issue as well.
The POTC one is in the backbox, in the silver PC box.

Probably not.

To give you an idea, I can’t even navigate through the menu system without a steady stream of static. It’s bad, but whatever.

Hopefully unplugging the 10 pin will solve as it has for others.

#1126 6 months ago
Quoted from harryhoudini:

Caught the ball skipping over the chapter select plastic. I don't know if you can get a good sense from the video, but it seems clear that the opto sensor is not the culprit. I can tell you the shot was fairly hard but clean. I can't tell precisely why it is riding up the ball guide. It obviously rides up and over the guide hits the star map and shoots back over the chapter select plastic. I can probably get this to happen once or twice a game. Any suggestions? I am guessing this isn't going to be good long term.
Skip ahead to like 1:19
https://photos.app.goo.gl/nKYfw8x7YGtg7cSz9

Man, that's violent. What's your flipper strength and pitch at?

#1127 6 months ago
Quoted from harryhoudini:

Caught the ball skipping over the chapter select plastic. I don't know if you can get a good sense from the video, but it seems clear that the opto sensor is not the culprit. I can tell you the shot was fairly hard but clean. I can't tell precisely why it is riding up the ball guide. It obviously rides up and over the guide hits the star map and shoots back over the chapter select plastic. I can probably get this to happen once or twice a game. Any suggestions? I am guessing this isn't going to be good long term.
Skip ahead to like 1:19
https://photos.app.goo.gl/nKYfw8x7YGtg7cSz9

Dial down your flipper power. Just because they set a Standard setting doesn't mean its perfect for everyone. As is pinball, there are so MANY variables that effect the ball many of which are individually determined such as flipper rubbers used, flipper angle, flipper power, lever front to back, level side to side, playfield wax and probably 50 more that could be listed. Bottom line, if its hitting That hard (clearly) just dial it down a bit and move on. There doesn't always need to be a complicated solution to normal play. You need to be able to make the shots, not hammer them home. lol As is 101 trouble shooting you have to ask yourself Why is my game special and what was the last thing I did. As few if any have an issue like this you need to refer back to 101.

#1128 6 months ago

I should show you a video of the rest of the playfield. Chest is just makeable, the flipper power is definitely not crazy. They were on stock (when I got it they were turned way up and I was shooting out of the maelstrom). I just took them both down 2 below stock. Still doesn't seem crazy, but we'll play like that for a while and see.

#1129 6 months ago
Quoted from harryhoudini:

I should show you a video of the rest of the playfield. Chest is just makeable, the flipper power is definitely not crazy. They were on stock (when I got it they were turned way up and I was shooting out of the maelstrom). I just took them both down 2 below stock. Still doesn't seem crazy, but we'll play like that for a while and see.

Understood and while I don't know the scientific trig formula a simple Plus .2 degrees of playfield incline changes any coil setting plus or minus. If its hitting hard, (which in that video it appeared to be hammering the chest compared to mine) simply keep lowering power till all seems equal. Many confuse Default setting with Correct setting. Completely different.

#1130 6 months ago

just an FYI for those people just receiving their machines.

Make sure the socket head cap screws are tight on your flipper coil stops. After about 20 games, my lower left flipper quit returning to its' neutral position. I raised the playfield to find that both of the screws had fallen out of the assembly. Went to check the others....yep, every single one of them was loose.

#1131 6 months ago
Quoted from indypinhead:

just an FYI for those people just receiving their machines.
Make sure the socket head cap screws are tight on your flipper coil stops. After about 20 games, my lower left flipper quit returning to its' neutral position. I raised the playfield to find that both of the screws had fallen out of the assembly. Went to check the others....yep, every single one of them was loose.

#1132 6 months ago
Quoted from indypinhead:

just an FYI for those people just receiving their machines.

These flipper assemblies are used by a few manufacturers. Wouldn't hurt to check them on any new game.

LTG : )

#1133 6 months ago
Quoted from Yelobird:

Understood and while I don't know the scientific trig formula a simple Plus .2 degrees of playfield incline changes any coil setting plus or minus. If its hitting hard, (which in that video it appeared to be hammering the chest compared to mine) simply keep lowering power till all seems equal. Many confuse Default setting with Correct setting. Completely different.

Ok, gotcha... I'll check incline and keep lowering flipper power.

#1134 6 months ago
Quoted from wesman:

I don't have one either.
[quoted image]

Nor do i.

#1135 6 months ago
Quoted from LTG:

These flipper assemblies are used by a few manufacturers. Wouldn't hurt to check them on any new game.
LTG : )

Agreed. My last two stern NIB has this issue. It happens no biggie.

#1136 6 months ago

I can’t understand for the life of me why some machines would have them and some would not. This just gets stranger and stranger.

#1137 6 months ago

I just realized that my chest ball lock isn't working at all.

Any pointers?

#1138 6 months ago
Quoted from indypinhead:

I just realized that my chest ball lock isn't working at all.
Any pointers?

Is the fork loose? Easy known fix.

#1139 6 months ago

Hi indypinhead, in the owners thread, last page coindropper has a fix with a washer

#1140 6 months ago
Quoted from indypinhead:

I just realized that my chest ball lock isn't working at all.
Any pointers?

What do you mean by not working? You can’t shoot a ball into the chest?

#1141 6 months ago

Update....

I removed the fork assembly from under the playfield. One of the plastic barrels was missing. I found the barrel and the screw, but I can't find the flat spacer washer.

#1142 6 months ago
Quoted from Lermods:

What do you mean by not working? You can’t shoot a ball into the chest?

I can shoot the ball into the chest...but the ball isn't being captured.

#1143 6 months ago
Quoted from indypinhead:

I can shoot the ball into the chest...but the ball isn't being captured.

Bend the little tab on the left side toward the right a little so the ball doesn't dribble past it.

#1144 6 months ago

I found the flat washer...went to re-install...dropped the barrel plastic, now I can't find it.

It's time to walk away from this machine for the night and go play something else.

#1145 6 months ago
Quoted from indypinhead:

I found the flat washer...went to re-install...dropped the barrel plastic, now I can't find it.
It's time to walk away from this machine for the night and go play something else.

Sometimes, that's the best choice.

#1146 6 months ago

The barrel plastic was a PITA to find...but My fork is now working. I had to bend one of the blades of the fork slightly. It was binding against the slot in the playfield.

#1147 6 months ago

I guess the entire time I've been playing this game, (around 25 games so far), my diverter fork has always been in the up position.

#1148 6 months ago

Regarding flippers. Simply snap them up once manually and you’ll have an idea of how tight they are based on the feedback.

#1149 6 months ago

So I don’t I know if it’s limited to just CE, but has anyone had any very noticeable vibration coming from the left side of the machine while playing?

I pointed out CE because I think it’s actually the barnacle on the left that is contributing.

Though, not an issue on the right.

Edit: I added the felt tape to the bottom of the machine. Perhaps, I could try adding in a few other places as well.

#1150 6 months ago

I can confirm that my chest fork is now raising and lowering during game play....but ever ball that I've shot into the chest passes through. I've yet to have the chest capture the ball.

Promoted items from the Pinside Marketplace
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
From: $ 18.00
Apparel - Men
Pinside Shop
$ 87.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
There are 2343 posts in this topic. You are on page 23 of 47.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside