(Topic ID: 200141)

JJP Pirates of the Caribbean Official Owners and Fan Club!


By goren1818

1 year ago



Topic Stats

  • 11,442 posts
  • 438 Pinsiders participating
  • Latest reply 13 minutes ago by Yelobird
  • Topic is favorited by 213 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,038 images uploaded to this topic. (View topic image gallery).

61EF3B68-58CB-4724-8409-0B434C623708 (resized).jpeg
B496E573-AC28-4F5F-A642-2329BE18427C (resized).jpeg
8D50ED29-392F-4861-B716-CEF06D271C37 (resized).jpeg
pasted_image (resized).png
00D27B8A-36B3-4391-A494-F23CBDD8D8AA (resized).jpeg
2DD66756-7F51-4F2F-92DD-701C9480773D (resized).jpeg
B6B35AD9-568A-4B01-94BD-4F3BCBA32E86 (resized).jpeg
FCE3918E-5DA5-4342-8D21-8809E2F397F6 (resized).jpeg
20190720_135608 (resized).jpg
20190720_140441 (resized).jpg
20190720_135637 (resized).jpg
20190720_135551 (resized).jpg
20190720_135535 (resized).jpg
20190720_135528 (resized).jpg
20190719_223935 (resized).jpg
MVIMG_20190717_191916 (resized).jpg

Topic index (key posts)

19 key posts have been marked in this topic

Post #222 Liar's Dice rules explained! Posted by goren1818 (9 months ago)

Post #644 Rules flow chart Posted by Rbviessman (8 months ago)

Post #1021 How to fix black pearl lamps Posted by Yelobird (8 months ago)

Post #1360 Black Pearl flippers are uneven when in upper position - Fix Posted by evh347 (7 months ago)

Post #2468 Hardware fix for balls getting hung up during multiball. Posted by Pinballpal (6 months ago)

Post #2892 Adjustment for auto plunger not hitting balls cleanly or correctly Posted by Pinballpal (6 months ago)

Post #3974 Deadflip stream from Valentine’s Day 2019. Posted by Tuna_Delight (5 months ago)

Post #4014 POTC trouble shooting guide Posted by zaphX (5 months ago)

Post #4856 Possibly let distributor go through machine and get it tuned in. Posted by dgposter (4 months ago)

Post #6315 Fix for dauntless positioning, canon shots not landing Posted by Yelobird (3 months ago)

Post #6631 Twitch Video - How to Remove and Reinstall Black Pearl Upper Playfield Posted by KevInBuffalo (3 months ago)

Post #6655 Mylar bubble at jjPotC Map hole. Posted by thc666 (3 months ago)

Post #6834 Titan ring sizes Posted by AUKraut (3 months ago)

Post #8145 Positives and Negatives for each character Posted by EaglePin (88 days ago)

Post #8288 Rubber Sizing and Location on Playfield Posted by f3honda4me (85 days ago)

Post #8602 How to see pictures the game has taken Posted by f3honda4me (78 days ago)

Post #8625 Version .99 release notes as of 5/6/2019 Posted by pinball_keefer (76 days ago)

Post #8709 How to backup settings before installing an update Posted by LTG (75 days ago)

Post #9273 Version .99 Character Plus and Minus Benefits Posted by pinball_keefer (66 days ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider zaphx.
Click here to go back to viewing the entire thread.

751 posts in this topic match your search for posts by zaphx. You are on page 1 of 4.
#2031 7 months ago

I’m taking delivery today!

To summarize what I need to look for:

- Braid in the leg holes
- Remove all the foam
- Look for loose parts
- Check the Black Pearl wiring

Anything else? Has the topper centering been fixed?

#2035 7 months ago
Quoted from heni1977:

This problem should be fixed as they are shipping with the bolts in them now.

You should only have to cut the one just under the leaf switches for the X and Bonus switches.
This will provide enough slack so they don't break "hopefully". as some of the soldering is not so good.

Do we have any confirmation the short wiring to the pearl is still an issue? Maybe they’ve added more at the factory.

#2037 7 months ago
Quoted from Hogbog:

The wire routing has been addressed and should no longer be an issue.

Great news! I’ll post my unboxing album later today

#2058 7 months ago

Am I supposed to leave the felt on when I put the legs on?

02033C54-5DC7-4445-B92E-3B933CD7108C (resized).jpeg
#2077 7 months ago

I don’t appear to have a tilt bob . Where should it be? It’s not anywhere in the coin box.

#2080 7 months ago
Quoted from LTG:

Should have been in a plastic bag in the coin box.
Call them if it's MIA.
LTG : )

Yes it’s MIA. Should it have been the fourth “cell” in the plastic “sausage” that contained the hex wrench etc? (Mine only has 3 cells).

Also separate problem, the metal wireform in the shooter lane is deformed and preventing proper shooter operation. Not sure how to fix this one.

https://www.icloud.com/sharedalbum/#B115aDWbrM9Ost;08271900-5313-4E4D-AED1-84262B64EC7E

#2082 7 months ago

Is the black “hair” around the chest insert part of the art? Or some kind of crack/issue?

Quoted from roddog:

Looking at the video frame-by-frame, it looks like the plunger is hitting the auto-plunger, which is bending the wireform. I moved my plunger just today to prevent this. Maybe that will help? It is worth a shot since it is just 3 ezpz screws.

No, the wireform is bent and is lifted from the shooter lane. You can see it move when I push it with my finger.

I don’t even see a way to remove the wireform to put a bend back into it to fix

6BCC57B4-3AAC-4DD7-B681-FB2C079D1F55 (resized).jpeg
#2096 7 months ago

I managed to fix my shooter lane issue! BIG thanks to my distributor Gary from Abel Electronics who conferenced me in with JJP support.
Their immediate response allowed me to learn how to safely remove the shooter wireform, bend it a bit so it snugs up where it should, and reassemble the game.

I am now only having three issues:

1. Sticking gold button (like everyone)
2. Off-center topper (like everyone)
3. No Star Map functionality (but I think upgrading the firmware may fix this? I’m on 0.96)
4. No tilt bob (replacement en route)

This has been an exhausting and frustrating day. Getting the 330lb of pin up the stairs was quite a challenge, even for two people and a rented power stair climber.

I am glad the game is now working and I can enjoy it!

And again, big ups for support from the two companies involved. Problems happen but it’s how you respond to them that matters.

#2113 7 months ago
Quoted from LTG:

What I did on my game. Took lockdown bar off. Looked down at arm on switch. Centered it a little and bent up past the point on the switch body where the arm pushes the tiny knob into the switch. Put a blob of hot glue on the end of the button and shaped it a little when cooling so the part going down was a little wider and not sticking of the side of the arm on the switch.
LTG : )

Not sure I follow. I just hit mine this morning with a little WD40 and it now seems fine.

#2114 7 months ago

Now that my star map works (loose cable) - how do I use it? I really don’t understand what it’s trying to tell me.

Also - does everyone have one pale green “star” on their map in the lower left?

CF16736B-9A8D-4B2E-B45D-D4A341BE371D (resized).jpeg
#2115 7 months ago

My monitor has a slight tilt. I’ve seen this on a couple JJP pins in the field also.

Is there a known fix?

DB768EDC-4C71-4C69-B915-BACF7074F4EE (resized).jpeg
#2116 7 months ago

I’m having a clearance issue between the “A” and “P” map targets, resulting in the P sticking often and throwing errors on boot up.

I’ve tried pushing on them a bit and can’t seem to resolve this.

Any suggestions?

https://www.icloud.com/sharedalbum/#B115aDWbrM9Ost;339A983C-1C2C-4A16-914D-F424E99ABF11

#2121 7 months ago
Quoted from pickleric:

Probably okay, but may want to avoid using WD40 in the future on your pinball machines. It is technically not a true lubricant. It was designed for water displacement to prevent rust.

Yeah I considered this, but since it’s only the plastic button I figured worst case I buy a new button. I can report it was super effective with just a tiny blast administered to the shaft from the underside while the button is depressed.

#2124 7 months ago
Quoted from pickleric:

They look like they are catching on each other. Can you adjust the right one and move it more to the right so it doesn't bind on the middle one? Notice how the left one has a little space in between it and the middle one, you want that for the right one as well.

How do I adjust their physical position? The screws under the playfield simply move the switch, not the target, right? (or are they connected?)

#2125 7 months ago
Quoted from f3honda4me:

Yes open up and ensure the monitor is secured properly. Sometimes it is not latched in all the way on one side or the other, and so it sags a bit. I can snap a pic later if you can't figure it out.

It wiggles a little on the right side but I don’t know what to adjust here.

956A51C6-F52C-4C63-AD5E-1AEB5732CB87 (resized).jpeg
#2130 7 months ago
Quoted from pickleric:

They have to be connected.
Notice the spacing on mine.
Mine could possibly use some adjusting to level out, but are working fine.
[quoted image]

Thanks for this, it turned out to be just that easy. Loosened the screws underneath, moved the target over, and tightened back down. No more error!

#2133 7 months ago
Quoted from f3honda4me:

You can pull up on the flat part I circled here. That is the "release" for that side. Pull it up and you can "swing" the monitor away from the machine, the left side of the monitor will be like the swivel/hinge (like a door). Then pull that up again and push the monitor all the way back into place and then push it back down and that should secure it.
[quoted image]

Thanks! I guess that wooden block has to be removed first? It seems to impede the operation of the release.

I’m wondering if mine is as straight as it’s going to get - it is pretty close.

#2146 7 months ago

Has anyone reported problems (and fixes) with The Depths VUK yet?

We’ve been playing a few hours and I noticed The Depths starting to struggle, taking 2-3 tries to eject the ball.

#2148 7 months ago
Quoted from Hogbog:

Adjust the power for the coil. Every coil can be individually adjustable in the Coil Settings menu. Different power, pitch, environment, etc can affect the coils. We configure then best we can for average conditions, but you're welcomed to and encouraged to adjust for your unique setup.

I’ll take a look. It was weird because it was 100% fine for hours and then seemed to struggle a couple of times later into gameplay.

While I have you - is there a way to adjust the contrast/brightness of the monitor? It looks a bit washed out by default to me, and I’d like to mess with it.
I haven’t found anything in the settings tree for this yet, but admittedly I haven’t spent much time in there. Too busy playing and learning the rules!

#2170 7 months ago

How can I check these switches? All appear to be hidden away in ships.

B04C6285-F4D8-4AB3-81AD-C5B3C13423ED (resized).jpeg
#2182 7 months ago
Quoted from evh347:

Many of the switch ‘errors’ that come up in test while powering up are just as simple as having not been triggered in a set # of plays.

I suspected this might be the case. I may have to disable the self test on boot to save my sanity

#2207 7 months ago
Quoted from konghusker:

Owners thoughts so far? Curious about code in regards to the level of excitement, adrenaline rush this game has, and is it easy to understand.

Having gotten it dialed in from the various tweaky things, I am very_ happy with it. It plays great and the software feels like production quality.
The video screen animations are the best I’ve seen in pinball.

I was initially fairly confused by the rule set, but I’ve got it now. Someone posted a really good succinct explanation:

https://pinside.com/pinball/forum/topic/simple-explanations-of-basic-goals-in-jjp-s-pirates-of-the-caribbean

#2214 7 months ago

New issue - when loading the cannon, the Pearl doesn’t move up and down, making the bullseye shot impossible.
It does move fine under normal circumstances.

I’ve run the “calibrate” step. Any suggestions here?

#2230 7 months ago
Quoted from Furio:

4. 27in monitor is clearly shifted and not seated properly. Main set of keys didn’t work to open the top. I think the are on the inside of the door but didn’t see them due to family commitments them this evening.

My backbox keys were loose inside the cabinet. In my case they were stuck to the subwoofer, shorting the terminals. Curious if yours turn up similarly loose.

I am very empathetic to your move up the stairs. My delivery day was similar - getting up the stairs was very difficult. We rented a “Power Mate” stair climbing lift truck. It did not make the experience trouble free. Once it was up, finding technical issues with the game made for a frustrating and disappointing first day.

https://www.icloud.com/sharedalbum/#B115aDWbrM9Ost

Once you get it dialed in you will forget all about the horrible move!

#2231 7 months ago
Quoted from musketd:

This game is really good but for the price they charge they need to have much better quality control and better testing of their games before they ship them out at the factory

I agree. Some of the issues in mine were definitely factory issues rather than transit-induced.

Generally speaking I’m finding this JJP to be much more “hands on.”
I’ve lifted the playfield on the POTC more times in 48 hours than I have my Stern Star Wars in 1.5 years.

#2232 7 months ago
Quoted from LTG:

Switch in the cannon working ? So it knows a ball is there.
LTG : )

The test -has- been complaining about that one. I’ll check it out this morning.

#2239 7 months ago

Hey can someone check two things for me on their machine?

I had to remove my shooter rail to fix an end which involved three contact points. After I reassembled everything, I found a stray washer in the machine. It is likely this was from my removal.

When you follow the shooter lane it attaches near the top, and again near the right strobe.

Does the top bolt use a washer? If not does the bolt on the strobe stack use one?

#2241 7 months ago
Quoted from LTG:

Switch in the cannon working ? So it knows a ball is there.
LTG : )

Switch reports ok and strangely the ship operation is as expected today. A gremlin I will keep an eye on.

As a side note I want to say how much I appreciate you posting responsive tech tips here! Thank you.

#2249 7 months ago
Quoted from wheels:

Considering getting one, but wondering how long, on average, folks are taking to get the machine properly working.

So my full issues list so far, solved and unsolved: (took delivery 12/20, today is 12/23):

[X] Wireform for shooter lane bent. Removed, reformed, replaced.
[X] Torn shooter tip. Replacement en route but got one at a local shop in the interim.
[X] Gold/action button sticking. Fixed with a small amount of WD40 to the plunger underneath.
[ ] Missing tilt bob. Replacement en route.
[X] MA[P] target sticking behind [A]. Fixed by loosening under the playfield and moving over slightly.
[X] GO[L]D target sticking behind wiring harness. Fixed by loosening switch and pressing the harness up and out of the way, then tightening back down.
[ ] Maelstrom exit ramp switch defective. Reported to distributor and JJP, replacement en route.
[ ] Black Pearl cannon is inconsistently detecting the loaded ball. Switch test reporting stuck closed. Unsure if this is a clearance issue or another bad switch.

So...I’m on my 4th day

#2255 7 months ago
Quoted from f3honda4me:

Did you check the sensors for the canon? They are optical and might be loose.

Not yet. Anything I should know about accessing it?

#2271 7 months ago

Had a success with my Maelstrom exit ramp!

I read an old pinside thread that suggested overly tight set screws (the ones on the switch itself) can cause them to stick.

I loosened the left one and the plunger came out with an audible pop! The switch is now working perfectly.

#2277 7 months ago
Quoted from wheels:

That's rough! Have you been playing at all? Enjoying?
Tempted to go against my rule of first playing before buying as I've been burned before.

Oh absolutely we’ve been playing! Hours and hours.
I initially had a preorder on this game, then decided to wait and play first.

As soon as I played it I knew I made a mistake and had to own it.

It really is that good.

My problems really haven’t been *that* severe, and the support I’ve gotten for each from distributor and JJP has been excellent.

I fixed my Maelstrom issue which was a game-breaker, and the only remaining issue I’m stuck on is the pearl cannon optos. I wanted to tackle that tonight, but my wife asked I wait for tomorrow so she could play

I have no regrets whatsoever about buying this pin.

#2282 7 months ago
Quoted from Hogbog:

It's a shipping block that should be removed and stored in the game . It will make your playfield harder than necessary to put back in the cabinet if left in.
Reinstall if you ever move your game folded on its back.

So that’s why the playfield is so hard to close! I removed all the white ones including the one “stuck” to the back of the playfield. Missed this one.

#2291 6 months ago

Well I’m still having trouble with the Pearl cannon.

I see no physical issue with the optos - see pics, maybe I’m missing it?

When I run the switch test and put a ball in the cannon, it sees it.
But during gameplay, the ship fails to list up and down during the cannon shot. It is somewhat inconsistent as it worked once this morning and failed once.

2CA5695B-1483-4780-BB16-6E68C9E8156D (resized).jpeg5FC30E45-273E-489D-91EE-CCEA377C36C7 (resized).jpegCAFFDEF9-291C-4E78-BABD-4A52D4080959 (resized).jpeg
#2298 6 months ago
Quoted from f3honda4me:

I see both sensors look to be in place. Nothing stands out to me from there far as I can tell. Have you called JJP yet about this one? Definitely odd.

Well strangely now it seems to be working again? Sometimes there is a substantial delay before it starts rocking the ship up and down. Sometimes not.
Sometimes the ship -never- starts rocking, and while I’m waiting for the aiming opportunity it eventually gives up and takes a shot automatically.

I guess I will open a ticket and see what support has for me. They’ve been very good with suggestions so far.

#2309 6 months ago
Quoted from SheriffBarclay:

Follow up, now the ship is constantly moving left to right, little tight rocking motions, and it won't stop lol.

I wonder if my problem (ship failing to move up/down during the cannon shot...sometimes) is the same as yours.

There were some people who had issues with wires breaking under the Pearl which stopped movement completely, but those have since been resolved at the factory. Mine is an 11/18 build.

#2317 6 months ago
Quoted from Crile1:

Can't believe I opened this up for Christmas! Also, would like to add that it has been playing flawlessly since opening the box. No issues at all. Now I need to start watching those tutorials.

That is excellent news! I’m really glad you’re having a trouble free experience.

#2320 6 months ago
Quoted from Wudchopper:

So im really new to this while "pinball to be ownership" lol. I have this machine ordered and coming at the end of January. Ive been following this thread for awhile now. And I've got to say I'm a little concerned about when i pull it out of the box im going to be working on the thing for days just to get to play it. I really dont believe a $10k pin should be that way. Am i over thinking this. Or maybe im reading this thread to much. But the last few pages have been all the things wrong... ugh. I hope im wrong, its alot of money and expect some quality.

Don’t stress out about it. Be aware of the common issues, which you will be since you read this thread. I’ve found JJP support to be amazing so far. And I’ve been playing the pin the whole time while tweaking things out.

In my view any issue you can fix at home yourself is a minor issue, and a major issue is one that requires a tech visit or replacement part. Mine have all been minor.

#2327 6 months ago
Quoted from ellips6:

Another error that I have is switch 82 'Bayou Subway Enter' left in open position. I have no idea what to do, anone had this issue and how to fix it?
Thanks again, I'm getting there!

While “stuck closed” can mean a jammed switch, I’ve found that “stuck open” just means it hasn’t been hit in a while. (It kind of irks me that this is reported as an error, but ¯\_(ツ)_/¯ )

Go into switch test and put a ball down the hole to confirm proper operation. If you see it close/open, it’s fine.

#2329 6 months ago

I’m starting to wonder if my Black Pearl aiming issue is a feature, not a bug.

Sometimes, it doesn’t move up and down when I load the cannon, and sometimes it does.

Are there gameplay rules that govern this behavior? Or is it always supposed to move up and down for aiming at the bullseye?

#2331 6 months ago
Quoted from Yelobird:

It is supposed to move throughout gameplay granted at different speeds depending on the character you select and mode you are in. While I suspect your optos are working I wonder if they are properly aligned? Hard to see from your photo if the bracket is slightly bent? Also, what level is your game set to and how did you verify it? I am betting its a simple issue.

The ship moves back and forth as expected during gameplay. The left/right optos pass tests and the ship tests all respond as I’d expect. The only failure state is when the cannon is loaded and it stays in the top position.

It’s probably time for me to remove the Pearl and get a better look at what is going on in there, but I’m not yet confident in the procedure to do so.

This is my last open issue on the game

#2332 6 months ago
Quoted from Yelobird:

Also, what level is your game set to and how did you verify it? I am betting its a simple issue.

The top of the bubble is at the second line from the bottom. The left/right leveling was verified by placing a level on the playfield while cranking the leg levelers.

#2340 6 months ago
Quoted from Pinballomatic:

Zaphx- check the opto control board under the playfield. Create some vibration and see if the cannon loaded opto is flaky. Unplug then replug the opto at the control board to make sure it’s seated properly. Ship should rock when cannon is loaded.

I will look, thanks! FWIW, the game does seem to know a ball is in the cannon. The drumroll begins, the mini screen changes etc.

On a possibly related note - does ship calibration have an effect on any of this? It looks like the minimum speed it detects varies.
I ran it once and got as low as 6, and another time as high as 14.

#2343 6 months ago
Quoted from Pinballomatic:

Zaphx- check the opto control board under the playfield. Create some vibration and see if the cannon loaded opto is flaky. Unplug then replug the opto at the control board to make sure it’s seated properly. Ship should rock when cannon is loaded.

Playfield is level at top and bottom.
I confirmed the plugs are well seated and the cannon opto detects the ball reliably.

Adding vibration with the cannon loaded does not cause any instability in the ball detection.

One thing I noticed is that when I run the calibration, there are certain speeds below which things really struggle. There is either a long delay before the moment occurs, or the movement times out.

This “struggle” behavior seems to match what I get with the cannon shot, when it fails. It either takes a long time before it starts the aim movement, or simply goes to the top and just stays there.

#2344 6 months ago
Quoted from Pinballomatic:

Mine usually lands at 6 as the slowest speed but I’ve seen 6-10 and I don’t believe there is a correlation.

Right now mine lands at 11, and it really struggles as it gets close to it.

https://www.icloud.com/sharedalbum/#B11G0ehgLGJRel5

Because the struggling behavior so closely matches the cannon aiming misbehavior, I have to think they are related.

#2346 6 months ago

Argh - and not the good pirate kind. I now have a new problem: the Chapter Select post coil will not fire.

The soldering connection looks fine, and the post can be freely manipulated. It does not raise during gameplay and it does not raise when I fire the coil test.

Suggestions?

PS - sorry to the thread, I’ve had so many little issues I feel like I am spamming it. Perhaps I should fork off into a tech support thread.

EC4C5324-652F-496C-8C46-9464533D99D4 (resized).jpeg
#2348 6 months ago
Quoted from Yelobird:

Minor observation from the image the jamb nut on the coil depth screw should be all the way down to keep the setting height correct.

Thanks for that, will spin it down. I did notice the height appears sunken below the playfield by about a 1/4 inch.

#2350 6 months ago
Quoted from Yelobird:

Its Possible if you raise the plunger (turn screw in to set height and lock jamb nut) that the coil will be able to draw the plunger again. I suspect its just out of range. Simple adjustment but we are here if that doesn't work.

Thank you very much!! Adjusting the position and tightening the nut was all it needed. The post now fires as it should.
Thank you for the tip!

#2353 6 months ago
Quoted from Yelobird:

No worries, LTG pays us in smiles and warm comments to be his helper elves! (monkeys) lol. Glad you got it working. The group is always around to help unless you want to know how to play better for that I'm at a loose.

I expect it will be months and months before I’m able to successfully finish all chapters for 1 movie.

#2356 6 months ago
Quoted from JayLar:

How do you think POTC compares to Dialed in difficulty-wize? I find DI pretty hard myself, never progressing more than about two sim-cards. Also newbies find DI a bit unforgiving.

It’s a really good balance IMO. Plenty of challenge and difficulty mastering the chapters/wizard modes, while it’s still pretty approachable to get multiballs, the cannon shot and other exciting events.

It seems equally interesting to newbies/casuals as well as hardcore pinheads.

#2365 6 months ago

I finally fixed my issue with the cannon! Recapped here in its entirety:

SYMPTOM: Frequently (but intermittently) the cannon shot would fail to move up and down, instead freezing in place. Also noticed that the ship calibration could not get single digit speeds, seeming to lose steam around 12-14.

DIAGNOSIS: Running the ship test seemed to work fine at higher speeds. Initially I took this to mean there were no physical issues with the ship movement. On closer examination, it felt like the ship wasn’t listing to the left as much as it should. I pulled the playfield into the service position and repeated the test where I could now see the motor assembly was bending upon each revolution:

https://www.icloud.com/sharedalbum/#B11G0ehgLGJRel5;19361558-3938-4DAE-BE51-A8E8BE8F2E5A

The reason for this was the adjustment bar which set set to the full topmost extent. This was causing the pin that moves the ship to halt against the top of the slot in the wood, causing the motor to press down and bend its bracket in order to keep moving.

FIX: After adjusting the screws to allow full range of movement, the ship now freely operates:

https://www.icloud.com/sharedalbum/#B11G0ehgLGJRel5;30C87B43-515A-404C-A1C4-AA6A485565EF

Additionally, the calibration test is now able to run all the way down to 4.

I am very happy to have this issue resolved, which is my last open problem with the game.

FD3CEFF7-BB9E-4161-A94F-75BA45F6F20A (resized).jpegE1C1D172-687E-471E-ACE8-D8C2A16ED18C (resized).jpeg
#2368 6 months ago
Quoted from tonycip:

So are you saying the ship moves at normal speed when loaded?

Yes, everything now works fine.

#2370 6 months ago
Quoted from SheriffBarclay:

Did y'all adjust any difficulty settings in menus? Ball save timer, etc?

I turned on a 5 second ball save timer. Aside from that, everything default with the “home” setup.

#2372 6 months ago
Quoted from Pinballomatic:

Well done Sir. Nicely solved. We were just discussing your issue amongst us and you got it.

Thank you! I’m feeling pretty great right now.

#2377 6 months ago
Quoted from Genjuro:

Is there any definitive fix for the button on the lock down bar? I am 8 days into ownership and the button is already sticking and behaving badly.

I hit mine with WD40. Many will cringe at that, but it worked. Pressed the button down and hit the exposed plunger with a tiny blast. It has been perfect since.

#2378 6 months ago
Quoted from zaphX:

I hit mine with WD40. Many will cringe at that, but it worked. Pressed the button down and hit the exposed plunger with a tiny blast. It has been perfect since.

I should point out, my issue was internal friction on the button - not travel to the microswitch.

#2400 6 months ago
Quoted from JWJr:

Across all_ JJP games, I'd like to see a way to scroll through and erase individual pictures. It's certainly possible to sneak something non-family-friendly into a pic, and it'd be a shame to need to erase everyone's_ pix (and scores) just to eliminate one_ bad apple.

I’m not entirely sure that is true. The game appears to use face detection algorithms.

#2401 6 months ago
Quoted from evh347:

Where exactly are the Black Pearl Motor Outer Opto #69 and Black Pearl Motor Inner Opto #70 located?

They appear to be under the playfield near the back. There’s a pretty good picture in the manual on page C-116.

#2403 6 months ago
Quoted from drewski28:

Just set up my CE and the game keeps resetting itself about every ten seconds which makes trying to fix it pretty tough. Any ideas? Shame my worries came true that it would have issues straight out the box. Oh well, just gotta keep at it right?

Does “reset” mean it acts like you powered it off/on, full reboot etc?

Maybe the harness to the CPU in the backbox is loose? This is something I checked when my machine initially failed to boot.

#2411 6 months ago
Quoted from drewski28:

So unplugging the topper solved my issue but thats not ideal considering Id love to see my Black Pearl rock back and forth. Any suggestions?

The topper was causing reboots?

#2412 6 months ago
Quoted from VillaThrills:

New goal...get the external sound as good as the headphone sound. Adding on the Polk subwoofer has given the Pirates some extra oomph. Unfortunately the internal speaker layout in the Pirates is tough to work with. Still missing a lot of low-midrange tones that you pick up with the headphones. So may be looking at an external solution to fill in the gaps. Will see. Would love a direct replacement solution.

Our games are in our media room with a nice 5.1.2 setup w/ subwoofer. We’ve been talking about trying a Bluetooth transmitter plugged into the headphone jack to push the audio to the sound system.

#2417 6 months ago
Quoted from abelelectronics:

We have 2 collectors editions available. If interested PM or text 586-530-8206
[quoted image][quoted image][quoted image]

Just to chime in, dealing with Gary has been excellent and I recommend him. Got two LE’s from him.

#2420 6 months ago

Anyone notice a rattle in their backbox during the cannon booms of chapter unlocking from the shaker motor? I have not investigated it yet, I suspect it’s the translite rattling. May try and tamp down with weatherstripping if so.

#2423 6 months ago
Quoted from PsychoPsonic:

I discovered as other have noted that there were no pilot holes in the top of the backbox for installing the PotC CE topper.
Steve Z at JJP support had this helpful info for me that I'll pass along here to hopefully assist others:
"For the position of the topper, I reached out to the Production Manager at the factory and asked about the spotting holes for the CE topper. He said that measuring from the front edge of the backbox, the holes should be 7 and 5/8" and then 8 and 1/2" back from the front edge, and then center the topper (don't put the holes in the center, center the topper) side to side. Four holes total to accommodate the four spots on the bracket."
JJP support continues to get it done. Lloyd and Steve get attaboys from me today for being responsive and helpful. Frank probably woulda gotten in on the act too, but he's on vacation!
Thanks, JJP Support!

So basically, we can just unscrew it and drill it down centered?

#2424 6 months ago

Sorry, I missed this was for the CE topper. Was hoping for a procedure to correct the off-center LE topper.

#2425 6 months ago

I’m unboxing another LE next week, and I made myself a checklist of things to do and look for during the process.

I thought I’d share it, if it helps anyone else. If you have suggestions for changes let me know!

https://www.icloud.com/pages/0-5P7Ad82b5f4Cat22MwfCd-w#JJP_POTC_Unboxing

#2430 6 months ago
Quoted from JWJr:

[quoted image]

I stand corrected!

#2434 6 months ago

And here I can’t even knock the default 500K score off the board yet.

#2445 6 months ago
Quoted from drewski28:

Anyone have the post #'s for how to cure the grinding center disc as well as the rocking ship losing power and rocking slower and slower?

https://pinside.com/pinball/forum/topic/jjp-pirates-of-the-caribbean-official-owners-and-fan-club/page/48#post-4754530

In my case the adjustment bar was too high, causing the ship to hit the top of the cabinet slot and bend the motor assembly. Let me know if this matches yours.

#2456 6 months ago
Quoted from VillaThrills:

Tried to search the posts for cannon issues. I thought I saw one before but didn’t find anything.
The issue that just started popping up is that the cannon was missing right. I noticed the Dauntless has a lot of front to back play in it. When pushed all the way back, it was making the shot easily. When it wiggles its way forward the shot misses right. Is there a physical adjustment for the cannon or should I look at the Dauntless for an adjustment to take some of the play out you think?

How is your Pearl range of motion? I’d look at that, as I had to tweak mine a bit before I was happy with its home position. Having done this, the Dauntless bullseye is now an easy center shot every time.

#2458 6 months ago
Quoted from VillaThrills:

Where in the rocking do you launch the cannon? If I don’t hit it right at the top, it does not make it and even then it skips off the bottom. My Pearl never goes up to the top of the slot like I believe yours did. Just wondering if mine is too low or if you are supposed to launch at the top of the arc.

My bullsys shot is directly in the center of the up/down travel. Sounds like mine was too high and yours is too low. What do the 2 screws look like on the motor bracket behind the playfield?

I believe topmost is no good, and bottommost is no good. I had to play with mine to find the sweet spot where the ship in “home” was level with the ramp.

#2460 6 months ago
Quoted from VillaThrills:

Don’t know if that fixed the right to left or not but that definitely was an issue. Add this to the things to check for new games. Mine was all the way up. Will try it out in the morning but thanks for the insights. The Pearl rocking arm should be centered in the slot. Will try the cannon shot again in the morning and see if mine now takes the center of the rocking to make the ship shot centered as well. Will also check the coil power on the cannon shot.

Sweet, glad it helped. I did add examination and calibration of this bar to my unboxing checklist.

After doing this fix, I found the Pearl played a lot better and it was now possible to trap the ball on the left flipper (in certain lower-speeds.)

#2462 6 months ago
Quoted from VillaThrills:

Bummer, even at high speeds I was able to do this! Lol. Guess I need to erase those high scores!

Hah, yeah - if your Pearl was listing too far to the left, you had a major advantage in ball retention.

I think you nailed it; the correct position is centered such that the gap between top & bottom of the slot are the same. That’s where mine ended up.
I used “home” position of the Pearl and even ramp alignment as my guide.

It will be fun to do this on pin #2 next week, with the benefit of going through this exploration.

I wonder how many Pearls in the field are randomly maladjusted?

#2469 6 months ago
Quoted from Pinballpal:

Here is the hardware you can buy at Ace Hardware if you have a ball hung up during multiball.
You need one of the 1 inch spacers, 1 of the 1/2 inch spacers and 1 wood screw number 8 x 2inches.
You will want to remove the left support rail for easier acces.
[quoted image][quoted image][quoted image][quoted image][quoted image]

Can you recap the fault this fixes? Is it balls stuck in the subway?

Thanks for the DIY details. We almost need a wiki to keep track of the fixes.

#2471 6 months ago
Quoted from Pinballpal:

If you are playing a multiball and your last ball drains and the pin goes into ball search and it shoots it out of depths.

Thanks! I’ll watch for that. Haven’t seen it yet.

#2489 6 months ago
Quoted from Energyspike:

Thanks for the discussion on this. I adjusted the two screws as the Pearl seemed to lean to the left too much and now it's even which makes the shot to the cannon a tad harder....perfect!

Sweet! Glad it helped. I’m unboxing another LE next week and calibrating the Pearl travel is on my TODO list before plunging my first ball.

#2503 6 months ago
Quoted from Pinballpal:

If you are playing a multiball and your last ball drains and the pin goes into ball search and it shoots it out of depths.

This happened to me a couple times tonight. I guess I will need to perform this mod.

Can you show me where exactly on the playfield it goes?

Or should I wait for an official JJP kit/procedure?

#2510 6 months ago
Quoted from Crile1:

Now that I have this game dialed in, it is a dream to shoot! Unfortunately, I am now to the point where I am trying to progress towards the wizard modes instead of just having fun with the muliballs. Man, this game can be brutal. I will have an amazing game followed by 10 horrible ones. Amazing how fast this game can turn on you!

I keep finding more layers and nuance. Tonight I realized how important the PIRATE inlane awards are, and how ARRR frenzy can really blow up a score coupled with multiballs.

#2516 6 months ago
Quoted from pascal-pinball:

How does the playfield X works?

I second this question and add, what/where is “Super X?”

#2534 6 months ago

I’ve had a couple of stuck balls so far. It seems to happen in two areas:

1. On the shelf to the right of the Pearl (usually after going overboard.)
2. Under the Pearl itself on the left side (which is more worrisome since the boat keeps a-rockin’.)

Places to keep an eye on.

#2541 6 months ago
Quoted from fastchef:

Couple of minor issues, I hope.....
1) added a player during my first ball and the flippers went dead.
2) during a game both screens went dead. Shut it down and it came back.
3) I keep getting check switches after power up and it’s usually has to do with the ship that the ball hits and all’s I do is move it and it’s goes green.

#3 is normal (but annoying.). It shows up if the ship hasn’t been hit/bullseyed in the last X games.

For the other issues, have you upgraded to 0.98?

#2546 6 months ago
Quoted from Crile1:

I cannot lock a ball in the chest on the fly. I have to cradle and hit dead on. Even then it doesn't make it up about 40 to 50 percent of the time. The fork works. I've already cranked the right flipper up three past standard. Should I keep increasing flipper power or is there something else I should check. It is level at 6.5 degrees.

When you say the fork works, have you removed it and tightened the 2 screws inside the mech? Mine was very iffy as you describe, requiring full power and direct hit. It is substantially improved after tightening.

#2552 6 months ago
Quoted from Crile1:

Woohoo! Fork ramp shoots like butter! Thanks for the help, mates. Just needed to tighten those screws!

YARR MATEY! Glad to hear it!

#2555 6 months ago
Quoted from Axl:

This thread desperately needs key posts with all the great information.
I wish robin would make a "suggest key post" button.

I agree. I’m trying to get an account on pinwiki.com to document everything I’ve learned and fixed there.

#2557 6 months ago
Quoted from Psw757:

Don’t have access to my game at the moment but where are these screws located?

The chest fork mech is held onto the playfield underside by 5 screws. When you remove those and pull the fork assembly out, you will see the 2 loose screws securing the fork.

#2574 6 months ago

I’m unboxing another one tomorrow and confirming proper operation (and center position) on the Pearl is part of my checklist.

#2576 6 months ago
Quoted from tonycip:

I was getting some kick outs from the chest as well so I had to do the same thing . what I noticed is the bracket that the screws thread through is pretty thin.and may not have much in the way of threads, I would suggest adding a jam nut on the other side or at least some lock tight. my .02 cents.
now working perfectly.. while your under there it would be worth checking the coil adjustment screws on the playfield posts .the one by the chapter start you would notice but the one in the left orb wasn't working on mine and I didn't know until I found the screw in the bottom of the cab.I think there's 3 such coils with this adjustment on them. correct me if I'm wrong ..

I found the chapter select post and the left orbit - both of mine needed adjustment and spinning the nut down. Where is the third?

#2580 6 months ago

Well I still don’t have a pinwiki account but here’s my list of problems and solutions for POTC so far. I will replicate it there once I am approved.

Problem: Chest seems to reject shots that it should have captured.
Solution: Remove the chest mech from under the playfield (5 screws.). Tighten the two screws for the fork which are likely loose. This is a common problem.

Problem: Balls getting stuck at the top of the Black Pearl ramp.
Solution: Ensure the game is horizontally level, measured at the playfield. Next, locate the screw to the right of the ramp which compresses a rubber crush washer. Tighten this screw clockwise until setting balls on the top of the ramp always makes them roll away right. This fixed the problem for me permanently.

Problem: The Black Pearl rocking motion sometimes halts (especially during the cannon shot) or otherwise seems to struggle in the calibration test.
Solution: Put the playfield in the first service position, such that you can observe the motion of the arm. Run the ship calibration test. If the pin that controls the rocking of the Pearl contacts the top or bottom of the slot, loosen the two screws on the control arm and correct the height travel is unimpeded in both directions. This took a bit for me to find, but after correcting it the calibration was able to run all the way down to 4, and the ship rocking was much more playable.

Problem: The metal rails in the shooter lane are malformed, causing bad plunges
Solution: Take pictures of the shooter lane before removal, noting the angle of attack into the right orbit. Remove the shooter lane. It has 3 connection points, one hex screw near the top, the “stack” which holds the right strobe, and a small black screw near the bottom. With the wireform removed, gently bend the bottom two forks such that they are slightly down and slightly apart. The goal here is to make them hug the shooter lane when reinserted. When reassembling, take care not to strip the black screw. I was advised to put the screw in and gently turn counterclockwise until it rises up, to ensure it hit the threads correctly on reinsertion. This fixed the problems with the shooter completely.

Problem: Maelstrom exit ramp switch reporting stuck closed
Solution: This may be more of a “general pinall troubleshooting” thing. I removed the switch and found the plastic plunger in the microswitch was stuck down. Loosening one of the set screws on the switch itself freed it and normal operation resumed.

Problem: Game reports switch errors on the ship on startup
Solution: This is a normal condition that happens if the ship hasn’t been hit in the last N games and usually does not indicate an actual fault.

Problem: Game reports stuck MAP targets
Solution: In my case the targets were mounted too closely together and were physically stuck behind one another. Loosening from under the playfield and moving them apart resolved the problem.

Problem: Game reports stuck GOLD targets
Solution: In my case the L target was getting caught under the wiring harness on the Pearl ramp. I loosened the target and pressed the harness up and out of the way, then reinstalled. The Pearl ramp adjustment to stop the ball from sticking on the ramp also helped.

Problem: Chapter Select or Left Orbit posts fail to raise up
Solution: Locate the posts under the playfield. Adjust the position with the screw and lock into place with the hex nut.

Problem: Action button sticking during gameplay
Solution: Remove the lockbar. Depress the action button and apply a small amount of lubricant to the exposed plunger. I had success with WD40, others used silicon spray. Clean off any excess before replacing the lockbar.

#2638 6 months ago
Quoted from pingod:

I do, and it's loud to.

My Jack Russell Terrier freaks out and tries to attack the machine every time he hears it.

#2672 6 months ago

Warning when adjusting your Black Pearl ramp crush washer!

I set up a second machine last night. It had far fewer issues and was almost perfect, save for the Pearl ramp catching the ball.

Knowing how to fix that, I started to crank down the crush washer...and cranked, and cranked. And the screw snapped, leaving the shaft inside the post.
I am now a sad pirate with a completely unplayable machine.

Upon further examination, I see the problem - I could have cranked forever or even removed the crush washer entirely and the ramp still wouldn’t have the proper right tilt. There needs to be something under the bottom left of the pearl ramp to give the left side a little bit of lift. I am planning to use one of those clear plastic “cabinet bumps” for this purpose.

But my roadblock now is that the post has a broken screw shaft in it, and I don’t know how to remove the post. I tried to unscrew it and it just spins in place.

I also tried a broken screw extractor, it did not work. I will need to replace the post.

LTG any suggestions on how to remove the post safely, and maybe where to find one so I don’t have to wait on parts?

DA9D3E01-6AA2-4DF8-9382-2A92EC663201 (resized).jpeg
#2674 6 months ago
Quoted from wheels:

That sucks! Can you drill it out?

I tried drilling it out with a broken screw extraction tool and was unsuccessful.

#2689 6 months ago

Good news, I was able to craft a workaround to make my new machine playable!

MacGyver would be proud, I crafted a reasonable facsimile of a hex post using a threaded rod, nuts, and nylon spacers from the hardware store. This will keep me playing until I get the proper part from JJP. For those who were curious, the two screws that flank the post release a bracket making the nut holding the post easy to access. (I did not reinstall the plastic as I will be dismantling all this a second time later.)

This machine was 100% OOTB except for the Pearl ramp adjustment. Well, and the off-centered topper which, LOL, what the hell? Anyone know how it is attached so we can fix it? Anyway, to revise the Pearl ramp troubleshooter...

PROBLEM: Ball sticks at the top of the Black Pearl ramp.
SOLUTION: First, attempt to crank down the screw to the right of the Pearl spotlight. If you can get it such that setting a ball at the top of the Pearl ramp -always- rolls away, you’re golden! However do NOT overdo it if it’s not happening. If you still can’t get the desired rightward (starboard?) tilt on the ramp, read on...

Experiment a little bit by pressing up on the underside of the ramp. I found that if I applied a small amount of vertical lift near the bottom where it (almost) contacts the screw, I could get the desired lift. I got some clear plastic cabinet bumpers and wedged one in there which is working perfectly...zero stuck balls.

Not sure why my other machine didn’t need this fix - maybe there is a factory bumper/lift of some sort that this machine didn’t get? ¯\_(ツ)_/¯

Hope this helps others. No stuck balls!

36EBA653-2A4D-4F5A-817E-F16D3945B1DE (resized).jpegE3DA2CCB-2EF1-4EF0-A505-C5CFEB80F3AF (resized).jpegFC007331-F907-4CC7-B0FF-ADC44C20EDE1 (resized).jpeg
#2691 6 months ago
Quoted from KirboTurbo:

I’m having an issue with the chest not releasing all 3 balls during multiball. It will release 1, but not the other 2. The release gate will twitch and try to let them out, but doesn’t open far enough for them to come out. It will not release the balls after the game is over either. I have to take the glass off. Zaphx, I can’t believe you haven’t seen this yet. LOL

That is a problem I haven’t had. I do have one machine that lets out too many balls at once when it intends to release one - I need to investigate the chest timing to fix.

#2702 6 months ago

Thanks yelobird for the heads up on the Dauntless wiring. I found mine to be loose, but I was still uncomfortable with bare wires on a moving part in proxmity to sharp-ish metal.

I added some wire loom today.

97D00F37-4AAC-4B37-B371-0B0519569F59 (resized).jpeg
#2703 6 months ago

I got the dreaded “left flipper EOS” error today. The fix was quite simple, resolder this wire:

B03B4174-7398-4036-AA9C-3EF92AFCB24B (resized).jpeg
#2706 6 months ago
Quoted from f3honda4me:

Had a small issue that started last night, and a quick 5 minute fix. Manual plunger shots were becoming erratic, and discovered it was because the manual plunger was hitting the top of the auto plunger. The quickest fix I could find was removing the auto plunger, putting into a vice, and using a dremel 952 bit to grind down the area that was rubbing. Plunger is butter smooth again.

Thanks for this fix! I believe my first machine has this problem - it has had inconsistent plunges from day one, where sometimes it’s fine and sometimes the ball just barely makes it to the mystery skill shot. My other machine shoots perfect.

#2709 6 months ago
Quoted from KingBW:

Instead of grinding the mechanism, just loosen the plunger housing and adjust the height.

Ah perfect!

#2720 6 months ago

I noticed my left flipper (and the left flipper on the pearl) both have an end position higher than the right one.

What’s the trick to adjuating the end position?

#2725 6 months ago

To confirm the bottom position of my flippers looks right, I believe it’s only the top position. And it’s both the bottom play field and the pearl doing it.

I did have a broken left flipper eos wire for a while - would overpowering the left flipper hold cause anything to go out of whack?

#2727 6 months ago
Quoted from Yelobird:

Your EOS did not cause an issue. The flippers always look correct in the down position because they are resting against something. Hold them both in the up position when adjusting (use a straight edge across them if you like) and tighten per the LTG movie.

Will do. Thanks!

Remaining question; how do I remove the Pearl to adjust his left flipper?

#2734 6 months ago

Delete

#2738 6 months ago
Quoted from xizor:

didn't have any wiring issues other than a harness blocking one of the GOLD targets. Moved it out of the way and everything is good. Auto plunger needed some adjustment and it's been good mechanically otherwise so far.

I had the same exact issue. Have you adjusted your ramp to prevent stuck balls? I have a theory that the gold target sticking is indicative of the ramp not being aligned right.

#2740 6 months ago

I’m getting a weird issue with the camera - there’s this rogue reflection spot in the camera and I haven’t been able to nail down the source.

If I remove the translite, the camera is fine, so it’s almost like there’s a weird imperfection in the bezel glass. You can see the spot come back into position as the glass settles.

I’ve cleaned it and my old eyes see nothing.
It’s kind of annoying because it mars the high score photos.

Anyone have an idea?

CE4A5E4C-E919-4C9B-B11F-90F8470AA8CB (resized).jpeg
#2741 6 months ago

So this one is kind of pedantic and maybe a stupid question...maybe hogbog can answer.

Which of these two flippers is correct? Is the left too high, or is the right too low?

This stuff matters, as it affects your shots which I’m practicing and trying to perfect my aim.

06A05CA4-CED2-4233-BB4C-3F71F8AAD83A (resized).jpeg
#2744 6 months ago
Quoted from wheels:

I'm having the same issue to the point I thought my face was bleeding. I figured I just needed to clean the lense, but now I'm thinking that won't matter.

Well I just took the bezel off and looked at it really closely - still clean - put it back and now the problem is gone. I guess it was catching a weird reflection in one specific position. I noticed the left/right position of the bezel favors the right, where before it favored the left. Maybe try messing with it?

#2745 6 months ago
Quoted from wheels:

Both flippers are even with the lane guides when lowered?

Well initially I thought the answer was yes, but I just took a good look and sure enough the left flipper rides a touch high. My mission is now clear, I guess!

4624AE15-25BF-4FFF-BA83-B71914701E9A (resized).jpeg
#2760 6 months ago
Quoted from ellips6:

Everyone loves this pirate experience, this is such a fantastic game.

Everyone’s thinkin’ it, I’m just sayin’ it...pirates is awesome!

#2762 6 months ago
Quoted from sirlonzelot:

Hope that they fix the chest multiball lock bug soon, that really sucks

What’s the bug on this?

#2766 6 months ago
Quoted from sirlonzelot:

That‘s curious while some others have it too, i definitely didn’t had it before the update

I will watch for it. Steps to repro: lock 3 times, get the multi ball, then locks don’t work?

#2768 6 months ago
Quoted from sirlonzelot:

No chest multiball played 3 times and then the lock switch don’t register anymore

In the same game? That explains why I haven’t seen it. My skills are lacking right now save for one breakout game.

#2770 6 months ago

@ltg should I wait on adjusting my flippers until I get the gap tool?

In other words is it possible that loosening the nut without one will screw up my gap?

#2784 6 months ago
Quoted from delt31:

yeah I just get a little concerned that new buyers are going to read this thread and get discouraged......thought i would mention my experience thus far.

I had several issues on my first machine but they were all solvable and as suggested, many (but not all) were general “pinball issues.”
Buyers should not be discouraged. I love this machine so much I got a second one!

#2786 6 months ago
Quoted from KingPinGames:

Also, JJP has an amazing tech support department that is there just in case you need them.

I want to second this. Obviously everyone wants a perfect game OOTB but when things happen, getting good support makes all the difference.

I’ve had absolutely stellar support from both JJP and my distributor Abel Electronics. This support really turned around what could have been a crappy experience.

I’d also like to add, I’m posting about my issues in the hopes that sharing my experiences (and fixes) will help others if they run into the same problems.
We’ve already seen a few recurring issues with easy fixes (for example the chest fork screws and the Pearl ramp adjustment.)

Perhaps I’m being too noisy but I assure you I am super happy with my purchases and I’m very enthusiastic about POTC and JJP.

#2788 6 months ago
Quoted from wheels:

Not too noisy at all! Your posting made it a lot easier for me to get it going. It's only getting easier for everyone else with manufacturing improving and all of the potential issues identified.
JJP is really making pinball better!

I’m glad to hear that. Helping people get past issues is my only goal so we can all get to happy pirating!

#2813 6 months ago
Quoted from NightTrain:

Hey all - I'm reading through this whole thread starting on page 1, but I've got a quick questions I'm too impatient on the answer for. What's the deal with the LED stars between the two ships on the back board? Is it just there for looks? Is it interactive?

It’s part of the game! It gives you hints by twinkling shapes which denote a hidden shot on the playfield. Once you make the shot you get a constellation award. Enough of those and you get an extra ball.

Some of the ones I’ve found are PIRATe letters, 2x-5x, the chest, maelstrom and ship.

#2843 6 months ago

I’m having so much fun with this machine! My pinball buddy keeps coming over and we kill multiple hours just trying to master it.

#2850 6 months ago
Quoted from Yelobird:

Set it to Dollar play and he'll come over less! lol

Playing with friends is awesome!

First off, what’s the point of having a great shot/game if nobody sees it?
Second, I need someont to plunder!

#2870 6 months ago
Quoted from FryDaddy:

Ok I hope someone can help me with this one. I turned the game off last night and all was playing fine. I try to start the game today and this message comes on screen. The message goes away but the game does not start up. Lights on the play field never turn on and does not start the boot screen. Just goes blank and nothing.
[quoted image]

Yikes. I’m just guessing here but I’d try doing the “full firmware update” process and see if rewriting the whole shebang brings it back to life.

#2872 6 months ago
Quoted from konghusker:

Curious if potc has an intense battle or moments like woz and hobbit melting the witch, or killing smaug? What is the main objective in potc?

Five different wizard modes and one grand overall “break the curse” wizard mode!

#2878 6 months ago
Quoted from FryDaddy:

That was the ticket. Back up and running on 97 now next update to 98. YEAH

Very happy to hear it! Now post some scores, brah!

#2884 6 months ago
Quoted from phoenixpin:

Just wanted to say a few things about my new POTC:
- imo, the game is one of the best of all time. It’s got amazing code, really deep in a good way for home use. Layout is fantastic, with opportunity for flow but also stop and shoot for those thinking through a strategy. Mechs that bring the magic to pinball like it should be. It’s been a hit for multiplayer, but also great playing alone. Incredible replay value. I couldn’t give a higher recommendation for it.

I couldn’t agree more. I think it’s destined to be a classic.

#2916 6 months ago

While we are talking abut those fork screws...has anyone had to tighten them more than once?

I’ve done mine, but every time I fail to load the chest I wonder if they’ve gone loose again.

I may crack it open once more and use some loctite.

#2918 6 months ago

Was that a vote in favor of using it, or an expression of incredulity I’d consider such a thing?

#2922 6 months ago
Quoted from dendoc:

Can you let me know what you did to fix the ship movement? Mine tests fine but in game play only goes level and to the left. thanks.

Did you confirm it has full range of motion? Is the “pin” passing through the rear of the cabinet hitting the top or bottom f the slot? I had and fixed this issue earlier in the thread.

#2933 6 months ago

Hi fellow pirates,

I'm streaming some gameplay on http://twitch.tv/nspinball if you'd like to check it out!

Lighting is not perfect, waiting on some more mic stands and mounts, but it's a passable first stream.

If you watch last nights recording, skip to 50 mins or so where I have a pretty good game with Arrr frenzy and liars dice.

#2938 6 months ago
Quoted from NightTrain:

How many balls are in this game? I'm going to order new balls.

Five but be forewarned you can’t use silver jets. They magnetize.

#2955 6 months ago
Quoted from Genjuro:

Yep, just trying to get it asap for league night. Unfortunately getting anything but a voice mail is difficult at the moment. Thats the reason i was hoping i could work on the internals, or just order a part from marcos, pbl, etc... unsure if the switch is proprietary or readily available from somewhere. Do you know LTG?

Is the switch sticking open, or closed?

#2962 6 months ago
Quoted from Genjuro:

Both, but mostly not registering closed. New one is on the way. I will take the one that is malfunctioning apart once the new one arrives just to see what is going on inside.

I had a sticking microswitch that cured itself miraculously when I loosed a set screw on it. Not sure if we're talking a leaf or a micro here for your problem.

#2971 6 months ago
Quoted from Genjuro:

Yes, its the microswitch for the action button.[quoted image]

Ah! So is the little red button under the blade sticking? If so, try slightly unscrewing the black screw closest to it.

#2973 6 months ago
Quoted from Genjuro:

The red portion doesn't stick, it just moves correctly, its the registration of the switch open closed state that is flaking out.
Check out the vid. BTW, it behaves the same if its my finger pushing the metal switch arm..i just took this video before I used my finger. You can hear the test screen in the audio.

Ah bummer. I guess the switch is just a bad one. At least it won't be too bad to replace.

#2975 6 months ago

We are streaming now at twitch.tv/NSPinball !

Two million plus games so far for the night.

#2989 6 months ago
Quoted from javagrind888:

Here it is. The slow motion shows it hitting the rubber post to the left every time. How do I fix that?

To me it looks like the ball guide rails are slightly bent inward on the right side which is affecting the trajectory. Removing this rail and reshaping it is something I had to do to mine.

I would advise contacting JJP support for walking you through this - I did it to mine but it requires great care and very gentle force applied in a specific way.

#2990 6 months ago
Quoted from JordanB:

For those having trouble with tortuga VUK shooting straight down the middle, or aiming inconsistently regardless of the coil strength, here's what I did.
My two screws were loose on the bracket directing the ball.

I've been experiencing SDTM from Tortuga so while I had the glass off today I checked - sure enough the guide is loose. Thanks for the steps to address this, I am about to fix it myself.

#2993 6 months ago
Quoted from javagrind888:

If that's the issue (hoping not) wouldn't it also do this on the manual plunge?

It's not a terrible fix, but it does require some care and instruction to avoid messing things up. I'm guessing it has to do with the power applied to the ball, you might be able to replicate it on a specific manual plunge depth.

#2994 6 months ago

I had a pretty good maintenance day.

I installed the “subway fix” post.
I adjusted a leaf on the right slingshot that was machine-gunning.
And I adjusted the loose scoop on Tortuga, fixing the SDTMs.

Now I’m having a new problem; twice so far tonight the ball has gotten stuck under the Dauntless after making the bullsye shot.
Any suggestions for this one?

380F5F32-9096-4EB4-B5D3-47113D3C51D9 (resized).jpeg
#2998 6 months ago
Quoted from wheels:

Had my best game yet. At one point, I think the monitor said "66666" or something close to that. I think I had all of the multiballs going at the same time. Anyone know what that was? Whatever was happening, it was fun! The lights, sounds, and call-outs were going crazy. What a great game!

I just can’t stop playing! And my pinball buddies keep finding their way over to play it too. Did you add your score to Pinside and/or Pindigo app?

#3000 6 months ago
Quoted from wheels:

No. Feel like I shouldn't because I play 5 ball games. Yes, I know I shouldn't, but I remember 5-ball games from my childhood.
By the way, checked out a few minutes of a recording from your live stream. Very cool!

Thanks! We had a good stream Friday night. Two million-plus games and Kraken wizard mode.

I’ll be doing more of this now that I have all the gear. It beats playing alone, and hey if I manage to have a great game I can re-watch it

#3004 6 months ago
Quoted from Eskaybee:

Isn’t there a rollover switch there that registers the shot? Check to make sure that switch isn’t hanging the ball up. I remember something similar like this happening to Karl’s game when we were streaming. 2 minute fix.

Assuming it is that rollover, what is the fix?

#3018 6 months ago

I’ve gotten “Special” a few times - anyone know what that is?

#3024 6 months ago
Quoted from dnaman:

You can select what Special hands out and and what score (IE:125,000 etc...) within the setup.

Given that free games are meaningless, what are people doing for special to make it competitive/fair? I want my scores to remain meaningful.

#3033 6 months ago
Quoted from sirlonzelot:

Yes,ship is removed within 5 minutes

People keep saying this but I’ve been unable to remove it. I removed the cotter pin on the back motor bar assembly and removed the hex nut behind the pearl. I was able to move it fore and aft slightly but was not able to remove it.

If someone can show the proper Pearl removal in a video it would be nice.

In my case I was trying to get a dropped screw.

#3036 6 months ago
Quoted from LTG:

Hopefully Butch will make one.
Pull the black pearl playfield back harder/farther. Try and release from two pivot points.
LTG : )

I was pulling it forward towards the front, not towards the backbox. Good to know.

#3044 6 months ago
Quoted from pinball_keefer:

...other than wizard mode 2...

I spent quite awhile on that sunset.

Ah, Sunset!

I viewed it as sinking underwater, slowly.

#3061 5 months ago
Quoted from Ramjet:

Since the bracket for the topper on the LE version is not centered correctly, has anybody tried moving it? How is it attached?

According to the manual it is just two screws. I plan to try and fix it this weekend and will report back.

#3087 5 months ago
Quoted from NightTrain:

What colored flipper rubbers are you guys going with? Brand? Got any pics?

I just ordered a full set of rubbers from Titan Pinball. I chose the original color scheme.

#3106 5 months ago

So, if your topper is off center...take it from me, just live with it. Don’t try to fix it.

It looked like two easy screws on either end so I attempted it tonight.
There is a threaded rod apparently built into the bracket in the center which screws into the backbox somehow. I couldn’t feel any nut inside the backbox so it’s probably some kind of socket in the wood. Definitely not a simple fix.

I gave up and reassembled.

I need to replace the black plastic plugs now but otherwise no worse for the experience.

#3118 5 months ago
Quoted from TomGWI:

I got a new gate from JJP and thought it solved my ball trap issue but no luck. I tried to tighten down the right side with the screw with the rubber on it but never had any luck.
I finally added a rubber under the ramp on the left side where the middle post of the slingshot under the ramp is and finally no ball hang ups.
[quoted image][quoted image]

I’ve got one machine where all I had to do was tighten the screw, and one where I had to prop the ramp in the same spot you did.
This appears to be a common adjustment for everyone!

Once it’s fixed it’s so nice. The ball -never- sticks there now.

#3123 5 months ago
Quoted from Yelobird:

I may have read it wrong but I don't think he had an issue putting 2 screws back in or the mount the issue was the threaded stud sticking out of the cabinet that you can't move. If that is the case you would need to drill a new hole in the channel they provided to move it over and remount. Just guessing.

Yeah, it appears the topper mount is T shaped with a threaded rod screwed into the top of the backbox. I didn’t feel a nut inside the backbox so I’m thinking it is probably a socket. Not a simple thing to relocate.

#3131 5 months ago
Quoted from JoinTheCirqus:

So many postings under this thread, so this may be a repeat. To you owners, what do you think of the impact of the spinning disc on gameplay? Like many I was pretty critical of the change from the original design, but I do love the JJP pins and am curious how the disc affects gameplay and how often is it activated, etc.

Now and then it will grab the ball and save you...or drain you...but overall it doesn’t affect gameplay that much. It seems like it’s spinning most of the time for me during gameplay.

#3132 5 months ago
Quoted from Crile1:

"Everybody's thinking it, I'm just saying it. Pirates!"

Absolutely my favorite game over callout! And also my vote, as I am a huge POTC pinball fan obviously. It’s the most fun I’ve had in pinball.

#3133 5 months ago
Quoted from Nytewatch33:

But my wife is more about bashing the ball around and doesn't pay attention to any of the rules. Still - the machine is mostly for me. Let me know if you have any feedback. Thanks!

My wife is primarily a “basher” too, but POTC has gotten her interested enough to start developing technique, trying for specific goals, and learning the rules.

There are so many goals in the game and some are easy while others are very difficult. This gives novice players a nice way to ease into the ruleset.
For example, she started off just wanting to do the Maelstrom multiball. Then she decided to she wanted to get loop champ. Then it was the other multiballs. Etc.

#3146 5 months ago

Is anyone having issues with tilt?

I have my bob set pretty permissively, and it feels about right for the level of effort vs tilt, but I find that hitting it once will often register 2-3 times in a row...and continue on into the next ball also.

Anyone else?

CD281D3C-A885-4264-A14C-DA5536426F20 (resized).jpeg
#3148 5 months ago
Quoted from Yelobird:

You just have to lower it just a bit more. Most every pinball machine will keep it swaying. Much more if your game is sitting on carpet. Looks like you have correctly bent the brass ring to center the weight so don't rock the boat!! lol

Believe it or not, it was much more active when I had it lower than it is now! It’s like concentrating the weight so far down increased the pendulum action.

I was thinking of trying it inverted.

#3152 5 months ago
Quoted from FlippinJB:

Could you try widening the brass ring carefully? (*Snap!*)

Nah. It really feels like the effort to trigger is about right. The problem is that it frequently multi triggers. Warning, warning, tilt all at once.

Perhaps yelobird is right and I just need to reign it in a bit. Those saveable drains really make me want to try!

#3161 5 months ago
Quoted from steigerpijp:

my inlane one way gate has a tendency to sometimes close two ways.. not amusing but on the tweak list.
Other than that, superb, what a game. JJP and crew can be proud .

One time my ball jumped through the “hoop” of the one way inlane gate. I was impressed!

This game is spectacular I agree. Could not be happier with it.

My friend who has been coming over to play with me bought himself a CE so I’ll be helping set up a third machine soon.

JJP knocked this game out of the park.

#3192 5 months ago

Gameplay questions!

1. What does “spot gold” on the Pearl do, exactly?

2. What do the MAP targets do in relation to the spinner and activating the map hole award? I haven’t figured this out.

3. Is there benefit/effect from hitting all 4 GOLD targets?

#3201 5 months ago
Quoted from steigerpijp:

Lets see here.. [quoted image]

Oops. RTFM’d!

I should have guessed it was in there. The manual is quite good.

#3252 5 months ago

I’m back in Texas working on PIN number one - the shooter rod contacts the auto plunger robbing power which the CA pin doesn’t do.

Does this look normal? Trying to determine if the auto plunge needs adjustment or the rod assembly itself.

57F274DB-99A9-4E5E-BEDC-558B63D6D913 (resized).jpeg
#3255 5 months ago
Quoted from wheels:

Hard to see if anything on the auto plunger is off. My shooter rod was also hitting the auto plunger. I adjusted the manual plunger by moving its housing around. Took 3 or 4 attempts to perfectly center it, but now works great. I'd start with the manual plunger housing so that rod is perfectly centered in relation to the auto plunger. If that doesn't fix it, then you have an issue with the auto plunger.

Thanks! I did the same. It did take some finagling but now it’s great. I do need to add a washer to the auto plunger to reduce its side/side motion as it still occasionally contacts the plunger lightly if it’s slid over too far. Easy peasy.

#3257 5 months ago
Quoted from Squizz:

ok, i haven't been following the disc thing, so 3 was dropped to a single?
good or bad?

It was controversial when it happened, and many people pulled their preorders (myself included.)
But what we didn’t realize was just how strong all the REST of the game still is, and that it totally stands alone as a top 10 pin without it.

#3274 5 months ago