(Topic ID: 200141)

JJP Pirates of the Caribbean Official Owners and Fan Club!


By goren1818

2 years ago



Topic Stats

  • 13,155 posts
  • 479 Pinsiders participating
  • Latest reply 1 hour ago by luckymoey
  • Topic is favorited by 221 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,302 images uploaded to this topic. (View topic image gallery).

shipbottle (resized).JPG
0F14393B-75AA-4034-96D9-EEF6D7154881 (resized).jpeg
6F2AA754-3952-4687-8141-733553E9D502 (resized).jpeg
D162E8A3-BB9C-4B0D-B02E-8FCC98BC9ED1 (resized).jpeg
2E77DEEB-B62E-4630-9C45-8A629A1884D6 (resized).jpeg
afmr10 (resized).jpg
D18D88D1-E5BA-4EC3-9B37-D018C11651C5 (resized).jpeg
D7FB3373-16ED-4F63-80F6-D67037B0A8BD (resized).jpeg
DB16933A-A530-4814-8A13-2C4D5482A968 (resized).jpeg
CF646859-E929-4F8D-AD3A-B265F64372FB (resized).jpeg
74593A2E-1DA7-4EDF-A6B2-37E2269F403D (resized).jpeg
B3EC1B63-94A1-4DF9-B51D-8AE1F11DB097 (resized).jpeg
272A263A-6416-430D-97A5-C17D831E0F02 (resized).jpeg
DFAD19C5-EA71-4744-97EC-CBCDCD4175CD (resized).jpeg
DSC00679 (resized).JPG
DSC00142 (resized).JPG

Topic index (key posts)

20 key posts have been marked in this topic

Post #222 Liar's Dice rules explained! Posted by goren1818 (1 year ago)

Post #644 Rules flow chart Posted by Rbviessman (1 year ago)

Post #1021 How to fix black pearl lamps Posted by Yelobird (1 year ago)

Post #1360 Black Pearl flippers are uneven when in upper position - Fix Posted by evh347 (1 year ago)

Post #2468 Hardware fix for balls getting hung up during multiball. Posted by Pinballpal (11 months ago)

Post #2892 Adjustment for auto plunger not hitting balls cleanly or correctly Posted by Pinballpal (10 months ago)

Post #3974 Deadflip stream from Valentine’s Day 2019. Posted by Tuna_Delight (9 months ago)

Post #4014 POTC trouble shooting guide Posted by zaphX (9 months ago)

Post #4856 Possibly let distributor go through machine and get it tuned in. Posted by dgposter (9 months ago)

Post #6315 Fix for dauntless positioning, canon shots not landing Posted by Yelobird (8 months ago)

Post #6631 Twitch Video - How to Remove and Reinstall Black Pearl Upper Playfield Posted by KevInBuffalo (8 months ago)

Post #6655 Mylar bubble at jjPotC Map hole. Posted by thc666 (8 months ago)

Post #6834 Titan ring sizes Posted by AUKraut (8 months ago)

Post #8145 Positives and Negatives for each character Posted by EaglePin (7 months ago)

Post #8288 Rubber Sizing and Location on Playfield Posted by f3honda4me (7 months ago)

Post #8602 How to see pictures the game has taken Posted by f3honda4me (7 months ago)

Post #8625 Version .99 release notes as of 5/6/2019 Posted by pinball_keefer (7 months ago)

Post #8709 How to backup settings before installing an update Posted by LTG (7 months ago)

Post #9273 Version .99 Character Plus and Minus Benefits Posted by pinball_keefer (6 months ago)

Post #11892 Clear concise video on removing the black pearl Posted by rlslick (3 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider sheriffbarclay.
Click here to go back to viewing the entire thread.

#1694 11 months ago

Any distros have any LEs ready to ship now? I want one...

10
#1749 11 months ago

Well, temporary insanity must have hit, because I've now got an LE on order and paid for.

1 week later
#2089 11 months ago

My LE found its way home today. Getting everything dialed in, everything seems to be working OK out of the box, had to bend one GOLD switch that was stuck.

I have a tilt bob, but it didn't come with a wing nut to attach it.

#2126 11 months ago

My spinning disc sounds like a binding sawblade. Short of ordering a third party plastic disc, what are the fixes?

#2307 11 months ago

First pinball machine and I love it, but intimidated trying to fix all the things that are popping up.

The ship isn't moving anymore during the game or when I try to run the ship test, however, when I start to pull the playfield out of the cabinet and onto the rails, the ship starts rocking back and forth, and then slows down, and slows further..and further..and further until it stops, almost like it's running out of batteries (I know that's not what's happening, just giving a visual).

Any ideas? Is this under the playfield? Is it on the playfield, under the ship?

#2308 11 months ago
Quoted from SheriffBarclay:

First pinball machine and I love it, but intimidated trying to fix all the things that are popping up.
The ship isn't moving anymore during the game or when I try to run the ship test, however, when I start to pull the playfield out of the cabinet and onto the rails, the ship starts rocking back and forth, and then slows down, and slows further..and further..and further until it stops, almost like it's running out of batteries (I know that's not what's happening, just giving a visual).
Any ideas? Is this under the playfield? Is it on the playfield, under the ship?

Follow up, now the ship is constantly moving left to right, little tight rocking motions, and it won't stop lol.

#2334 11 months ago
Quoted from Hogbog:

Sounds like it is binding on the playfield main harness. Make sure the main harness is off to the right when putting the playfield back in. I've seen the harness bind that motor linkage when it had a weird kink in it.

This worked.. Thanks!

#2369 11 months ago

Did y'all adjust any difficulty settings in menus? Ball save timer, etc?

1 week later
#2635 11 months ago

When y'all turn your machine on, while booting up, do any of y'all hear a really loud feedback click or two ff the speakers?

#2675 11 months ago

Love this game but another fun issue.

The black pearl magnet/catch is happening far too often - almost every time I get there, whether it's through pop bumpers, left orbit, etc.

#2822 10 months ago

A couple more items, curious to hear the owners' feedback:

1) Often times when shooting the inner loop, the ball will drop into the pearl ship area and go up on the ship. Doesn't seem like it should be happening.

2) Auto-plunge is all sorts of jacked up..not sure if it's wireform or what.

#2919 10 months ago

And now my pearl has stopped all motion.

Freaking love this game but I'm not the only one that's had a host of issues, I disagree with the posters that keep saying majority of buyers have had zero issues.

They really rushed my LE out. For my first pin purchase (and 10k to boot), having so many game breaking issues on a NIB HUO is disappointing.

4 weeks later
#3797 9 months ago

Ship still won't move at all. I removed the ship and set it on its side, couldn't find any broken wires.

I checked the metal arm in the back and loosened the two screws. By pulling on the little bar that connects the ship, I can make the ship move back and forth, but it will not move on its own. Motor doesn't seem to move at all.

Really frustrating.

#3799 9 months ago
Quoted from LTG:

Start there. Please check wiring from motor to the I/O board in the head. Something came loose or unplugged along the way.
LTG : )

Thanks Lloyd! First pin so I'm a newbie. Is this easy to follow? So many wires. Do I just start from the motor under the playfield? Which wires do I trace?

#3870 9 months ago

Thanks for your help Lloyd - still tearing my hair out on this ship not moving. I guess I need to figure out how to test the motor/board. I tried following the wires all the way up to the head unit, don't see anything loose, but there's a lot of cable covered up by the black conduit with sections along the way; I peeked in where it was possible.

I've emailed support as well. Will let everyone know if I come up with a solution.

Edit: It is an amazing pin, but an extremely frustrating experience to have my first NIB have so many issues with <150 plays on it.

#3915 9 months ago

Thanks to LTG, Kingpin, zaphx, and the others that posted here on the ship issue. I've almost got it working.

Now the ship will fully move during the ship test, but still barely moves/stops moving during the game. I'm thinking it's still a loose wire somewhere, but will keep playing and see how it does.

#3918 9 months ago
Quoted from zaphX:

What is the lowest speed achieved during the ship test? Are you certain the motor is running smoothly without bending the mount during any point?

Yes it goes all the way down to 5 during the ship test.

#3919 9 months ago

drfright, those mods look great!! Are they all modcouple? Does your Jack the Monkey have a pinball in his hand?

#3977 9 months ago

Can, someone post a pic of their "spot character" target on the middle left Outlane?

That lane drains 95% of the time, can almost never nudge it over. My spot character target is bent pretty far out and I'm wondering if that's the cause.

1 week later
#4864 9 months ago

Are there any rulesheets/rule cards, or is it just pricing cards?

#4897 9 months ago

Turned on the ol' NIB LE today and Switches 9,10, and 12 are stuck open and don't respond/activate when you press the targets manually. These are the BONUS, X, and LOAD targets on the Pearl.

Also, there is no foam behind the BONUS and X targets on the Pearl.

Any ideas?

20190302_130222 (resized).jpg
#4899 9 months ago
Quoted from zaphX:

Sorry to say I know exactly what that is.
You have a broken wire under the Pearl, likely the green/brown one. You’ll have to pull the Pearl, find it and resolder it. Did this to a NIB CE for a friend.

Thanks zaph, found the broken wire, can't quite tell where to solder it back on. Did you remove the ship completely from the playfield, or just lean it on its side?

I find it doesn't lean very well on its right side/there's not enough room. The broken wire is on the left side.

#4905 9 months ago
Quoted from tonycip:

Man I would have thought they had a handle on that broken wire by now!

Seriously. Thanks zaph by the way..the solder worked!

On a side note, we've had a few posts of "No QC issues at all, vast majority of POTCs have had zero issues, the people posting are just a very small minority". Those posts really irritate me.

Back to silver ball!

#4981 9 months ago
Quoted from AUKraut:

LE #78 (Build date 2/4/19) is now setup in my house, picked it up yesterday from zmeny from Flip N Out Pinball, even got hollywoodbone to help us load it:
[quoted image]
[quoted image]
Went thru everything with a fine tooth comb, some fixes were already installed from the factory, which shows they do listen to Pinside:
[quoted image]
Also added Titan Silicone rings on the Black Pearl and Flippers, tonycip's Medallion Shooter, as well as MezelMods clear plastic protectors. Hopefully the ordered Cliffys will come in sometime soon.....
I've only problems with two issues, one is the Black Pearl wasn't quite centered in its rocking action, which was easily addressed adjusting the screws on back.
The other issue is a PITA that I've yet to been able to fix: Upon setting up the pin I discovered that the display itself not latched in place correctly during shipping on the right side. Luckily it did not damage the backglass. Once I moved the wooden shipping blocks and latched the display into place the right is sagging almost 3/8-1/2" too low. I tried everyday possible to adjustment to the display and mounting arm possible short of total disassembly of the mount with no improvement, the silver frame of the display is still visible and showing on the left. My temporary solution for now is inserting a wooden block as wedge to push up the right side, it's not visible while the backglass is on but its not right. I'm contacting Zach &amp; JJP tomorrow to see if they have any suggestions. I tried most tricks in this thread with no avail.
Besides that she is a best to play. Be looking for an order in the next couple of days yelobird ! Hoping to keep her in the lineup for a long time:
[quoted image]

I had this happen with my screen too. Here's how I fixed it: loosen the screw on the wooden block on right side above the tab and slide wooden block up. Raise the tab, push the right side of monitor in towards the center and up simultaneously. It should catch the latch and hold better.

2 weeks later
#6002 8 months ago

At the JJP seminar at TPF. They just announced they have the Pirates license for 3 more years. Can we call out and hold those to account those posters that keep saying the license is done?

Promoted items from the Pinside Marketplace
$ 239.99
Cabinet - Toppers
Tilttopper
$ 65.00
Playfield - Toys/Add-ons
Pinball Mod Co.
Wanted
Machine - Wanted
Flagstaff, AZ
From: $ 6.00
Playfield - Protection
Pin Monk
Wanted
Machine - Wanted
Flagstaff, AZ
From: $ 175.00
Gameroom - Decorations
Pinball Photos
$ 18.25
Playfield - Toys/Add-ons
The MOD Couple
$ 38.75
Playfield - Toys/Add-ons
The MOD Couple

You're currently viewing posts by Pinsider sheriffbarclay.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside