(Topic ID: 200141)

JJP Pirates of the Caribbean Official Owners and Fan Club!


By goren1818

2 years ago



Topic Stats

  • 13,024 posts
  • 476 Pinsiders participating
  • Latest reply 19 hours ago by MurphyPeoples
  • Topic is favorited by 222 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,278 images uploaded to this topic. (View topic image gallery).

20191117_230337 (resized).jpg
20191116_140814 (resized).jpg
20191115_190558 (resized).jpg
GIF-191114_223447 (resized).png
IMG_0086 (resized).jpg
1 (resized).jpg
2 (resized).jpg
IMG_0077 (002) (resized).jpg
678A8AC9-EEFD-414A-8CF4-2A19FF9FB727 (resized).jpeg
127996A1-64F7-4385-BDA3-AC6B165DBA5F (resized).jpeg
42E58E05-D832-427D-9962-7BA05CDAAAA7 (resized).jpeg
229BD32B-9F41-4BE1-BFC5-CD723A59520C (resized).jpeg
98407DFF-5970-457D-8285-8D2EE942AD28 (resized).jpeg
3972995E-AE77-4A6F-BB41-463E01C2DC29 (resized).jpeg
469B3A96-B426-4162-BA85-78056D5D8A28 (resized).jpeg
1FD43333-D654-432F-AD2A-1784E352FE3B (resized).jpeg

Topic index (key posts)

20 key posts have been marked in this topic (Show topic index)

There are 13024 posts in this topic. You are on page 54 of 261.
#2651 10 months ago

I have attract mode off and free play. It cycles through all the cool stuff on lcd but no noise. Not sure if that helps.

#2652 10 months ago

Totally off track , but can anyone tell me what the middle symbol does it looks like a link if so how do you use it ?

IMG_20190106_033406 (resized).jpg
#2653 10 months ago
Quoted from f3honda4me:

Where can I get Mylar for slingshot and lanes for this pin? I have some chipping already so I’d like to protect that area.

Can you share some photos of the problem areas? Thank you.

#2654 10 months ago
Quoted from screaminr:

Must be a jjp thing my Hobbit does it as well .

Agreed - DI does it as well. I have DI next to POTC, and when switching them both on together at the power outlet, it sounds like a comedy rimshot (badum-tssh!)

I quite like it

#2655 10 months ago
Quoted from wheels:

Can you share some photos of the problem areas? Thank you.

I can't speak for the post you're referring to but here are some pictures of some chipping

Quoted from FlippinJB:

I quite like it

For some weird reason I don't mind it either it tells me the pin is " alive "

IMG_20190106_041801 (resized).jpgIMG_20190106_041844 (resized).jpg
#2656 10 months ago

I can't speak for the post you're referring to but here are some pictures of some chipping

Wow. I'm sorry to see that. Are the posts on the playfield too tight or is the ball actually able to reach those areas?

#2657 10 months ago
Quoted from screaminr:

I can't speak for the post you're referring to but here are some pictures of some chipping

For some weird reason I don't mind it either it tells me the pin is " alive "
[quoted image][quoted image]

See, with the tortuga hole and mylar, it is chipping where the mylar has left an uncovered edge. I refer to this in one of my previous posts about what to look for across the PF. Some factory mylar may be skewed or not up to the edge where necessary.

In this instance we could use a carbon fiber Cliffy like on WOZ!

#2658 10 months ago
Quoted from Psw757:

No and I really would like them to add something besides the JJP logo music. I’d ideally like yo ho yo ho a Pirates life for me but if they can’t, a custom Pirate track from David Thiel would fit the bill as well. Something to lure people in!

I think that we've bounced around the idea but if they would just allow an MP3 or sound file option in attract mode then we could choose our own music/audio.

Simple add-on and they could even restrict it to free play only. This way we can add what we want for our home arcade and they don't really have to worry about operators adding something that they shouldn't (if that matters). Who is interested in this?

#2659 10 months ago

Apparently some posts had sharp bottom edges.

IMG_20190106_050819 (resized).jpg
#2660 10 months ago
Quoted from wheels:

Can you share some photos of the problem areas? Thank you.

1471B95A-0CDF-49E7-8A3A-DAACE8B0615A (resized).jpeg
#2661 10 months ago

Ok for clarity so this doesn't become a viral concern is this the same one persons playfield chip or your actual game? Not defending just hate to see panic on a one off issue due to an over/under tightened or sharp edge post.

#2662 10 months ago
Quoted from dnaman:

I think that we've bounced around the idea but if they would just allow an MP3 or sound file option in attract mode then we could choose our own music/audio.
Simple add-on and they could even restrict it to free play only. This way we can add what we want for our home arcade and they don't really have to worry about operators adding something that they shouldn't (if that matters). Who is interested in this?

I’d certainly be down with this. Makes sense to have this option.

#2663 10 months ago

Here’s mine that I posted previously. Still nothing from JJP on this which drives me crazy. In mid-Dec Jack said he was going to talk to his production guys on the post. So hopefully for the new guys this is fixed.

Calling again on Monday. You can see on the one, the post cut a perfect circle into the playfield with the black ring all the way around but a chip after that. You can see the posts have mushroomed. I changed out to a star post for now to stop the effects.

0DC2A81C-9685-42A0-A4AA-4594FA1A0247 (resized).jpeg8D3BEFDA-7C61-4862-AA35-0395439985B7 (resized).jpegC6551AC8-F115-421A-84CD-50A6BCEE0B54 (resized).jpegC9C89E78-A81A-4B3E-B789-9E902E5E8FE9 (resized).jpeg
#2664 10 months ago
Quoted from Yelobird:

Ok for clarity so this doesn't become a viral concern is this the same one persons playfield chip or your actual game? Not defending just hate to see panic on a one off issue due to an over/under tightened or sharp edge post.

My actual game.

#2665 10 months ago

An early post of mine detailed (with pics) a few concerns. One was the fork for the chest as it was rubbing on one side of the PF but didn't seem to be restricted so I left it.

With the recent talk about the fork being loose, I opened mine and although the two screws were tight, the fork was skewed. Loosened the screws and straightened the fork, all is good. It does seem that I am landing a few more balls into the chest but too early to tell.

IMG_20181124_1104273 (resized).jpgIMG_20190105_1255045 (resized).jpgIMG_20190105_1256208 (resized).jpg
#2666 10 months ago

Put mirrors in...boy they are a tight fit!

15467160376894270401351539681708 (resized).jpg
#2667 10 months ago
Quoted from f3honda4me:

Where can I get Mylar for slingshot and lanes for this pin? I have some chipping already so I’d like to protect that area.

Your goodie bag in the coin box should have mylar for the two sling shot areas as well as at least two squares. I used the two squares for the ball drop areas on the in-lanes and now have just added 2 Cliffy slot protectors.

There is also a mylar for the black pearl in there. Look at a few of my old posts for images.

#2668 10 months ago
Quoted from Crile1:

Put mirrors in...boy they are a tight fit!
[quoted image]

I've always worried about that, scratches suck!

I have thought that it would be cool if there was a 1/8" recessed/routed space for the mirror blades. This would be extra time and money but it would be cool.

#2669 10 months ago

Seems like a lot of issues for this game.

#2670 10 months ago
Quoted from Halfwasted:

Seems like a lot of issues for this game.

I don’t think so at all. Minor stuff that takes a few minutes to fix in most cases.

#2671 10 months ago

For me was mostly adjusting switches. A LOT of switches on this game because a lot of toys.

I still can't figure out when it takes the picture at the end. I guess it depends on lighting. If room is dark, then usually when hit END...but if well lit seems like when I am entering my letters.

#2672 10 months ago

Warning when adjusting your Black Pearl ramp crush washer!

I set up a second machine last night. It had far fewer issues and was almost perfect, save for the Pearl ramp catching the ball.

Knowing how to fix that, I started to crank down the crush washer...and cranked, and cranked. And the screw snapped, leaving the shaft inside the post.
I am now a sad pirate with a completely unplayable machine.

Upon further examination, I see the problem - I could have cranked forever or even removed the crush washer entirely and the ramp still wouldn’t have the proper right tilt. There needs to be something under the bottom left of the pearl ramp to give the left side a little bit of lift. I am planning to use one of those clear plastic “cabinet bumps” for this purpose.

But my roadblock now is that the post has a broken screw shaft in it, and I don’t know how to remove the post. I tried to unscrew it and it just spins in place.

I also tried a broken screw extractor, it did not work. I will need to replace the post.

LTG any suggestions on how to remove the post safely, and maybe where to find one so I don’t have to wait on parts?

DA9D3E01-6AA2-4DF8-9382-2A92EC663201 (resized).jpeg
#2673 10 months ago
Quoted from zaphX:

Warning when adjusting your Black Pearl ramp crush washer!
I set up a second machine last night. It had far fewer issues and was almost perfect, save for the Pearl ramp catching the ball.
Knowing how to fix that, I started to crank down the crush washer...and cranked, and cranked. And the screw snapped, leaving the shaft inside the post.
I am now a sad pirate with a completely unplayable machine.
Upon further examination, I see the problem - I could have cranked forever or even removed the crush washer entirely and the ramp still wouldn’t have the proper right tilt. There needs to be something under the bottom left of the pearl ramp to give the left side a little bit of lift. I am planning to use one of those clear plastic “cabinet bumps” for this purpose.
But my roadblock now is that the post has a broken screw shaft in it, and I don’t know how to remove the post. I tried to unscrew it and it just spins in place.
I also tried a broken screw extractor, it did not work. I will need to replace the post.
LTG any suggestions on how to remove the post safely, and maybe where to find one so I don’t have to wait on parts?
[quoted image]

That sucks! Can you drill it out?

#2674 10 months ago
Quoted from wheels:

That sucks! Can you drill it out?

I tried drilling it out with a broken screw extraction tool and was unsuccessful.

#2675 10 months ago

Love this game but another fun issue.

The black pearl magnet/catch is happening far too often - almost every time I get there, whether it's through pop bumpers, left orbit, etc.

#2676 10 months ago
Quoted from SheriffBarclay:

Love this game but another fun issue.
The black pearl magnet/catch is happening far too often - almost every time I get there, whether it's through pop bumpers, left orbit, etc.

There is a setting you can adjust it.

#2677 10 months ago
Quoted from zaphX:

I tried drilling it out with a broken screw extraction tool and was unsuccessful.

Is there a screw on the underside of the playfield on which the post attaches that was stripped? May have to start with removing that?

#2678 10 months ago

I’m having an issue with the chest not releasing all 3 balls during multiball. It will release 1, but not the other 2. The release gate will twitch and try to let them out, but doesn’t open far enough for them to come out. It will not release the balls after the game is over either. I have to take the glass off. Zaphx, I can’t believe you haven’t seen this yet. LOL

#2679 10 months ago
Quoted from KirboTurbo:

I’m having an issue with the chest not releasing all 3 balls during multiball. It will release 1, but not the other 2. The release gate will twitch and try to let them out, but doesn’t open far enough for them to come out. It will not release the balls after the game is over either. I have to take the glass off. Zaphx, I can’t believe you haven’t seen this yet. LOL

Adjust the timing in settings. Go from 3 to 4 to see if that helps.

#2680 10 months ago
Quoted from f3honda4me:

Adjust the timing in settings. Go from 3 to 4 to see if that helps.

Thank you. I will try that.

#2681 10 months ago
Quoted from wheels:

Is there a screw on the underside of the playfield on which the post attaches that was stripped? May have to start with removing that?

Hopefully there is a nut and you just need to hold either the post or nut while turning the other to loosen it. Unfortunately I am not at the pin to check it out for you. Good luck!

#2682 10 months ago
Quoted from f3honda4me:

Almost everything the mod couple sells.

This. I think I have every mod they make for mine.

#2683 10 months ago

Is anybody else having an issue with the VUK up to the black pearl? I will hear the callout “Welcome aboard” and hear the VUK engage but then the ball rolls out from under the black pearl into the pops. Happens about half the time.

#2684 10 months ago
Quoted from Mindcrime:

Is anybody else having an issue with the VUK up to the black pearl? I will hear the callout “Welcome aboard” and hear the VUK engage but then the ball rolls out from under the black pearl into the pops. Happens about half the time.

Nope, that is a new one for me.

#2685 10 months ago
Quoted from KirboTurbo:

I’m having an issue with the chest not releasing all 3 balls during multiball. It will release 1, but not the other 2. The release gate will twitch and try to let them out, but doesn’t open far enough for them to come out. It will not release the balls after the game is over either. I have to take the glass off. Zaphx, I can’t believe you haven’t seen this yet. LOL

I have this EXACT same issue, it’s frustrating when it happens deep into a good game. Please post if you find a solution

#2686 10 months ago
Quoted from darkryder:

I have this EXACT same issue, it’s frustrating when it happens deep into a good game. Please post if you find a solution

Adjust the chest release setting in menu as I mentioned before.

#2687 10 months ago
Quoted from Mindcrime:

Is anybody else having an issue with the VUK up to the black pearl? I will hear the callout “Welcome aboard” and hear the VUK engage but then the ball rolls out from under the black pearl into the pops. Happens about half the time.

I have this problem often.

#2688 10 months ago
Quoted from Genjuro:

I have this problem often.

Thats an Odd issue?? Basically the ball gets stopped by the magnet, lets it roll down into the hole, drop into the trough and then it rolls to the VUK. Once its in the VUK it can only go up with the design configuration. The only thing I can think of is that you didn't use the factory balls and they are magnetized. Therefore stuck on the magnet and when it finally releases continues toward the pops? The Only ship VUK issue I have seen and repaired (not my game) is the game was set to 8.3 degrees and the ball would not roll down the trough to the VUK. turns out the clear flap on the subway plastic was slightly bent up. Put some heat to it and lowered it further so it would roll to the VUK correctly.

#2689 10 months ago

Good news, I was able to craft a workaround to make my new machine playable!

MacGyver would be proud, I crafted a reasonable facsimile of a hex post using a threaded rod, nuts, and nylon spacers from the hardware store. This will keep me playing until I get the proper part from JJP. For those who were curious, the two screws that flank the post release a bracket making the nut holding the post easy to access. (I did not reinstall the plastic as I will be dismantling all this a second time later.)

This machine was 100% OOTB except for the Pearl ramp adjustment. Well, and the off-centered topper which, LOL, what the hell? Anyone know how it is attached so we can fix it? Anyway, to revise the Pearl ramp troubleshooter...

PROBLEM: Ball sticks at the top of the Black Pearl ramp.
SOLUTION: First, attempt to crank down the screw to the right of the Pearl spotlight. If you can get it such that setting a ball at the top of the Pearl ramp -always- rolls away, you’re golden! However do NOT overdo it if it’s not happening. If you still can’t get the desired rightward (starboard?) tilt on the ramp, read on...

Experiment a little bit by pressing up on the underside of the ramp. I found that if I applied a small amount of vertical lift near the bottom where it (almost) contacts the screw, I could get the desired lift. I got some clear plastic cabinet bumpers and wedged one in there which is working perfectly...zero stuck balls.

Not sure why my other machine didn’t need this fix - maybe there is a factory bumper/lift of some sort that this machine didn’t get? ¯\_(ツ)_/¯

Hope this helps others. No stuck balls!

36EBA653-2A4D-4F5A-817E-F16D3945B1DE (resized).jpegE3DA2CCB-2EF1-4EF0-A505-C5CFEB80F3AF (resized).jpegFC007331-F907-4CC7-B0FF-ADC44C20EDE1 (resized).jpeg
#2690 10 months ago
Quoted from Yelobird:

Thats an Odd issue?? Basically the ball gets stopped by the magnet, lets it roll down into the hole, drop into the trough and then it rolls to the VUK. Once its in the VUK it can only go up with the design configuration. The only thing I can think of is that you didn't use the factory balls and they are magnetized. Therefore stuck on the magnet and when it finally releases continues toward the pops? The Only ship VUK issue I have seen and repaired (not my game) is the game was set to 8.3 degrees and the ball would not roll down the trough to the VUK. turns out the clear flap on the subway plastic was slightly bent up. Put some heat to it and lowered it further so it would roll to the VUK correctly.

Factory balls, 6.5 degree setup...balls kicks up, but then rolls out from the ship. Haven't really investigated yet, but it happens.

#2691 10 months ago
Quoted from KirboTurbo:

I’m having an issue with the chest not releasing all 3 balls during multiball. It will release 1, but not the other 2. The release gate will twitch and try to let them out, but doesn’t open far enough for them to come out. It will not release the balls after the game is over either. I have to take the glass off. Zaphx, I can’t believe you haven’t seen this yet. LOL

That is a problem I haven’t had. I do have one machine that lets out too many balls at once when it intends to release one - I need to investigate the chest timing to fix.

#2692 10 months ago
Quoted from Genjuro:

Factory balls, 6.5 degree setup...balls kicks up, but then rolls out from the ship. Haven't really investigated yet, but it happens.

Same, factory balls and 6.5 pitch. Hard to see what is going on back there. Going to do some testing this week.

#2693 10 months ago

Anyone else having the chipping from the posts ? Haven’t seen my chip but wondering if we should loosen them as a precaution.

#2694 10 months ago

Had a small issue that started last night, and a quick 5 minute fix. Manual plunger shots were becoming erratic, and discovered it was because the manual plunger was hitting the top of the auto plunger. The quickest fix I could find was removing the auto plunger, putting into a vice, and using a dremel 952 bit to grind down the area that was rubbing. Plunger is butter smooth again.

First pic you can see a bit of wear on the underside of the top of the auto plunger. You can see the wear even more once it’s removed. The last pic is post dremel grinding.

185658E2-0218-4DEE-9ECB-3CCCDEEFCE35 (resized).jpegAF1DE06D-8CC6-459F-8CD4-333E8B22B995 (resized).jpeg8D60BBBB-520D-4705-985B-9980D7996B8F (resized).jpegE667B181-705D-4836-A2D1-BD8C53BD37EB (resized).jpeg
#2695 10 months ago

I have a problem with my right Flipper finger from the black pearl. Sometimes it didn’t react and sometimes it only comes up half way. I was thinking of a broken cable. I dismount the black pearl playfield to check it, but everything looks ok.
I also check the flipperbutton switch’s but they are working also nice.

Any idea or do I have a bad coil ?
1F8371FA-11E9-4FE9-97AD-99E53F5EF08D (resized).jpegC7913C73-0436-4C36-B280-3D79C361B2B1 (resized).jpeg

#2696 10 months ago
Quoted from sirlonzelot:

I have a problem with my right Flipper finger from the black pearl. Sometimes it didn’t react and sometimes it only comes up half way. I was thinking of a broken cable. I dismount the black pearl playfield to check it, but everything looks ok.
I also check the flipperbutton switch’s but they are working also nice.
Any idea or do I have a bad coil ?
[quoted image][quoted image]

Hard to tell from the photo but is it possible as the plastic ship is a molded part that the right spring mount clip is dragging along the plastic when flipped? You could rotate the flipper by hand to see if its close. Also, check that the flipper shaft has a correct up/down clearance in the flipper guide.

POTChelp (resized).jpg
#2697 10 months ago
Quoted from Hogbog:

Post some pics of your Pearl as well, or pm them to me. Something seems off.

Hogbog, were you able to see anything in my pictures?

#2698 10 months ago
Quoted from f3honda4me:

Adjust the timing in settings. Go from 3 to 4 to see if that helps.

This did solve my problem with the balls not releasing out of the chest during multiball. I adjusted the “chest release fire time” setting to 5. 4 didn’t seem to do it. Thx again.

#2699 10 months ago
Quoted from Yelobird:

Hard to tell from the photo but is it possible as the plastic ship is a molded part that the right spring mount clip is dragging along the plastic when flipped? You could rotate the flipper by hand to see if its close. Also, check that the flipper shaft has a correct up/down clearance in the flipper guide.
[quoted image]

I checked it and that’s all fine.

I try to resolder the coil.

#2700 10 months ago

Another DIYarrrrrr segment for those of us with older eyes or needing to see the flippers just a little bit better. This Very simple to install and low cost LED strip really adds just the right amount of light to both the flippers as well as the lower playfield area without any obtrusive lighting fixtures. With the small LCD encloser its like they designed this upgrade from the start. I used a simple ($2) LED strip (must be 12v!!) from CometPinball. They have it in several colors though I prefer the simply clear white for my view. Remove adhesive strip, center and it is completely hidden from the players view. Route the wire through the trough and connect to several 12v options below including the LCD itself which has a 12v power connector. Note in the CometPinball (Secret Stash) shelf on their website they offer a Longer 12v LED strip (as I used here) which can be cut to the correct length to add even more light though that costs ($5). Happy Pirating!

IMG_1836 (resized).jpgIMG_1837 (resized).jpgIMG_1838 (resized).jpgIMG_1839 (resized).jpg
Promoted items from the Pinside Marketplace
$ 74.00
Cabinet - Armor And Blades
Id Rather Play Pinball
8,500 (Firm)
Machine - For Sale
Santa Clarita, CA
$ 39.00
Playfield - Toys/Add-ons
The MOD Couple
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 41.25
Playfield - Toys/Add-ons
The MOD Couple
Wanted
Machine - Wanted
Baltimore, MD
Wanted
Machine - Wanted
Redmond, WA
There are 13024 posts in this topic. You are on page 54 of 261.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside