(Topic ID: 200141)

JJP Pirates of the Caribbean Official Owners and Fan Club!


By goren1818

2 years ago



Topic Stats

  • 12,985 posts
  • 476 Pinsiders participating
  • Latest reply 10 minutes ago by GamerRick
  • Topic is favorited by 222 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,275 images uploaded to this topic. (View topic image gallery).

GIF-191114_223447 (resized).png
IMG_0086 (resized).jpg
1 (resized).jpg
2 (resized).jpg
IMG_0077 (002) (resized).jpg
678A8AC9-EEFD-414A-8CF4-2A19FF9FB727 (resized).jpeg
127996A1-64F7-4385-BDA3-AC6B165DBA5F (resized).jpeg
42E58E05-D832-427D-9962-7BA05CDAAAA7 (resized).jpeg
229BD32B-9F41-4BE1-BFC5-CD723A59520C (resized).jpeg
98407DFF-5970-457D-8285-8D2EE942AD28 (resized).jpeg
3972995E-AE77-4A6F-BB41-463E01C2DC29 (resized).jpeg
469B3A96-B426-4162-BA85-78056D5D8A28 (resized).jpeg
1FD43333-D654-432F-AD2A-1784E352FE3B (resized).jpeg
034B0BD6-4A3B-40B8-8A68-6D475A859FD1 (resized).jpeg
20191015_163622 (resized).jpg
20191015_163716 (resized).jpg

Topic index (key posts)

20 key posts have been marked in this topic (Show topic index)

There are 12985 posts in this topic. You are on page 27 of 260.
#1301 11 months ago

POTC LE #484 joined the herd yesterday, what an amazing game by JJP. Next to Hobbit, this is definitely the most immersive pin ever, wow. I played two games and managed 850M on the second game. Started every wizard mode except for Dead Men Tell No Tales, what a rush!

My game had some issues out of the box, most likely due to vibration during transport cross country. The pirate on the pop bumper barrel figure was loose at the bottom of the playfield and scratched up with a broken hat. That loose part scratched the star/constellation plastic on the backboard. The compass spinner decal has some big air bubbles I couldn’t rub out. The metal weldment under the chest is cracked from vibration and the British ship at the upper left was loose and flopping around as its shaft had slipped out of the bushing (clip was at the bottom of the backbox). I slid the shaft back into the bushing and pressed the clip back in. Now the ship is where it should be, but it still feels pretty loose and the tip of the ship seems to touch the ramp in front of it as well as the side of the cabinet. I’m not sure how that ship is supposed to work if someone can explain. There were also a few loose screws at the bottom of the cabinet I couldn’t trace down. If anyone knows where they go, please let me know.

I called JJP support this morning and they’re going to send replacement parts at no charge. Love these guys, they’re absolutely killing it with each new title. The depth and complexity of the rules, incredible sound and innovative shots all over this game just blow me away.

Time to start modding this beauty! Wish they had POTC movie clips, callouts and music in the game, but I’m not complaining, it’s a masterpiece.

23CF89E5-C116-409C-8F5A-93DE9DD9F723 (resized).jpeg3C4FD647-034F-4D8F-8A65-CF6737BBAC83 (resized).jpeg5D72F428-A2AC-4E1C-90F3-2414C728F0E0 (resized).jpeg6C7DAFDA-4FF7-4DCC-A043-8AAD6516CE3D (resized).jpeg75FF0250-45F5-4CEE-813B-91AF60BD4DEF (resized).jpeg7BFEDBC0-FC26-4A97-942E-928AF2C6F933 (resized).jpeg9C5C93E2-961E-4B35-90E8-461C401A9549 (resized).jpegA1D8D5DD-0198-49BF-908F-80EE5128437C (resized).jpegBCF8584F-009D-42A8-8024-F2A9C5210C9F (resized).jpegD7DA02B1-D056-4E8F-BD6B-5425020475A0 (resized).jpegF6A18FAA-D224-4003-8D2C-7CE2C6643C96 (resized).jpeg
#1302 11 months ago

Anyone else getting that alert? I swear it's adjusted fine....

20181129_212622 (resized).jpg
#1303 11 months ago
Quoted from Gusphan:

Anyone else getting that alert? I swear it's adjusted fine....
[quoted image]

Haven’t seen that particular alert but the one I keep getting is the target ship switch stuck closed. Think it’s number 79 and it seems to work when I do hit it.

#1304 11 months ago
Quoted from Psw757:

target ship switch stuck

I get this one too, but I think I am not hitting it enough!

#1305 11 months ago
Quoted from Gusphan:

Can some kind soul make a video showing how to do this bend and where it's at?

You have to bend the arm in a manner that tightens up the spring tension on the flap/gate. If you zoom in close on the first pic you can see the markings from where I had my pliers. I believe I twisted my wrist to the left a little bending the arm down just slightly.

I apologize for the poor lighting.
20181130_121931 (resized).jpg20181130_122047 (resized).jpg

#1306 11 months ago

deleted as I didn't have to "go there"

#1307 11 months ago
Quoted from DerGoetz:

Wow...Quality Control is out of control at JJP it seems.
This reminds me of the Heighway days when it comes to amount of games shipped to problems reported ratio, and keep in mind that only a fraction of customers are here on Pinside which makes it only worse.

You might not want to visit the Iron Maiden issues thread then...

#1308 11 months ago

I picked up a LE, that was used at IAPPA, this week. Had to solder broken wires on one target and one EOS under the Black Pearl. Taking the Black Pearl out wasn't as difficult as I was expecting. A bit time consuming removing all the connectors and marking three of them to make sure they went back correctly. The hardest part was getting it back on the bushings.

I also had to move the shooter housing as it was hitting the autoplunger and would not launch a ball. Not sure how they even played it at IAPPA as it was unplayable when I got it.

After these couple of repairs I played my first game last night. Very pleased with the game and looking forward to many more games this weekend.

#1309 11 months ago
Quoted from Gusphan:

Anyone else getting that alert? I swear it's adjusted fine....
[quoted image]

Are the wires broken/loose? I don't remember if mine said stuck open or stuck closed but both wires were broken. I gave them some slack and resoldered them.

#1310 11 months ago

deleted as I didn't have to "go there"

#1311 11 months ago
Quoted from DerGoetz:

Thousands released vs dozens.
What are you talking about.
I own both IMDNLE and FullTLE. i am an owner of both, are you?

Im not talking about FullTLE. Could care less about that game. Just saying Maiden has a lot of issues too, like Pirates. And Pirates has way more going on mechanically than Maiden LE. Typically, early production games (stern and JJP alike) have always needed the most tweaks out of the box. What’s going on with JJP QC isn’t what problems come off these early runs, but more about what they do to correct it. And, Eric has posted that he has visits with the factory ironing out issues that he’s gathered and makes adjustments. Stern does the same thing; and in some cases they just fix it in software (i.e. GOT).

All in all, you make it sound like JJPOTC and Heighway are alone with these issues. If JJP we’re having serious board issues (like WOZ - which has been corrected), then I would certainly raise a flag. But the bottom line, and a good rule of thumb is, if you want to avoid having to make these kind of tweaks and iron them out with the community, or just don’t like having to tweak your game so often, stay away from being an early adopter of the game. This goes across the board with all manufacturers. That’s the nature of this hobby. And, if you don’t like that part of the hobby one bit, then you best stay clear of new manufacturers till they can whether any storms.

#1312 11 months ago
Quoted from DerGoetz:

Thousands released vs dozens.
What are you talking about.
I own both IMDNLE and FullTLE. i am an owner of both, are you?

Oh I spent way more tech time on IMLE versus two Potc.
Just my experience

#1313 11 months ago

Thanks WOLFMANCAT! That did the trick. I lied about taking a video because your photos definitely make it clear. Just a slight bend down and it's now working reliably for me.

J.

Quoted from WolfManCat:

You have to bend the arm in a manner that tightens up the spring tension on the flap/gate. If you zoom in close on the first pic you can see the markings from where I had my pliers. I believe I twisted my wrist to the left a little bending the arm down just slightly.
I apologize for the poor lighting.
[quoted image][quoted image]

#1314 11 months ago

This game is becoming crack in my house!
I will be adjusting auto plunger as I noticed it’s getting a little worse. 1 out of every 5 balls. Also the depths vuk will need turned up a notch as it is starting to lack. But all in all still playing well! And super fun.
I find myself trying different things to do ie.
Shooting for the ship cannon
Starting a early multi ball like Dead mans chest.
Or
Going for a certain chapter
There is a lot going on in code alone! Not to mention pf toys.
Oh and did I mention I like leds!!

image (resized).jpg
#1315 11 months ago

I had a weird thing happen tonight. Was putting up a solid game and was on my 2nd liar's dice when I made the liar selection and the game... crashed? ... with a tilt. Very odd. Wonder if anyone else has seen that?

#1316 11 months ago
Quoted from pinmaniac:

Are the wires broken/loose? I don't remember if mine said stuck open or stuck closed but both wires were broken. I gave them some slack and resoldered them.

Hmmm.. would I be able to see it without taking the ship off?

#1317 11 months ago
Quoted from DerGoetz:

Thousands released vs dozens.
What are you talking about.
I own both IMDNLE and FullTLE. i am an owner of both, are you?

But this is the jjpotc owner and fan club... you don’t sound like either

#1318 11 months ago
Quoted from mountaingamer:

But this is the jjpotc owner and fan club... you don’t sound like either

I just realized that and apologize for stinking up the room...my bad, hands down

#1319 11 months ago
Quoted from JordanB:

I had a weird thing happen tonight. Was putting up a solid game and was on my 2nd liar's dice when I made the liar selection and the game... crashed? ... with a tilt. Very odd. Wonder if anyone else has seen that?

Did you wager tilts and lose?

#1320 11 months ago
Quoted from JordanB:

Thanks WOLFMANCAT! That did the trick. I lied about taking a video because your photos definitely make it clear. Just a slight bend down and it's now working reliably for me.
J.

You're welcome! Just glad I could help.

#1321 11 months ago

This game is incredible, nothing more to say. The family is out of town this weekend so I was able to put some serious time on it. A couple things I noticed...

Anyone get to the “666” mode, or whatever you want to call it? Massive stacked Multiball where I think had every Multiball going, and I may have collected all of the SP’s. All of a sudden over the whole screen “666” floated over all the Multiball flags, but not sure what I did to activate it.

I’ve been lucky, and haven’t had any issues with my pin except for a “pearl left flipper EOS error” like the earlier poster. I haven’t had to make one repair, just some small adjustments here and there, but the EOS switch error is throwing me for a loop. I looked it over and everything seems fine, even pulling the pearl to make sure I didn’t have a wire break off. Not sure where to go from here, but at least it doesn’t stop play.

Lastly, if I had one complaint it would be the noise from the spinning disk. I think they’re mod1 pinions which are pretty common in the rc world. One of my huge speed helis has the same metal to metal gear, and we use a lubricant called “dry fluid extreme”. It dries almost like a grease, but when applied is liquid form so it gets in all the nooks. It made a huge difference on the lower rpm spins, and took away rattling noise during high speed spins. It didn’t take away all the noise, but did a great job making it just a bit quieter and calming the loudest of spins. I’ll post the lubricant info when I get home if anyone is interested.

Overall, absolutely having a blast. It’s always a tough pill to swallow when buying a JJP machine as they are so darn expensive, but I haven’t been disappointed yet by the final product. They are 4 for 4 in my house, and I can’t wait to see what they come out with next.

#1322 11 months ago
Quoted from KevInBuffalo:

Did you wager tilts and lose?

Nope, I wagered souls, and I don't know if I won or lost, because as soon as I clicked LIAR it flashed to tilt.

It's a computer, and I'm a developer, so I'm not surprised or upset. Just thought I'd see if anyone else encountered it.

#1323 11 months ago

Just got back from Flip Out Melbourne Mr jersey Jack himself was there and it was a great day. Finally got to play the production version of pirates, in the pictures the apron looked too bright and out of place I'm not sure if it was just the pictures or they toned it down but in real life it looks really good .

#1324 11 months ago
Quoted from screaminr:

Just got back from Flip Out Melbourne Mr jersey Jack himself was there and it was a great day. Finally got to play the production version of pirates, in the pictures the apron looked too bright and out of place I'm not sure if it was just the pictures or they toned it down but in real life it looks really good .

I'm glad you've mentioned this. I thought the same but haven't taken the time to say it; the apron art and colouring is beautiful! I recall when it was revealed and wasn't a fan as it look odd in the video and I didn't like the split decal. Completely loved it when my pin arrived.

#1325 11 months ago

Are radcals worth the extra 400$ or should i order the le without.

#1326 11 months ago
Quoted from the_belgian:

Are radcals worth the extra 400$ or should i order the le without.

There are a lot of mixed opinions on RADCALS but I think they are great. They make a huge difference in appearance and should hold up better over time. I ordered my LE with them. I have them on my RRWOZ and wish I bought them for my THBA but I got a great deal on an in stock machine; I should have waited until a RADCAL equipped version was available. That is what I am doing with my POTC LE purchase. JJP mistakenly sent a machine without RADCALS (JJP said the distributor erred in my order); I told my distributor to deliver the machine to someone else and reorder another one for me with RADCALS. That means another month long wait for my POTC but so what, I expect to have it a long time.

#1327 11 months ago

Anybody else having Ball Trough problems? The balls aren't feeding down and getting hung up in the trough during multi balls and sometimes during regular play ? We spent a few hours last night tinkering with it but still getting stuck, any ideas? Such a fun game but so annoying having your balls not feed out when you've stacked 3 multiballs together and you tilt trying to nudge the balls over in the trough.....

#1328 11 months ago

I would go over the plunger at the end of the ball trough that kicks the balls into play. If it's a tiny bit higher than should be, it will trap the balls from rolling into position.

The plunger/coil/bracket as a whole can be moved up or down using by loosening the four screws on the end of the ball trough. Don't go too high or two low.

LTG : )

#1329 11 months ago
Quoted from LTG:

I would go over the plunger at the end of the ball trough that kicks the balls into play. If it's a tiny bit higher than should be, it will trap the balls from rolling into position.
The plunger/coil/bracket as a whole can be moved up or down using by loosening the four screws on the end of the ball trough. Don't go too high or two low.
LTG : )

I'll look at this later today... Although I don't think its my issues as I've looked down the trough from above after a ball has been ejected and I can see the empty trough... It seems like its 1 or two balls back, I have to nudge the machine to push them over so the optos see them....

#1330 11 months ago
Quoted from Aurium:

Anybody else having Ball Trough problems? The balls aren't feeding down and getting hung up in the trough during multi balls and sometimes during regular play ? We spent a few hours last night tinkering with it but still getting stuck, any ideas? Such a fun game but so annoying having your balls not feed out when you've stacked 3 multiballs together and you tilt trying to nudge the balls over in the trough.....

I am also but have not looked at it yet. First check that your game is level and pitched right as I have done. Might be a metal burr inside. I will check mine after playing for a while to see if it works out itself.

Bill

#1331 11 months ago
Quoted from Aurium:

I have to nudge the machine to push them over so the optos see them....

https://www.marcospecialties.com/pinball-parts/03-16809 Cures magnetized ball issues. ( and later divot in the ball trough issues )

LTG : )

#1332 11 months ago
Quoted from Procrastinator:

Anyone get to the “666” mode, or whatever you want to call it? Massive stacked Multiball where I think had every Multiball going, and I may have collected all of the SP’s. All of a sudden over the whole screen “666” floated over all the Multiball flags, but not sure what I did to activate it.

It does that when you get all 5 multiballs and Tortuga stacked together.

#1333 11 months ago
Quoted from Procrastinator:

I’ve been lucky, and haven’t had any issues with my pin except for a “pearl left flipper EOS error” like the earlier poster. I haven’t had to make one repair, just some small adjustments here and there, but the EOS switch error is throwing me for a loop. I looked it over and everything seems fine, even pulling the pearl to make sure I didn’t have a wire break off. Not sure where to go from here, but at least it doesn’t stop play.

Can you take a picture of the coil and EOS area on the left?

I was at a friend's last night I helping to resolver one of the grounds from a switch and he has the same EOS error, it was in fact the top wire (Black/Orange) that was off. Resoldered and up she went.

That said, he sure did have a number of things that needed doin'. From the BP' broken wires (zip ties pulling wires too tight), to loose screws in the BP VUK and Mystery hole reflector, to slightly moving and securing the wires/harness between the GOLD targets, to a 'new to me' issue; ball trough ball stalls/hangups.

He is checking this today to see if it might be magnetism

#1334 11 months ago
Quoted from LesManley:

It does that when you get all 5 multiballs and Tortuga stacked together.

Thanks!

Quoted from dnaman:

Can you take a picture of the coil and EOS area on the left?
I was at a friend's last night I helping to resolver one of the grounds from a switch and he has the same EOS error, it was in fact the top wire (Black/Orange) that was off. Resoldered and up she went.
That said, he sure did have a number of things that needed doin'. From the BP' broken wires (zip ties pulling wires too tight), to loose screws in the BP VUK and Mystery hole reflector, to slightly moving and securing the wires/harness between the GOLD targets, to a 'new to me' issue; ball trough ball stalls/hangups.
He is checking this today to see if it might be magnetism

Sure, I’ll pull it again tomorrow and recheck. I will say on every JJP game I’ve had I had trough issues. 95% of the time it’s been magnetized balls. Heck, with JJP stock balls, my woz would had a 50% success rate after 50 plays. It was crazy how fast they magnetized. If it was me, the first thing I would try would be a new set, because the stock JJP balls have been notoriously bad for me. I actually have a gauss meter and could test the magnetic strength tomorrow afternoon and see how bad they are, because my POTC trough has gotten flakier little by little over the last 100 games.

#1335 11 months ago
Quoted from Procrastinator:

my POTC trough has gotten flakier little by little over the last 100 games.

https://www.marcospecialties.com/pinball-parts/03-16809 Cures magnetized ball issues.

LTG : )

#1336 11 months ago

Thanks! Will give it a shot!

#1337 11 months ago

That seems weird - I’ve never had a issue with the woz trough but have replaced the balls at least 2 or 3 times since it was new. I’ve had Dialed In a few weeks and that game has the craziest magnet action I can remember, but the trough seems fine for now. Is there more magnet action with pirates than DI? Maybe I will grab a few shims also just in case.

#1338 11 months ago
Quoted from mountaingamer:

That seems weird - I’ve never had a issue with the woz trough but have replaced the balls at least 2 or 3 times since it was new. I’ve had Dialed In a few weeks and that game has the craziest magnet action I can remember, but the trough seems fine for now. Is there more magnet action with pirates than DI? Maybe I will grab a few shims also just in case.

could be many things, but there is always a possibility of a batch of balls that are just more susceptible to magnetism. I received a batch of 200 balls from a vendor once that all had to be sent back. I had them in a customers lord of the rings, theater of magic and woz, and they all became magnetized after about 20 games or so. took me over an hour to figure out what was going on, but in the end, I just changed out the balls and all has been great since then.

not saying this is the case for these customers, but it is a possibility.

#1339 11 months ago

Are both upper flippers supposed to be even when triggered at the flippers? (both are being held at the time of this pic)

image1 (resized).jpeg
#1340 11 months ago
Quoted from evh347:

Are both upper flippers supposed to be even when triggered at the flippers? (both are being held at the time of this pic)
[quoted image]

Yes they should be I believe

#1341 11 months ago
Quoted from evh347:

Are both upper flippers supposed to be even when triggered at the flippers? (both are being held at the time of this pic)
[quoted image]

Huh, thats not right! My Guess is the shaft on the right flipper loosened up. Probably looks correct in the down position as its resting on a wire rail. Time to get more close and personal with your pirate ship... lol

#1342 11 months ago
Quoted from evh347:

Are both upper flippers supposed to be even when triggered at the flippers? (both are being held at the time of this pic)
[quoted image]

You need to tighten the nut that holds the flipper shaft in place. One of mine did the same thing, and I moved it into the correct position by hand then tightened the nut that clamps down on the shaft. It’s a little difficult on the right side of the ship, but if you pull the cotter pin in the back it’s doable without removing the ship.

#1343 11 months ago

Mine is now running perfectly. Not only is it beautiful, it's my favorite game I've played.

I was super upset when the disc change occurred, but looking now this actually looks better and functionally diverts better I was wrong and the animations are nothing short of spectacular.

This game is amazing.

#1344 11 months ago
Quoted from the_belgian:

Are radcals worth the extra 400$ or should i order the le without.

they are absolutely beautiful.

#1345 11 months ago
Quoted from dnaman:

Can you take a picture of the coil and EOS area on the left?
I was at a friend's last night I helping to resolver one of the grounds from a switch and he has the same EOS error, it was in fact the top wire (Black/Orange) that was off. Resoldered and up she went.
That said, he sure did have a number of things that needed doin'. From the BP' broken wires (zip ties pulling wires too tight), to loose screws in the BP VUK and Mystery hole reflector, to slightly moving and securing the wires/harness between the GOLD targets, to a 'new to me' issue; ball trough ball stalls/hangups.
He is checking this today to see if it might be magnetism

Played some games on it last night and it seems better. I put a pack of brand new superjets in when I got the game but I’ve switched to the balls that came with it. Seems good right now.

#1346 11 months ago
Quoted from Gusphan:

Hmmm.. would I be able to see it without taking the ship off?

Yes, I could but couldn’t reach it to resolder without removing the ship.

#1347 11 months ago
Quoted from Gusphan:

Anyone else getting that alert? I swear it's adjusted fine....
[quoted image]

I am getting this as well Nick. The EOS was closed without the left flipper activated originally, there was no gap at rest.

I adjusted the EOS so that it is open and closes once the left flipper activates.

Still getting the #D04 EOS stuck open in Test Report. Did you ever figure yours out?
Screen Shot 2018-12-02 at 11.32.34 AM (resized).pngScreen Shot 2018-12-02 at 11.53.36 AM (resized).png

#1348 11 months ago

Anyone come up with a easy solution to fix action button? Mine is progressively getting worse.

#1349 11 months ago
Quoted from Psw757:

Haven’t seen that particular alert but the one I keep getting is the target ship switch stuck closed. Think it’s number 79 and it seems to work when I do hit it.

I had this same error at the same time as the #D04. I shot a few balls into the ship and it went away. I think the switch needed to be activated.

#1350 11 months ago
Quoted from Psw757:

Anyone come up with a easy solution to fix action button? Mine is progressively getting worse.

If it hangs : Get some wd40 from the underside in there

If it didn’t register: loosen the screws from the switch a Bit

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Flagstaff, AZ
Wanted
Machine - Wanted
Flagstaff, AZ
From: $ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 175.00
Gameroom - Decorations
Pinball Photos
From: $ 175.00
Gameroom - Decorations
Pinball Photos
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 38.75
Playfield - Toys/Add-ons
The MOD Couple
There are 12985 posts in this topic. You are on page 27 of 260.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside