(Topic ID: 200141)

JJP Pirates of the Caribbean Official Owners and Fan Club!


By goren1818

1 year ago



Topic Stats

  • 11,913 posts
  • 449 Pinsiders participating
  • Latest reply 32 minutes ago by kidchrisso
  • Topic is favorited by 210 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,130 images uploaded to this topic. (View topic image gallery).

9F7335D3-321E-458E-B3A2-43D2F99388C7 (resized).jpeg
20190820_152447 (resized).jpg
IMG-4527 (resized).JPG
IMG-4522 (resized).JPG
IMG-4523 (resized).JPG
IMG-4525 (resized).JPG
IMG-4524 (resized).JPG
IMG-4526 (resized).JPG
20190817_173334 (resized).jpg
20190817_135857 (resized).jpg
20190816_233723 (resized).jpg
20190816_233832 (resized).jpg
20190816_231501 (resized).jpg
20190816_231435 (resized).jpg
IMG-4491 (resized).JPG
IMG-4486 (resized).JPG

Topic index (key posts)

20 key posts have been marked in this topic (Show topic index)

There are 11913 posts in this topic. You are on page 143 of 239.
#7101 4 months ago
Quoted from wesman:

I wish my issue was just brushing the shooter rod. I can't wedge the hooks back in at all, no matter how I adjust the angle, press backwards, or shift the wire looms. The apron itself, for me, looks misaligned/not flush at all.

Can you loosen the nuts and remove the screws from the lock down bar reciever and move it to the left slightly?

Did that to a friend's Woz and it took very little time and solved his lock down bar issue.

Tighten the nuts after and maybe reinstall the screws obviously . And make sure the lockdown bar still fits

#7102 4 months ago
Quoted from wesman:

I wish my issue was just brushing the shooter rod. I can't wedge the hooks back in at all, no matter how I adjust the angle, press backwards, or shift the wire looms. The apron itself, for me, looks misaligned/not flush at all.

Your left hook looks like it's mis-mounted. It's WAY too far left. The gap on the left side of the left hook should be about the same as the right, but you have NO GAP, which is why you're probably having problems getting it to rest correctly. Unfortunately the hooks are t-nutted into the PF, so moving them is no simple task.

#7103 4 months ago

Took a break from playing Pirates to go see the real ones! My wife likes to find cool key chains that embody the themes for the keys to our machines. She found this in one of our favorite shops at Disneyland. Dead men tell no tales

4CCDA46A-F854-43EE-9343-CBA8156928DA (resized).jpegA6E54803-5F9C-408E-88C4-1895AB68AEE1 (resized).jpeg
#7104 4 months ago
Quoted from vireland:

Your left hook looks like it's mis-mounted. It's WAY too far left. The gap on the left side of the left hook should be about the same as the right, but you have NO GAP, which is why you're probably having problems getting it to rest correctly. Unfortunately the hooks are t-nutted into the PF, so moving them is no simple task.

That's what I was figuring. The apron isn't flush against the shooter lane either. And even my right hook doesn't look flush with the playfield, it's sagging a bit. All of this would explain why I can't seat the playfield at all, yet alone with ease, and also having lockdown bar issues. I had to entirely remove the styrofoam braces just to let that sit against the glass.

Thank you for your thoughts.

#7105 4 months ago
Quoted from wesman:

That's what I was figuring. The apron isn't flush against the shooter lane either. And even my right hook doesn't look flush with the playfield, it's sagging a bit. All of this would explain why I can't seat the playfield at all, yet alone with ease, and also having lockdown bar issues. I had to entirely remove the styrofoam braces just to let that sit against the glass.
Thank you for your thoughts.

Styrofoam "braces"? You mean the foam shipping blocks? Those are supposed to be removed. Did you take ALL of them out? From the manual:

potc-shipping-blocks (resized).jpg
#7106 4 months ago
Quoted from heni1977:

Anyone else turn there shaker motor all the way up?

Soo... I guess this is a no? Haha

I have not made *ANY* changes to configuration.

#7107 4 months ago
Quoted from vireland:

Styrofoam "braces"? You mean the foam shipping blocks? Those are supposed to be removed. Did you take ALL of them out? From the manual:[quoted image]

THIS could explain why I have some-what hell getting my playfield flush again when I seat it back in. I swear my pin doesn't have these in the back under the pf, but I'm gonna go check again...

Also, let me go tinker with my left spinner on BP and see if it's spinning okay or if I have an "actual" problem. Haven't noticed any issues with the right spinner on BP or the Devil's Triangle.

#7108 4 months ago
Quoted from vireland:

Styrofoam "braces"? You mean the foam shipping blocks? Those are supposed to be removed. Did you take ALL of them out? From the manual:[quoted image]

I meant foam, as in the sticky tape under the lockdown bar.

All of the packing foam is removed. I was installing the map Cliffy's last night. Those are all long gone.

#7109 4 months ago
Quoted from wesman:

I meant foam, as in the sticky tape under the lockdown bar.
All of the packing foam is removed. I was installing the map Cliffy's last night. Those are all long gone.

The two pieces of foam that go on the "prongs" came off the second time I put the lockdown bar on, and I never put them back on. The long piece is beer seal to trap out liquids and should stay on as it's an important function.

#7110 4 months ago

Did you move the loom from the left of the machine towards the middle. Once I did that my playfield went in much easier and the not sitting properly on hanger went away.

#7111 4 months ago
Quoted from joseph5185:

THIS could explain why I have some-what hell getting my playfield flush again when I seat it back in. I swear my pin doesn't have these in the back under the pf, but I'm gonna go check again...

There's one large block of foam screwed to the back of the cabinet inside, about 2/3 from the bottom.

#7112 4 months ago
Quoted from vireland:

There's one large block of foam screwed to the back of the cabinet inside, about 2/3 from the bottom.

Screwed?

Oh yea... I definitely missed that I think.

I'm about to snap a pic...

#7113 4 months ago

100% agree on these. I hope someone is paying attention. Along with a lot more polish on the wizard modes, this would make this game absolutely amazing.

Quoted from zaphX:

I agree. I think MGC will be all about Wonka and I for one can’t wait.
I still love pirates though and eagerly await fixes. Some of the main ones I want to see:
1. Chest lock fix
2. Don’t give/announce map awards until after the animation
3. Lock in character select immediately on plunge (newbs who don’t use the action button sometimes get unexpected characters)
As a nice to have, I’d like to see the color scheme on movie 5 to be more purple and less blue. It doesn’t match the inserts and it is sometimes confusing to tell if I’m in movie 4 or 5 chapters. (Just me?)

#7114 4 months ago
Quoted from joseph5185:

Screwed?
Oh yea... I definitely missed that I think.
I'm about to snap a pic...

Don't I feel stupid ...

Yea so I DEFINITELY wasn't expecting anything to be screwed as far as packing goes.
Still a newbie.

pasted_image (resized).png
#7115 4 months ago

Update on the LEFT BP Spinner..

Yea, it's 100% stiff. I can move it with my finger and it pretty much stops there.
The RIGHT BP is VERY responsive.

The Devil's Triangle is PRETTY responsive.

Is this going to require taking out the BP to fix?

#7116 4 months ago

I *MAY* have a problem.

I was thinking that I could just rock the Dauntless to the side or w/e and it would clear this error.

Unfortunately, I'm unable to clear this error...

pasted_image (resized).png
#7117 4 months ago
Quoted from joseph5185:

I *MAY* have a problem.
I was thinking that I could just rock the Dauntless to the side or w/e and it would clear this error.
Unfortunately, I'm unable to clear this error...
[quoted image]

Did you rock it in gameplay? Did you test switch activation in test?

#7118 4 months ago
Quoted from joseph5185:

I *MAY* have a problem.
I was thinking that I could just rock the Dauntless to the side or w/e and it would clear this error.
Unfortunately, I'm unable to clear this error...
[quoted image]

Drop a ball into the Dauntless side hole.

Or play better.

#7119 4 months ago
Quoted from joseph5185:

I *MAY* have a problem.
I was thinking that I could just rock the Dauntless to the side or w/e and it would clear this error.
Unfortunately, I'm unable to clear this error...
[quoted image]

That's the ship hit one. As stated, you have to drop a ball into the hole to clear. Or just ignore it. :p

#7120 4 months ago
Quoted from BC_Gambit:

Did you rock it in gameplay? Did you test switch activation in test?

I did not rock it in gameplay, but before starting a game.

Quoted from zaphX:

Drop a ball into the Dauntless side hole.
Or play better.

=P

Quoted from f3honda4me:

That's the ship hit one. As stated, you have to drop a ball into the hole to clear. Or just ignore it. :p

Might just ignore it for now .. haha .. I thought there was a switch specifically for the bullseye which I thought meant a ball going into the hole.

Either way, if you guys recall, I had two matrixed switch errors and just the one now. =)

#7121 4 months ago
Quoted from joseph5185:

I *MAY* have a problem.
I was thinking that I could just rock the Dauntless to the side or w/e and it would clear this error.
Unfortunately, I'm unable to clear this error...
[quoted image]

Move the ship with your hand. The one here was rubbing on the back of the maelstrom whirlpool so it never fully closed the switch.

#7122 4 months ago
Quoted from joseph5185:

I did not rock it in gameplay, but before starting a game.

=P

Might just ignore it for now .. haha .. I thought there was a switch specifically for the bullseye which I thought meant a ball going into the hole.
Either way, if you guys recall, I had two matrixed switch errors and just the one now. =)

There's one for the bullseye and one for hitting the ship and making it move, but not hitting the bullseys (a miss).

#7123 4 months ago
Quoted from joseph5185:

Don't I feel stupid ...
Yea so I DEFINITELY wasn't expecting anything to be screwed as far as packing goes.
Still a newbie.
[quoted image]

Don't feel bad. I initially missed it until I RTFM and realized that maybe it wasn't supposed to be there after unpacking was completed.

#7124 4 months ago
Quoted from vireland:

The two pieces of foam that go on the "prongs" came off the second time I put the lockdown bar on, and I never put them back on. The long piece is beer seal to trap out liquids and should stay on as it's an important function.

I'm only referencing that to illustrate I've had a few issues. I'd like that foam on there for protection, but I can't even place it due to not having a proper gap for the bar's prongs.

I'd imagine whatever overall alignment issues I have are cumulative, and are affecting that entire region in a few ways.

I haven't even played a ball yet either...

#7125 4 months ago
Quoted from vireland:

Move the ship with your hand. The one here was rubbing on the back of the maelstrom whirlpool so it never fully closed the switch.

Yea.. Let me start a game .. move it with my hand and then report back after the game is over and see if it clears the error.
I thought the "ball going in a hole" was the bulls-eye switch or w/e.

Thanks!

#7126 4 months ago
Quoted from joseph5185:

Yea.. Let me start a game .. move it with my hand and then report back after the game is over and see if it clears the error.
I thought the "ball going in a hole" was the bulls-eye switch or w/e.
Thanks!

Yea so... that error is definitely still there.

I basically moved the dauntless to the left and let it just rock back into place at least 5-10 times ... with an actual game started.

#7127 4 months ago
Quoted from joseph5185:

Yea so... that error is definitely still there.
I basically moved the dauntless to the left and let it just rock back into place at least 5-10 times ... with an actual game started.

If you go into switch test and rock it like it was hit with the ball, but not destroyed, does it trigger the switch?

#7128 4 months ago
Quoted from vireland:

If you go into switch test and rock it like it was hit with the ball, but not destroyed, does it trigger the switch?

Uhh... testing!

#7129 4 months ago

Bad News Bears ...

I can't clear the error..

I rocked it several times and nothing. Other switches triggered fine.
I through a ball into the hole for fun as well and no dice.

I guess I "actually" have an issue now..

=(

#7130 4 months ago
Quoted from joseph5185:

Uhh... testing!

BTW, the switch for this is easy to get to, it's behind the backboard at the bottom of the PF. If you can't make it happen with the ship, put your finger down there. The switch triggers when it RELEASES, not when it's depressed, so it may be too compressed and can't release enough to trigger without some bending or loosening and re-situating the switch mount.

#7131 4 months ago
Quoted from BC_Gambit:

Can you loosen the nuts and remove the screws from the lock down bar reciever and move it to the left slightly?
Did that to a friend's Woz and it took very little time and solved his lock down bar issue.
Tighten the nuts after and maybe reinstall the screws obviously . And make sure the lockdown bar still fits

I'm going to have to try that later tonight. Past that, and I don't think I have many options left.

I'm concerned that the wiring is pushing the right side out rather than being flush.

Quoted from GnarLee:

Did you move the loom from the left of the machine towards the middle. Once I did that my playfield went in much easier and the not sitting properly on hanger went away.

I did that quite a bit, after reading your suggestion, and someone else the other day. No luck unfortunately.... Thank you though!

PSX_20190409_175436 (resized).jpg
#7132 4 months ago
Quoted from joseph5185:

Don't I feel stupid ...
Yea so I DEFINITELY wasn't expecting anything to be screwed as far as packing goes.
Still a newbie.
[quoted image]

You need to move the loom on the left side to the middle. will help with you dauntless issues as well. If dauntless error does not clear after moving loom you might have a bad opto or lose opto.

#7133 4 months ago

Hi Guys, Joined the club today with LE 197 thanks to some peer pressure from kevinbuffalo

This is my first home pinball, have been an arcade guy in the past, so have some experience with wiring, pcbs, etc.

Having a couple of issues, and have a call in to the distributor, but figured Pinside might have some ideas?

1.) Have a Fork Malfunction/Device Broken error and balls wont lock in the chest
- Checked the suggested 2 screws to make sure they were tight
- Checked wiring under the play field for the fork mechanism and everything seems ok
- Individual coil tests will raise and lower the fork successfully
- The specific fork test itself will not work
- No balls will physically enter or lock in the chest, but screen animations show ball locks when hit through the middle chest shot

Anything else to check?

2.) Have a stuck closed switch #50 on the right high slingshot. It wont activate when depressed manually.
-Checked under playfield wiring and seems ok from a glance (no broken wires)

Read through every post in this thread in preparation. So far have done these checks/minor fixes:
- Cut some zip ties to give slack to the Black Pearl
- Subway post was there from the factory - Manufacture date was 1/21/2019
- Protected cabling behind dauntless
- Leveled to 6.5

20190409_144807 (resized).jpg20190409_144906 (resized).jpg

#7134 4 months ago
Quoted from vireland:

BTW, the switch for this is easy to get to, it's behind the backboard at the bottom of the PF. If you can't make it happen with the ship, put your finger down there. The switch triggers when it RELEASES, not when it's depressed, so it may be too compressed and can't release enough to trigger without some bending or loosening and re-situating the switch mount.

Thanks.

To confirm, it's UNDER the playfield?

#7135 4 months ago
Quoted from joseph5185:

Thanks.
To confirm, it's UNDER the playfield?

Pull the playfield out to the second rubber feet. Look behind the backboard right behind the ship, almost at the bottom of the backboard. The switch is directly behind the ship on the back of the backboard. Move the ship and you can see the bar that's supposed to be easing up and releasing the switch so it registers.

#7136 4 months ago
Quoted from D_N_G:

Hi Guys, Joined the club today with LE 197 thanks to some peer pressure from kevinbuffalo
This is my first home pinball, have been an arcade guy in the past, so have some experience with wiring, pcbs, etc.
Having a couple of issues, and have a call in to the distributor, but figured Pinside might have some ideas?
1.) Have a Fork Malfunction/Device Broken error and balls wont lock in the chest
- Checked the suggested 2 screws to make sure they were tight
- Checked wiring under the play field for the fork mechanism and everything seems ok
- Individual coil tests will raise and lower the fork successfully
- The specific fork test itself will not work
- No balls will physically enter or lock in the chest, but screen animations show ball locks when hit through the middle chest shot
Anything else to check?
2.) Have a stuck closed switch #50 on the right high slingshot. It wont activate when depressed manually.
-Checked under playfield wiring and seems ok from a glance (no broken wires)
Read through every post in this thread in preparation. So far have done these checks/minor fixes:
- Cut some zip ties to give slack to the Black Pearl
- Subway post was there from the factory - Manufacture date was 1/21/2019
- Protected cabling behind dauntless
- Leveled to 6.5
[quoted image][quoted image]

You just need to re-gap that upper right slingshot's switch leaves. If you pull the rubber AWAY it should release the contact and make the switch register. The problem is the back leaf is too close to the front, so when the rubber's just at rest it's always making contact. Move the back leaf away so it's not making contact until the rubber is depressed.

On that test, it looks to me like the switch that detects forks are up is stuck on, so it always thinks they're up. What does switch test say? If it's always on, you need to adjust that switch so it changes when the forks come down.

#7137 4 months ago
Quoted from vireland:

Pull the playfield out to the second rubber feet. Look behind the backboard right behind the ship, almost at the bottom of the backboard. The switch is directly behind the ship on the back of the backboard. Move the ship and you can see the bar that's supposed to be easing up and releasing the switch so it registers.

Awesome!

#7138 4 months ago
Quoted from D_N_G:

2.) Have a stuck closed switch #50 on the right high slingshot. It wont activate when depressed manually.

If it's stuck closed it won't register when hitting in.

Two leaf blade switches on each slingshot. High one would be towards the rear of the game. TURN GAME OFF - thank you. Remove slingshot plastic. Look down at slingshot leaf blade switch. See the two blades ? Long one resting on the rubber ring, short one behind it ? Adjust the short rear one away from the front long one so it isn't touching at the top where the two rivet looking things on the blades are. You want it close enough so the slightest ball hit triggers it, but vibration doesn't it. A tweak or tow and you are good to go.

LTG : )

#7139 4 months ago

Can anyone confirm if JJP has Titan from the factory?
If not, what is it?

How much of an "improvement" does Titan make?

#7140 4 months ago

Hey,

So I guess audio clipping is "rare."

...Yay!

#7141 4 months ago
Quoted from joseph5185:

Hey,
So I guess audio clipping is "rare."
...Yay!

Did you play with the sound/fx/volume mixes from factory levels? That can cause it.

#7142 4 months ago

vireland

BING-O WAS HIS NAME-O

I see EXACTLY what you are referring to...
And when I moved the ship, the switch works!

So now I have a new fun problem.

It seems that it's only an issue when the playfield is actually in place... =/

#7143 4 months ago
Quoted from vireland:

Did you play with the sound/fx/volume mixes from factory levels? That can cause it.

Hey, no. (I didn't even know you could do that.. haha)

Everything is set exactly as it came.

#7144 4 months ago
Quoted from joseph5185:

vireland
BING-O WAS HIS NAME-O
I see EXACTLY what you are referring to...
And when I moved the ship, the switch works!
So now I have a new fun problem.
It seems that it's only an issue when the playfield is actually in place... =/

You just need to either loosen the screws holding the switch on and rotate the switch body to give it more room so it "disconnects" easier when the bar moves away, or bend the roller leaf on the switch back towards the body of the switch so it registers the release easier.

In either case, it's a relatively easy switch adjustment.

#7145 4 months ago
Quoted from joseph5185:

Can anyone confirm if JJP has Titan from the factory?
If not, what is it?

Some of the rubber is Titan. The flipper rubber is Suzo red rubber and some of the other rings might be regular rubber. If it's clear silicone, it should be Titan. Dialed In also came with white Titan rubber and Suzo red flipper.

#7146 4 months ago
Quoted from vireland:

You just need to either loosen the screws holding the switch on and rotate the switch body to give it more room so it "disconnects" easier when the bar moves away, or bend the roller leaf on the switch back towards the body of the switch so it registers the release easier.
In either case, it's a relatively easy switch adjustment.

And I assume it would be easier with a nut driver set? Need to pick that up tonight.

Also, there's black tubing or w/e zip tied on the left side. I almost feel like when the playfield is down that maybe it's inteferring?

I can get the playfield down where the hooks are off a few inches and the switch will "sometimes" trigger .. when the playfield is fully seated, it is definitely 0% triggered.

#7147 4 months ago
Quoted from Titan_Pinball:

Some of the rubber is Titan. The flipper rubber is Suzo red rubber and some of the other rings might be regular rubber. If it's clear silicone, it should be Titan. Dialed In also came with white Titan rubber and Suzo red flipper.

So then the slings and the upper right sling? I guess is Titan.
Maybe?

That's pretty cool.

#7148 4 months ago
Quoted from joseph5185:

And I assume it would be easier with a nut driver set? Need to pick that up tonight.
Also, there's black tubing or w/e zip tied on the left side. I almost feel like when the playfield is down that maybe it's inteferring?
I can get the playfield down where the hooks are off a few inches and the switch will "sometimes" trigger .. when the playfield is fully seated, it is definitely 0% triggered.

A few more inches???

Get Klein magnetic nut drivers. Available quickly on amazon. Or any magnetic ones really.

#7149 4 months ago
Quoted from wesman:

A few more inches???
Get Klein magnetic nut drivers. Available quickly on amazon. Or any magnetic ones really.

Yea I just meant where the hooks aren't seated properly. Like the hooks are above the slots if that makes sense?

So "definitely" magnetic, yea?
The magnetism won't cause any ill effects on the table I take it.

Thanks for this!

#7150 4 months ago
Quoted from Titan_Pinball:

Some of the rubber is Titan. The flipper rubber is Suzo red rubber and some of the other rings might be regular rubber. If it's clear silicone, it should be Titan. Dialed In also came with white Titan rubber and Suzo red flipper.

Those flipper rubbers that come stock are GROSS. They look bad and feel yukky. Marco would give them better standard red rubber than whatever they're using.

Promoted items from the Pinside Marketplace
$ 189.00
9,800 (OBO)
Machine - For Sale
Phoenix, AZ
From: $ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 38.00
Playfield - Decals
Pinball Mod Co.
$ 42.00
Playfield - Toys/Add-ons
The MOD Couple
There are 11913 posts in this topic. You are on page 143 of 239.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside