(Topic ID: 235176)

Is my shadow battlefield acting weird?


By Djshakes

83 days ago



Topic Stats

  • 20 posts
  • 8 Pinsiders participating
  • Latest reply 64 days ago by Syco54645
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

Screenshot_20190204-030552 (resized).png
Screenshot_20190204-030506 (resized).png
Screenshot_20190204-030329 (resized).png
20190202_075301 (resized).jpg

#1 83 days ago

I got a new shadow. It's been a couple years since I owned on. I notice when I get the ball up on the battlefield the plunger fires when I hit the flipper buttons as well as move the plunger side to side. I thought it was only suppose to fire when the opto is interrupted and the flipper buttons only move the plunger side to side not fire the plunger coil?

What would cause this or is it not an issue?

#2 83 days ago

Congrats.
is this the stupid ass setting you can do to turn the gun "off." Does the gun work?
When you're first picking the plunging award do the buttons fire the gun?

#3 83 days ago
Quoted from TheLaw:

Congrats.
is this the stupid ass setting you can do to turn the gun "off." Does the gun work?
When you're first picking the plunging award do the buttons fire the gun?

I don't think so. Diverters only choose awards. Must physically pull trigger to launch ball.

#4 83 days ago

I'm starting to think this may be the way it should be or a rom issue. I'm running L6. I tried everything to get that opto switch to fire in test mode. Messed with all the opto board connectors, lifted the mini playfield and messed with stuff under there. It only seems to fire if beam is broken like it should or when hitting flipper buttons randomly during game play. annoying.

#5 83 days ago

Any Shadow owners out there?

#6 83 days ago
Quoted from Djshakes:

I'm starting to think this may be the way it should be or a rom issue. I'm running L6. I tried everything to get that opto switch to fire in test mode. Messed with all the opto board connectors, lifted the mini playfield and messed with stuff under there. It only seems to fire if beam is broken like it should or when hitting flipper buttons randomly during game play. annoying.

Not supposed to do it randomly. Only when a ball is kicked in to the battlefield. And then only when beam broken.

You have an issue somewhere check the wires under the battlefield are not pinched or frayed or shorting to eachother or ground.

Then check coil diodes and clean and test your flipper optos.

How it's supposed to behave 3:20 into vid.

#7 83 days ago
Quoted from erak:

Not supposed to do it randomly. Only when a ball is kicked in to the battlefield. And then only when beam broken.
You have an issue somewhere check the wires under the battlefield are not pinched or frayed or shorting to eachother or ground.
Then check coil diodes and clean and test your flipper optos.
How it's supposed to behave 3:20 into vid.

Wait, did you say the ball being kicked into the battlefield causes the kicker to actuate? I ask because that popper switch where it's staged is very sensitive on my game. When you thump you hand on the playfield it registers in switch test. It doesn't cause the opto switch to register on upper playfield so I ignored it. Maybe that switch is firing when I flip the flippers causing the upper playfield kicker to fire? I thought I check that in switch test mode coin door shut and the popper switch didn't register when flipping the flippers. Maybe I need to check again?

In the video it doesn't look like the kicker actuated when the ball was shot up on the playfield.

I would think if a wire was frayed under the playfield it would register in switch test when I was messing with them to try to find the issue.

I will check what you mentioned tomorrow.

#8 82 days ago

Checked flipper coil diodes and for the life of me can't get that opto switch to trigger in test mode unless broken. I notice this board under playfield triggers the switch if I unplug one of the three connectors but if all plugged in and jiggling wires, nothing, which is good. No loose connections. I'm at a serious loss here and sort of bummed.

I literally changed flipper opto board out of desperation. In addition I removed the playfield optos and connected with a straw so nothing could break beam, flippers still fire plunger randomly. Checked all connections in back box. Put game in single switch test in switch 36 so it will beep if triggered. Fucked around with everything above and below playfield and in back box to try to trigger switch. Nothing. Wtf. Are you sure the plunger shouldn't fire randomly? I'm obsessive about game playing correctly and this drives me nuts. Half tempted to sell game and I just got it. Fuck this Pos. So pissed

20190202_075301 (resized).jpg
#9 82 days ago

Plunger doesn't fire randomly. And never should.
I would suspect a flaky (but partially working)opto on the battlefield.
You will never be able to tell during switch test.
As testing that way won't show vibration and voltage fluctuations that happen during gameplay. Because of other coils fireing, lamps, flashers etc.

Good luck.

#10 82 days ago
Quoted from erak:

Plunger doesn't fire randomly. And never should.
I would suspect a flaky (but partially working)opto on the battlefield.
You will never be able to tell during switch test.
As testing that way won't show vibration and voltage fluctuations that happen during gameplay. Because of other coils fireing, lamps, flashers etc.
Good luck.

But wouldn't the opto fire in switch test with coin door shut which allows flipper coils to fire? If only that opto controls the plunger then technically I should see that opto switch fire when flipping the flippers right?

#11 82 days ago

Replaced both optos and the wires connecting opto to board under playfield, same shit.

#12 82 days ago

Do you have any flourescent lights on above the game.

#13 82 days ago

Swapped out mpu and the power driver board. Seems to improved enough with different pdb to be tolerable. Still does it, annoying as fuck but I exhausted everything. I'm over it.

#14 81 days ago

If it does it with another PCB. 100% you have a short or more likely break in your wireing. Somewhere.

Check the insulation where the wires touch the battlefield. And any stray wires not tied into the harness that might be broken internally if flexed or vibrated and can't be visibly seen. (Like stray ones in pic)

I had that on my shadow causing some battlefield targets to work intermittent

Check all the opto control boards and optos (every opto in the machine) one bad opto can mess the whole switch matrix. Don't forget the sanctum opto. Check for bad connections or solider blobs as well. Or cold solider joints.

Check the coindoor interface board for solider blobs or cold solider.

And if you haven't already. Visibly inspect the wires coming off the battlefield coil. And DMM test or replace the diode on it. And if it was done before, is it on the right direction?

It's not as hard as it seems. Just a little time and patience and you will sort it out.

Good luck.
Screenshot_20190204-030329 (resized).pngScreenshot_20190204-030506 (resized).pngScreenshot_20190204-030552 (resized).png

#15 81 days ago

Had/have similar issue — when balls were popped up to battlefield, kicker Fred every time I moved the paddle. Tried everything from connecting cables, to opto solder, motor driver board, rebuilt power section with new caps.. annoying as hell. I finally got it fixed for a long while by replacing one of the Optos (after already previously trying that). Comes back occasionally now though.. maybe solder flakiness now. your issue has to lie somewhere in those connections / components — keep at it, youlll find it. Is your 12v ok?

2 weeks later
#16 67 days ago

I have this issue intermittently. Always figured it was just how the game operates. I'll have to check the optos. I originally used electrical tape around all metal parts and replaced the motor driver board. It fixed a few problems, but once and awhile still get a dot error on it.

#17 67 days ago

It should only kick when the ball breaks the beam. There has to be some short causing it to kick.

#18 67 days ago

Hey, forgot about this thread. I fixed it!!! I replaced the dedicated opto board under playfield and it fixed it. I figured that had to be it because every other test failed t o fix. Pinballife has them.

Wow, so much better when it operates correctly. I almost lived with it. No way.

#19 64 days ago
Quoted from Djshakes:

Hey, forgot about this thread. I fixed it!!! I replaced the dedicated opto board under playfield and it fixed it. I figured that had to be it because every other test failed t o fix. Pinballife has them.
Wow, so much better when it operates correctly. I almost lived with it. No way.

Sweet!! It is def so much more enjoyable to have it operating correctly!

#20 64 days ago

glad it is fixed. was going to suggest you replace your optos as maybe one of them is bad and causing it to act up. but the opto board could have been doing it as well.

Promoted items from the Pinside Marketplace
From: $ 369.95
Boards
PinSound
€ 95.00
Lighting - Led
FlipperLED
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 29.00
Boards
KAHR.US Circuits
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 9.99
Eproms
Matt's Basement Arcade
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 50.00
5,700
Machine - For Sale
Winchester, VA
$ 40.00
Lighting - Other
Rock Custom Pinball
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 229.99
Lighting - Other
Lighted Pinball Mods
3,250
Machine - For Sale
Saint Petersburg, FL
$ 129.00
Lighting - Led
LED OCD
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 15.00
Playfield - Protection
Pin Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 22.00
$ 59.00
Wanted
Machine - Wanted
Portland, OR
Hey modders!
Your shop name here

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside