(Topic ID: 260531)

Iron Maiden Premium Ramp Issue

By Ike

1 year ago



Topic Stats

  • 10 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Ike
  • No one calls this topic a favorite

You

Topic Gallery

View topic image gallery

1F42455B-2672-4A6A-9B77-42E1FF605C24 (resized).jpeg
E6BB3999-D9AA-4626-8530-E117B1BF6BEA (resized).jpeg
Screenshot_20200125-120640 (resized).png

#1 1 year ago

Just picked up an Iron Maiden Premium. Awesome pin. Having an issue though with the ramp getting stuck in up position. Doesn’t seem to be due to rubbing on the back rail. Only way to release is to lift playfield and manually release. Seems like the release mechanism may not be working properly. There are two washers fixed with a screw that seem to be holding it up and the other mechanism seems to release it. Odd thing is when I go into the service menu and make the ramp go up and down it will do it but you have to hit it a few times. I tried just taking the washers off altogether but then in gameplay it won’t hold it open for any length of time. Any help would be greatly appreciated. For now have changed the settings to make it work like a Pro.

#2 1 year ago

I had this same problem on mine. Just ended up needing to adjust the position of the small coil bracket (part 27).

Screenshot_20200125-120640 (resized).png
#3 1 year ago

Thanks. Did you end up taking it all apart or just loosening screws and wiggling into different position? I’m wondering if the ramp lift post that feeds into the spring/coil or some part of the mechanism is dirty. When I hold the locking mechanism apart that would normally catch on the washer and move the ramp post with the washers on it back and forth freely it tends to want to lock when fully extended. Not sure if that’s a magnet or if it should move freely without locking.

#4 1 year ago

Anyone else have any other thoughts on how to fix this. Wondering if when the machine is off if the ramp post should lock into the extended position or not. Thanks.

#5 1 year ago

Here are a couple photos showing how the ramp post will stay locked even when the end washer isn’t touching the locking mechanism. This is with the power off.

1F42455B-2672-4A6A-9B77-42E1FF605C24 (resized).jpegE6BB3999-D9AA-4626-8530-E117B1BF6BEA (resized).jpeg
#6 1 year ago

I loosened the screws, moved the bracket, and tightened the screws.

I think it's staying up because you have the playfield up.

#7 1 year ago
Quoted from Ike:

Here are a couple photos showing how the ramp post will stay locked even when the end washer isn’t touching the locking mechanism. This is with the power off.[quoted image][quoted image]

I had this same issue with my LE right out of the box.

Called Stern and they sent me a brand new ramp assembly and swapped it out. Don't remember it being too difficult. Problem has never came back.

#8 1 year ago

Mine was having this issue and someone on here suggested using the some lube on back where the ramp catches. Did that once and problem never came back.

#9 1 year ago

Appreciate the feedback. Will try these ideas and if all else fails will call Stern on Monday. Thanks.

#10 1 year ago

Just wanted to thank all of you for the advice. Ended up putting a tiny amount of white lightning grease on the washer where it rubs against the other metal part as well as on the rail on the play field behind the ramp where it comes close to touching when it raises up. Issue solved for now. Great community we have here. Play on!

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside