(Topic ID: 217498)

Iron Maiden issues


By rvdv

1 year ago



Topic Stats

  • 2,186 posts
  • 299 Pinsiders participating
  • Latest reply 5 days ago by NeilMcRae
  • Topic is favorited by 129 Pinsiders

You

Topic Gallery

There have been 276 images uploaded to this topic. (View topic image gallery).

IMG_20191026_121732 (resized).jpg
AE80355F-5C88-4F47-ACF9-CD1947559B71 (resized).jpeg
IMG_2459 (resized).jpg
C4C11B34-E040-48CA-92DC-99801E773D7D (resized).jpeg
IM right ramp fix (resized).jpg
IMG_2220 (resized).JPG
IMG_2219 (resized).JPG
IMG_2218 (resized).JPG
newton-ball-unscrew (resized).jpg
7728A7C8-BFD1-44AB-83AB-91CB1B9128EB (resized).jpeg
A24B7A39-59AD-45C4-8CA2-27C135D501F3 (resized).png
MVIMG_20190818_220245 (resized).jpg
image (resized).png
IMG_9941 (resized).jpg
IMG_9939 (resized).jpg
MVIMG_20190817_233035 (resized).jpg

Topic index (key posts)

9 key posts have been marked in this topic

Post #96 sarcophagus switch fix. Posted by DG_Amuse (1 year ago)

Post #434 Black t-moulding pictured to replace stock banana yellow. Posted by Strummy (1 year ago)

Post #597 Stern fix for Newton Ball issues on LE Posted by Fytr (1 year ago)

Post #887 Fix for fast balls not registering on upper loop Posted by PinNin (1 year ago)

Post #1039 Picture of factory fix for bad mummy newton ball on Prem/LE Posted by RA77 (1 year ago)

Post #1343 Fix for fast balls leaving wireforms Posted by Kevlar (1 year ago)

Post #1452 Shim method to get auto launch to work nearly 100% Posted by hank35 (1 year ago)

Post #1713 How to fix auto launch forever. Posted by NeilMcRae (10 months ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider bojo.
Click here to go back to viewing the entire thread.

#579 1 year ago
Quoted from Robertstone0407:

Has anyone considered upgrading there flipper coils to the next level? I feel like even on hard and 6.3 level its a chore to get stuff done sometimes

Do your coils have any slop? I would make sure nothing is wrong because mine are super strong on the default settings. One person was missing a coil sleeve so check that as well.

1 month later
#836 1 year ago
Quoted from BananaJet:

Hello, noob here. I tried doing a search for this on Pinside and the web, but has anybody else experienced a flipper that retracts very slowly?
I just set up a NIB Iron Maiden Premium (first pinball machine) yesterday, and after the game is played for a while the upper left flipper retracts at about 1/2 speed. It works fine after being shut down for a bit, then starts acting up again after it is played for a while. The flipper looks like it extends just fine, but the slow retraction ends up getting in the way of the pinball. I can't see any rubbing on the playfield or anything obstructing the mechanism with the playfield lifted up.
I sent a message to Stern, waiting to hear back, but any insight would be greatly appreciated.
Thanks!
[quoted image]

Can you lift the flipper bat upward from the topside of the playfield? Not rotating it but pulling up on it. There should be a little play there and if they didn't leave a gap been the flipper and bushing then it might be too tight.

#844 1 year ago
Quoted from BananaJet:

Thanks for the reply, it does not have any play if I try to pull up on it. Stern has been in touch, we were looking at the spring but that seems to be working okay. I will let them know that there is no up/down play when the flipper bat is pulled up. It's pretty tight in there.

Since the machine has 4 flippers and the issue is only occurring on 1 lift up on the others to see how they compare. Normally the gap is small but there. You don't need to buy this tool but to give you an idea of what used to come with the older games.

https://www.marcospecialties.com/pinball-parts/03-8194

#857 1 year ago

I think some are overanalyzing the issue. The one flipper he is having issues with is also the only 1 out of 4 that does not have any vertical play. If I had to guess that is the issue and they did not gap the flipper correctly. I agree it could be a spring issue or alignment issue as well but the first thing I would do is make sure all 4 flippers have the same amount of vertical movement and then go from there. If you want to test the spring theory then just swap a spring from one of the other 3 flippers that are working correctly to see if it goes away.

2 weeks later
#1021 1 year ago
Quoted from bigdaddy07:

To be clear, my playfield is physically smooth as glass on the surface, but you can see the ribbing in the wood underneath. You really have to be looking for it, but it's certainly there.

I've seen that as well where the clear is nice and smooth but you can see the grain under. What's ironic is the LE around here on location is perfect.

Quoted from FightNightFZ:

1.) mine has the woodgrain effect all over it, I know this is a historic problem with Stern. Is there a point where it’s worth asking for a replacement?

If yours is a LE you have a shot since they were made for the home collector and Stern is more accommodating on those. If it's a premium then I wouldn't bother since they won't do anything. You can also just start a thread about it and hope the squeaky wheel gets the grease.

Promoted items from the Pinside Marketplace
9,000
Machine - For Sale
Oakland, NJ
From: $ 99.99
6,899
Machine - For Sale
West Chicago, IL

You're currently viewing posts by Pinsider bojo.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside