(Topic ID: 217498)

Iron Maiden issues


By rvdv

1 year ago



Topic Stats

  • 2,035 posts
  • 277 Pinsiders participating
  • Latest reply 13 hours ago by 85vett
  • Topic is favorited by 119 Pinsiders

You

Topic Gallery

There have been 255 images uploaded to this topic. (View topic image gallery).

0711191301_HDR (resized).jpg
ED212633-8B87-4115-BD68-3D63F23AF7F6 (resized).jpeg
maiden3 (resized).JPG
maiden2 (resized).JPG
maiden (resized).JPG
IMG_1180 (resized).jpeg
IMG_1173 (resized).jpeg
IMG_0223 (resized).jpg
IMG_0222 (resized).jpg
Screen Shot 2019-06-04 at 12.44.58 am (resized).png
0BE969CB-CAB2-4F51-A17C-5BE6FBD6BE44 (resized).jpeg
5D3ED81C-5F21-473F-A37B-B871EE2C7BE0 (resized).jpeg
F3D7E97D-6C62-4DAB-B2FF-0379D64284F1 (resized).jpeg
stern-drop-target-shelf (resized).jpg
15544219001762474006989679341006 (resized).jpg
15544217621351279828953441567147 (resized).jpg

Topic index (key posts)

9 key posts have been marked in this topic (Show topic index)

There are 2035 posts in this topic. You are on page 41 of 41.
#2001 12 days ago
Quoted from Milltown:

Im having this issue ..
Same exact deal ... Mine was perfect and after a few days my auto launch and my manual are either hitting the upper left flipper or the post .. Sometimes perfect sometimes not.. Sometimes it makes it around the orbit sometimes it flys around ... I've only had mine for 10 days from nib... Very frustrating on a brand new game ...

Try cleaning the PF. I have to keep mine squeaky clean or Satan starts f-ing with the trajectory.

#2002 12 days ago
Quoted from Milltown:

Im having this issue ..
Same exact deal ... Mine was perfect and after a few days my auto launch and my manual are either hitting the upper left flipper or the post .. Sometimes perfect sometimes not.. Sometimes it makes it around the orbit sometimes it flys around ... I've only had mine for 10 days from nib... Very frustrating on a brand new game ...

The coil fix (stronger coil) and clean playfield seems to be the best combination.

#2003 12 days ago

bigger coil fix!

#2004 12 days ago
Quoted from NeilMcRae:

bigger coil fix!

Do you have a coul that works or has worked or a recomendation ? My maiden is only a week old.. I waxed the shooter lane and no difference ..

#2005 12 days ago
Quoted from vireland:

The coil fix (stronger coil) and clean playfield seems to be the best combination.

Do have a coil that works or a recommended one I should say that will work ?

#2006 12 days ago
Quoted from Milltown:

Do have a coil that works or a recommended one I should say that will work ?

Click on the topic index link at the top of this page and click on the "how to fix auto launch forever" link.

#2007 12 days ago

Good Afternoon,

My upper left flipper is sticking and not returing to resting position. I slightly loosened the 2 screws underneath attached to flipper, it worked at first then problem returned next day. Any fixes? Thanks in advance.

#2008 12 days ago
Quoted from NeilMcRae:

Few have you have asked now.
I had the auto launch problem. I tried everything:
1: The washer
2: The wax
3: the adjustment of the mech.
4: cardio surgery
5: Frontal lobotomy
6: Faith healers
7: dentistry
8: turning it off and on again.
none of them worked.
Then I was watching Star Trek, not that new rubbish, Star Trek 4, full power now sir!
More power! that's what this needs.
So I stuck a bigger coil in https://www.pinballlife.com/stern-090-5023-ot22-600-coil.html 22-600. Don’t install the diode. And I’m using 205 on power settings.
Boom, all good. but with trooper a little too much power, so dialled it back on the settings. No more Fucking problem.
You're Welcome.
Cheers,
Neil.

Thanx for posting this ..,im ordering it now..

#2009 12 days ago
Quoted from CHIEF1893:

Good Afternoon,
My upper left flipper is sticking and not returing to resting position. I slightly loosened the 2 screws underneath attached to flipper, it worked at first then problem returned next day. Any fixes? Thanks in advance.

Sounds like your coil stop is borked. Remove and inspect.

#2010 11 days ago

With ease I was able to remove the ball gate from the shooter lane and 1 nut holding down the plastic ,.
A regular screwdriver fit perfect to loosen the ball guide in the shooter lane . I pushed it all the way to the right and tightened it back up..
I leveled the game perfectly ,..
Then adjusted the manual plunger ...
95 % the ball makes the orbit on auto or manual ...
I ordered the stronger coil and will install it upon arrival... I belive that will be the final dial in..
Im happy so far...
Thank you for this post on all,the suggestions ..

#2011 10 days ago

I posted this in another IMDN thread. Thought I’d share here in case anyone else is successful doing it, this post can get indexed if so...

You guys can give my fix a shot. I did this probably about 7 mos ago, and besides one minor quirk (noted below), it has been flawless *knock on the biggest wooden boat ever*
I added (2) 1/4” e-clips to the inside of the right elbow of the auto plunger (see pic). This helps keep the prongs stay in place from the torque of the coil. A bigger size coil helps as it Speeds up coil reducing the chance of any movement with the prongs.
I had one anomaly issue with this fix. After about 3 mos of flawless play, I had to lift the playfield, when I put it back, my ball from the shooter plunger would hit the bottom tip of the upper right flipper. To fix, I just replaced it with a lightning flipper and has been perfect since (going on approx 4 mos.).
Give it a shot; I’d like to hear other people’s results from this or wonder if I’m just lucky or not. Last couple fixes I shared on this issue caused my game to go out of whack the next day, so hoping I don’t repeat history lol. But it’s been 99.9999% solid with the e-clip fix for a long time, even after cleaning the playfield. Good luck!

ED212633-8B87-4115-BD68-3D63F23AF7F6 (resized).jpeg
#2012 10 days ago

Possibly in this thread not sure..
Me and my gal were just playin and her ball drained ..
When it went to player 2 it automatically shot into play ?
I know this isn't correct .
Anyone know wich switch would need adjusting ?
Its not consistent at all so having trouble tracking it down....
Thank you....

#2013 10 days ago
Quoted from Milltown:

Possibly in this thread not sure..
Me and my gal were just playin and her ball drained ..
When it went to player 2 it automatically shot into play ?
I know this isn't correct .
Anyone know wich switch would need adjusting ?
Its not consistent at all so having trouble tracking it down....
Thank you....

Take the glass off. Put the game in switch test mode. Smack the playfield firmly with your open palm at various places all over the playfield, multiple times, if necessary. See which switch(es) register from the vibration. Fix that or those ones.

#2014 10 days ago
Quoted from vireland:

Take the glass off. Put the game in switch test mode. Smack the playfield firmly with your open palm at various places all over the playfield, multiple times, if necessary. See which switch(es) register from the vibration. Fix that or those ones.

Ok much like a williams bally ECT....

#2015 10 days ago
Quoted from Milltown:

Ok much like a williams bally ECT....

I think it was the inner orbit spinner bracket it was pretty bent up makimg the spinner go real easy...
We will c soon...

#2016 10 days ago
Quoted from Eskaybee:

I posted this in another IMDN thread. Thought I’d share here in case anyone else is successful doing it, this post can get indexed if so...
You guys can give my fix a shot. I did this probably about 7 mos ago, and besides one minor quirk (noted below), it has been flawless *knock on the biggest wooden boat ever*
I added (2) 1/4” e-clips to the inside of the right elbow of the auto plunger (see pic). This helps keep the prongs stay in place from the torque of the coil. A bigger size coil helps as it Speeds up coil reducing the chance of any movement with the prongs.
I had one anomaly issue with this fix. After about 3 mos of flawless play, I had to lift the playfield, when I put it back, my ball from the shooter plunger would hit the bottom tip of the upper right flipper. To fix, I just replaced it with a lightning flipper and has been perfect since (going on approx 4 mos.).
Give it a shot; I’d like to hear other people’s results from this or wonder if I’m just lucky or not. Last couple fixes I shared on this issue caused my game to go out of whack the next day, so hoping I don’t repeat history lol. But it’s been 99.9999% solid with the e-clip fix for a long time, even after cleaning the playfield. Good luck![quoted image]

Tried this tonight.. No difference... Haha . dam machine...

#2017 9 days ago

I really hope the next update fixes revive. Its sucks how often I will drain down an outlane while in MB and lose my revive even though ball save is still going

#2018 8 days ago
Quoted from Graysonsdad:

I really hope the next update fixes revive. Its sucks how often I will drain down an outlane while in MB and lose my revive even though ball save is still going

this seems like it only happens when the ball saver timer is about to expire (but still blinking). I almost thought it was intentional.

#2019 7 days ago
Quoted from Graysonsdad:

I really hope the next update fixes revive. Its sucks how often I will drain down an outlane while in MB and lose my revive even though ball save is still going

And that right drain after successful skill shot doesn't cancel ball save. It's such a contradiction: the shot has the perfect rebound for a right outlane drain, at least on my machine. I'd say mine drains 50% of the time immediately after I make the skill shot. What's the point of the extra time for ball save if it just drains and cancels it?

#2020 4 days ago

Funny . I loosend the ball guide adjust in the shooter lane ... Maybe 1 whole turn out and the ball shoots perfect in manual and auto 99 percent of the time...

#2021 4 days ago
Quoted from Milltown:

Funny . I loosend the ball guide adjust in the shooter lane ... Maybe 1 whole turn out and the ball shoots perfect in manual and auto 99 percent of the time...

Hope to not sound stupid here, but could you post a pic of exactly what you adjusted?

#2022 4 days ago
Quoted from Bohdi:

Hope to not sound stupid here, but could you post a pic of exactly what you adjusted?

Gimme a minute

#2023 4 days ago
Quoted from Milltown:

Gimme a minute

At the end of the shooter lane under the plastic ... Remove the ball gate and plastic holds ... You can carefully get a flat head in there ...i loosened mine about 3/4 to half a turn and let it sit natural..,,,
I was having a horrible time making the orbit in manual and auto.... Now it works 99 percent of the time...

0711191301_HDR (resized).jpg
#2024 4 days ago
Quoted from Milltown:

At the end of the shooter lane under the plastic ... Remove the ball gate and plastic holds ... You can carefully get a flat head in there ...i loosened mine about 3/4 to half a turn and let it sit natural..,,,
I was having a horrible time making the orbit in manual and auto.... Now it works 99 percent of the time...[quoted image]

That's what i loosened and tried to push the guide as much "up" as i could because the ball was hitting the post below the upper left flipper, just above the skill shot target. It's better, but still not right. Are most people trying to move this guide up or down is my question. Thanks for the pic

#2025 4 days ago
Quoted from Milltown:

At the end of the shooter lane under the plastic ... Remove the ball gate and plastic holds ... You can carefully get a flat head in there ...i loosened mine about 3/4 to half a turn and let it sit natural..,,,
I was having a horrible time making the orbit in manual and auto.... Now it works 99 percent of the time...

This worked for me too.
I think it changes the angle of the lane guide so it's more on a 90 angle to the playfield.
Go back and read the wedge fix I posted. Although it's not 100% anymore, it's works 99.9999% of the time.

#2026 4 days ago
Quoted from Bohdi:

That's what i loosened and tried to push the guide as much "up" as i could because the ball was hitting the post below the upper left flipper, just above the skill shot target. It's better, but still not right. Are most people trying to move this guide up or down is my question. Thanks for the pic

I originally tried that .,then i tried the leave it one turn loose and it worked...

#2027 4 days ago

I also just got in the mail a stronger shooter lane coil im gonna give a shot... And reduce the setting so it makes the orbit better... And faster...

#2028 4 days ago
Quoted from Milltown:

I originally tried that .,then i tried the leave it one turn loose and it worked...

So you leave that screw just a bit loose then huh? I'll fuss with it some more. Appreciate it

#2029 4 days ago
Quoted from Bohdi:

That's what i loosened and tried to push the guide as much "up" as i could because the ball was hitting the post below the upper left flipper, just above the skill shot target. It's better, but still not right. Are most people trying to move this guide up or down

I filed the end of my guide a hair since a little lip/bur was bashed into the end from the balls flying around the playfield. It was small, but just big enough to change the trajectory of the ball. It works like a champ now

#2030 4 days ago
Quoted from wyopin:

I filed the end of my guide a hair since a little lip/bur was bashed into the end from the balls flying around the playfield. It was small, but just big enough to change the trajectory of the ball. It works like a champ now

Seems like the issue is the same but a little different on all,of them...,

#2031 4 days ago
Quoted from Bohdi:

So you leave that screw just a bit loose then huh? I'll fuss with it some more. Appreciate it

Yup.. 3/4 to 1 turn loose .. Worked on mine.. Seems odd.. But it works.. Haha

#2032 3 days ago

I farted about 3/4 foot from my ball guide and quickly spit on the adjustment screw. Then I tightened the screw half a turn. Now my ball guide hits the upper flipper every time. What did I do wrong?

#2033 3 days ago
Quoted from Tranquilize:

I farted about 3/4 foot from my ball guide and quickly spit on the adjustment screw. Then I tightened the screw half a turn. Now my ball guide hits the upper flipper every time. What did I do wrong?

Didn't spit enough. ?. Maybe try some exlax .. ?
Im unsure at this point..

#2035 13 hours ago
Quoted from Tranquilize:

I farted about 3/4 foot from my ball guide and quickly spit on the adjustment screw. Then I tightened the screw half a turn. Now my ball guide hits the upper flipper every time. What did I do wrong?

Was it a juicy fart or a dry fart? Has to be juicy or it doesn't count.

Promoted items from the Pinside Marketplace
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
Wanted
Machine - Wanted
Granville, OH
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 79.99
Cabinet - Shooter Rods
Great American Pinball
$ 399.99
Cabinet - Toppers
Great American Pinball
There are 2035 posts in this topic. You are on page 41 of 41.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside