(Topic ID: 277508)

Indiana Jones Williams Idol Motor Issue


By RCSP

2 days ago



Topic Stats

  • 1 post
  • 1 Pinsider participating
  • No one calls this topic a favorite

You

Linked Games

#1 2 days ago

Hi, I am doing a playfield swap on my IJ. It has sat for 10 years, and then I started shopping and swapping. I'm 5 months into this project, hand polishing ramps takes a long time.

The mini playfield appears to work, when the machine is powered on it rocks back and forth, and the test mode says it is working.

My problem is the Idol motor on the right side of the Playfield. I hook up a 9v battery and it turns over fine in both directions, this is removed from the gearbox. When I power on the machine, I see the motor spin. But in test mode it does not spin. The test mode gives me a "Idol Lock" error message. What is the Idol lock? The motor board (tiny 2" x 1.5") pins to the motor do not have power when testing the motor in test mode. I reflowed the pins on this board, and replaced the transistor which was shorted. Also reflowed both ball trough optos (another post said to do it), reflowed the opto board in the backbox (the board in the upper right corner of the backbox). In test mode the switches all work. The motor does not spin. I can manually turn the idol head with the motor removed (it spins freely), and the optos have been cleaned.

I've read quite a few posts, but they are mostly bad optos not a motor issue. Any ideas?

Thanks!

Promoted items from the Pinside Marketplace
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 19.50
Apparel - Unisex
ArcadeMade

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside