(Topic ID: 286582)

I’m stumped. Please help.

By Johncare07

1 year ago



Topic Stats

  • 7 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by Johncare07
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    73201131-26F4-4D4C-9B64-1A6BA8274F79 (resized).jpeg
    138756FE-6C7F-414E-91F6-3E859F1C8163 (resized).jpeg
    2EC74969-AF5D-4493-83B2-32AA4ED75EC0 (resized).jpeg

    #1 1 year ago

    Please help.

    IJ Williams.

    I did a playfield swap. Fuse f110 on the main powerboard keeps blowing. When I put in a new fuse the GI string of lights works (pop bumper caps, etc) but then the fuse blows.

    I’ve visually inspected all the brown white wire contacts and cannot find any type of a short. What do you recommend to do next?

    2EC74969-AF5D-4493-83B2-32AA4ED75EC0 (resized).jpeg
    #2 1 year ago

    can be a short within a socket itself. look at the sockets for easy tip offs like solder splashes... remove the bulbs.

    Then start breaking the string up into smaller segments if you can't find the culprit. It's probably in a socket tho if you haven't found it tracing the wires.

    #3 1 year ago

    Also a good time to make some resettable fuses, while you trace the problem. Looks Like F110 is 5 AMPS.

    https://pinside.com/pinball/forum/topic/making-and-using-a-fuse-breaker

    #4 1 year ago

    Although you did a playfield swap, I've had a case where the fuse holder itself was the culprit. The GI works for a while, then the fuse gets so hot from the slight resistance in the holder, that it blows the fuse.

    #5 1 year ago

    is one of the socket leads accidentally touching something it shouldn't be?

    #6 1 year ago

    Also be sure to VERY closely inspect the pop bumper socket leads under the playfield. They can very easily touch the pop bumper brackets and short out.
    If you get desperate you can pull all the bulbs in that circuit and see if it pops, then add them one by one.

    #7 1 year ago

    Wanted to thank everyone for the help. Problem solved.

    A string of LEDs was touching the bridge (metal that is not shown in the pics) and was shorting the circuit. It actually fried one of the bulbs. I used a glue gun to insulate the leads against shorting it in the future.

    138756FE-6C7F-414E-91F6-3E859F1C8163 (resized).jpeg73201131-26F4-4D4C-9B64-1A6BA8274F79 (resized).jpeg

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!