(Topic ID: 68869)

IJ Williams "You Cheat, Dr. Jones!" Club


By RDReynolds

5 years ago



Topic Stats

  • 4,825 posts
  • 396 Pinsiders participating
  • Latest reply 3 days ago by KornFreak28
  • Topic is favorited by 192 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,599 images uploaded to this topic. (View topic image gallery).

917ECE83-3109-4225-AEE9-84C480CB0C08 (resized).jpeg
46914232-1815-40BB-9333-951DCCC48D73 (resized).jpeg
90CEF4CF-B0BE-4D53-81DE-CC077AE98A52 (resized).jpeg
A267B015-A397-473C-972F-F5BC78F15A05 (resized).jpeg
DSCN4928 (resized).JPG
DSCN4924 (resized).JPG
F31487F9-02AD-4737-B2A3-AB998BA7D075 (resized).jpeg
53A4A204-328D-46E2-B5D5-AA7C42AAC962 (resized).jpeg
CCCAA565-3D31-4435-A8E5-995C2FDEF470 (resized).jpeg
E84F67CD-4DB5-49C8-9E0B-2070B4E339A1 (resized).jpeg
40CB038B-2C28-40D1-B42B-33F8E983F435 (resized).jpeg
821AD53A-1D2B-4FB1-8EC6-3BD538802C40 (resized).jpeg
3AEC8BA3-3787-4F03-A4EE-5A774FC4E4C1 (resized).jpeg
9930169A-8F2B-4C8F-9BEF-79EF26A4A991 (resized).jpeg
DSCN4778 (resized).JPG
DSCN4780 (resized).JPG

You're currently viewing posts by Pinsider utesichiban.
Click here to go back to viewing the entire thread.

#4073 7 months ago

I have a question for those of you that know this game (and pinball) better then me. I installed a led mod with alligator clips to my IJ Sunday night. Attached it to the GI on the left side just in front of the POA and fed wires under the targets on that side.

It lit up for about 10 minutes and went out. As it turns out, now all the led lights on both the left and right side in the GI and pop bumpers are out. Does anyone know if a blown fuse would cause this due to this mod overloading things? Would it be something else that would cause this? I am kicking myself for installing this mod and hoping I didn’t blow something more seriosvthen just a fuse.

Any insight or guidance you guys can provide is very appreciated.

#4077 7 months ago
Quoted from Davi:

Check fuses F106 to F110 (5A fuses) - lower left side on Power Driver Board.

Thank you! Will do that.

#4079 7 months ago
Quoted from rx3:

I cringe at mods using alligator clips for a connection. IMO, alligator clips should only be used for testing purposes.

Yeah, I don't think I will reconnect this mod again unless I buy a separate power supply.

4 months later
#4556 3 months ago

Hey guys, I noticed a few days back that the led ENT & lock/center shot lights on my IJ are all out (see pic). All other playfield lights including the led that lights the center shot area are all working fine.

Any ideas why this group of lights would all be out? Is there a fuse that controls those lights that may be blown?

20190717_220008 (resized).jpg
#4559 89 days ago

Thanks. I will check that when I get back home. Anyone know of anything else that could cause that? Will pro ably try to troubleshoot this weekend.

Promoted items from the Pinside Marketplace
$ 49.95
Playfield - Toys/Add-ons
pinballmod

You're currently viewing posts by Pinsider utesichiban.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside